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Preface

Oracle's StorageTek SL8500 Modular Library System is an enterprise storage solution 
that provides fully automated tape-cartridge storage and retrieval. Not all features 
described in this document are available on libraries running earlier firmware 
versions. For a description of features available with a particular firmware release, 
refer to the firmware release notes or contact an Oracle representative.

This document is intended for administrators and operators using the SL8500 library. 
This document assumes the reader is familiar with the SL8500 library modules and 
components. For introductory and planning information, see the SL8500 Systems 
Assurance Guide on OTN (refer to the Related Documentation section below). 

Related Documentation
For more information related to the SL8500 library, see the following documents on the 
Oracle Technical Network (OTN) at:

http://www.oracle.com/technetwork/documentation/tape-storage-curr-187744.h
tml

■ SL8500 Systems Assurance Guide — overview of the library and installation 
planning guide

■ SL8500 Host Connectivity Guide — networking information on Dual TCP/IP, Multi 
TCP/IP, redundant electronics, and partitioning

■ SL8500 SNMP Reference Guide — SNMP information

■ Library management software documentation:

■ ACSLS Administrator's Guide

■ ELS System Programmer's Guide

Documentation Accessibility
For information about Oracle's commitment to accessibility, visit the Oracle 
Accessibility Program website at 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

Access to Oracle Support
Oracle customers have access to electronic support through My Oracle Support. For 
information, visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or 
visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing 
impaired.

http://www.oracle.com/technetwork/documentation/tape-storage-curr-187744.html
http://www.oracle.com/technetwork/documentation/tape-storage-curr-187744.html
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1StorageTek Library Console

Oracle's StorageTek Library Console (SLC) is a graphical user interface (GUI) 
application for configuring, monitoring, and managing the SL8500 tape library.

■ SLC Versions

■ Downloading the SLC Media Pack

■ SLC GUI Overview

■ Standalone SLC

■ Web-launched SLC

■ Local Operator Panel

■ User Management

SLC Versions
There are three SLC versions. Throughout this document, you can perform the 
procedures using any SLC version, unless otherwise noted.

■ Standalone SLC — enables SLC to run remotely from any system that has a 
network connection to the library.

■ Web-launched SLC — enables SLC to be installed on a server, allowing individual 
clients to use a browser to access SLC.

■ Local Operator Panel — a limited version of SLC is pre-installed on the touch 
screen interface built into the Customer Interface Module. The local operator panel 
enables library operators to access most SLC functions directly at the library.

Downloading the SLC Media Pack
The media pack includes the web-launched SLC server, web-launched SLC client, and 
the standalone SLC. To download the media pack:

1. Go to the Oracle Software Delivery Cloud at: http://edelivery.oracle.com/

2. Click Sign In/Register.

Note: Customer data on tape cartridges is never available to SLC or 
the library. The external data interface of the tape drives is separate 
from the library infrastructure.
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3. On the Terms & Restrictions screen, read the License Agreement and Export 
Restrictions, and select the check boxes to indicate your acceptance. Click 
Continue.

4. On the Media Pack Search screen:

a. In the Select a Product Pack list, select Oracle StorageTek Products.

b. In the Platform list, select Generic Platform.

c. Click Go.

5. Select the SLC version to download. Click Continue.

6. To review the download instructions, click Readme. Optionally, use the View 
Digest button to verify the MD5 and SHA-1 digests of the download files.

7. Verify the SLC version is correct. Click Download.

8. Save the file. Extract the media pack to the desired location.

SLC GUI Overview

Figure 1–1 SLC Screen Layout

Figure Legend:

1. Menu Bar — includes the Tools menu and Help menu.
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2. Utility Title — displays the title of the current utility.

3. Function Tabs — identifies the available functions for a utility. Some utilities 
contain second level tabs.

4. Options Bar — location of buttons related to the current utility screen.

5. Utility content.

6. Library health indicator — identifies the library connected to SLC, and displays 
library health (see "Library and Device Status Overview" on page 6-1).

7. UserID indicator — displays the user ID currently logged in to SLC.

8. Server communication health indicator — Displays the heartbeat monitor 
indicating the state of server communication health (see "Library and Device 
Status Overview" on page 6-1).

9. Navigation tree — lists the devices contained in the library.

Modifying a Tabular Display
Many SLC utilities use a tabular display. You can modify the table:

■ To sort by a column, click the heading of the column. Initially the sort is in 
ascending order. Click the heading again to switch to descending order.

■ To move a column, click and drag the column heading horizontally to any position 
in the heading row.

■ To re-size a column, click and drag the border of the column heading.

Synchronizing SLC with the Controller Database
SLC receives library configuration data from the library controller. Configuration data 
may be unavailable if you log in to SLC before the library is fully initialized. Exit and 
log in again after initialization. Additionally, configuration data displayed during an 
audit may not be accurate until the audit completes.

SLC displays the most recently saved data from the library controller database. When 
the configuration changes (such as taking a drive offline, or removing or adding a 
cartridge), synchronize SLC by clicking the Refresh button.

Multiple users can access the library simultaneously. Coordinate with other library 
users when making major modifications to the configuration (such as adding modules, 
defining partitions, and so on) to prevent conflicts.

Standalone SLC
The standalone version of SLC runs remotely from any system with a network 
connection to the library.

You must uninstall all previous versions of standalone SLC before installing the latest 
version. Running multiple versions of SLC on the same system can cause inconsistent 
data.

Security Considerations
SLC interfaces with the primary library interface (PLI) over a secure sockets layer 
(SSL). SSL provides a secure communication path between the library and the SLC 
session. This prevents unauthorized network users from monitoring library activity.
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Installation Requirements

Qualified Platforms
■ Solaris 10 SPARC, Solaris 10 x86

■ Windows Server 2008 SP2 64-bit, Windows 2012 Enterprise Server

■ Windows 7 SP1 64-bit, Windows 8 64-bit, Windows 8.1 64-bit

■ Oracle Unbreakable Linux 5 (2.6.18) 32-bit

■ SUSE Enterprise Linux 10.2 (2.6.16) 32-bit

Other
■ Network connection to the library

Installing the Standalone SLC
Uninstall all previous versions of SLC before installing an update.

1. Download and extract the standalone SLC media pack (see "Downloading the SLC 
Media Pack" on page 1-1).

2. Select the SLC installer file for your operating system (refer to the media pack 
readme).

3. Review the information. Click Next.

4. Specify where to install SLC. Click Next.

5. Specify where to create the SLC shortcut icons. Click Next.

6. Verify the information is correct. Click Install.

7. Click Done.

Logging in to the Standalone SLC
1. To start SLC on your system, either:

■ Double-click the SLC desktop icon.

■ Select Start > RunSLConsole or Launch > RunSLConsole.

2. Enter your login information. Click Log on.

For additional login and user management information, see"User Management" on 
page 1-7.

Web-launched SLC
The web-launched version enables SLC to be installed on a server. Then, individual 
clients can use a browser to access SLC.

To install the web-launched version on a server, download the web-launched SLC 
server (.war) file from the Oracle Software Delivery Cloud (see "Downloading the SLC 
Media Pack" on page 1-1). Deploy the file on the server of your choice (refer to the 

Note: On Solaris, you cannot choose the default root directory. 
Oracle recommends /u-sr/bin or a similar location.
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media pack readme). The web-launched SLC is delivered to clients as a Java Web Start 
process, which executes outside the browser.

You only need to install updates to the web-launched SLC on the server. You can 
update the web-launched SLC server while it is running. After the updates are 
installed on the server, they are downloaded automatically to all clients whenever the 
application starts.

Security Considerations
The web-launched SLC software is digitally signed, which guarantees that it has been 
issued by Oracle Corporation and has not been altered or corrupted since it was 
created. As a Java Web Start process, the web-launched SLC includes the security 
features provided by the Java 2 platform.

You are responsible for implementing all appropriate additional security systems, 
including firewalls, user access, and so on.

Client Requirements

Qualified Platforms
■ Internet Explorer 8 (on Windows 7: 64-bit)

■ Firefox 17.0.2 ESR (on Windows 7: 64-bit)

Other
■ Java 1.5 Plug-in (the browser should install this automatically)

■ Network connection to the web-launched SLC server

Logging in to the Web-launched SLC
To log in using a browser, download Mozilla Firefox from http://www.mozilla.com. 
On Solaris platforms, you can also log in to the web-launched SLC using the command 
line. 

1. Obtain the DNS alias or IP address of the SLC server. Contact your library 
administrator for assistance.

2. Choose a login method:

– Command line: Available on Solaris only. In the terminal window, enter:

javaws http://server_ID:port_ID/opel/slc.jnlp

– Browser: Available on either Windows or Solaris. In a browser on the client 
system, go to the SLC Web Start application:

http://server_ID:port_ID/opel

where:

■ server_ID — Either the IP address or DNS alias of the SLC server.

■ port_ID — Port ID of the SLC application, typically 8080.

■ opel — The name (context root) of the web-launched SLC application on the 
server.

3. Click Launch Now.

4. Specify the action to take with the slc.jnlp file. Select either:
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■ Open with Java Web Start Launcher to start SLC directly.

■ Save to Disk to save the slc.jnlp file to your client and log in to the SLC later.

5. If this is your first time running the web-launched SLC, complete the digital 
signature warning dialog box: verify the publisher and click Run.

6. Enter your SLC login information. Click Log on.

For additional login and user management information, see"User Management" on 
page 1-7.

Local Operator Panel
The local operator panel is a touch screen interface built into the Customer Interface 
Module (CIM). It enables you to run most SLC functions directly at the library. 

Logging in to the Local Operator Panel
Only one user at a time can log in to the local operator panel.

1. If the screen is blank, touch the screen anywhere to activate the login screen.

2. Use the virtual keypad to enter your login information.

3. Click Log on.

For additional login and user management information, see "User Management" 
on page 1-7.

Calibrating the Touch Screen
Alignment of the touch screen is calibrated at the factory. If the touch screen becomes 
mis-aligned, you can re-calibrate or reset it. View the operator panel type and version 
using the Tools > Diagnostics > Library Folder > Op Panel Tab:

■ If you have a Linux-based local operator panel (DL or OL), you can re-calibrate it 
yourself or reset it to factory setting with the procedures below.

■ If you have a Windows-based local operator panel (W), contact your Oracle 
support representative.

Re-calibrating the Local Operator Panel
For an accurate calibration, make sure there is no debris on the touch screen.

1. Log in to the local operator panel.

2. Select Tools > Calibrate.

3. Tap Calibrate.

4. A series of targets will display. Gently tap the center of each target with your 
finger or a pointing stylus.

5. To save the new settings:

a. Tap the Click Me buttons within the indicated time period.

If the buttons do not depress, the touch screen is not properly aligned. Discard 
the new settings (see step 6).

b. Click OK to save the new settings.

6. To discard the new settings:
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a. Let the timer run out without tapping the Click Me button.

b. Return to step 4 and re-calibrate.

The local operator panel reboots automatically after an unsuccessful second 
calibration and restores the previously saved alignment.

Resetting the Local Operator Panel Calibration
To restore the touch screen alignment to the factory settings:

1. Log in to the local operator panel.

2. Select Tools > Calibrate.

3. Click Reset Calibration. The local operator panel reboots.

Rebooting the Local Operator Panel
You may need to reboot the local operator panel if it hangs or the help content is not 
visible.

1. Select Tools > Diagnostics > Library Folder > OpPanel Tab

2. Click the Reboot Operator Panel button.

3. If rebooting from the local operator panel, the screen will go blank. The reboot is 
complete when the operator panel comes back online.

If rebooting from a remote SLC session, a series of messages will display. "Reboot 
Complete" indicates the reboot of the local operator panel has finished.

User Management
To access SLC you must have a valid user ID and password. Only one user at a time 
can log in to the local operator panel, but multiple users can log in to the standalone or 
web-launched SLC.

User IDs
Each user ID is assigned a set of permissions that determines access to utilities within 
SLC. There are a fixed set of user IDs at each site:

■ admin: customer administrator

■ service: Oracle support representative

■ oem: third-party field service technician

Passwords
After library installation, an Oracle support representative will provide a one-time use 
activation password. The library administrator must activate the admin user ID with 
the first eight characters of this password. After the initial log in, the administrator 
should change the admin user ID password to ensure system security.

Changing a User Password
1. Log in to SLC using the account you want to modify.

2. Select Tools > User Mgmt
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3. On the navigation tree, expand the Permanent folder. Select the current user 
account.

4. Complete the following fields: Current Password, New Password, and Retype 
Password.

5. Click Modify.
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2Hardware Activation Files

Hardware activation files enables you to activate and monitor optional features on the 
SL8500 library. Some library features are activated by the customer, while others must 
be installed and enabled by an Oracle support representative. Features activated by a 
hardware activation file include capacity upgrades, dual TCP/IP, redundant 
electronics, and partitioning.

■ Oracle Hardware Activation Files Overview

■ Downloading a New Hardware Activation File

■ Installing a New Hardware Activation File

■ Deleting a Hardware Activation File

■ Displaying Current Hardware Activation Files

■ Displaying the Feature Audit Log

Oracle Hardware Activation Files Overview
A hardware activation file is a digitally signed Java archive (.jar) file containing a 
feature activation key. You must install one hardware activation file for each feature 
purchased. Once installed, the feature is added to the features already activated on the 
library.

As of SL8500 firmware FRS_8.31 and SLC 6.25, a single partitioning hardware 
activation file activates partitioning across an entire library complex.

Legacy Hardware Activation Files
For SL8500 libraries with firmware before version FRS_7.00, Oracle support 
representatives must install hardware activation files. In addition, all purchased 
features are included in a single hardware activation file. When a new hardware 
activation file is installed on the library, it replaces older activation files.

After you upgrade a SL8500 library to firmware version FRS_7.00 and above, use the 
processes described in this chapter to activate any new features.

Hardware Activation File Installation Overview
1. Purchase the feature from Oracle.

2. Download the file from the Oracle Software Delivery Cloud and save it to a 
system accessible to your SLC session. See "Downloading a New Hardware 
Activation File" on page 2-2.
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3. Install the file using SLC. See "Installing a New Hardware Activation File" on 
page 2-2.

4. Configure the new feature. See:

a. Chapter 3, "Capacity Activation" 

b. Chapter 4, "Library Partitioning"

c. Chapter 5, "Redundant Electronics".

Downloading a New Hardware Activation File
1. Go to the Oracle Software Delivery Cloud at: http://edelivery.oracle.com/

2. Click Sign In /Register.

3. On the Terms & Restrictions screen. Read the License Agreement and Export 
Restrictions, and select the check boxes to indicate your acceptance. Click 
Continue.

4. On the Media Pack Search screen:

a. In the Select a Product Pack list, select Oracle StorageTek Products.

b. In the Platform list, select Generic Platform.

c. Click Go.

5. Select the SL8500 hardware activation file media pack. Click Continue.

6. Verify that you have selected the correct media pack. Click Download beside each 
feature purchased. 

7. Save the file.

8. Extract the files to a location accessible to your SLC session.

Installing a New Hardware Activation File
1. Complete the steps in "Downloading a New Hardware Activation File" on 

page 2-2.

2. Use SLC to log in to the target library.

3. Select Tools > Hardware Activation.

4. Click the Install Hardware Activation Keys tab. 

5. Enter the full path of the hardware activation file to install, and press Enter. 
Optionally, click Browse and navigate to the file location.

6. Review the hardware activation file details. Click Install.

7. Click Yes, and then OK.

8. Verify that the activation file has been installed and activated successfully (see 
"Displaying Current Hardware Activation Files" on page 2-3). 

Depending on the feature activated, you may need to perform additional tasks to 
use the new feature (refer to the feature-specific chapter within this guide).



Displaying the Feature Audit Log

Hardware Activation Files 2-3

Deleting a Hardware Activation File
Deleting a hardware activation file is rarely necessary and can impact library 
operations. Having extra hardware activation files installed on a library does not cause 
problems (for example, capacity activation files that exceed the physical capacity of the 
library). The extra activation files are simply not used. 

1. Use SLC to log in to the target library.

2. Click Tools > Hardware Activation.

3. Click the Delete Hardware Activation Files tab.

4. Click the activation file to delete.

5. Verify the correct activation file is selected, and click Delete...

6. Click Yes.

Depending on the feature of the hardware activation file, you may need to 
perform additional tasks after deleting the file (see "Deleting a Partition 
Definition" on page 4-4).

Displaying Current Hardware Activation Files
Use SLC to display the features currently activated on a target library. 

As of SL8500 firmware FRS_8.31 and SLC 6.25, all hardware activation files for a 
library complex are shown on a single screen. There is no need to log in to individual 
libraries to view hardware activation files for that library.

1. Click Tools > Hardware Activation

2. Click the Current Hardware Activation Keys tab.

Displaying the Feature Audit Log
The Feature Audit Log displays a list of all feature activation activity for the life of the 
library. Use this log to verify the features installed on the library.

By default, the report is sorted in chronological order. Optionally, you can change the 
sort order and rearrange and re-size the columns (see "Modifying a Tabular Display" 
on page 1-3).

1. Select Tools > Reports.

2. Expand the Audit Logs folder, and then click Feature Audit Log. 
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3Capacity Activation

There are two types of capacity: physical and active. Physical capacity is the number of 
storage cells in the library. Active capacity is the number of storage cells activated with 
a hardware activation file. The active capacity does not have to equal the full number 
of physical storage cells.

■ Active Capacity Configurations

■ Capacity Activation in Non-partitioned Libraries

■ SLC Capacity Icons

■ Activating Capacity using SLC

Active Capacity Configurations
The purchased capacity can be activated in a default configuration or a customized 
configuration. Coordinate with other library users before configuring the library to 
prevent conflicts.

Default Configuration
For a non-partitioned single library with a single host, the SL8500 library controller 
can automatically activate the amount of cells you purchased after you reboot the 
library. As of FRS_8.31, the default configuration activates capacity from the center-out 
until the capacity license is exhausted.

Customized Configuration
For non-partitioned libraries, see "Configuring Active Capacity in a Single Library" on 
page 3-3 and "Configuring Active Capacity in a Library Complex" on page 3-4.

For partitioned libraries, capacity is automatically applied to the entire partition. The 
total number of storage cells allocated to all library partitions cannot exceed the 
purchased capacity of the library (see "Library Partitioning" on page 4-1).

Guidelines for Customized Activation
■ Select storage resources in the largest blocks possible (rails, library sides, or library 

walls). Avoid selecting individual drives and storage cell arrays.

■ For best access to drives, activate library inner and outer library walls together and 
activate storage cells that are near the tape drives.

■ When rapid import and export of cartridges is a priority, activate storage cells that 
are near the Cartridge Access Ports (CAPs).
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Capacity Activation in Non-partitioned Libraries
In non-partitioned libraries, be careful in changing the active status of cells because 
this may cause orphaned cartridges. A cartridge becomes orphaned when it is 
inaccessible to the host. This may occur if you: 

■ Change the active capacity status of a non-partitioned library

■ Manually move a cartridge to an inactive or otherwise inaccessible cell

You must resolve orphaned cartridges. SLC warns about orphaned cartridges and 
provides detailed identifying information. You can then resolve the orphaned 
cartridges by performing recovery moves on the listed cartridges (see "Moving 
Cartridges (Recovery Moves)" on page 9-4).

Capacity Activation in HLI Hosted Libraries
After activating capacity, in a non-partitioned single library or a library in a complex 
attached to an HLI host, the library will temporarily go offline upon reboot and then 
come back online. While offline, the library stops accepting new incoming host jobs, 
but will complete the jobs already accepted. There is no need to disconnect and 
re-connect the HLI host.

The library controller sends an asynchronous message to any host, notifying them that 
the library configuration has changed. ACSLS hosts must perform an audit of a 
non-partitioned library to account for the new capacity. Hosts can continue processing 
jobs while the audit takes place. 

SLC Capacity Icons
The icons used for single library capacity configuration differ greatly from those used 
for complex capacity configuration.

Table 3–1 Single Library Capacity Icons

Icon Description

 (white rectangle) Inactive — cell not yet licensed for use

 (white rectangle with triangle) Active — cell licensed for use

 (purple rectangle) Selected — cell designated for activation or deactivation

 (dark red rectangle) No Activation Needed — resource is active by default

Table 3–2 Library Complex Capacity Icons

Icon Description

 (white rectangle)
Unallocated — cell not yet licensed for use

 (red rectangle)
Allocated — cell licensed for use.

 (black border)
Selected — cell designated for activation or deactivation
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Activating Capacity using SLC
Capacity changes cannot be performed at the local operator panel. 

No changes are committed to the library controller database unless you click Apply at 
the top of the screen and confirm your choice. If you log off the SLC session, if the 
session times out, or if the connection to the library is lost before you save changes, 
any changes will be lost. At any time, you can discard changes and restore the last 
saved configuration by clicking Refresh.

Configuring Active Capacity in a Single Library
For a single library you can design the active cells configuration or display an active 
cells report.

Designing the Active Cells Configuration in a Single Library
You can either accept the default configuration or choose your own.

1. Select Tools > Select Active Cells.

2. Click the Design By Library tab.

3. To apply a default capacity configuration and remove drives from the media 
validation pool, click Apply Default Capacity. Go to Step 6. 

To configure a custom capacity design, go to Step 4.

4. To customize the capacity design, choose areas of the library from the menus and 
click Add or Remove.

5. When you have completed the configuration, click Apply User Design.

6. Click Yes. If there are no warnings, click OK. Continue to Step 8.

7. If there are warnings, click Details >>

If orphaned cartridges are reported, do not continue with this process until you 
have performed recovery moves on the listed cartridges (see "Moving Cartridges 
(Recovery Moves)" on page 9-4).

8. Reconfigure library host applications to recognize the changes (see the tape 
management software documentation).

Displaying Active Cells Report
These reports only display data saved to the library controller database.

1. Select Tools > Select Active Cells, then select the View Reports tab. 

2. Select a report:

■ Cartridge and Cell Media Summary - displays cell addresses and volume 
serial numbers (volsers) for the media in each partition

■ Orphaned Cartridge Report - displays a detailed list of all orphaned 
cartridges

3. To save a report to a comma-separated value (csv) file, click Save to File.

Note: Capacity is automatically applied in a partitioned library. You 
may only apply capacity to a non-partitioned library.
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Configuring Active Capacity in a Library Complex
The smallest capacity activation increment is a quarter rail for a maximum of 16 
regions per library. The Capacities section displays purchased, allocated, and 
unallocated capacity values for the entire library complex. The figure below shows a 
sample of the SLC interface for rail 1 of library 1 in the complex. 

Figure 3–1 Library Complex Capacity Activation SLC Interface

Figure Legend:

1. Active half rail (allocated capacity)

2. Inactive quarter rail (unallocated capacity)

3. Selected inactive quarter rail

Designing the Active Cells Configuration in a Library Complex
1. Select Tools > Active Cells.

2. To customize capacity, select areas of the library. Red sections indicate activate 
capacity. White sections indicate inactive capacity. Options are:

■ Full Library — selects the full library

■ Rail 1 Left, Rail 1 Right, Rail 2 Left, and so on — selects a half rail

■ Outside Wall or Inside Wall — selects a quarter rail

3. Click Add or Delete to modify the configuration. 

4. When you have completed the configuration, click Apply User Design.

5. Click Yes. If there are no warnings, click OK. Continue to step 7.

6. If there are warnings, click Details >> 

If orphaned cartridges are reported, do not continue with this process until you 
have performed recovery moves on the listed cartridges (see "Moving Cartridges 
(Recovery Moves)" on page 9-4).

7. Reconfigure library host applications to recognize the changes (see the tape 
management software documentation).

Note: Clicking Reset Capacity removes the current capacity 
configuration and all drives from the media validation pool, requiring 
you to create a custom capacity design (see step 2).
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4Library Partitioning

Library partitioning reserves library resources (drives and cells) for the exclusive use 
of specified hosts, and is an optional feature enabled with a hardware activation file 
(see "Hardware Activation Files" on page 2-1).

Partitions support non-contiguous resource assignments. However, CAPs are a shared 
library resource and are not assigned to specific partitions. You can partition a single 
library or a library complex using SLC. 

■ Single Library versus Library Complex Partitioning

■ Affect of Partitioning on Active Capacity

■ Host Access to Partitions

■ Planning and Preparations for Partitioning

■ Partitioning to Maximize Library Performance

■ Partitioning the Library Using SLC

■ Overriding a CAP Reservation of a Partition

Single Library versus Library Complex Partitioning

Single Library Partitioning
■ Up to eight partitions.

■ Smallest slot increment is one array.

■ Smallest drive increment is one drive.

■ Requires minimum SL8500 firmware FRS_7.01 and SLC 5.50.

Library Complex Partitioning
■ Up to 16 partitions total, with a maximum of eight per library.

■ Smallest slot increment is a quarter rail.

■ Smallest drive increment is one drive.

■ Partition boundaries can span across pass-thru ports (PTPs).

■ Requires minimum SL8500 firmware FRS_8.31 and SLC 6.25.

■ Requires the following minimum level for library management software:

– ACSLS 8.3, HSC 6.2: PTF L1H16SG (VM), ELS 7.0: PTF L1H15SI (MVS), ELS 
7.1: PTF L1H16SJ, ELS 7.2: integrated
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Affect of Partitioning on Active Capacity
As you allocate cells to a partition, the library controller automatically activates these 
cells. The number of cells allocated to each partition is subtracted from the total 
purchased capacity authorized in the hardware activation files. The total cells allocated 
to partitions can never exceed the purchased capacity of the library. Therefore, ensure 
there is enough purchased active capacity for your partitioning design.

For more information about hardware activation files, see Chapter 2, "Hardware 
Activation Files".

Host Access to Partitions
A host that has access to a partition is granted use of all available storage cells, 
cartridges, and drives in that partition. The host has no access to resources that are 
assigned to other partitions in the library.

Individual ACSLS hosts can control one or more SL8500 library partitions. Individual 
HSC hosts and groups of up to 16 HSC hosts that share a database can control a single 
partition.

CAPs in a Partitioned Library are a Shared Resource
In a partitioned library, hosts share CAPs. Each host reserves the CAP for exclusive use 
as needed, then releases the CAP when it is no longer required. A host can reserve a 
CAP if the CAP is empty, closed, locked, and not already reserved by another 
partition. CAP auto enter mode is disabled in partitioned libraries, because it interferes 
with the reservation system (see "Auto Enter Mode" on page 7-1).

Once the enter or eject operation is complete, the host releases the reservation and 
makes the CAP available to other host partitions. Then, either the user terminates the 
enter command or the host automatically terminates the command. The library 
releases the CAP after verifying that the CAP is closed and empty.

If for any reason a CAP reservation is not released and the enter or eject command 
cannot be terminated in ACSLS or HSC on the host, a library administrator must 
override the host partition reservation (see "Overriding a CAP Reservation of a 
Partition" on page 4-6).

Planning and Preparations for Partitioning
You should verify minimum firmware and SLC requirements for partitioning. Then, 
configure and administer ACSLS and HSC host software applications. Before creating 
a partition, verify the physical configuration and resolve any orphaned cartridges.

Verifying the Physical Configuration of a Partition
Before creating partitions, verify that all tape drives and cartridges have been moved 
to the proper location. For example, if a partition will be owned by an ACSLS host, 
only ACSLS-compatible drives can be installed in that partition, and all cartridges 
containing data for the ACSLS host must be migrated to the partition.

Resolving Orphaned Cartridges
An orphaned cartridge is a cartridge which is inaccessible to a host. Orphaned 
cartridges can occur when you change the capacity of a partition, delete a partition, or 
move a cartridge to a cell or drive that is not allocated to a partition.
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In a partitioned library, orphaned cartridges can cause data loss. A host that finds an 
orphaned cartridge in its partition may treat the cartridge as a scratch volume and 
overwrite the data. 

SLC will warn you when it identifies orphaned cartridges. Resolve the orphaned 
cartridges by performing recovery moves on listed cartridges. Recovery moves 
transfer the orphaned cartridges to accessible locations within their parent partitions 
(see "Moving Cartridges (Recovery Moves)" on page 9-4).

Partitioning to Maximize Library Performance
Use the following resource allocation guidelines to minimize contention between host 
applications and maximize performance:

■ Select storage resources in the largest blocks possible (rails, library sides, or library 
walls). Select complete library rails to minimize the use of elevators. In a library 
complex, keep a partition contained within a library to minimize the use of PTPs.

■ For best access to drives, activate library inner and outer library walls together.

■ Avoid selecting individual drives and storage cell arrays. Individually select and 
deselect resources only when you need to fine-tune a capacity that has already 
been broadly defined in larger blocks.

■ For quicker enter and ejects, partition storage cells close to the CAPs. For quicker 
access to stored data, partition storage cells close to the drives.

Identifying workloads can improve library performance. Generally, a workload is 
defined as a group of tape drives and cartridges used for a particular application. To 
maximize the performance of the SL8500 library: 

■ Minimize elevator operations between rails within a library and pass-thru 
operations between libraries. Limit the distance cartridges must travel.

■ Minimize contention for library resources between different application requests.

■ Configure the library so each workload uses a separate pool of library resources 
(tape drives, data tapes, scratch tapes, and free cells). Group workload resources as 
close together to minimize PTP and elevator activity.

■ Place applications that require significant enters and ejects on rails adjacent to 
CAP magazines. Inactive tapes should be placed on the top rail. These tapes are 
not entered or ejected frequently, and the top rail is not directly adjacent to a 
rotational-CAP magazine.

■ Put different types of tape drives on different rails to reduce pass-thru activity.

■ Ensure there are enough tape drives and storage cells to support a workload.

Partitioning the Library Using SLC
■ "Preparing for Partitioning" on page 4-4

■ "Adding or Deleting Partition Definitions" on page 4-4

■ "Allocating and Verifying Resource in a Partition for a Single Library" on page 4-5

■ "Allocating and Verifying Resources in a Partition for a Library Complex" on 
page 4-5

■ "Committing Partitioning Changes" on page 4-6

■ "Generating Partitioning Reports (Single Library Only)" on page 4-6
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Preparing for Partitioning
1. Quiesce any host operations.

Host applications such as library management software (ACSLS, ELS) and data 
management software (backup and archiving applications) should not try to use 
the library during partitioning.

2. Select Tools > Partitions.

3. Review the Instructions (Step 1) tab.

Adding or Deleting Partition Definitions
Use these procedures to add or delete partition definitions.

Adding a Partition Definition
1. Select the Summary (Step 2) tab of the Partitions utility.

2. On the left side of the screen, note:

■ Total Library Resources (storage cells, drive bays, CAPs and CAP cells and 
activated capacity)

■ Resources Allocated (assigned to a partition)

■ Resources Unallocated (not assigned to a partition)

3. In the Partition Allocation Summary area, click Add Partition.

4. Select a partition ID from the menu or enter a partition name.

5. Click OK.

6. Repeat steps 3-5 until you have added all required partitions.

Deleting a Partition Definition
When you delete a partition:

■ All resources allocated to the partition are marked available.

■ All host connections for the partition are deleted.

■ The partition ID is deleted.

Use this procedure to delete a partition from the library.

1. To prevent orphaned cartridges, move valid data cartridges out of the partition 
that will be deleted.

2. Select the Summary (Step 2) tab of the Partitions utility.

3. In the Partition Allocation Summary area, select the table row of the partition to 
delete.

4. Click Delete Partition.

5. Make sure the partition number is correct. Click OK.

6. For a library complex, proceed to step 7. For a single library, click the Design by 
Library (Step 3) tab. Then, click Verify.

Note: No actual changes to partitioning occur until the design is 
applied using the Commit (Step 4) tab.
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7. If there are warnings, click Details >>

If orphaned cartridges were found, perform recovery moves on all listed volumes. 
See "Moving Cartridges (Recovery Moves)" on page 9-4. After you have resolved 
all orphaned cartridges, re-verify the partitioning configuration.

8. If there are no warnings, commit the partition design. See "Committing 
Partitioning Changes" on page 4-6.

Allocating and Verifying Resource in a Partition for a Single Library
Use this procedure to allocate and verify library resources to partitions in a single 
library. For a library complex, see "Allocating and Verifying Resources in a Partition 
for a Library Complex" on page 4-5.

1. Select the Design by Library (Step 3) tab of the Partitions utility.

2. Use the list control to select a partition ID.

3. Select the sections of the library to add to the partition using the menus:

■ All Rails, Rail 1, Rail 2, Rail 3, or Rail 4 — defines the rail of the selection

■ Left/Right Sides, Left Side, or Right Side — defines the side of the selection

■ Inside/Outside Walls, Inside Wall, or Outside Wall — defines the wall of the 
selection

4. Click Add to allocate the specified resources to the partition. Click Remove to 
un-allocate the resources from the partition.

5. To refine the partition, select Remove Array or Add Array from the rails menu. 
Then, click the drive(s) and array(s) to add/remove them from the partition.

6. Repeat steps 2 - 5 for each partition ID.

7. When you complete the partition design, click Verify.

8. If there are warnings, click Details>>

If orphaned cartridges were found, perform recovery moves on all listed volumes. 
See "Moving Cartridges (Recovery Moves)" on page 9-4. After you have resolved 
all orphaned cartridges, re-verify the partitioning configuration.

9. If there are no warnings, see "Committing Partitioning Changes" on page 4-6.

Allocating and Verifying Resources in a Partition for a Library Complex
Use this procedure to allocate resources to partitions in a library complex. For a single 
library, see "Allocating and Verifying Resource in a Partition for a Single Library" on 
page 4-5.

1. Select the Design (Step 3) tab of the Partitions utility.

2. Select the partition.

3. Select the resources of the library to include in the partition.

■ Rail 1 Left, Rail 1 Right, Rail 2 Left, and so on — selects half a rail.

■ Full Library — selects the entire library

■ Outside Wall or Inside Wall — selects a quarter rail

To un-highlight areas, select any of the above again.
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4. Click Add to allocate the selected resources to the partition. Click Delete to 
remove the selected resources from the partition.

5. Repeat steps 2-5 for each partition.

6. Commit the partition design. See "Committing Partitioning Changes" on page 4-6.

Committing Partitioning Changes
No changes are made to the library partitioning configuration until you complete 
these procedures.

1. When all partitions are configured, select the Commit (Step 4) tab.

2. Click Apply.

3. If there are no warnings, click OK. If there are warnings, click Details >>.

If orphaned cartridges were found, perform recovery moves on all listed volumes 
before committing partitioning changes. See "Moving Cartridges (Recovery 
Moves)" on page 9-4. 

Generating Partitioning Reports (Single Library Only)
1. Select the Reports tab of the Partitions utility.

2. Select a type of report from the menu:

■ Cartridge Cell and Media Summary — displays cell addresses and volume 
serial numbers (volsers) for the media in each partition

■ Orphaned Cartridge Report — displays cell addresses and volume serial 
numbers (volsers) for orphaned cartridges

■ Partition Summary — displays the resources allocated to each partition

■ Partition Details — displays details for a specific partition ID

3. Click Print to print the report or click Save To File to create a comma-separated 
value (csv) file.

Overriding a CAP Reservation of a Partition
If a CAP reservation by a partition is not released and the enter or eject command 
cannot be terminated in ACSLS or HSC on the host, use this procedure to override an 
existing CAP reservation.

1. Select Tools > Diagnostics.

2. Expand the CAP folder. Click the reserved CAP to override.

3. Click the Unreserve tab. Note the partition ID for the CAP.

4. Click Apply to override the reservation.

5. Select OK. The CAP user changes to "default", which makes the CAP unavailable 
to all partitions.

6. If the CAP is locked, unlock it. See "Locking/Unlocking a CAP" on page 7-3.

Note: You must follow all steps in this procedure, or the CAP could 
be left unavailable to all partitions.
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7. Open the CAP. Remove any cartridges and label them with the partition ID.

8. Close the CAP. The library verifies the CAP is empty. The CAP status changes to 
"unreserved", which makes the CAP available to all partitions.

9. Determine if the cartridges should be re-entered into the library and enter the 
cartridges into the correct partition.
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5Redundant Electronics

The optional redundant electronics (RE) feature provides failover protection for the 
library controller. This allows an Oracle support representative to replace a faulty 
controller card while the library is online and provides minimal disruption to library 
operations during firmware upgrades.

■ Redundant Electronics Requirements

■ Redundant Electronics Overview

■ Controller Card Status Overview

■ Displaying Redundant Electronics Information

■ Performing a Manual Redundant Electronics Switch

Redundant Electronics Requirements
■ Two library controller cards (HBC) 

■ Two drive controller cards (HBT) 

■ Minimum SL8500 firmware version FRS_6.00 and SLC version 4.65

■ Hardware activation file (see Chapter 2, "Hardware Activation Files")

Redundant Electronics Overview
If the library controller or drive controller experiences errors, operations can switch to 
the standby controller, with minimal disruption to library and host operations. The 
library controller and drive controller installed on the same side of the card cage are 
always switched as a pair. Failover can be initiated automatically or manually. A 
failover cannot occur if: 

■ The standby library or drive controller is in a fault or eject state.

■ The standby code is not running on the standby library or drive controller cards.

■ A firmware download or card initialization is in progress.

In a failover, the active library controller attempts to complete all in-process jobs and 
copies the cartridge database to the standby controller card. If the database cannot be 
copied (usually only in a sudden failure), you must perform an audit after failover 
completes (see "Auditing the Library" on page 6-6). Any in-transit cartridges are 

Note: Any reference to the HBC card also refers to the HBCR card.
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returned to their home slots. If a cartridge cannot be moved to its home slot, it is 
moved to a library system cell. The host must return the cartridge to its home cell (see 
the ACSLS and ELS documentation).

After all in-process jobs have completed or timed out, the card roles are switched. 
Active software is brought up on the standby controller. This controller becomes active 
and the previously active controller becomes the standby. If the standby software 
cannot be brought up on the previously active controller, the controller enters a fault 
state.

Automatic Failover
An automatic failover can be initiated by either the active or standby library controller.

The active library controller initiates an automatic failover when:

■ Its partner drive controller card is not installed or it is not communicating.

■ It detects a catastrophic internal software error.

The standby library controller initiates an automatic failover if the active controller is 
not functioning normally.

Manual Failover
Before initiating a manual switch, you should verify that the standby library and drive 
controllers are running normally. You can initiate a manual switch using:

■ Host tape management (ACSLS or ELS): Failover can be initiated from either the 
active or standby library controller. The standby library controller accepts only set 
host path group and force switchover HLI requests.

■ SLC: Failover is initiated from the active library controller only (see "Performing a 
Manual Redundant Electronics Switch" on page 5-4).

■ CLI: Failover can be initiated from either the active or standby library controller. 
This function is only available to your Oracle support representative.

You may want to perform a manual switch after initial installation of the standby 
cards, after a firmware upgrade, or periodically to check that the failover function is 
working properly. It is not possible to manually switch the library controllers without 
the drive controllers — the controllers are always switched as a pair.

Network Connections
Each library controller card requires a unique IP address. For libraries with Dual 
TCP/IP, each card requires two unique IP addresses: one for the primary port (2B) and 
one for the secondary (2A) port. A library equipped with both RE and Dual TCP/IP 
requires four unique IP addresses.

The failover process is minimally disruptive to host operations.

■ Users of tape management software (Symantec or Virtual Storage Manager) do not 
see an interruption.

■ HLI host applications (ACSLS and ELS) queue requests during the failover process 
for completion after the failover switch. For ACSLS, only mount and dismount 
requests are affected (see the ACSLS and ELS documentation).

■ SLC and CLI connections are terminated. You must re-establish connections to the 
library using the IP address or DNS alias of the new active library controller (the 
former standby controller).
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Firmware Upgrades
Firmware upgrades for libraries with RE are minimally disruptive to library 
operations. New code is loaded and unpacked simultaneously on the active and 
standby controller cards and on all devices. The code is then activated, and the active 
and standby controllers and most devices are re-initialized. Under most circumstances, 
robot initialization is bypassed.

The loading, unpacking, and activation of code are not disruptive to library operations 
until the library is rebooted. During the reboot process (which takes approximately 10 
minutes), the HLI host applications (ACSLS and ELS) queue all mount and dismount 
requests. After the reboot is complete, the queued requests are submitted to the library 
controller.

See "Upgrading Library Firmware" on page 6-8 for firmware download and activation 
information.

Controller Card Status Overview
Controller card status is indicated by LEDs on the card and displayed in SLC.

Controller Card LEDs
The LEDs and meanings are the same on both card types (HBC and HBT).

SLC Status of Controller Cards
Some SLC screens identify the individual library controller with an A or B suffix. "A" 
indicates the left card slot and "B" indicates the right card slot, as viewed from the back 
of the library. To display the status the controller cards in SLC, see "Displaying 
Redundant Electronics Information" on page 5-4.

Table 5–1 LED Status Indicators

LED Definition

ACTIVE - Green Card is functioning as the active and is running active code.

STANDBY - Amber Card is functioning as the standby and is running standby code.

FAULT - Red Card has experienced a serious error.

EJECT OK - Blue Support representative can safely initiate a card eject. 

Table 5–2 SLC Controller Card Statuses

Status Definition

Duplex: Software ready, 
switch possible

Active library controller is functioning normally.

Not installed Card is not installed in the library.

Ok Active or standby drive controller card is functioning normally.

Pre-standby:

Software not ready

Standby library controller card is loading standby code and is not 
ready to be used in an automatic failover or manual switch.

Standby: 

Software ready

Standby library controller card is functioning normally and can be 
used for an automatic failover or manual switch.
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Displaying Redundant Electronics Information
1. Select Tools > System Detail.

2. Click the Redundant Electronics folder to display summary information. 

3. For detailed information about each card, expand the Redundant Electronics 
folder in the navigation tree.

4. Select a card (see "SLC Status of Controller Cards" on page 5-3 for status 
meanings):

a. hbca: Library controller, A (left) slot

b. hbcb: Library controller, B (right) slot

c. hbta: Drive controller, A (left) slot

d. hbtb: Drive controller, B (right) slot

Performing a Manual Redundant Electronics Switch
This procedure is not available at the local operator panel.

1. Verify the device state of the card indicates "switch is possible" (see "Displaying 
Redundant Electronics Information" on page 5-4).

2. Select Tools > Diagnostics.

3. Select the Redundant Electronics folder

4. Click Apply to begin the switch process. If there is a problem with the standby 
library and drive controller cards, you are not allowed to continue with the switch.

5. If there are no errors, click Yes.

6. Click OK to log off the SLC.

7. Wait until the switch is complete before logging back into the library. You must 
specify the IP address or DNS alias of the new active controller.
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Library management tasks include monitoring library and device status, upgrading 
firmware, performing diagnostic tests, generating diagnostic files, rebooting the 
library, placing the library online or offline, and auditing the library.

■ Library and Device Status Overview

■ Clearing Library Status Alerts

■ Displaying Library Information

■ Generating Library Diagnostic Files

■ Performing a Library Self-Test

■ Auditing the Library

■ Upgrading Library Firmware

■ Rebooting the Library

■ Placing the Library Online or Offline

Library and Device Status Overview
SLC shows health status for devices, SLC communication, and the library. Refer to 
Figure 1–1 for the location of the various indicators in SLC.

Health Status of a Device
Found in the navigation tree of System Details and Diagnostics page.

■ Normal — library device is functioning normally

■ Warning — device is offline or operating in a degraded state

■ Error — device has experienced a failure

Table 6–1 Status Indicators

Icon Meaning

Normal

Warning

Error
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Communication Status
Found in the lower left of all SLC screens. Indicates the communication status between 
SLC and the library controller.

■ Normal — SLC is communicating normally with the library controller

■ Warning — server is taking longer than 10 seconds to respond

■ Error — server is taking longer than 30 seconds respond

After about 30–60 seconds of lost communication with the library controller, the 
heartbeat monitor turns gray, then red, and displays:

Heartbeat message not received from the library controller.

Log off the SLC and log on again to restore communication.

Health Status of the Library
Found in the lower right of all SLC screens.

■ Normal — all library devices are functioning normally

■ Warning — one or more library devices is offline or operating in a degraded state

■ Error — one or more library devices has experienced a failure

After a device error is fixed, the library health indicator changes to "Warning". The 
indicator will not change to "Normal" until the library is taken offline. If there are 
multiple problems with a device or status alert condition, the health indicator 
displays the most severe condition.

Clearing Library Status Alerts
You can only clear alerts marked as "Clearable" and only if service is active on the 
library.

Clearing an alert only removes it from the Status Module display; it does not resolve 
the underlying cause. The library health indicator returns to "Normal" if there are no 
other device or status alerts. If the alert is subject to periodic updates, it will reappear 
at the next update cycle. 

1. Select Tools > System Detail, and click the Library folder.

2. Click the Status tab, and then the Status Module tab.

3. On the Clear Alert Number list, select the alert number to clear, and then click 
Apply.

Displaying Library Information
■ Displaying Library Status

■ Display Library Properties

■ Viewing Library Reports

■ Displaying Library Power Supply Information

Displaying Library Status
1. Select Tools > System Detail, and then click the Library folder in the navigation 

tree.
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2. Click the Status tab.

3. Select a secondary tab:

■ General - displays the current operational state of the library. These values 
update whenever there is host activity, background operations, or operator 
activity.

■ Complex - displays the current operational state of a library complex.

■ Status Module - displays library status alerts. This feature is available only if 
service is active on the library. If service is not active on the library, this screen 
will be blank except for a message indicating that the "Service activation is not 
valid". If you see the "warning" status, a failure may occur. Contact a service 
representative.

■ HLI - displays the current status of all HLI interface ports on the library. 
Information includes the local TCP/IP socket, local IP, connection status, port 
status, and transmission sent and received from the time of connection.

■ Internal Networks - displays port status

Display Library Properties
1. Select Tools > System Detail, and then click the Library folder.

2. Click the Properties tab.

3. Select a secondary tab:

■ General - displays the physical, mechanical, logical, and network 
configuration of the library. Some of the information can be set up 
automatically during library initialization, while other information can be 
defined by the user.

■ Complex - displays IP address information for a library complex.

■ Library Controller - displays details of the library controller, including the 
serial number and firmware versions.

■ Drive Controller - displays details of the drive controller, including the serial 
number and current firmware versions.

Viewing Library Reports
Use this procedure to display, search, or save library reports available from the Tools > 
Reports menu. Additional reports are available from the Tools > Partitions menu.

All report output is a static display of information at the time the report is generated. 
Click Update in the upper right corner to refresh the information.

1. Select Tools > Reports.

2. In the navigation tree, expand a report category.

3. Select a report.

Note: Running multiple instances of SLC on the same workstation 
can cause inconsistent data on reports. It is recommended that only 
one user at a time produce SLC reports.
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Search a Library Report
1. With the report displayed, click Search.

2. Enter a text string (case-sensitive and wildcards are invalid). Click Search.

Save Library Report Data to a File
1. With the report displayed, click Save.

2. Browse to the desired directory, enter a file name, select a format, and click Save.

Display Library Events Statistics
The General Events Statistics Report displays summary statistics for library 
operations. For each event, the report lists the event type, number of occurrences, and 
the date and time of the most recent occurrence of the event.

To change the sort order of the screen or rearrange and resize the columns, see 
"Modifying a Tabular Display" on page 1-3.

1. Select Tools > Reports.

2. Expand the Statistics folder, and then click General Events.

Displaying Library Power Supply Information
For power configuration information, see the SL8500 Systems Assurance Guide "Power" 
chapter found on OTN.

The Power Supply Data screen displays summary information for all power supplies 
in the library. Use this screen to monitor the status of the power supplies for 
maintenance or replacement. By default, the display is sorted by internal address. To 
change the sort order, and rearrange and resize the columns, see "Modifying a Tabular 
Display" on page 1-3.

1. Select Tools > System Detail.

2. In the Library navigation tree, click the Power Supply folder to display summary 
information.

3. For detailed information, expand the Power Supply folder. Select a power supply.

Generating Library Diagnostic Files
These procedures generate files to diagnose library problems.

■ Transferring the Library MIB File

■ Generating and Transferring the Library Log Snapshot File

Transferring the Library MIB File
Use this procedure to transfer the public SNMP management information base (MIB) 
file to an Oracle support representative.

1. Select Tools > Diagnostics.

2. Click the Library folder in the navigation tree.

3. Click the TransferFile tab.

4. Select the Transfer Type of SNMP MIB. Click Transfer File.

5. Browse to the desired directory, and then enter the file name with a .txt suffix.
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6. Click Save.

7. E-mail the file to your Oracle support representative.

Generating and Transferring the Library Log Snapshot File
If a support representative requests a library Log Snapshot, use this procedure to 
generate and transfer the file. The system saves the file in an encrypted format, so you 
cannot view or edit it. You must save the log within 15 minutes of generation.

1. Select Tools > Diagnostics.

2. Click the Library folder in the navigation tree.

3. Click the Transfer File tab.

4. Select the Log Snapshot option.

5. In the Selected Devices list, select either All Devices or Selected Device. If you 
choose Selected Device, select the device.

6. Click Generate Log Snapshot on Library.

7. Click Yes, and then OK.

8. Click Transfer Log Snapshot To Your Computer.

9. Browse to the desired directory or enter the directory path. Click Save. The file is 
named automatically.

10. E-mail the file to your Oracle support representative.

Performing a Library Self-Test
The self-test diagnostic can help diagnose library operational problems. A self-test 
typically runs after the library is installed. You can run library self-test routines in 
either non-disruptive (cartridges are returned to home cells) or disruptive mode 
(cartridges may be moved to new cells).

When performing a self-test, the system:

■ Checks the communication path between the library controller, drives, elevators, 
and robots.

■ Performs get and put operations to check the health of the robots, elevators, and 
CAPs. This includes get and put operations from a reserved system cell to a 
random empty storage cell or CAP cell.

■ Performs a full library audit.

■ Performs mounts and dismounts of diagnostic cartridges for all the drives 
installed in the library. The self-test does not begin unless a diagnostic cartridge is 
found in the system cells. If the system finds a compatible diagnostic cartridge, the 
self-test repeats for each drive type. If the system does not find a diagnostic 
cartridge for a drive type, the system skips the mount/dismount operation for the 
drive.

1. Make sure the proper drive diagnostic cartridges are in the library (see 
"Displaying Cartridge Information" on page 9-3).

 Note: Before performing a disruptive test, the library must be taken 
offline. See "Placing the Library Online or Offline" on page 6-9.
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2. Select Tools > Diagnostics, and click the Library folder.

3. Click the SelfTest tab.

4. In the Mode list, select the type of self-test:

■ Non-Disruptive - all cartridges used in the test are returned to their original 
locations

■ Disruptive - the library must be taken offline to all hosts before running this 
test

5. Click Run. When the test completes, the results of the test display. 

6. For disruptive tests, bring the library online to resume normal operations.

Auditing the Library
■ Performing a Physical Audit

■ Performing a Verified Audit

An audit is the process of cataloging or verifying cartridge locations within a library 
and updating the cartridge database. The database contains the volume ID (vol-id or 
volser), current location (in library internal address format), and verified status (true 
or false). 

You can use the SLC to perform a physical audit, verified audit, or virtual audit. A 
virtual audit displays a report listing the contents of the cartridge database. Audit 
times vary according to the type of audit, size of the library, the number of robots, and 
the speed of the scan engine for the barcode scanner.

The library performs an audit when:

■ One or both access doors have been opened and closed.

■ An audit request is made through the SLC.

■ A host request to audit the library is entered. (System-level problems may occur if 
a host's record of the cartridge does not match what is in the cartridge database of 
the library controller.)

■ The library initializes at start up.

Audit Indicator
To indicate an audit is in progress, the SLC displays a spinning indicator and the 
message "Audit in progress". When you see this indicator do not open the library 
access door. This will cause the audit to restart.

The audit indicator only displays when an audit is initiated automatically (library 
access door has been opened and closed, library power up or reboot). The indicator 
does not display for audits initiated from SLC or the host.

Performing a Physical Audit
In a physical audit, the robot visits cartridge locations and records the vol-id of the 
cartridges. The library controller updates the cartridge database based on the physical 
audit. This audit changes the "verified" status of the cartridge locations to true.

You can manually initiate a physical audit for either the entire library or a specific 
range of cells.
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Auditing the Entire Library
The robot verifies all cells (storage, CAP, drive, reserved). Although an entire library 
audit is a background process and does not interrupt library operations, it does require 
sharing of robot resources. It is not recommended that you run this audit during peak 
activity periods.The audit takes approximately 1/2 second per cartridge slot.

After a few hours of the audit, you can view the Cartridge Summary report for the 
latest cartridge locations and vol-ids. See "Viewing Library Reports" on page 6-3.

1. Select Tools > Diagnostics.

2. Click the Library folder on the navigation tree.

3. Click the Audit tab.

a. In the Entire Library section, click Yes.

b. Click Audit.

4. Click OK to begin the audit.

Auditing a Range of Cells
During this audit, the library verifies only a specific range of storage cells (including 
the CAP and drives). The audit information is displayed on the SLC while the audit is 
performed. After the audit completes, view the Cartridge Summary report for the 
latest cartridge locations and vol-ids. See "Viewing Library Reports" on page 6-3.

1. Select Tools > Diagnostics.

2. Click the Library folder on the navigation tree.

3. Click the Audit tab.

a. In the Entire Library section, click No.

In the Physical Audit section, select Yes. 

In the Verified Audit section, select No.

b. In the Start Address and End Address sections, select the device types to audit 
and the internal address locations.

c. Click Audit.

4. Click OK to begin the audit. The Audit Console section displays the progress of 
the audit. 

Performing a Verified Audit
A verified audit validates the status of a specific cartridge location or range of 
locations (including CAPs and drives) in the cartridge database. If a cartridge address 
has a verified status of false, a physical audit of that location is performed and the 
cartridge database is updated.

1. Select Tools > Diagnostics.

2. Click the Library folder on the navigation tree. 

3. Click the Audit tab.

a. In the Entire Library section, select No. 

Note: You cannot stop a physical audit after it begins.
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In the Physical Audit section, select No. 

In the Verified Audit section, select Yes.

b. In the Start Address and End Address sections, select the device types to audit 
and the internal address locations.

4. Click Audit. The Audit Console section displays the progress of the audit.

Upgrading Library Firmware
To upgrade firmware, an Oracle service representative can use the SLC code load 
utility. You cannot perform a code download or activation at the local operator panel.

Library firmware does not contain drive code upgrades (see drive-specific 
documentation). Firmware upgrades for libraries with the redundant electronics 
feature are minimally disruptive (see Chapter 5, "Redundant Electronics"). 

Downloading Code to the Library Controller
1. Locate the firmware upgrade package (.jar file) at: http://edelivery.oracle.com

2. Download the code to your system.

3. Log in to SLC.

If you are upgrading an SL8500 complex, you can connect to any library in the 
complex. The upgrade simultaneously downloads to all libraries in the complex 
from a single SLC session.

4. Select Tools > Diagnostics, and then click the Library folder.

5. Click the Load Code tab.

6. Enter the full path of the firmware package to download, and then press Enter. 
Optionally, click Browse and navigate to the file location. 

7. Verify the contents and file name. Click Load.

8. Click OK. The download process could take up to 10 minutes.

9. After the code unpacks, activate the code at any time (see "Activating Code on the 
Library Controller" on page 6-8).

Activating Code on the Library Controller
Only Oracle service representatives should install new library firmware. Contact 
Oracle Support for assistance. A reboot of the library or entire library complex is 
required. Schedule the code activation accordingly.

 The library controller can store up to two versions of firmware, but only one is active. 
The active version is identified as "running". You can restore the earlier firmware 
version if required.

1. If you have not done so, download and unpack the code (see "Downloading Code 
to the Library Controller" on page 6-8).

Note: Next to the Failed label, you should see "0". If there are any 
failures indicated, contact your Oracle support representative for 
assistance.
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2. Select Tools > Diagnostics, and then click the Library folder.

3. Click the Activate Code tab.

4. In the Target list, select the code package to activate (in this case SL8500 Code).

5. In the Available Versions section, select the code version to activate.

6. Click Activate.

7. Click OK to start activation.

8. When the activation process finishes, click OK to reboot the library.

9. Click OK to terminate the SLC session.

10. After library initialization completes, log in to SLC.

Rebooting the Library
Use this procedure to reboot the library. This process involves reloading the firmware 
from flash memory and restarting the library controller.

1. Select Tools > Diagnostics.

2. Click the Library folder in the navigation tree.

3. Click Reboot. 

4. All other users must log off. Click OK. 

5. If the library is online, click OK to take the library offline. 

6. Click OK to reboot the library.

7. Click OK to terminate this SLC session. Do not log back in to the SLC until the 
library has fully initialized.

Placing the Library Online or Offline
Use this procedure only if you are not using ACSLS or ELS tape management 
software, or if ACSLS/ELS servers cannot communicate with the library. For 
instructions on changing the state of the library and its components through ACSLS or 
ELS, see the appropriate tape management software documentation.

■ Placing the Library Offline

■ Bringing the Library Online

■ Bringing the Drives Online

Placing the Library Offline
You may need to place the library offline at the following times:

■ Before powering down the library

■ Before opening a library access door

Caution: POTENTIAL INTERNAL FILE CORRUPTION. Do not 
reboot any devices in the library or execute any operations on the 
library while activating code.
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■ When the library is inoperative and requires maintenance

To place the library offline:

1. Take all library drives offline. See "Changing the Drive Online/Offline Status" on 
page 8-4.

2. Select Tools > System Detail.

3. Click the Library folder in the navigation tree.

4. Click the Status tab, and then the General tab.

5. In the Transition Request field, click Take offline. 

6. Click Apply. Before the library goes offline, all outstanding library jobs complete.

7. Wait for the offline confirmation message. If the library does not come offline, 
check the status of the library.

Bringing the Library Online
1. Select Tools > System Detail.

2. Click the Library folder in the navigation tree.

3. Click the Status tab, and then the General tab.

4. In the Transition Request field, click Bring online.

5. Click Apply.

6. If applicable, bring the library online to ACSLS and ELS hosts. See the ACSLS and 
ELS documentation.

Bringing the Drives Online
LTO drives are automatically brought online when you bring the library online. To 
bring T-series drives online manually:

1. To verify that the T-series drives are ready and online, press the MENU switch. 
The display should now read Online.

2. If the drive displays Offline, press the SELECT switch once to bring it online.

■ If the drive message indicates Online, the transition to online completed.

■ If the Onl Pend message appears, the online state is pending due to 
completion of diagnostic tests.

■ If other messages appear, refer to the drive documentation.
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7CAP Management

Cartridge access ports (CAPs) are used to enter or eject cartridges to or from the 
library. This chapter describes general CAP activities: 

■ CAP Modes

■ Recommendations for CAP Use

■ Displaying CAP Information

■ Changing the CAP Online/Offline Status

■ Locking/Unlocking a CAP

■ Performing a CAP Self-test

■ For partitioned libraries, see also "Overriding a CAP Reservation of a Partition" on 
page 4-6

CAP Modes

Auto Enter Mode
Only non-partitioned HLI libraries support the CAP auto enter mode.

Auto enter mode enables you to open a CAP and begin an enter operation without 
issuing an explicit enter request or having an explicit CAP reservation from a host 
application. However, to eject cartridges through the CAP, you still have to issue an 
explicit eject command.

Host applications manage the auto enter mode. To place a CAP in auto enter mode, 
enter the appropriate tape management command to unlock the CAP (see the tape 
management software documentation).

When in auto mode, a CAP is unlocked and its LED is on. The system locks the CAP 
only during cartridge enter, eject, or audit operations. To initiate an enter operation 
using an automatic CAP, press CAP Open on the key pad. 

Manual Mode
Manual mode is the most secure method of CAP operations. When in manual mode, 
the system locks a CAP by default, and its LED is off. To initiate an enter or eject 
operation using a manual CAP, you must enter an explicit enter or eject request before 
pressing CAP Open on the keypad.
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Recommendations for CAP Use
■ Whenever possible, enter cartridges through the CAP. Insert cartridges with the 

correct orientation. Slots in the CAP can be skipped when loading cartridges.

■ If only one CAP is required to do the job, do not open both CAPs. Opening both 
CAPs will increase the audit time.

■ If a robot adjacent to the CAP is inoperative, that portion of the CAP is 
inaccessible.

Maximizing Library Performance
■ When planning workloads, place cartridges that require significant enters and 

ejects on rails adjacent to CAP magazines. 

■ Load magazines adjacent to the rail in which the cartridges will reside.

■ To help identify what cartridges go to which rail, place labels outside the CAP to 
indicate the type of cartridge for a magazine.

■ Enter cartridges using a CAP magazine adjacent to the desired rail where 
compatible tape drives are located.

Displaying CAP Information
Use this procedure to display CAP information, including the current operation state 
of the CAP. This information is also available through Reports > CAP Details (see 
"Viewing Library Reports" on page 6-3).

1. Select Tools > System Detail.

2. Select the CAP folder in the navigation tree. SLC lists all the library's CAPs and 
their locations.

3. For more detailed information, expand the CAP folder. Select a CAP.

4. Select a tab:

■ Status Tab - displays the current operational state of a CAP. The online/offline 
state of the CAP is independent of the online/offline state of any LSM in an 
SL8500.

■ Properties Tab - displays static information for a CAP, including the serial 
number and number of cells.

Changing the CAP Online/Offline Status 
Use this procedure only if you are not using ACSLS or ELS tape management 
software, or if ACSLS/ELS servers cannot communicate with the library. For 
instructions on changing the state of the library and its components through ACSLS or 
ELS, see the tape management software documentation.

1. Select Tools > System Detail.

2. Expand the CAP folder. Select the CAP to modify.

Note: Library devices that are offline and in an error state cannot go 
online. The error condition must be cleared first.
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3. Click the Status tab.

4. In the Transition Request list select either: 

■ Take Offline - All outstanding jobs for the CAP will complete first.

■ Bring Online

5. Click Apply. 

Locking/Unlocking a CAP
Normally, the host locks or unlocks a CAP access door. Use this procedure when you 
need to manually lock or unlock the CAP using SLC. An unlocked CAP is reserved by 
the library and unavailable to all hosts until it is locked. This procedure applies only to 
HLI CAPs.

1. Select Tools > Diagnostics.

2. Expand the CAP folder. Select the CAP to modify.

3. Click the Access tab.

4. In the Locked list select:

■ False to unlock.

■ True to lock.

5. Click Apply.

6. When unlocking a CAP, a confirmation message appears. Click OK to unlock the 
CAP.

Performing a CAP Self-test
1. Select Tools > Diagnostics.

2. Expand the CAP folder. Select the CAP to test.

3. Click the SelfTest tab.

4. In the Mode list, select Non-Disruptive.

5. Click Run. A message appears when the test finishes.

Note: If the CAP is reserved by a host, the host must release the CAP 
reservation before you can unlock the CAP. 
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8Drive Management

Drive management tasks include configuring drive cleaning, displaying drive 
information, configuring the drive tray serial number, changing the drive status, and 
performing self-tests.

■ Maximizing Library Performance with Drive Placement

■ Configuring Drive Cleaning

■ Displaying Drive Information

■ Displaying the Drive and Drive Media Reports

■ Configuring the Drive Tray Serial Numbers

■ Changing the Drive Online/Offline Status

■ Performing a Drive Self Test

■ For media validation information, see Chapter 10, "Media Validation".

■ For drive address identification, see "Tape Drive Addressing" on page B-6.

Maximizing Library Performance with Drive Placement
■ Install tape drives that use the same media types on the same rails. Check that 

there are enough drives for the number of mounts during peak usage. Make sure 
the number of mounts during peak usage won't exceed the capacity of the robots.

■ For high mount rate applications, do not place sixteen drives on an rail. This can 
lead to increased wait times for the robot to be available. High mount rate 
applications may require clustering drives on more than one rail.

■ In a redundant robotics library, install drives in the outer columns (± 2) first. This 
allows both robots to access drives at the same time.

Configuring Drive Cleaning 
Library tape drives require periodic cleaning to prevent read/write errors. A drive 
cleaning occurs when the system mounts a compatible cleaning cartridge in response 
to a cleaning request from the drive.

As of SL8500 firmware FRS_7.00 and SLC 5.50, host applications (such as ACSLS or 
ELS) manage all cleaning cartridge and drive clean functions.

However, as of SL8500 firmware FRS_8.31 and SLC 6.25, drives in the media validation 
pool can request cleaning, and will automatically be cleaned by the library. Therefore, 
a library using the media validation feature requires cleaning cartridges in the 
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reserved system cells. These cleaning cartridges are not used by the host 
tape-management software, only by drives in the media validation pool. Customers 
should manage cleaning cartridges using the CLI. See the cleaning section of 
Appendix A, "Command Line Interface Reference".

Configuring Host-Managed Drive Cleaning
You can use host tape management software (ACSLS or ELS) to manage drive cleaning 
in HLI libraries or partitions. 

1. Confirm that the library auto clean function is disabled for the library and all 
partitions. (The auto clean function is disabled by default).

2. Enable automatic cleaning within the tape management software.

a. For ELS, see the ELS System Programmer's Guide for instructions on enabling 
the cleaning function.

b. For ACSLS, automatic cleaning is enabled by default. See the ACSLS 
Administrator's Guide.

3. To enter cleaning cartridges into the library, use the applicable ACSLS or ELS 
commands.

4. Have the tape management software manage drive cleaning as required.

5. To monitor the status of cleaning cartridges and drives, use the applicable ACSLS 
or ELS commands.

6. To eject cleaning cartridges from the library, use the applicable ACSLS or ELS 
commands. You cannot use the SLC Import/Export page to eject host-managed 
cleaning cartridges.

Displaying Drive Information
Use this procedure to display drive information for all drives in the library. Drive 
information is also available through Reports > Drive Details. See "Viewing Library 
Reports" on page 6-3.

If you must perform a manual mount to a drive, this procedure displays a mapping of 
all addresses (firmware, HLI-PRC, drive bay) for each library drive.

1. Select Tools > System Detail.

2. Click the Drive Folder in the navigation tree to display a table of drive 
information, including the drive FPGA version and the drive tray card type — 
LOD or HBD.

Note: As of SL8500 firmware version FRS_7.00 and SLC version 5.50, 
enabling/disabling auto clean is not available through the SLC. It is 
only available to the library administrator through the CLI.

Note: Only use the SLC Import/Export page to enter cleaning 
cartridges if you have a media validation drive pool. The library 
controller will store the cartridges in reserved system cells. ACSLS 
and ELS do not have access to these cells.
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3. For more detailed information, expand the Drive folder in the navigation tree. 
Select a drive.

4. Select a tab:

■ Status Tab - displays the current operational state of the selected drive

■ Properties Tab - displays configuration information, including the drive type, 
serial number, and port configuration

■ Display Tab - displays network data, the Virtual Operator Panel (VOP) for 
T10000 and T9840D drives, and drive LED status

■ Drive Tray Tab - displays the current status of a drive tray 

Displaying the Drive and Drive Media Reports
The Drive and Drive Media Events Reports summarize drive and media events and 
errors that have occurred on library drives. Use these reports to help identify and 
diagnose faulty drives and cartridges. 

By default, the reports are sorted in drive serial number order. Optionally, you can 
change the sort order, and rearrange and re-size the columns. See "Modifying a 
Tabular Display" on page 1-3 for more information

1. Select Tools > Reports.

2. Expand the Statistics folder.

3. In the navigation tree, click the report type to view:

■ Drive Events - summarizes drive events and errors. For each drive that has 
experienced an event, the report lists the type of drive, type of error, the 
number of occurrences, and the date and time of the last such event. The 
report can display up to 70 entries.

■ Drive Media Events - summarizes media events. For each drive that has 
experienced media events, the report lists the vol-id of the cartridge, the type 
of event, the number of occurrences, and the date and time of the last such 
event. The report can display up to 500 entries.

Configuring the Drive Tray Serial Numbers
1. Select Tools > Configuration.

2. Click the Drive Tray S/N tab.

3. Click Refresh to display the current data.

4. To edit an individual drive tray serial number:

a. Double-click the Drive Tray S/N field.

b. Enter the drive tray serial number. Proceed to step 6.

5. To edit multiple drive tray serial numbers at once, you can edit a 
comma-separated value (csv) file:

a. Click Export, and then save the file to a desired location.

b. Open the file and edit only the drive tray serial numbers. Do not alter any 
other values. Save the changes.

c. In SLC, click Import. Locate the updated .csv file, and then click Open.
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6. Click Apply, then Yes.

Changing the Drive Online/Offline Status
A drive can be in one of the following states:

■ Online: The drive is available for read/write operations.

■ Offline: The drive is not available for read/write operations.

Use this procedure only if you are not using ACSLS or ELS tape management 
software, or if their servers cannot communicate with the library. For instructions on 
changing the state of the library and its components through ACSLS or ELS, see the 
appropriate tape management software documentation.

1. Select Tools > System Detail.

2. Expand the Drive folder, and click the drive to modify.

3. Click the Status tab.

4. In the Transition Request field select either:

■ Take Offline - the system completes all outstanding jobs for the drive first.

■ Bring Online

5. Click Apply. The drive status updates accordingly.

Performing a Drive Self Test
1. Select Tools > Diagnostics.

2. Expand the Drive folder, and click the drive to test.

3. Click the SelfTest tab.

4. In the Mode list, select Non-Disruptive.

5. Click Run. A message appears when the test finishes.

Note: Library devices that are offline and in an error state cannot go 
online. Clear the error condition first.
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9Cartridge Management

■ Cartridge Types

■ Cartridge Handling

■ Maximizing Library Performance with Cartridge Placement

■ Displaying Cartridge Information

■ Locating Cartridges

■ Moving Cartridges (Recovery Moves)

■ Entering Cartridges

■ Ejecting Cartridges

■ Importing or Exporting Diagnostic Cartridges

Cartridge Types
There are three basic cartridge types:

■ Data cartridges — used to store customer data.

■ Diagnostic cartridges — used by service representatives to run read/write tests on 
drives (see "Importing or Exporting Diagnostic Cartridges" on page 9-7)

■ Cleaning cartridges — used to clean the tape path and read/write heads of the 
tape drives (see "Configuring Drive Cleaning" on page 8-1)

Library cartridges must meet specifications defined in American National Standard 
Magnetic Tape and Cartridge for Information Interchange. For more information on 
cartridges, refer to the drive vendor's publication and website.

Cartridge Labels
For information about media label standards for each cartridge type, see the Barcode 
Technical Brief on OTN. All library cartridges must have a readable external label. The 
robot reports an error when it encounters an unreadable label.

Caution: Do not re-enter a cleaning cartridge ejected by the library. 
The library will consider it to be new, and set the usage counter to 
zero. 
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Non-labeled cartridges are not supported. The library exports any non-labeled 
cartridges it finds through the CAP. A non-labeled or unknown type cartridge will not 
mount to a drive.

Cartridge Handling

■ Keep cartridges clean and inspect for damage before each use.

■ Never open a cartridge.

■ Do not handle tape that is outside the cartridge; the tape edge might be damaged.

■ Do not expose the tape or cartridge to direct sunlight, moisture, or magnetic fields.

Inspecting a Cartridge
Always inspect a cartridge before you insert it into a tape drive or a library. A 
defective or dirty cartridge can damage a tape drive. Never use a damaged cartridge. 
Look for:

■ Dirt or debris

■ Cracked or broken housing

■ Damaged write-protect switch

■ Liquid in the cartridge

■ Labels not firmly attached, or that extend over the cartridge edge

Cleaning the Cartridge Exterior
Wipe all dust, dirt, and moisture from the cartridge with a lint-free cloth. Use Oracle 
StorageTek Tape Cleaner Wipes to clean the cartridges. These wipes are saturated with 
isopropyl alcohol. Do not let any solution touch the tape or get inside the cartridge.

Storing Cartridges
Store cartridges in a clean environment. Do not take a cartridge out of its protective 
wrapping until you are ready to use it. Use the tear string, not a sharp instrument, to 
remove the wrapping. Before using a cartridge, ensure that it has been in its operating 
environment for at least 24 hours.

Maximizing Library Performance with Cartridge Placement
■ Cluster cartridges by workload on separate rails. Make sure each rail has the 

correct amount of free cells, data cartridges, scratch cartridges, and tape drives to 
support peak usage.

Caution: When cartridges are improperly handled, loss of data or 
damage to a library component can occur.

Caution: Potential damage to cartridges. Do not use acetone, 
trichloroethane, toluene, xylene, benzene, ketone, methylethyl ketone, 
methylene chloride, ethyldichloride, esters, ethyl acetate, or similar 
chemicals to remove labels or clean cartridges.
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■ Move inactive cartridges out of the library. Move less frequently used cartridges 
away from the tape drives.

■ When entering cartridges through the CAP, place cartridges in the magazine 
adjacent to the rail in which the cartridges will reside. This minimizes elevator and 
robot activity.

■ Use Library Content Manager (LCM) to automatically manage free cells for z/OS 
customers. 

■ Use the float option available with host management software (ACSLS and HSC). 

Displaying Cartridge Information
The reports feature can display information about all library cartridges, including 
cartridge vol-id, location, and media type. You can display the information in a tabular 
format or a list. For drive-related media events, see "Displaying the Drive and Drive 
Media Reports" on page 8-3.

1. Select Tools > Reports.

2. Expand the Status Summary folder in the navigation tree.

3. Click the report to view:

■ Cartridge Table - displays cartridge information in a tabular form. You can 
modify the layout and display of this screen. See "Modifying a Tabular 
Display" on page 1-3.

■ Cartridge Summary - displays cartridge information in a list.

4.  To search the report data or save it to a file, see "Viewing Library Reports" on 
page 6-3.

Locating Cartridges
You can display the library internal address of any cartridge by using the SLC. You can 
locate a cartridge based on vol-id, internal library address, or HLI address.

This utility is especially useful when you must perform a manual mount of a cartridge. 
The library management software (ELS or ACSLS) provides the vol-id, HLI-PRC 
address of the cartridge, and drive bay address of an available drive. Before you enter 
the library, write down the vol-id, cartridge location, and the drive slot location. If the 
library is in a complex, be sure to enter the correct library number/LSM number (see 
"Library Addressing" on page B-1)

Locating a Cartridge by vol-id
Use this procedure to display the current location of a cartridge with a specified 
volume ID. You can display cartridge location in the library internal address or 
HLI-PRC address format.

1. Select Tools > Diagnostics, and then click the Library folder.

2. Click the Search tab.

3. In the Search Type list, select VOLID.

4. Enter the VOLID (wildcards are valid).

5. The Requester field controls the address format of the search results. Select:

■ default to display in library internal address format.



Moving Cartridges (Recovery Moves)

9-4 StorageTek SL8500 User Guide

■ hli0 or hli1 to display in HLI-PRC address format.

6. Select the Cartridge Type.

7. Click the Search tab. The Search Results section updates.

Locating a Cartridge by Address
Use this procedure to display detailed information for cartridges with a specified 
location. You can specify the location using library internal address or HLI-PRC 
address.

1. Select Tools > Diagnostics, and then click the Library folder.

2. Click the Search tab.

3. In the Search Type list, select Location.

4. In the Location list, select the type of search.

5. In the Location field, enter the address (wildcards are invalid)

6. In the Requester list, select the type of address format - HLI or default (internal 
address). Make sure the type matches what was entered in the Location field.

7. Click the Search tab. The Search Result section updates.

8. To see details about a cartridge or to view a location mapping, click the ". . ." 
button in the Details column. 

Moving Cartridges (Recovery Moves)
Use the recovery move diagnostic function to move a cartridge from one location to 
another. For example, you can:

■ Return a cartridge to its original location from a CAP cell, drive, or another storage 
cell location.

■ Transfer orphaned cartridges to accessible locations

■ Group cartridges by data type or move them closer to assigned drives.

■ Eject a cleaning or diagnostic cartridge that has expired.

■ Enter a new cleaning or diagnostic cartridge and move it to a reserved storage cell.

A cartridge in a storage cell can be moved only to a CAP, a system cell, or another 
storage cell, and not to a drive. A cartridge currently in a drive, CAP, or system cell can 
be moved to an unoccupied location in the library. 

Before moving any cartridge, it is helpful to display or print a report showing where 
cartridges are currently located and which storage cells are unoccupied (see 
"Displaying Cartridge Information" on page 9-3).

Moving a Cartridge by Vol-id or Specified Location
Use these procedures to move a cartridge in the library to a new specified location. 
These procedures update the cartridge's location in the library controller database, but 
not in the host database. You must perform an audit from the host software to update 
the host database. Failure to do so will cause future mount requests from the host 
software to fail.
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1. Select Tools > Diagnostics. Click the Library folder.

2. Click the RcvrMove tab.

3. In the Source Location Mode section, select either:

■ VOLID to use vol-id. In the VOLID field, enter the vol-id of the cartridge to 
move.

■ Location to use a specific location. Select the cartridge's current location type. 
Options are: CAP, Slot, Drive, Reserved Slots.

4. In the Destination Location Type list, select the type of location to which to move 
the cartridge. Options are: CAP, Storage Slots, Drive, and Reserved Slots.

Selection restrictions include:

■ The destination can be a drive only if the source is a CAP or reserved slot.

■ To move a cartridge to a drive, the cartridge media type must be compatible 
with the drive type.

■ You cannot move a cartridge to a location that is already occupied.

■ Only diagnostic or cleaning cartridges should be moved to reserved slots.

5. In the Destination Location table, specify the cartridge destination with the library 
internal address lists: Library, Rail, Column, Side, Row.

Options include:

■ Min: First element of that location type (library, rail, column, side, row) in the 
library

■ Max: Last element of that location type (library, rail, column, side, row) in the 
library

6. Click Start to begin the move.

7. Click OK.

8. To verify the new location, you can display a Cartridge Summary report. See 
"Displaying Cartridge Information" on page 9-3.

9. To update the new cartridge location in the host database, initiate a library audit 
from the host software (see the tape management software documentation).

Entering Cartridges
Before you enter a cartridge, verify that it is labeled properly. Do not enter unlabeled 
cartridges or place cartridges upside-down.

The CAP can hold 39 cartridges. Place cartridges in any magazine slot and in any 
order with the hub gear facing down and cartridge label facing you. The magazine is 
removable for cartridge placement.

After a cartridge is entered through the CAP, the library moves the cartridge from the 
CAP to a library storage slot, records the cartridge's location, and sends the location to 
the host.

Caution: Potential data loss. Use caution when moving cartridges in 
partitioned libraries. Accidentally moving a cartridge from one 
partition to another allows the new partition to overwrite data.
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1. If the CAP is in auto enter mode (see "CAP Modes" on page 7-1), proceed to the 
next step. If it is in manual mode, initiate the enter operation at the host (see tape 
management software documentation for the procedures and commands). 

2. Press the CAP button (CAP A or CAP B) on the operator key pad.

The CAP door opens, and the CAP button light turns ON.

3. Place the cartridges in the CAP with the hub gear face down and barcode toward 
you.

4. Press the CAP button (CAP A or CAP B) on the operator key pad.

The CAP closes and locks automatically, and the CAP button light turns OFF. 
When the CAP is empty, the library returns the CAP to its default state

Ejecting Cartridges
To export a cartridge, specify the vol-id of the cartridge to remove from the library. The 
system retrieves the vol-id location from the library's memory. The robot locates the 
cartridge and places it into the CAP slot. The CAP can hold 39 cartridges. 

After the CAP opens, the system erases the location of the cartridge from the library 
controller database and the host database. The robot does not read cartridge labels 
during export operations.

1. Initiate the eject operation at the host. Specify the vol-ids of the cartridges to 
remove from the library. See the appropriate tape management software 
documentation for the procedures and commands.

2. Press the appropriate CAP button (CAP A or CAP B) on the operator key pad.

The CAP door opens, and the CAP button light turns ON.

3. Remove the cartridges from the CAP.

4. Push the CAP button to close the CAP.

The CAP closes and locks, and the CAP button light turns OFF.

5. If more cartridges must be exported, the robot continues filling the CAP. Wait until 
the CAP door is unlocked and repeat step 2 through step 4.

Once the system ejects all cartridges, the robot audits the CAP to verify it is empty. 
The CAP returns to its default state.

Caution: Possible equipment damage: DO NOT force the CAP to open 
or close.

Caution: Possible equipment damage: DO NOT force the CAP to open 
or close.

CAUTION: Potential data loss. If you do not remove the cleaning 
cartridge from the CAP and the CAP closes, the library treats the 
cartridge as new and the expired cleaning cartridge is used again.
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Importing or Exporting Diagnostic Cartridges
Library self-tests and some other diagnostic activities require the use of diagnostic 
cartridges. Make sure the library contains a enough diagnostic cartridges for these 
activities. Diagnostic cartridges are stored in the reserved system cells, and cannot be 
imported or exported with host management software.

To import/export a diagnostic cartridge through a CAP, use the SLC Import/Export 
function. The library controller reserves the CAP for the entire operation. The system 
can perform only one diagnostic or cleaning cartridge import or export operation at a 
time.

Diagnostic cartridge volume IDs (vol-ids or volsers) must be eight characters in length, 
with DG as the first two characters. The library import/export function works only for 
diagnostic cartridges with labels in this format. You can use any of the following SLC 
reports and searches to display information about diagnostic cartridges. Search for 
cartridges that begin with DG.

■ "Displaying Cartridge Information" on page 9-3

■ "Locating Cartridges" on page 9-3

Importing Diagnostic Cartridges
Make sure that the library has enough empty reserved system cells for the diagnostic 
cartridges. There must be at least one empty system cell on each side of the library for 
robot recovery or library initialization. The diagnostic cartridges are distributed as 
evenly as possible in reserved system cells, or you can assign priority to one rail.

1. Verify that the CAP is empty, available for use (not reserved by a host), and closed 
and locked.

2. Select Tools > Diagnostics.

3. Expand the CAP folder and click a CAP to use. Click the Import/Export tab.

4. In the Operation section, select Import Cleaning/Diagnostic cartridges.

5. In the "Select favored rail for import" list, select the preferred storage rail or No 
affinity.

The system enters diagnostic cartridges into reserved system cells on the favored 
rail on a space-available basis. After the system cells on the rail are full, the system 
distributes cartridges among system cells on other rails.

6. Click Start. 

7. Click OK to begin the import operation.

8. Follow steps 2 to 4 of "Entering Cartridges" on page 9-5 to complete the import 
operation.

Exporting Diagnostic Cartridges
1. Verify that the CAP is empty, available for use (not reserved by a host), and closed 

and locked.

2. Select Tools > Diagnostics.

3. Expand the CAP folder, click a CAP to use. Click the Import/Export tab.

4. In the Operation list, select the type of export operation:
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■ Export specific diagnostic cartridges, then select the cartridges to export in 
the "Select Cartridge(s) to export" list

■ Export all diagnostic cartridges, then select a rail in the "Select rail to export 
cartridges from" list.

5. Click Start. 

6. Click OK to begin the export operation.

7. Follow steps 2 to 5 of "Ejecting Cartridges" on page 9-6 to complete the export 
operation.
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Media validation allows customers to verify all T10000 tape cartridge types using SLC. 
The SLC indicates the progress of the validation at the initial start, one minute after the 
start, and then every 10 minutes. The validation provides a "success" or "failure" result 
for each tape cartridge tested.

The media validation feature requires minimum SL8500 firmware FRS_8.31, SLC FRS_
6.25, and a high memory HBT card. You can only validate one cartridge at a time per 
each SLC session. Refer to the StorageTek Tape Analytics (STA) documentation to use 
STA to automate media validation.

■ Media Validation Pool Overview

■ Validation Types

■ Adding Drives to the Media Validation Pool

■ Removing Drives from the Media Validation Pool

■ Validating a Cartridge

■ Stopping a Validation in Progress

Media Validation Pool Overview
Media validation requires a designated pool of T10000C or T10000D type tape drives 
at TTI level 5.40+. Up to 10 drives can be placed in the media validation pool using 
SLC (see "Adding Drives to the Media Validation Pool" on page 10-2). The drives in 
the pool are not available to host applications, such as ACSLS or ELS. The pool is not 
considered a partition and does not contain cartridges. 

Drives in the media validation pool are automatically cleaned by the library. This 
occurs regardless of the auto clean status for the entire library or for partitions in the 
library (see "Configuring Drive Cleaning" on page 8-1).

Validation Types
Table 10–1 shows the five types of validation available through the SLC.

Note: The CSE should ensure there are cleaning cartridges in the 
reserved system slots for auto-cleaning of the drives in the media 
validation pool.
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Adding Drives to the Media Validation Pool
Use the Media Validation > Slot Selection Tab to create or modify the media 
validation drive pool. Hosts cannot access drives or drive slots in the media validation 
pool.

1. Ensure host applications are not using the drives you want to add to the media 
validation pool. Finish any read or write operations and dismount any cartridges 
from the selected drives.

If the drives are managed by ACSLS, vary the drives offline to ACSLS to prevent 
drive activity.

2. Log in to the library or any of the libraries within the complex. Ensure all libraries 
in the complex are online.

3. Using SLC, select Tools > Media Validation. Click the Slot Selection tab

4. Click Refresh to update the screen.

5. Highlight the drive slots to place in the media validation pool (a maximum of 10)

Table 10–1 Media Validation Types

Type of Validation Description Starts at
Approximate Duration per 
Cartridge

Basic Verify Simple mount/dismount of the cartridge 
to determine if MIR is unreadable or out of 
sync

N/A: Simple mount and 
dismount

2 minutes

Standard Verify Reads:

- 1000 records from the beginning of the 
tape

- The wrap that contains EOD, then into 
the EOD

- Outermost wraps on top and bottom 
bands to verify edges

Beginning of tape (BOT) Maximum of 30 minutes

Complete Verify 
(default)

Reads data at tape speed - Beginning of tape 
(BOT)

- Resumes where it left 
off

T10000C: 6 hours 

T10000D: 9 hours max

Complete Verify 
Plus StorageTek Data 
Integrity Validation1

1 Decompression and encryption key management system are required.

Checks DIV CRC to determine if it exists - Beginning of tape 
(BOT)

- Resumes where it left 
off

T10000C: 6 hours for 
compression ratios less than 
2.5:1.

T10000D: 9 hours for 
compression ratios less than 3:1

Rebuild MIR Reads data at tape speed At invalid position in 
the MIR

T10000C: 5 hours 

T10000D: 9 hours

Table 10–2 Status Indicators for Drive Slots

Status Indicator Meaning

 Blank
Empty drive slot

 Rectangle
Slot contains either an invalid drive type or a correct drive type 
in an invalid state

 Rectangle with bar
Correct drive type (T10000C or T10000D) in a valid state
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6. Click Add.

An error message appears if you add more than 10 drives to the pool. Click OK. 
De-highlight slots until only 10 are highlighted. Click Add.

7. Click Apply. 

Only a non-partitioned library, or the partitions containing drive slots moved into 
the pool, will go offline.

ACSLS and ELS hosts connected to affected partitions receive "Configuration 
Changed", "LSM Ready", and then "Not Ready" messages from the library. ELS 
automatically removes any media validation drives from its configuration. ACSLS 
automatically updates any media validation drives to an offline state, but ACSLS 
requires you to initiate re-configuration (see step 8).

8. ACSLS only — To remove a media validation drive from the ACSLS configuration, 
use the config drives <panel_id> utility. You can run config drives while the 
library is online and mounts/dismounts to other drives are occurring.

Removing Drives from the Media Validation Pool

1. Select Tools > Media Validation. Click the Slot Selection tab

2. Click Refresh to update the screen.

3. Highlight the drive slots to remove from the pool. Click Remove.

4. Click Apply.

5. To reassign a drive slot removed from the pool:

■ For a non-partitioned library managed by ACSLS or ELS, the drive slot will be 
available to hosts immediately. ELS hosts begin re-configuration. ACSLS host 
require you to initiate re-configuration with the config drives <panel_id> 
utility.

■ For a partitioned library, a drive slot removed from the validation pool is not 
allocated to a partition. To assign the drive slot to a partition, see "Partitioning 
the Library Using SLC" on page 4-3.

Validating a Cartridge
Use the Media Validation > Media Validation Tab to validate a cartridge. You can 
only validate one cartridge at a time per each SLC session.

 Number
Partition number of drive slot/bay

 MV and colored
Drive slot is in media validation pool

Note: If you try to remove a drive from the pool that is in the process 
of validating a cartridge, an error will be reported.

Table 10–2 (Cont.) Status Indicators for Drive Slots

Status Indicator Meaning
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1. Log in to the library. For a library complex, log in to the library that contains the 
drive that will be used for validation.

2. Select Tools > Media Validation. Click the Media Validation tab.

3. In the Drive column, select the drive to use. A drive may not be selectable if:

■ The drive is in an invalid state.

■ The drive type is invalid.

■ You are not logged into the library containing the drive.

4. In the center column, choose the cartridge to validate from a list, or type the 
cartridge VOLSER.

5. In the right-hand column, select the validation type. See Table 10–1 for details.

6. Click Start. Validation begins if the cartridge loads successfully.

After validation completes, the cartridge is returned to its source location. If the 
source location is lost, the library moves the cartridge to a system slot for host 
recovery.

Stopping a Validation in Progress
Media validation can be stopped by either a host requesting the cartridge being 
validated or the technician who initiated the validation through the SLC.

To stop a validation in progress through the SLC:

1. Select Tools > Media Validation. Select the Media Validation tab.

2. Click Stop. 

Once validation stops, the cartridge is returned to its source location. If the source 
location is lost, the library moves the cartridge to a system slot for host recovery. 

Note: If media validation for a cartridge is interrupted, follow the 
procedures below to resume the validation. For Complete Verify 
validation types, select Resume to resume the validation where it left 
off.

Note: You must log in as the user who initiated the validation.
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11Robot and Safety Door Management

■ Safety Door Overview

■ Displaying Safety Door Information

■ Robots Overview

■ Displaying Robot Information

■ Changing the Robot Online/Offline Status

■ Performing a Robot Self-Test

■ Defining and Running Robot Diagnostic Moves

Safety Door Overview
The safety door is a sliding barrier that closes off the left or right maintenance area 
from the operational portion of the library. The maintenance area is the space between 
the two front doors and the rear of the elevator assembly. A safety door allows a 
service representative to perform maintenance on a robot while the library remains 
online. For additional information, see "Operating the Service Safety Door" on 
page 14-6.

The safety door is activated by your Oracle support representative using a 
maintenance key. You can use the SLC to monitor the status of the safety door. 

Displaying Safety Door Information
1. Select Tools > System Detail.

2. Click the Safety Door folder on the navigation tree to display summary 
information.

3. For detailed information, expand the Safety Door folder, and then click the Safety 
Door.

4. Select a tab:

■ Status Tab - displays the current operational state of the safety door

■ Properties Tab - displays safety door configuration information, including the 
serial number and current firmware levels

Robots Overview
Robots move cartridges between storage slots, tape drives, and CAPs. Each robot 
travels along one of the four library rails and services up to 16 tape drives.
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With the optional redundant robotics feature, two robots operate on a single rail, 
significantly increasing the overall performance of the library. If one robot fails, the 
other robot moves the defective robot into the forward service area. 

Fast Load Feature
The fast load feature optimizes system performance. After a robot successfully inserts 
a cartridge into a drive, it is immediately available for the next request and does not 
wait until the drive reports that the cartridge has been loaded. The library controller 
waits to return the mount request response until it detects that the tape drive has 
successfully loaded the cartridge.

Robot Initialization
Robots initialize when the library is powered on. If an initialization failure occurs, the 
robot is flagged as defective. In a library with redundant robotics, after the other 
robots successfully initialize, the defective robot is pushed into the maintenance area 
for replacement.

Displaying Robot Information

1. Select Tools > System Detail.

2. Click the Robot folder on the navigation tree to display summary information.

3. For detailed information, expand the Robot folder in the navigation tree, and then 
select a robot.

4. Select a tab:

■ Status Tab - displays the current operational state of the selected robot

■ Properties Tab - displays robot configuration information, including the serial 
number and current firmware levels

Changing the Robot Online/Offline Status
Use this procedure only if you are not using ACSLS or ELS tape management 
software, or if their servers cannot communicate with the library. For instructions on 
changing the state of the library and its components through ACSLS or ELS, see the 
tape management software documentation.

Use this procedure to take a robot offline or bring a robot online through the SLC.

Note: If any hand or robotic errors cannot be resolved by error 
recovery routines, the entire robot must be replaced. Contact your 
service representative.

Note: This information is also available through Reports > Robot 
Summary. See "Viewing Library Reports" on page 6-3.

Note: Library devices that are offline and in an error state cannot go 
online. The error condition must be cleared first.
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1. Select Tools > System Detail.

2. Expand the Robot folder, and then click the robot to modify.

3. Click the Status tab.

4. In the Transition Request field, select either:

■ Take Offline - the system completes all outstanding jobs for the robot.

■ Bring Online - the robot moves to the end of the rail, and the library cannot 
use it. If the library is using the redundant robotics feature, the second robot 
will take all requests.

5. Click Apply. 

Performing a Robot Self-Test

1. Select Tools > Diagnostics.

2. Expand the Robot folder, and then click the robot to test.

3. Click the SelfTest tab.

4. In the Mode list, select Non-Disruptive.

5. Click Run in the upper right corner.

Status messages display as the self-test runs. After the test finishes, the system 
displays a message indicating the diagnostic test is complete.

Defining and Running Robot Diagnostic Moves
Diagnostic moves can help monitor or diagnose robotic problems by issuing a series of 
"get" and "put" operations. The system chooses a robot for the diagnostic move based 
on the minimum and maximum ranges set for the target and pool addresses. Multiple 
robots may be selected if the address range requires it. 

Successful diagnostic moves do not rearrange the cartridges in the library — the 
system returns cartridges to their original locations. However, some diagnostic move 
failures can cause cartridges to be left in new locations.

A diagnostic move is defined by:

■ Target Address Range — defines the area used to perform the "get" operation in a 
diagnostic move. Valid target address types are storage cells, CAP, drive and 
storage cells, system cells, or all.

■ Pool Address Range — defines the area used to supply cartridges or empty cells if 
a target address does not contain a cartridge or no empty cells are available. The 
pool and target address can overlap.

Note: To perform a robot self-test, diagnostic cartridges must be 
available in the library.

Note: All resources within the target address range are reserved. 
However, only the location currently being accessed by the robot for a 
get/put operation is unavailable to the host.
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■ Access Order — determines how the robot performs get operations within the 
target address range. There are two options:

– Sequential — robot performs a get operation starting with the first location in 
the target address ranges. The robot continues visiting the locations 
sequentially through the range until it completes the requested number of 
moves.

– Random — robot randomly picks a location in the target address range to get a 
cartridge. The robot can also visit the same location in the target address range 
multiple times to get a cartridge, however if you specify enough move request 
the robot is guaranteed to visit all cells. The random access routine ends after 
the requested number of moves is complete.

Defining a Diagnostic Move
You can set up and run multiple diagnostic move routines simultaneously if the target 
and pool ranges for each diagnostic move do not overlap.

1. Select Tools > Diagnostics.

2. Click the Library folder in the navigation tree.

3. Click the DiagMove tab, and then the Manage tab.

4. In the Defined Sequence section, click Add. 

5. Complete the Sequence screen to define the target address:

a. In the Selection Mode section, select the type of cells to diagnose.

b. In the Minimum Address and Maximum Address sections, select the library 
internal address of the starting and ending locations of the cells to diagnose.

6. Click Next.

7. Complete the SOURCE screen to define the pool address:

a. In the Selection Mode sections, select the appropriate cartridge pool address 
type.

b. In the Minimum Address and Maximum Address sections, select the library 
internal addresses of the starting and ending locations of the cartridge pool to 
use.

8. Click Next.

9. Complete the Sequence screen:

a. Name of the diagnostic move.

b. Move Count: Specify a number between 1 and 5000.

c. Access order: Sequential or Random.

d. Move Type: Robot and Cartridge or Robot Only.

e. Only if you are certain the cartridges and drives in the diagnostic move are 
compatible, select "Disable pre-move cartridge compatibility check".

Note: This procedure requires sharing of the robots. You should not 
run it during peak activity periods.
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10. Click Finish to complete the setup. The new diagnostic sequence is listed in the 
Defined Sequences section.

Managing Diagnostic Move Definitions
Use this procedure to manage diagnostic move sequence definitions. Each diagnostic 
move has its own monitor screen.

1. Select Tools > Diagnostics.

2. Click the Library folder on the navigation tree.

3. Click the DiagMove tab, and then the Manage tab.

4. In the Defined Sequences section, select an option:

5. See "Monitoring and Controlling Open Diagnostic Moves" on page 11-6 to manage 
the diagnostic moves currently open.

Saving a Diagnostic Move
You can save a defined diagnostic move to a file on your system. The file is saved as a 
JavaBean component represented as an XML 1.0 document (.xml). You can use the file 
to restore a move that has been deleted from the library or Copy it to a different 
library.

1. Select Tools > Diagnostics.

2. Click the Library folder on the navigation tree.

3. Click the DiagMove tab, and then the Manage tab.

4. Select a diagnostic move. Click Save. 

5. Browse to the desired directory, enter a file name, and click Save.

Starting a Diagnostic Move
A monitor window displays for each move you start. You can repeat this procedure to 
open multiple moves, if the target and pool address ranges for the moves do not 
overlap.

1. Select Tools > Diagnostics.

2. Click the Library folder on the navigation tree.

3. Click the DiagMove tab, and then the Manage tab.

Table 11–1 Diagnostic Moves Options

 Option Definition Notes

Add Define a diagnostic move None

Open Start a diagnostic move Multiple diagnostic moves may be open at a time, 
so long as the target and pool address ranges setup 
for the moves do not overlap.

Modify Modify options for a 
diagnostic move

This diagnostic move routine must not be open or 
if open must be in a "Stopped" state.

Remove Remove a diagnostic move This diagnostic move routine must not be open.

Copy Copy an existing diagnostic 
move

Copy a diagnostic move definition, make changes 
if necessary, and assign a different name.
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4. In the Defined Sequences section, select a diagnostic move. Click Open.

5. From each monitor window, select File > Start Sequence to start the move.

Monitoring and Controlling Open Diagnostic Moves
1. See "Starting a Diagnostic Move" on page 11-5 for instructions on starting one or 

more diagnostic moves.

2. Select Tools > Diagnostics. Click the Library folder.

3. Click the DiagMove tab, and then the Monitor tab. Each monitor window 
indicates the status of the move.

4. Use the File menu in each Monitor window to start/stop/pause the sequence, 
clear the output window, or start/stop spooling.

Table 11–2 Status Indicators for Moves

Status Indicators Valid Values

Spooling Status — whether the move output is being spooled to a file True, False

State — execution state of the move Running, pausing, paused, 
stopping, stopped

Health — health state of the move OK, warning, error

Completed moves — Number of moves completed in the requested move 
count

N/A
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12Elevators and Pass-Thru Ports

■ Maximizing Library Performance by Reducing PTP and Elevator Usage

■ PTP Installation Overview

■ Displaying Elevator Information

■ Displaying Pass-Thru Port Information

Maximizing Library Performance by Reducing PTP and Elevator Usage
Reduce elevator and pass-thru operations to improve library performance:

■ Mount cartridges in tape drives that are on the same rail.

■ Limit the distance cartridges must travel.

■ Ensure a sufficient quantity of scratch cartridges are available.

PTP Installation Overview

Non-disruptive Installation
For non-disruptive growth, add libraries to the left (viewed from front or CAP-side of 
library complex). This method does not require system reconfiguration. Installing 
PTPs from right to left has several advantages:

■ Existing libraries can remain operational while the PTP frame is attached to them 
during the installation of the adjacent library.

■ No rebooting of ELS or ACSLS is required.

■ If cartridges are placed into the new SL8500, an ACSLS or ELS audit must be run 
to add these cartridges to the database. The pre-existing LSMs can remain online 
during the audit.

Disruptive Installation
Left-to-right installation is highly disruptive. You must take the libraries offline, 
update the configuration, and perform an audit to update volume locations and 
renumber LSMs (see "Library Complex HLI Numbering" on page B-2).

To perform a disruptive PTP installation with ACSLS or ELS:

1. Take the libraries offline.

2. Dynamically update the ELS or ACSLS configurations.
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3. Run an audit all libraries in the complex. The audit process must proceed 
sequentially from left-to-right. (Failure to reconfigure or perform an audit will 
result in mount failures and cartridge collisions.)

4. Bring the libraries in the complex online.

Refer to the library management software documentation for more information.

Displaying Elevator Information
Use this procedure to display information for library elevators. This information is also 
available through Reports > Status Summary > Library Information. See "Viewing 
Library Reports" on page 6-3.

1. Select Tools > System Detail.

2. Click the Elevator folder in the navigation tree to display summary information.

3. For detailed information, expand the Elevator folder. Select an elevator.

4. Select a tab:

■ Status Tab - displays the current operational state of the elevator

■ Properties Tab - displays elevator configuration information, including the 
serial number and current firmware levels

Displaying Pass-Thru Port Information
Use this procedure to display PTP information in a library complex.

1. Select Tools > System Detail.

2. Select the PTP folder in the navigation tree to display summary information.

3. For detailed information, expand the PTP folder. Select a pass-thru port.

4. Select a tab:

■ Status Tab - displays the current operational state of the selected PTP

■ Properties Tab - displays PTP configuration information, including the serial 
number and current firmware levels
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13SLC Diagnostics and Utilities

SLC enables you to perform many diagnostic tasks, including library self-tests, 
monitoring events, and device diagnostics.

■ Library and Device Self-tests

■ Diagnostic Support Information

■ Troubleshooting

■ Using the Monitors Utility to Open an Event Monitor

For information on using SLC diagnostic tools not described in this chapter, see:

■ "Importing or Exporting Diagnostic Cartridges" on page 9-7

■ "Defining and Running Robot Diagnostic Moves" on page 11-3

Library and Device Self-tests
Self-tests can help diagnose issues, see:

■ "Performing a Library Self-Test" on page 6-5

■ "Performing a CAP Self-test" on page 7-3

■ "Performing a Drive Self Test" on page 8-4

■ "Performing a Robot Self-Test" on page 11-3

Diagnostic Support Information
The following diagnostic tools aid in troubleshooting. Your Oracle support 
representative may request that you capture and transfer these files.

■ Management Information Base (MIB) file - an SNMP database used to manage 
your library devices. This file can be saved as a text file. See "Transferring the 
Library MIB File" on page 6-4.

■ Log Snapshot file - an encrypted snapshot of the library event log. You cannot 
view or edit this file. This file is available for only 15 minutes from the time it is 
generated. See "Generating and Transferring the Library Log Snapshot File" on 
page 6-5.

■ Device Reserve Table - a table displaying device information and status. See 
"Viewing Library Reports" on page 6-3.

■ Event monitors - spool of events that captures error data. See "Using the Monitors 
Utility to Open an Event Monitor" on page 13-3.
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Troubleshooting
Before you run diagnostic tests, review the following troubleshooting tips.

Service Required (amber) LED is constantly on
Use SLC to check the health of the library and the attached devices (drives, CAPs, and 
robots). See Chapter 6, "Library Management".

To perform a health check:

1. Log in to the SLC.

2. Access the System Detail module, View > System Detail.

3. Check the navigation tree for the following indicators: Device Healthy or Device 
Error

Additional checks:

1. Check the Status (for example, online/offline) and Statistics (for example, uptime, 
downtime, errors and warnings) tabs for more information on the health of the 
library and devices.

2. Ensure the cartridges are fully seated and properly oriented in their storage cells.

3. Inspect the X table for any foreign objects or debris and remove them if found.

Library does not power-on and SLC does not display any messages
1. Check that the library power switch is in the ON position.

2. Check all power cord connections.

3. Replace the power cord.

4. Ensure that there is power to the outlet.

CAP Open LED is on and blinking
Open the CAP and ensure the cartridges properly seated. Close the CAP.

SLC does not display modified data or information remains static
Check the SLC Heartbeat icon.

Robot Fault or Library Fault Amber LED is constantly on
1. Check the SLC for any displayed error messages. Write down the error messages 

reported.

2. Open the front door. Observe and note the state of the cartridges, hand, and tape 
drives.

3. Ensure cartridges are fully seated and properly oriented in their storage cells.

4. Ensure packing materials have been removed.

5. Inspect the library floor for any objects or debris. If there are any, remove them.

6. Check the status of the tape drives.

7. Close the front door.

8. Ensure the tape drives are fully seated and locked forward by pushing and pulling 
on the rear of the drive tray. Any motion of the tray indicates that it requires 
re-seating and locking down.
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Client computer cannot communicate with the library or tape drives
Ensure cables are securely attached to their connectors on the rear of the library, the 
tape drives, and the client computer.

Library cannot communicate with the drives and drive status on the SLC displays 
"Not communicating" 
Ensure cables are securely attached to their connectors on the rear of the library, the 
drives, and the client computer.

Repeated or excessive drive cleaning or cleaning messages
1. Replace the cleaning cartridge with a new cleaning cartridge.

2. Run the Library Self-Test and note if errors are reported for the drive.

3. Run any client computer-based drive diagnostic tests.

Using the Monitors Utility to Open an Event Monitor
The library controller continually monitors library operations and logs all events. 
Using the Monitors utility of SLC, you can open an event monitor to display event 
data or spool it to a file. Event monitors are useful tools for root cause analysis.

■ Event Monitor Overview

■ Opening an Event Monitor

■ Spooling Event Monitor Data to a File

■ Displaying Result Code Definitions

Event Monitor Overview
There are four types of event monitors: All, Error Warn Info, Error and Warnings, and 
Errors. Each monitor type logs events based on the severity of the event. For example, 
the Errors monitor only logs error events (see "Severity" on page 13-4 for a description 
of the event types).

Each event logged in the event monitor contains the following information:

Time
Identifies when the event occurred.

Device ID
Identifies the library address of the device corresponding to the event.

User
Identifies the user that originated the event. This is "root" for HLI or SCSI host 
activities.

I / F
Identifies the interface type of the requester. The interface can be hli, scsi, or default 
(for SLC or CLI requests). 

Activity
Identifies the command that was issued, such as "load drive".

Request Identifier
Identifies all host interface requests. Helps track the sequence of log activity resulting 
from each host request.
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Severity
Identifies the significance of the event. Some event data is non-volatile, meaning it 
persists across system power cycles.

Error — non-volatile data indicating a fault that prevented a request (host or 
diagnostic) from completing successfully.

Warning — non-volatile data indicating a fault that has not stopped the library's ability 
to complete requests (host or diagnostic). A warning can identify a loss of performance 
or a condition that may indicate future irrecoverable errors.

Information — volatile data indicating general device or library information (such as 
the device state, device added, listener registered, tray serial number updated, and so 
on). This information may be important to establish a history of activity for the 
warning or error event.

Trace — volatile data indicating diagnostic activity tracing.

Result Code
Identifies the library event type (result codes are the same as library EventIds). To 
search for the meaning of the Result Code using SLC, see "Displaying Result Code 
Definitions" on page 13-5 or refer to the SL3000_FRSxxx_JavaErrorCodes.html file 
included in the library firmware code package.

Result Text
Provides information about the results of the request or event.

Opening an Event Monitor
1. Select Tools > Monitors.

2. Expand the Permanent Monitors folder in the navigation tree.

3. Click an event monitor type. Click Open.

4. Use the Monitor menu to pause, resume, permanently stop, or clear the event 
monitor.

5. To close a monitor, click the X in the upper right corner of the window.

Arranging Multiple Monitors
Arrange multiple event monitors using the Window menu in the upper right corner.

Spooling Event Monitor Data to a File
You can send an event monitor file to Oracle Support to assist in diagnosing problems.

1. Open an event monitor (see "Opening an Event Monitor" on page 13-4).

2. In the event monitor window, select Spool File > Start Spooling.

3. Browse to the desired directory, enter the file name, and click Save.

Menu Option Description

Window > Arrange Custom arrange the open monitors on screen

Window > Tile Horizontal Arrange the event monitor windows horizontally

Window > Tile Vertical Arrange the event monitor windows vertically

Window > Cascade Stack the event monitors
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4. To stop spooling, select Monitor > Stop Spooling.

Displaying Result Code Definitions
Use the following procedure to search for the definition of a result code from the event 
monitor.

1. Select Tools > Diagnostics.

2. Click the Library folder in the navigation tree.

3. Click the Search tab.

4. In the Search Type list, select Result Code.

5. Complete the remaining fields:

a. To search for a specific result code, enter the complete code. Wildcards or 
partial codes are not accepted.

b. To list all result codes, select List All.

6. Click Search.
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■ Modes of Operation

■ Safety Precautions when Entering the Library

■ Entering or Exiting the Library

■ Turning the Library On or Off

■ Manually Mounting and Dismounting Cartridges

■ Operating the Service Safety Door

Modes of Operation

Manual Mode
Manual operation may be required if the library has experienced an unrecoverable 
error or a library component requires service or installation. To perform manual 
operations, the library is placed in manual mode. 

A library in manual mode cannot accept host requests (host requests may continue to 
generate and cartridge mounts and dismounts require human intervention). The 
library is in manual mode when a library main access door is open, a robot does not 
automatically mount and dismount cartridges, or the navigation tree in the SLC 
indicates that there is a problem with the library.

Maintenance Mode
Maintenance mode is active when a service representative enters the access door to 
perform maintenance or to replace a component. The library continues to operate and 
process host request (see "Operating the Service Safety Door" on page 14-6).

Safety Precautions when Entering the Library

When entering a library, strictly observe the following safety precautions:

■ Ensure the library is offline (see "Placing the Library Offline" on page 6-9). Do not 
enter the library or move any of the robot mechanisms if you have any reason to 
suspect the robots are online.

WARNING: POTENTIAL FOR INJURY. Lock the access door open 
and retain the key to prevent accidental closure while in the library.
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■ Do not attempt to override any of the electrical or mechanical safety devices in the 
library.

■ Do not enter the library without informing someone in the immediate area (see 
"Emergency Robotics Stop Switch" on page 14-2)

■ Leave both the front access doors open whenever you work inside the library and 
lock them open. There are switches on each door frame that disconnect DC power 
and signal lines to the library's robotic motors when either access door is opened.

■ Know the physical restrictions of the library. Be careful not bump your body 
against the arrays or to snag clothing on the arrays (only 0.4 m [18 in.] of aisle 
clearance).

■ If you must move a robot avoid damaging the robot's mechanical or electronic 
components (see "Moving a Robot" on page 14-2).

■ If you are manually loading or unloading a cartridge, your hands must remain 
clear of the drive's mechanical and electronic load components.

Emergency Robotics Stop Switch
The emergency robotics stop (EMS) switch removes all power to the robots.

In the unlikely event that someone becomes locked inside the library and the system 
begins to turn on, lights flash for 30 seconds before the robot starts to move. This 
provides enough time for someone outside the library to push the emergency robotic 
stop switch on the CAP door (Figure 14–1). This actions stops any further robotic 
movement.

Figure 14–1 Emergency Robotic Stop Switch

1. Emergency Robotic Stop Switch (ERS)

Moving a Robot
When moving a robot, follow these precautions:

■ Do not enter the library or move any of the robot mechanisms if you have any 
reason to suspect the robots are online.

WARNING: You could trip or injure yourself on a robot. Before you 
enter the library, move the robots out of your way one at a time 
starting at the lowest rail. 



Entering or Exiting the Library

Manual Operation 14-3

■ Do not touch any shiny polished surfaces or lubricated parts. Body oils can 
destroy the lubrication on these surfaces.

■ Only hold the robot carriage handle to push or pull.

■ The robot should move freely. Do not force the robot if movement is restricted. 
Before you close the library access doors, look inside the library and ask in a loud 
voice if anyone is inside the library.

■ Leave the library only when you are certain that the robots can move freely in all 
directions. Ensure no extra materials (manuals, eyeglasses, tools) are left inside. 
These objects would cause the robot to stop and could damage it.

Figure 14–2 Moving the Robot

1. Robot handle

Entering or Exiting the Library

Entering the Library
Use this procedure to open the main doors of the library.

1. Place the library offline. See "Placing the Library Offline" on page 6-9.

2. Insert the key and unlock the access door.

3. Pull the paddle handle to activate the opening mechanism and open the access 
door. Opening the access door activates a switch, which automatically causes a 
software interrupt and stops the robot.

Before you enter the library, move the robots out of your way one at a time starting 
at the lowest rail. Follow all precautions in "Moving a Robot" on page 14-2.

4. Turn the key in the lock, to lock the door open, and then remove the key from the 
lock and keep it with you. This will prevent the door from being closed while you 
are in the library.

Exiting the Library 
Use this procedure to close and lock the main doors of the library.

WARNING: To avoid injury, you must follow all safety precautions 
before entering/exiting the library. See "Safety Precautions when 
Entering the Library" on page 14-1.
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1. Return any cartridges removed for a manual mount/dismount to their slots.

2. Before you leave the library, check for tools or foreign objects, and ensure no 
cartridges are outside the cartridge slots.

3. Step outside the library.

Before you close the library access door, look inside the library and ask in a loud 
voice if anyone is inside the library.

4. Close the front access door.

5. Insert the key and lock the access door. Keep the key in a secure location.

Turning the Library On or Off
Use the following procedures to power the library on or off.

Turning Off the Library

1. Ensure that all jobs have completed processing.

2. Quiesce the library to ensure the library and tape drives are not in use.

3. Take the library and the drives offline.

Refer to your library management software publication for commands and syntax 
for this step and step 4.

4. Ensure that the drives are empty by verifying the drive state using the SLC. See 
"Displaying Drive Information" on page 8-2 for more information.

5. Open the rear doors of the library.

6. Locate the power distribution unit (PDU) in the lower right corner at the rear of 
the library and move the system power-off/on switch to the OFF position (0). If 
the library has a 2N power configuration, you must switch off both the PDUs.

Caution: Do not slam the door. You could damage the door or cause 
cartridges to fall onto the floor.

Caution: If you turn off the library without performing the following 
procedure, you risk possible equipment or cartridge damage or loss of 
data.
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Figure 14–3 AC PDU

1. Retainer

2. LEDs

3. System Power Off/On Switch

Turning On the Library
Use this procedure to turn off the library.

1. Close and lock the front access door if the doors are open.

If you DO NOT want to turn on the robots, CAPs, and the elevators, leave the 
doors open.

2. Move the power off/on switch to the ON position.

If the library has a 2N power configuration, you must switch on both the PDUs.

Manually Mounting and Dismounting Cartridges
The library management software provides the location and the vol-id of the cartridge 
and also the drive bay address available for the manual mount. Before you enter the 
library, write down the vol-id, cartridge location, and the drive bay location.

■ For locating a drive. see "Displaying Drive Information" on page 8-2.

■ For locating a cartridge, see "Locating Cartridges" on page 9-3.

Manually Mounting a Cartridge in a Drive
1. Orient the cartridge, so the hub gear is facing down and the vol-id label is facing 

you, with the numeric characters above the bar code.

2. Do not force the cartridge into the tape drive. If you feel some resistance as you 
insert the cartridge, ensure you are installing the cartridge into the appropriate 
tape drive.

Note: Only insert the correct media type for the tape drive.
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For more information on manually mounting a cartridge into a drive, refer to the tape 
drive specific documentation.

Manually Dismounting a Cartridge from a Drive
All T-series and LTO Ultrium tape drives have a unload button on the operator panel.

1. Ensure that the tape drive is not in use by the system.

2. Press the UNLOAD switch. One of the following conditions occurs:

a. After the tape rewinds, the cartridge is ejected from the drive. Remove the 
cartridge from the drive. The cartridge is not ejected after the tape rewinds. 
Refer to your drive documentation for more information. For more 
information on manually dismounting a cartridge from a drive, refer to the 
relevant tape drive publication.

Operating the Service Safety Door
When the service safety door is in place, the library continues to function. A mount 
request for a cartridge in the slot closer to the side (left or right) where the service 
safety door is engaged may be inhibited until the maintenance activity is completed. 
The reserved slots on the other side of the service area may still be accessed if the 
service safety door is not engaged on that side as well.

After the maintenance activity is completed, the access door is closed and locked and 
the service safety door moves to the center, clearing the area for robot operations. The 
robots then resume their full service.

Left Maintenance Area
During normal operation, take the left elevator offline to the library management 
software using the SLC before the service representative activates the service safety 
door. After the maintenance activity is complete, bring the left elevator online through 
SLC.

Right Maintenance Area
During normal operation:

■ Take the CAPs offline to the to the library management software.

■ Take the right elevator offline (using SLC) before the service representative 
activates the service safety door to the right side of the library.

After the maintenance activity is complete, bring the CAPs and the right elevator 
online to the system through SLC. 
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ACommand Line Interface Reference

This appendix describes the Command Line Interface (CLI) commands available for an 
Admin user. Since the CLI is firmware-based, not all commands may be available for 
your library. 

Admin accessible CLI commands include:

■ audit

■ capCommand

■ cleaning

■ config

■ date

■ drive

■ hwActivation

■ mediaValidation

■ network

■ partition

■ reControl

■ snmp

■ ssh

■ time

■ traceRoute

■ version

■ whereAmi

audit
This command performs a physical audit on all or part of the library.

audit
Displays help for the audit command, the same as "help audit".

audit *
Initiates a physical audit of the entire library. This command returns immediately and 
displays no results.
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Example:

SL8500> audit *
   requestId
   requestId 9
   Done
   Failure Count 0
   Success Count 1
COMPLETED

audit <device address> <address>
Performs a physical audit of a single address and displays the results.

■ <device address> - specifies the robot to use in library, rail, column, side, row 
format.

■ <address> - specifies the cell location to audit in library, rail, column, side, row 
format.

Example:

SL8500> audit 1,4,0,1,0 1,4,-45,1,1
   requestId
   requestId 9
   Attributes Media Label #EMPTY..
   Object     Location    1,4,-45,1,1
   Done
   Failure Count 0
   Success Count 1
COMPLETED

audit <device address> <start address> <end address>
Performs a physical audits of a range of addresses and displays the results.

■ <device address> - specifies the robot to use in library, rail, column, side, row 
format.

■ <start address> <end address> - specifies the starting and ending cell location to 
audit in library, rail, column, side, row format. Only the row is variable between 
the start and end addresses.

Example:

SL8500> audit 1,4,0,1,0 1,4,-45,1,1 1,4,-45,1,2
   requestId
   requestId 10
   Attributes Media Label #EMPTY..
   Object     Location    1,4,-45,1,1
 
   Attributes Media Label EN34410R
   Object     Location    1,4,-45,1,2
   ...
   Done
   Failure Count 0
   Success Count 5
COMPLETED

audit multiRowScan {enable | disable | print} <device address>
Enables or disables multiple row scan audit capability to speed up audit time.

■ print - prints the multi-row scan audit state.

■ <device address> - specifies the robot to use in library, rail, column, side, row 
format.
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Example:

SL8500> audit multiRowScan print 1,1,0,1,0
   requestId
   requestId 8401
   Attributes Multi Row Scan enabled
   Object     Robot          1,1,0,1,0
   Done
   Failure Count 0
   Success Count 1
COMPLETED

capCommand
This command is for managing CAPs.

capCommand
Displays help for the capCommand command, the same as "help capCommand".

capCommand forceUnreserve <device address>
Forces the release of a CAP. If cartridges are in the CAP, the reservation changes to 
"default". If there are no cartridges in the CAP, the reservation changes to "none".

■ <device address> - specifies the CAP to release in library, rail, column, side, row 
format.

capCommand {lock | unlock} <device address>
Locks or unlocks a CAP specified by the device address.

■ <device address> - specifies the CAP to lock/unlock in library, rail, column, side, 
row format.

cleaning
This family of commands displays and controls cleaning and diagnostic 
cartridge-related functions within the library. Only customers with the media 
validation feature should use these commands.

cleaning
Displays help for the cleaning command, the same as "help cleaning".

cleaning list cleaning
Lists all cleaning cartridges in the system cells.

Example:

SL8500> cleaning list cleaning
   requestId
   requestId 9001
   Attributes Expired  false
      Label            CLN0080U
      Location         1,1,-52,1,13
      Max Usage Count  100
      Media Type       9840_Cleaning
      Status           ok
      Usage Count      0
Object Cartridge       cleaning
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cleaning import <cap device address> [ to { 1 | 2 | 3 | 4 | * } ]
Imports cleaning and diagnostic cartridges to system cells. Only one import/export 
operation is allowed at a time. There must be a minimum 9 empty system cells for 
SL8500 libraries to allow imports. 

■ <cap device address> - specifies the CAP to use for the import operation, in library, 
rail, column, side, row format.

■ to { 1 | 2 | 3 | 4 | * } - specifies the rail to import cartridge to if possible (optional)

Example:

SL8500> cleaning import 1,2,55,1,0 to 1
   requestId
   requestId 10101
   Message CAP open(ing). Place cartridges to import in CAP, then close CAP.Use 
CONTINUE cmd to proceed...
   Done
   Failure Count 0
   Success Count 0
COMPLETED

cleaning export <cap device address> cleaning select { 1 | 2 | 3 | 4 | expired }
Exports selected cleaning cartridges. Only one import/export operation is allowed at a 
time.

■ <cap device address> - specifies the CAP to use for the export operation, in library, 
rail, column, side, row format.

■ select { 1 | 2 | 3 | 4 | expired } - specifies the rail number to export cleaning 
cartridges from.

Example:

SL8500> cleaning export 1,2,55,2,0 cleaning select expired
   requestId
   requestId 9601
   Address      1.4.-52.1.12
   Success      Cartridge Exported
   Volume Label CLN002CU
   Message CAP open(ing). Remove cartridges, then close CAP.Use CONTINUE cmd to 
proceed...
   Done
   Failure Count 0
   Success Count 1
COMPLETED

cleaning export <cap device address> <cartridge address>
Exports a specific cleaning or diagnostic cartridge to the specified cap. Only one 
import/export operation is allowed at a time. 

■ <cap device address> - specifies the CAP to use for the export operation, in library, 
rail, column, side, row format.

■ <cartridge address> - specifies the location of the cartridge to export in library, rail, 
column, side, row format. The specified cartridge must be in a system cell and 
must be either a cleaning or diagnostic cartridge.

Example:

SL8500> cleaning export 1,2,55,2,0 1,4,-52,1,12
   requestId
   requestId 9601
   Address      1.4.-52.1.12
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   Success      Cartridge Exported
   Volume Label CLN002CU
   Message CAP open(ing). Remove cartridges, then close CAP.Use CONTINUE cmd to 
proceed...
   Done
   Failure Count 0
   Success Count 1
COMPLETED

cleaning threshold list
Displays a list of cleaning cartridge types and their warning thresholds. Each cleaning 
cartridge type has 4 attributes: 

■ Index - cleaning cartridge type used by the "cleaning threshold set" command

■ Media type - the type of cleaning cartridge used

■ Maximum usage count - recommended max usage by tape manufacturer

■ Warning threshold value - user-defined threshold that determines when a 
warning status is set for a cleaning cartridge once its usage count reaches that 
threshold.

Example:

SL3000> cleaning threshold list
   requestId
   requestId 15001
   Attributes
   Object     Index               1
              Media Type          SgtUltrium1_Cleaning
              Recommend Max Usage 100
              Warning Threshold   0
   Attributes
   Object     Index               3
              Media Type          T10000_Cleaning
              Recommend Max Usage 50
              Warning Threshold   0

cleaning threshold set <warning threshold value> <list index number>
Sets a warning threshold value for a particular cleaning cartridge type.

■ <warning threshold value> - can be any positive integer up to 1000. A value of 0 
indicates no warning threshold.

■ <list index number> - cleaning cartridge type as specified by the index number from 
the table listing of the "cleaning threshold list" command.

Example:

SL3000> cleaning threshold set 55 11
   requestId
   requestId 15101
   Attributes
   Object      Success true
   Done
COMPLETED

cleaning driveWarning set { on | off }
Sets the drive cleaning warning flag to either on or off.

■ on - the drive health status will be set to warn if it needs cleaning

■ off - the drive health status is not affected if the drive needs cleaning
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config
This command will either display the current physical library configuration or set 
library configuration parameters.

config
Displays help for the config command, the same as "help config".

config complexId set {1 - 127}
Sets the complexId used for SDP for just the library in which the command is 
executed. If more than one library exists in a complex, the complexId must be set 
individually for each library in the complex.

config complexId set {1 - 127} <library address>
Sets the complexId used for SDP for a remote library. If more than one library exists in 
a complex, the complexId must be set individually for each library in the complex.

■ <library address> - specifies the library in library, rail, column, side, row format. For 
example: 2, 0, 0, 0, 0.

config complexId clear
Clears the complexId number for a library. This command will restart the network 
stack and cause the SDP ILC IP address to stop responding.

config complexId clear <library address>
Clears the complexId number for a remote library. This command will restart the 
network stack and cause the SDP ILC IP address to stop responding.

■ <library address> - specifies the library in library, rail, column, side, row format. For 
example: 2, 0, 0, 0, 0.

config complexId print
Displays the current complexId for the library in which the command is executed.

config ilc print
Display the ilc status.

config ilc {enable | disable}
Enables or disables the Inter-Library Communications (ILC) LAN. If a disable is 
requested, the library must first be taken offline using the "accessState offline <device 
address>" command.

config libraryId print
Displays the current library identifier for this library.

config libraryId set {1 - 32}
Sets the libraryId with a value from 1-32. The library must be offline for this command.

config print
Displays the current physical library configuration.

config serviceInfo print
Displays the library service information.

config serviceInfo set
Sets service information: contact 'contactName' phone 'phoneNumber' streetAddr 
'streetAddress' city 'city' state 'state' country 'country' zip 'zipCode' description 
'description data'. 
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Currently the maximum string length is 31 characters. Each string must be delimited 
by ' ' (single quotes) to provide the ability to use spaces and other characters.

Example:

SL8500> config serviceInfo set city 'Denver' contact 'Andy' country 'USA' 
description 'Manager' phone '303 222-4444' state 'C0' streetAddr '1 tape drive' 
zip '80027'

requestId
requestId 1512402
Device serviceInfo
Success true
Done
Failure Count 0
Success Count 1
COMPLETED

date
This command sets the library date in Greenwich Mean Time (GMT).

date
Displays help for the date command, the same as "help date".

date print
Displays the current system date.

date <MM> / <DD> / <YYYY>
Sets the system date. In a library complex, the library with libraryId = 1 is the master. 
Change the date on the master library.

■ <MM> - two digit month

■ <DD> - two digit day

■ <YYYY> - four digit year

drive
This command displays information about the drives or executes the drive utilities 
such as adiEnable, fastLoad, power, and rewindUnload.

drive
Displays help for the drive command, the same as "help drive".

drive adiEnable {on | off | print}
Turns on or off or prints status of drive discovery with ADI. Once enabled, any 
subsequently added drives will attempt ADI drive discovery. To enable ADI for all 
ADI capable drives in the library, the library must be rebooted.

drive fastLoad {on | off | print}
Turns on or off or prints the status of the fastLoad feature. FastLoad changes the 
behavior of drive mounts (move commands). With fastLoad on, the robot will not wait 
for a complete load of a PUT to a drive, but will go immediately to the next operation. 
Also changes the behavior of the rewindUnload command to return immediately, not 
waiting for the drive to unload. The state of the fastLoad applies to all drives.



hwActivation

A-8 StorageTek SL8500 User Guide

drive print { <drive address> | * }
Displays summary drive information: location, state, status, type, firmware version, 
interface type, in use, serial number, state (online/offline), status (ok, warning, or 
error), and drive vendor.

■ <drive address> - specifies the drive in library, rail, column, side, row format.

■ * - displays drive information for all drives in the library

drive search {on | off} <drive address>
Causes the green LED on the drive tray to blink. Blinking continues until the search off 
command issued.Used to locate a drive within the library.

■ <drive address> - specifies the drive in library, rail, column, side, row format.

hwActivation
This command activating certain library features after purchasing a hardware 
activation permit.

hwActivation
Displays help for the hwActivation command, same as "help hwActivation".

hwActivation addLicenseFile
Adds a license file. The license file must be named SL8500_license_config.dsf. The full 
path name being /usr/local/SL8500_license_config.dsf.

hwActivation deleteFile <index>
Deletes the specified installed feature file.

■ <index> - specifies file number to delete as specified in the library controller 
hwActivation module database. See "hwActivation listFiles".

hwActivation listFiles
Lists the installed feature files in the library controller hwActivation module database.

hwActivation print
Lists all of the enabled features in the library controller hwActivation module 
database.

mediaValidation
This command manages the media validation feature.

mediaValidation
Displays help for the mediaValidation command, same as "help mediaValidation"

mediaValidation print { all | poolOnly } { * | @ }
Displays drive locations of the media validation pool.

Note: This command only affects commands issued in the same CLI 
session where this command was issued.

Note: The library must be rebooted when disabling openVolser, 
dualRobot, partitioning, or redundant electronics.
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■ all - lists all drive slots

■ poolOnly - lists only drive slots in the media validation pool

■ * - displays only information for the target library

■ @ - displays information for the entire complex

mediaValidation reservation clear <drive address>
Clears media validation reservation for specified drive.

■ <drive address> - specifies the drive in library, rail, column, side, row format.

mediaValidation stopValidation <drive address>
Stops a validation currently in progress. Cartridge is returned to source storage cell.

■ <drive address> - specifies the drive in library, rail, column, side, row format.

network
This command is used to configure and display network configuration for the 
controller card. For additional information, see the SL8500 Host Connectivity Guide on 
OTN.

network clone [Port 2B IP address] [Port 2A IP address]
Used for redundant electronics configuration. Copies all port, routing, and IP policy 
configurations to side B HBC. IP addresses are replaced with the ones specified in the 
command for side B. If no port IP address is specified, then they are not set on side B.

network config print
Displays the target library side (A or B) that is set for network commands.

network config side {a | b}
Sets the target library side for network commands.

network config clear
Clears the network configuration. This command stops network connectivity. 
Reconfiguration requires access to the serial port on the HBC card.

network export
Exports library network configuration file (.lnc) and generates a network configuration 
script (.scr). It can only be used in cases where no prior network configurations have 
been set.

network gateway <IP address>
Sets the external network default gateway.

network gateway clear
Clears the external network default gateway.

network import
Imports a library network configuration file (.lnc).

network ip <IP address>
Sets the IP address of port 2B.

network ip address add <IP address> dev {2A | 2B}
Sets the IP address of a particular port.
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network ip address del <IP address> dev {2A | 2B}
Removes the IP address of a port.

network ip address show [dev {2A | 2B}]
Displays the current address information for a particular port or both ports if dev is 
not specified.

network ip link set dev {2A | 2B} {up | down}
Sets the operation status of a port, which controls whether a port can send and receive 
Ethernet traffic.

■ up - sets port online

■ down - sets port offline

network ip policy {enable | disable} dev {2A | 2B}
Enables or disables policy routing for device 2A or 2B.

network ip policy status
Displays policy routing status for devices 2A and 2B.

network ip policy route {add | del} <IP address> dev {2A | 2B}
Adds or deletes a static route to policy for device 2A or 2B.

network ip policy route {add | del} <IP address> via <Gateway IP address> dev {2A | 
2B}
Adds or deletes a static route to policy for device 2A or 2B via gateway.

network ip policy route show [ dev {2A | 2B} ]
Displays policy route information for device 2A or 2B.

network ip route add default via <IP address>
Sets the default gateway routing IP address.

network ip route delete default
Deletes the default gateway routing IP address.

network ip route {add | del} <IP address [/netmask] > dev {1A | 1B | 2A | 2B}
Adds or deletes a static IP (Internet Protocol) routing address for a specified host. This 
command also enables a user to set the netmask for a particular port.

Example:

SL8500>network ip route add 129.80.81.59/24 dev 1B
COMPLETED

network ip route {add | del} <IP address [/netmask] > via <Gateway IP address>
Adds or deletes a static route to a destination network IP gateway address.

network ip route show [dev {2A | 2B}]
Displays the current routing table information or routing table information for a 
particular port.

network name <host name string>
Sets the host name.

network netmask <netmask>
Sets the external network netmask in xxx.xxx.xxx.xxx form.
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network print
Displays the current network configuration for the external Ethernet ports (2A and 
2B).

partition
This command displays the current status or disables the partition feature.

partition
Displays help for the partition command, same as "help partition".

partition autoClean set { * | <Partition Id> }
Set auto clean in a specified partition (0, for a non-partitioned library).

partition attribute status { * | <Partition Id> }
Displays the status attributes of a single specified partition or all partitions.

partition disable
Disables partitioning in the library.

partition getCapacity
Displays the capacity values for library or any defined partitions.

partition status
Displays the current partitioning status.

partition setCapacity { <Partition Id> , <Capacity> }
Sets the capacity for the designated partition. Existing partitions not listed in the 
command will have their capacity set to zero.

Example:

SL8500> partition setCapacity 1,200 2,50 3,600
   requestId 7601
   Done
   Failure Count 0
   Success Count 1
COMPLETED

partition setNonPartitionedHLI
Sets the partition to hli0. If there are any drives in the media validation pool, they must 
be removed beforehand. If in complex, it sets all the libraries to hli0. 

partition set state {online | offline} <Partition Id>
Sets the current state (offline/online) of a specified partition.

reControl
This command controls/switches the redundant electronics and retrieves the library 
controller redundant electronics statuses.

reControl
Displays help for the reControl command, same as "help reControl".

reControl status [ <library address> | * ]
Retrieves the redundant electronics status.
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■ <library address> - specifies the library in library, rail, column, side, row format. For 
example: 2, 0, 0, 0, 0.

■ * - retrieves status from all libraries in a complex

snmp
This command configures the Simple Network Management Protocol (SNMP). For 
detailed information, see the SNMP Reference Guide on OTN.

ssh
This command controls configuration for the ssh daemon/server which resides on the 
HBC. This is the protocol utility which SLC and other various applications use to 
connect to the library controller.

ssh print
Prints the current ssh daemon protocol settings.

ssh set version1and2
Sets the ssh daemon protocol restriction to v1 and v2. (this is the default). The ssh 
server is restarted.

ssh set version2
Sets the ssh daemon protocol restriction to v2 only.

time
This command sets the library time in military time notation.

time
Displays help for the time command, same as "help time".

time print
Displays the current system time.

time <HH> : <MM>
Sets the system time. Resolution is within one minute. In a library complex, the library 
with libraryId = 1 is the master. Change the time on the master library.

■ <HH> - two digit hour

■ <MM> - two digit minute

time <HH> : <MM> : <SS>
Sets the system time. Resolution is within one second. In a library complex, the library 
with libraryId = 1 is the master. Change the time on the master library.

■ <HH> - two digit hour

■ <MM> - two digit minute

■ <SS> - two digit second

traceRoute
This command traces the network route to a specified IP address.
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traceRoute <IP Address>
Executes a traceRoute to the IP address specified.

version
This command displays the customer version and the versions of the software for the 
device(s) requested.

version print [ <device address> | *]
Displays the software version of code for a device or all devices.

■ <device address> - specifies the device in library, rail, column, side, row format. 

whereAmi
This command displays the system and logic card information relative to the library 
and card related to redundant electronics command is being executed.

whereAmi
Displays the information relating to where the command is being issued.

Example:

SL8500> whereAmI
   Host Name: gulibtst02b
   Port 2B IP Address: 172.20.151.24
   Library Type: SL8500
   HBC side: B
   Active side: B
COMPLETED
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BLibrary Addressing

This appendix explains the addressing schemes used in the SL8500 library. There are 
two types of software addressing schemes: and one external numbering scheme:

■ Internal Firmware Addressing Scheme (Library, Rail, Column, Side, Row) used 
by the firmware and internal communications to represent all devices and 
locations within the library.

■ HLI-PRC Addressing Scheme (LSM, Panel, Row, and Column) used by HLI 
clients, such as ACSLS and ELS, to represent library locations and components.

Additionally, there is an external hardware numbering scheme for drive bay locations. 
This differs from both the internal firmware addressing and HLI-PRC addressing. See 
"Tape Drive Addressing" on page B-6 for more information.

■ Structural Elements Used in Addressing

■ Internal Firmware Addressing Scheme

■ HLI-PRC Addressing Scheme

■ Comparison of the Addressing Schemes

■ Tape Drive Addressing

■ Internal Firmware Addressing Components

Structural Elements Used in Addressing
The addressing of components in the library is based on key structural elements: 
library walls, slot arrays, LSMs/rails, and columns/panels.

Library Walls, Arrays, and Slots
■ Inner walls: consist of 14-slot arrays

■ Outer walls: consist of 13-slot arrays with space for the robotic rails

In addition to the 13 and 14-slot arrays, there are arrays:

■ In the pass-thru port panels: 8-slot arrays

■ Underneath the stop brackets for the service safety door: 8-slot arrays

■ On the elevators and pass-thru ports: 4-slot arrays

Note: In this chapter, left and right refer to viewing the library from 
the CAP-side (front) unless otherwise specified.
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■ At the ends of each robot rail: 3-slot arrays (end stops)

Library Storage Module (LSM)
The SL8500 library has four rails. Each of these rails is considered an LSM.

Library Complex HLI Numbering
For the HLI addressing scheme, in a library complex the LSM number increases 
sequentially right to left with each additional library. 

■ Library 1 (Home library on right): LSM 0 to 3

■ Library 2 (middle library): LSM 4 to 7

■ Library 3 (left library): LSM 8 to 11

The pattern continues for up to ten libraries. When adding an additional library to a 
complex, you should add the library to the left side to prevent renumbering of LSMs 
within the complex. 

It is possible to add libraries to the right of the complex, but it is disruptive. You must 
re-configure the system, re-number the LSMs, and re-IPL the library.

Figure B–1 shows two examples of three libraries connected with PTPs.

■ Example 1 on the left shows the preferred method. Adding another library (C) to 
the left of the library complex increases the LSM numbering sequentially. 

■ Example 2 on the right shows the disruptive method. Adding another library (C) 
to the right of the library complex requires a reconfiguration of LSM numbering.

Figure B–1 Pass-thru Port Planning Example

Figure Legend:

1. Preferred, non-disruptive method of installation

2. Disruptive method of installation

3. New library and PTP

4. PTP connecting existing libraries
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Panels and Columns
Panels (used in HLI-PRC addressing) and columns (used in firmware addressing) refer 
to the horizontal location of a component in the library. Special panels/columns 
include:

■ Corners because there is no inner wall

■ Pass-thru ports because the top six slots are inaccessible because of the PTPs and 
because the top cartridge slot (under the port) is reserved as a redundant robotics 
drop-off slot (two for each rail, one on each side)

Internal Firmware Addressing Scheme
Internal firmware addressing designates physical location using five parameters: 
Library, Rail, Column, Side, Row (L,R,C,S,W).

■ Library: The number of the library within a library complex

■ Rail: Numbered top down from 1 to 4.

■ Column: The horizontal location of a tape cartridge referenced from the center of 
the drive bay at the rear of the library forward, where:

– +1 is just right of the center of the drive bays.

– -1 is just to the left of center of the drive bays.

– Column numbering is consecutive—the first columns that contain tape 
cartridges are +3 and -3 and continue forward to the front access doors.

■ Side: Indicates the inner and outer walls, left and right robots in a redundant 
configuration, or left and right CAPs.

– Walls: Outer wall =1, Inner wall =2

– Robots: Left robot =1, Right robot =2

– CAPs: Right Cap =1, Left Cap =2

■ Row: The vertical location of a tape cartridge in an array, consecutively numbered 
from the top (1) down (13 outer wall and 14 inner wall).

See also, "Internal Firmware Addressing Components" on page B-9.
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Figure B–2 Internal Firmware Addressing Scheme

HLI-PRC Addressing Scheme
This addressing scheme is used by HLI clients, such as ACSLS and ELS. Cartridge 
locations for HLI-PRC addressing use four parameters: LSM, Panel, Row, and Column.

■ LSM: Each rail is considered a separate library storage module (LSM). Rails are 
numbered 0 to 3 (from the top down).

The libraries in a complex are identified by LSM. For example, library one contains 
LSMs 0-3, library two: LSMs 4-7, library three: LSMs 8-11, and so on (see "Library 
Storage Module (LSM)" on page B-2).

■ Panel: Indicates the horizontal position in the library. Panels span across the width 
of the library to include both sides (left and right) and both walls (inner and outer) 
for each LSM. Panel 0 = CAP. Panel 1 = Drives. Panel 2 to n = Storage slots

■ Row: Is the vertical location of a tape cartridge in the arrays and are consecutively 
numbered from the top down. Outer walls = 0 to12. Inner walls = 13 to 26.

■ Column: Indicates the left or right side of the library (as viewed from the front). 
Left = 0. Right = 1.
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Figure B–3 HLI-PRC Addressing Scheme

The following lists the panel numbering ranges for various library configurations:

Table B–1 Panel Numbering

Configuration Panel Numbering

Base Library RIM CIM

2 - 7 8 - 10

One Expansion Module RIM SEM CIM

2 - 7 8 - 15 16 - 18

Two Expansion Modules RIM SEM SEM CIM

2 - 7 8 -15 16 - 23 24 - 26

Five Expansion Modules RIM SEM SEM SEM SEM SEM CIM

2 - 7 8 -15 16 - 23 24 - 31 32 - 39 40 - 47 48 - 50
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Comparison of the Addressing Schemes

Tape Drive Addressing
There are three types of addressing used to define drive location:

■ Hardware Address

■ Internal Firmware Address

■ HLI-PRC Address

Hardware Address
The HBC controller card assigns a physical hardware number from 1 to 64, depending 
on the location of the drive in the drive array.

The perspective in Figure B–4 is from the drive-side (rear) of the library.

Figure B–4 Physical Hardware Numbering of Tape Drive (viewed from rear of library)

Internal Firmware Address
For firmware addressing (Library, Rail, Column, Side, Row) a drive is distinguished 
based on rail, column, and row. The side value is always equal to 1.

Table B–2 Comparison of Addressing Schemes

Factor Internal Addressing HLI-PRC Addressing

Begins with: 1 and uses negative numbers 0 with no negative numbers

Uses: Library, rail, column, side, and row LSM, panel, row, and column

Column refers to: The horizontal location in the library The left or right side of the library

Row numbering: Outer walls =1 to13, inner walls =1 to 14 Outer walls = 0 to12, inner walls =13 to 26
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The perspective in Figure B–5 is from the CAP-side (front) of the library. For this 
example, the library number is 1.

Figure B–5 Tape Drive Internal Firmware Addressing (viewed from front of library)

HLI-PRC Address
The HLI-PRC (LSM, panel, row, column) distinguishes a drive in a library based on 
LSM and row. The panel value is always equal to 1 and the column value is always 
equal to 0.

The perspective in Figure B–6 is from the CAP-side (front) of the library.
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Figure B–6 Tape Drive HLI-PRC Addressing (viewed from front of library)

Drive Numbering Comparison
Figure B–7 shows the three address schemes side by side. The perspective in the figure 
is from the CAP-side (front) of the library.

Figure B–7 Comparison (viewed from front of library)
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Internal Firmware Addressing Components 
Components (such as CAPs, elevators, PTP, and robots) have unique addressing rules. 
Host software does not address these components directly. Therefore, only internal 
firmware addressing of specific components is explained in this document.

Important internal firmware addressing concepts for components include:

■ A row value equal to 0 indicates the address is referring to the device, not a slot in 
the device.

■ The side value may not directly correlate to inner and outer walls.

■ The column value of elevators and CAPs depends on the number of storage 
expansion modules in the library.

CAP Internal Firmware Addressing
■ Rail and Row:

– When numbering the device, the rail value is 2 and the row value is 0.

– When numbering a specific slot, the rail refers to the rail adjacent to the CAP 
magazine (can be values 2-4) and the row is the slot in the CAP magazine (can 
be values 1-13).

■ Column: The column value depends on the size of the library. The column value is 
the number of customer accessible columns plus 3. In a library with no SEMs, 
there are 11 customer accessible columns, therefore the CAP column value is 14.

■ Side:

– Right CAP = side value of 1

– Left CAP = side value of 2

Example
Firmware address 1, 3, 22, 2, 10 — The library value is 1. The CAP magazine referred 
to is adjacent to the third rail from the top (rail 3). The example library contains one 
SEM (so there are 19 customer accessible columns). Therefore, the column value is 
19 + 3 = 22. The CAP is on the left (side 2), and the address is referring to slot 10 in the 
CAP magazine (row 10).

PTP Internal Firmware Addressing
■ Rail: The value (1 to 4) refers to the rail adjacent to the PTP.

■ Column: Right PTP = column value of +6, left PTP = column value of -6.

■ Side: The side value is always 1, because the PTPs are on the outer wall.

■ Row:

– When numbering the device, the row is 0.

– When numbering a specific slot, the row is the slot in the PTP (1 or 2).

Example
Firmware address 1, 2, -6, 1, 0 — The library value is 1. The PTP referred to is on the 
second rail from the top (rail 2) and on the on the left side of the library (column -6) on 
the outer wall (side 1). The address is referring to the device (row 0).
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Elevator Internal Firmware Addressing
■ Rail: The value is always 0, since the elevators do not correspond to a specific rail.

■ Column: The value depends on the size of the library. The column value is the 
number of customer accessible columns plus 2. In a library with no SEMs, there 
are 19 customer accessible columns, therefore the elevator column value is 13.

■ Side: The value is always 2, because the elevators are on the inner wall.

■ Row:

– When numbering the device, the row is 0.

– When numbering a specific slot, the row is the slot in the elevator (1-4).

Example
Firmware address 1, 0, 21, 2, 4 — The library value is 1. The rail value is always 0 for 
elevators. The example library contains one SEM (so there are 19 customer accessible 
columns). Therefore, the column value is 19 + 2 = 21. The elevator is on the inner wall 
(side 2). The address is referring to the fourth slot in the elevator (row 4).

Robot Internal Firmware Addressing
■ Rail: The value (1 to 4) refers to the rail the robot is on.

■ Column: The value is always 0.

■ Side:

– If there is only one robot per rail, the value is always 1.

– For redundant robot configurations, the left robot = 1, and the right robot = 2.

■ Row:

– When numbering the device, the row is 0.

– When numbering the specific slot, the row is the slot value (1).

Example
Firmware 1, 1, 0, 2, 0 — The library value is 1. The address is referring to the right 
robot on the top rail.
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CControlling Contaminants

This appendix explains controlling contaminants.

Environmental Contaminants
Control over contaminant levels in a computer room is extremely important because 
tape libraries, tape drives, and tape media are subject to damage from airborne 
particulates. Most particles smaller than ten microns are not visible to the naked eye 
under most conditions, but these particles can be the most damaging. As a result, the 
operating environment must adhere to the following requirements:

■ ISO 14644-1 Class 8 Environment.

■ The total mass of airborne particulates must be less than or equal to 200 
micrograms per cubic meter.

■ Severity level G1 per ANSI/ISA 71.04-1985.

Oracle currently requires the ISO 14644-1 standard approved in 1999, but will require 
any updated standards for ISO 14644-1 as they are approved by the ISO governing 
body. The ISO 14644-1 standard primarily focuses on the quantity and size of 
particulates as well as the proper measurement methodology, but does not address the 
overall mass of the particulates. As a result, the requirement for total mass limitations 
is also necessary as a computer room or data center could meet the ISO 14644-1 
specification, but still damage equipment because of the specific type of particulates in 
the room. In addition, the ANSI/ISA 71.04-1985 specification addresses gaseous 
contaminations as some airborne chemicals are more hazardous. All three 
requirements are consistent with the requirements set by other major tape storage 
vendors.

Required Air Quality Levels
Particles, gasses and other contaminants may impact the sustained operations of 
computer hardware. Effects can range from intermittent interference to actual 
component failures. The computer room must be designed to achieve a high level of 
cleanliness. Airborne dusts, gasses and vapors must be maintained within defined 
limits to help minimize their potential impact on the hardware.

Airborne particulate levels must be maintained within the limits of ISO 14644-1 Class 8 
Environment. This standard defines air quality classes for clean zones based on 
airborne particulate concentrations. This standard has an order of magnitude less 
particles than standard air in an office environment. Particles ten microns or smaller 
are harmful to most data processing hardware because they tend to exist in large 
numbers, and can easily circumvent many sensitive components' internal air filtration 
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systems. When computer hardware is exposed to these submicron particles in great 
numbers they endanger system reliability by posing a threat to moving parts, sensitive 
contacts and component corrosion.

Excessive concentrations of certain gasses can also accelerate corrosion and cause 
failure in electronic components. Gaseous contaminants are a particular concern in a 
computer room both because of the sensitivity of the hardware, and because a proper 
computer room environment is almost entirely recirculating. Any contaminant threat 
in the room is compounded by the cyclical nature of the airflow patterns. Levels of 
exposure that might not be concerning in a well ventilated site repeatedly attack the 
hardware in a room with recirculating air. The isolation that prevents exposure of the 
computer room environment to outside influences can also multiply any detrimental 
influences left unaddressed in the room.

Gasses that are particularly dangerous to electronic components include chlorine 
compounds, ammonia and its derivatives, oxides of sulfur and petrol hydrocarbons. In 
the absence of appropriate hardware exposure limits, health exposure limits must be 
used.

While the following sections will describe some best practices for maintaining an ISO 
14644-1 Class 8 Environment in detail, there are some basic precautions that must be 
adhered to:

■ Do not allow food or drink into the area.

■ Cardboard, wood, or packing materials must not be stored in the data center clean 
area.

■ Identify a separate area for unpacking new equipment from crates and boxes.

■ Do not allow construction or drilling in the data center without first isolating 
sensitive equipment and any air targeted specifically for the equipment. 
Construction generates a high level of particulates that exceed ISO 14644-1 Class 8 
criteria in a localized area. Dry wall and gypsum are especially damaging to 
storage equipment.

Contaminant Properties and Sources
Contaminants in the room can take many forms, and can come from numerous 
sources. Any mechanical process in the room can produce dangerous contaminants or 
agitate settled contaminants. A particle must meet two basic criteria to be considered a 
contaminant:

■ It must have the physical properties that could potentially cause damage to the 
hardware.

■ It must be able to migrate to areas where it can cause the physical damage.

The only differences between a potential contaminant and an actual contaminant are 
time and location. Particulate matter is most likely to migrate to areas where it can do 
damage if it is airborne. For this reason, airborne particulate concentration is a useful 
measurement in determining the quality of the computer room environment. 
Depending on local conditions, particles as big as 1,000 microns can become airborne, 
but their active life is very short, and they are arrested by most filtration devices. 
Submicron particulates are much more dangerous to sensitive computer hardware, 
because they remain airborne for a much longer period of time, and they are more apt 
to bypass filters.
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Operator Activity
Human movement within the computer space is probably the single greatest source of 
contamination in an otherwise clean computer room. Normal movement can dislodge 
tissue fragments, such as dander or hair, or fabric fibers from clothing. The opening 
and closing of drawers or hardware panels or any metal-on-metal activity can produce 
metal filings. Simply walking across the floor can agitate settled contamination 
making it airborne and potentially dangerous.

Hardware Movement
Hardware installation or reconfiguration involves a great deal of subfloor activity, and 
settled contaminants can very easily be disturbed, forcing them to become airborne in 
the supply air stream to the room's hardware. This is particularly dangerous if the 
subfloor deck is unsealed. Unsealed concrete sheds fine dust particles into the 
airstream, and is susceptible to efflorescence -- mineral salts brought to the surface of 
the deck through evaporation or hydrostatic pressure.

Outside Air
Inadequately filtered air from outside the controlled environment can introduce 
innumerable contaminants. Post-filtration contamination in duct work can be 
dislodged by air flow, and introduced into the hardware environment. This is 
particularly important in a downward-flow air conditioning system in which the 
sub-floor void is used as a supply air duct. If the structural deck is contaminated, or if 
the concrete slab is not sealed, fine particulate matter (such as concrete dust or 
efflorescence) can be carried directly to the room's hardware.

Stored Items
Storage and handling of unused hardware or supplies can also be a source of 
contamination. Corrugated cardboard boxes or wooden skids shed fibers when moved 
or handled. Stored items are not only contamination sources; their handling in the 
computer room controlled areas can agitate settled contamination already in the room.

Outside Influences
A negatively pressurized environment can allow contaminants from adjoining office 
areas or the exterior of the building to infiltrate the computer room environment 
through gaps in the doors or penetrations in the walls. Ammonia and phosphates are 
often associated with agricultural processes, and numerous chemical agents can be 
produced in manufacturing areas. If such industries are present in the vicinity of the 
data center facility, chemical filtration may be necessary. Potential impact from 
automobile emissions, dusts from local quarries or masonry fabrication facilities or sea 
mists should also be assessed if relevant.

Cleaning Activity
Inappropriate cleaning practices can also degrade the environment. Many chemicals 
used in normal or "office" cleaning applications can damage sensitive computer 
equipment. Potentially hazardous chemicals outlined in the "Cleaning Procedures and 
Equipment" on page C-8 section should be avoided. Out-gassing from these products 
or direct contact with hardware components can cause failure. Certain biocide 
treatments used in building air handlers are also inappropriate for use in computer 
rooms either because they contain chemicals, that can degrade components, or because 
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they are not designed to be used in the airstream of a re-circulating air system. The use 
of push mops or inadequately filtered vacuums can also stimulate contamination.

It is essential that steps be taken to prevent air contaminants, such as metal particles, 
atmospheric dust, solvent vapors, corrosive gasses, soot, airborne fibers or salts from 
entering or being generated within the computer room environment. In the absence of 
hardware exposure limits, applicable human exposure limits from OSHA, NIOSH or 
the ACGIH should be used.

Contaminant Effects
Destructive interactions between airborne particulate and electronic instrumentation 
can occur in numerous ways. The means of interference depends on the time and 
location of the critical incident, the physical properties of the contaminant and the 
environment in which the component is placed.

Physical Interference
Hard particles with a tensile strength at least 10% greater than that of the component 
material can remove material from the surface of the component by grinding action or 
embedding. Soft particles will not damage the surface of the component, but can 
collect in patches that can interfere with proper functioning. If these particles are tacky 
they can collect other particulate matter. Even very small particles can have an impact 
if they collect on a tacky surface, or agglomerate as the result of electrostatic charge 
build-up.

Corrosive Failure
Corrosive failure or contact intermittence due to the intrinsic composition of the 
particles or due to absorption of water vapor and gaseous contaminants by the 
particles can also cause failures. The chemical composition of the contaminant can be 
very important. Salts, for instance, can grow in size by absorbing water vapor from the 
air (nucleating). If a mineral salts deposit exists in a sensitive location, and the 
environment is sufficiently moist, it can grow to a size where it can physically interfere 
with a mechanism, or can cause damage by forming salt solutions.

Shorts
Conductive pathways can arise through the accumulation of particles on circuit boards 
or other components. Many types of particulate are not inherently conductive, but can 
absorb significant quantities of water in high-moisture environments. Problems caused 
by electrically conductive particles can range from intermittent malfunctioning to 
actual damage to components and operational failures.

Thermal Failure
Premature clogging of filtered devices will cause a restriction in air flow that could 
induce internal overheating and head crashes. Heavy layers of accumulated dust on 
hardware components can also form an insulative layer that can lead to heat-related 
failures.

Room Conditions
All surfaces within the controlled zone of the data center should be maintained at a 
high level of cleanliness. All surfaces should be periodically cleaned by trained 
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professionals on a regular basis, as outlined in the "Cleaning Procedures and 
Equipment" on page C-8 section. Particular attention should be paid to the areas 
beneath the hardware, and the access floor grid. Contaminants near the air intakes of 
the hardware can more easily be transferred to areas where they can do damage. 
Particulate accumulations on the access floor grid can be forced airborne when floor 
tiles are lifted to gain access to the sub-floor.

The subfloor void in a downward-flow air conditioning system acts as the supply air 
plenum. This area is pressurized by the air conditioners, and the conditioned air is 
then introduced into the hardware spaces through perforated floor panels. Thus, all air 
traveling from the air conditioners to the hardware must first pass through the 
subfloor void. Inappropriate conditions in the supply air plenum can have a dramatic 
effect on conditions in the hardware areas.

The subfloor void in a data center is often viewed solely as a convenient place to run 
cables and pipes. It is important to remember that this is also a duct, and that 
conditions below the false floor must be maintained at a high level of cleanliness. 
Contaminant sources can include degrading building materials, operator activity or 
infiltration from outside the controlled zone. Often particulate deposits are formed 
where cables or other subfloor items form air dams that allow particulate to settle and 
accumulate. When these items are moved, the particulate is re-introduced into the 
supply airstream, where it can be carried directly to hardware.

Damaged or inappropriately protected building materials are often sources of subfloor 
contamination. Unprotected concrete, masonry block, plaster or gypsum wall-board 
will deteriorate over time, shedding fine particulate into the air. Corrosion on 
post-filtration air conditioner surfaces or subfloor items can also be a concern. The 
subfloor void must be thoroughly and appropriately decontaminated on a regular 
basis to address these contaminants. Only vacuums equipped with High Efficiency 
Particulate Air (HEPA) filtration should be used in any decontamination procedure. 
Inadequately filtered vacuums will not arrest fine particles, passing them through the 
unit at high speeds, and forcing them airborne.

Unsealed concrete, masonry or other similar materials are subject to continued 
degradation. The sealants and hardeners normally used during construction are often 
designed to protect the deck against heavy traffic, or to prepare the deck for the 
application of flooring materials, and are not meant for the interior surfaces of a 
supply air plenum. While regular decontaminations will help address loose 
particulate, the surfaces will still be subject to deterioration over time, or as subfloor 
activity causes wear. Ideally all of the subfloor surfaces will be appropriately sealed at 
the time of construction. If this is not the case, special precautions will be necessary to 
address the surfaces in an on-line room.

It is extremely important that only appropriate materials and methodology are used in 
the encapsulation process. Inappropriate sealants or procedures can actually degrade 
the conditions they are meant to improve, impacting hardware operations and 
reliability. The following precautions should be taken when encapsulating the supply 
air plenum in an on-line room:

■ Manually apply the encapsulant. Spray applications are totally inappropriate in an 
on-line data center. The spraying process forces the sealant airborne in the supply 
airstream, and is more likely to encapsulate cables to the deck.

■ Use a pigmented encapsulant. The pigmentation makes the encapsulant visible in 
application, ensuring thorough coverage, and helps in identifying areas that are 
damaged or exposed over time.
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■ It must have a high flexibility and low porosity to effectively cover the irregular 
textures of the subject area, and to minimize moisture migration and water 
damage.

■ The encapsulant must not out-gas any harmful contaminants. Many encapsulants 
commonly used in industry are highly ammoniated or contain other chemicals 
that can be harmful to hardware. It is very unlikely that this out-gassing could 
cause immediate, catastrophic failure, but these chemicals will often contribute to 
corrosion of contacts, heads or other components.

Effectively encapsulating a subfloor deck in an on-line computer room is a very 
sensitive and difficult task, but it can be conducted safely if appropriate procedures 
and materials are used. Avoid using the ceiling void as an open supply or return for 
the building air system. This area is typically very dirty and difficult to clean. Often 
the structural surfaces are coated with fibrous fire-proofing, and the ceiling tiles and 
insulation are also subject to shedding. Even before filtration, this is an unnecessary 
exposure that can adversely affect environmental conditions in the room. It is also 
important that the ceiling void does not become pressurized, as this will force dirty air 
into the computer room. Columns or cable chases with penetrations in both the 
subfloor and ceiling void can lead to ceiling void pressurization.

Exposure Points
All potential exposure points in the data center should be addressed to minimize 
potential influences from outside the controlled zone. Positive pressurization of the 
computer rooms will help limit contaminant infiltration, but it is also important to 
minimize any breaches in the room perimeter. To ensure the environment is 
maintained correctly, the following should be considered:

■ All doors should fit snugly in their frames.

■ Gaskets and sweeps can be used to address any gaps.

■ Automatic doors should be avoided in areas where they can be accidentally 
triggered. An alternate means of control would be to remotely locate a door trigger 
so that personnel pushing carts can open the doors easily. In highly sensitive areas, 
or where the data center is exposed to undesirable conditions, it may be advisable 
to design and install personnel traps. Double sets of doors with a buffer between 
can help limit direct exposure to outside conditions.

■ Seal all penetrations between the data center and adjacent areas.

■ Avoid sharing a computer room ceiling or subfloor plenum with loosely controlled 
adjacent areas.

Filtration
Filtration is an effective means of addressing airborne particulate in a controlled 
environment. It is important that all air handlers serving the data center are 
adequately filtered to ensure appropriate conditions are maintained within the room. 
In-room process cooling is the recommended method of controlling the room 
environment. The in-room process coolers re-circulate room air. Air from the hardware 
areas is passed through the units where it is filtered and cooled, and then introduced 
into the subfloor plenum. The plenum is pressurized, and the conditioned air is forced 
into the room, through perforated tiles, which then travels back to the air conditioner 
for reconditioning. The airflow patterns and design associated with a typical computer 
room air handler have a much higher rate of air change than typical comfort cooling 
air conditioners so air is filtered much more often than in an office environment. 
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Proper filtration can capture a great deal of particulates. The filters installed in the 
in-room, re-circulating air conditioners should have a minimum efficiency of 40% 
(Atmospheric Dust-Spot Efficiency, ASHRAE Standard 52.1). Low-grade pre-filters 
should be installed to help prolong the life of the more expensive primary filters.

Any air being introduced into the computer room controlled zone, for ventilation or 
positive pressurization, should first pass through high efficiency filtration. Ideally, air 
from sources outside the building should be filtered using High Efficiency Particulate 
Air (HEPA) filtration rated at 99.97% efficiency (DOP Efficiency MILSTD-282) or 
greater. The expensive high efficiency filters should be protected by multiple layers of 
pre-filters that are changed on a more frequent basis. Low-grade pre-filters, 20% 
ASHRAE atmospheric dust-spot efficiency, should be the primary line of defense. The 
next filter bank should consist of pleated or bag type filters with efficiencies between 
60% and 80% ASHRAE atmospheric dust-spot efficiency.

Low efficiency filters are almost totally ineffective at removing sub-micron particulates 
from the air. It is also important that the filters used are properly sized for the air 
handlers. Gaps around the filter panels can allow air to bypass the filter as it passes 
through the air conditioner. Any gaps or openings should be filled using appropriate 
materials, such as stainless steel panels or custom filter assemblies.

Positive Pressurization and Ventilation
A designed introduction of air from outside the computer room system will be 
necessary in order to accommodate positive pressurization and ventilation 
requirements. The data center should be designed to achieve positive pressurization in 
relation to more loosely controlled surrounding areas. Positive pressurization of the 
more sensitive areas is an effective means of controlling contaminant infiltration 
through any minor breaches in the room perimeter. Positive pressure systems are 
designed to apply outward air forces to doorways and other access points within the 
data processing center in order to minimize contaminant infiltration of the computer 
room. Only a minimal amount of air should be introduced into the controlled 
environment. In data centers with multiple rooms, the most sensitive areas should be 
the most highly pressurized. It is, however, extremely important that the air being 
used to positively pressurize the room does not adversely affect the environmental 
conditions in the room. It is essential that any air introduction from outside the 
computer room is adequately filtered and conditioned to ensure that it is within 
acceptable parameters. These parameters can be looser than the goal conditions for the 
room since the air introduction should be minimal. A precise determination of 
acceptable limits should be based on the amount of air being introduced and the 
potential impact on the environment of the data center.

Because a closed-loop, re-circulating air conditioning system is used in most data 
centers, it will be necessary to introduce a minimal amount of air to meet the 

Table C–1 Filtration Percentages 

ASHRAE 52-76 Dust spot 
efficiency percentage 3.0 micron 1.0 micron 0.3 micron

25-30% 80% 20% <5%

60-65% 93% 50% 20%

80-85% 99% 90% 50%

90% >99% 92% 60%

DOP 95% N/A >99% 95%
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ventilation requirements of the room occupants. Data center areas normally have a 
very low human population density; thus the air required for ventilation will be 
minimal. In most cases, the air needed to achieve positive pressurization will likely 
exceed that needed to accommodate the room occupants. Normally, outside air 
quantities of less than 5% make-up air should be sufficient (ASHRAE Handbook: 
Applications, Chapter 17). A volume of 15 CFM outside air per occupant or 
workstation should sufficiently accommodate the ventilation needs of the room.

Cleaning Procedures and Equipment
Even a perfectly designed data center requires continued maintenance. Data centers 
containing design flaws or compromises may require extensive efforts to maintain 
conditions within desired limits. Hardware performance is an important factor 
contributing to the need for a high level of cleanliness in the data center.

Operator awareness is another consideration. Maintaining a fairly high level of 
cleanliness will raise the level of occupant awareness with respect to special 
requirements and restrictions while in the data center. Occupants or visitors to the data 
center will hold the controlled environment in high regard and are more likely to act 
appropriately. Any environment that is maintained to a fairly high level of cleanliness 
and is kept in a neat and well organized fashion will also command respect from the 
room's inhabitants and visitors. When potential clients visit the room they will 
interpret the overall appearance of the room as a reflection of an overall commitment 
to excellence and quality. An effective cleaning schedule must consist of specially 
designed short-term and long-term actions. These can be summarized as follows:

Daily Tasks
This statement of work focuses on the removal of each day's discarded trash and 
rubbish from the room. In addition, daily floor vacuuming may be required in Print 
Rooms or rooms with a considerable amount of operator activity.

Weekly Tasks
This statement of work focuses on the maintenance of the access floor system. During 
the week, the access floor becomes soiled with dust accumulations and blemishes. The 
entire access floor should be vacuumed and damp mopped. All vacuums used in the 
data center, for any purpose, should be equipped with High Efficiency Particulate Air 
(HEPA) filtration. Inadequately filtered equipment cannot arrest smaller particles, but 
rather simply agitates them, degrading the environment they were meant to improve. 
It is also important that mop-heads and dust wipes are of appropriate non-shedding 
designs.

Table C–2 Cleaning Schedule for Data Center 

Frequency Task

Daily Actions Rubbish removal

Weekly Actions Access floor maintenance (vacuum and damp mop)

Quarterly Actions Hardware decontamination

Room surface decontamination

Bi-Annual Actions Subfloor void decontamination

Air conditioner decontamination (as necessary)
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Cleaning solutions used within the data center must not pose a threat to the hardware. 
Solutions that could potentially damage hardware include products that are:

■ Ammoniated

■ Chlorine-based

■ Phosphate-based

■ Bleach enriched

■ Petro-chemical based

■ Floor strippers or re-conditioners.

It is also important that the recommended concentrations are used, as even an 
appropriate agent in an inappropriate concentration can be potentially damaging. The 
solution should be maintained in good condition throughout the project, and excessive 
applications should be avoided.

Quarterly Tasks
The quarterly statement of work involves a much more detailed and comprehensive 
decontamination schedule and should only be conducted by experienced computer 
room contamination-control professionals. These actions should be performed three to 
four times per year, based on the levels of activity and contamination present. All 
room surfaces should be thoroughly decontaminated including cupboards, ledges, 
racks, shelves and support equipment. High ledges and light fixtures and generally 
accessible areas should be treated or vacuumed as appropriate. Vertical surfaces 
including windows, glass partitions, doors, etc. should be thoroughly treated. Special 
dust cloths that are impregnated with a particle absorbent material are to be used in 
the surface decontamination process. Do not use generic dust rags or fabric cloths to 
perform these activities. Do not use any chemicals, waxes or solvents during these 
activities.

Settled contamination should be removed from all exterior hardware surfaces 
including horizontal and vertical surfaces. The unit's air inlet and outlet grilles should 
be treated as well. Do not wipe the unit's control surfaces as these areas can be 
decontaminated by the use of lightly compressed air. Special care should also be taken 
when cleaning keyboards and life-safety controls. Specially treated dust wipes should 
be used to treat all hardware surfaces. Monitors should be treated with optical 
cleansers and static-free cloths. No Electro-Static Discharge (ESD) dissipative 
chemicals should be used on the computer hardware, since these agents are caustic 
and harmful to most sensitive hardware. The computer hardware is sufficiently 
designed to permit electrostatic dissipation thus no further treatments are required. 
After all of the hardware and room surfaces have been thoroughly decontaminated, 
the access floor should be HEPA vacuumed and damp mopped as detailed in the 
Weekly Actions.

Biennial Tasks
The subfloor void should be decontaminated every 18 months to 24 months based on 
the conditions of the plenum surfaces and the degree of contaminant accumulation. 
Over the course of the year, the subfloor void undergoes a considerable amount of 
activity that creates new contamination accumulations. Although the weekly above 
floor cleaning activities will greatly reduce the subfloor dust accumulations, a certain 
amount of surface dirt will migrate into the subfloor void. It is important to maintain 
the subfloor to a high degree of cleanliness since this area acts as the hardware's 
supply air plenum. It is best to perform the subfloor decontamination treatment in a 
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short time frame to reduce cross contamination. The personnel performing this 
operation should be fully trained to assess cable connectivity and priority. Each 
exposed area of the subfloor void should be individually inspected and assessed for 
possible cable handling and movement. All twist-in and plug-in connections should be 
checked and fully engaged before cable movement. All subfloor activities must be 
conducted with proper consideration for air distribution and floor loading. In an effort 
to maintain access floor integrity and proper psychrometric conditions, the number of 
floor tiles removed from the floor system should be carefully managed. In most cases, 
each work crew should have no more than 24 square feet (six tiles) of open access 
flooring at any one time. The access floor's supporting grid system should also be 
thoroughly decontaminated, first by vacuuming the loose debris and then by 
damp-sponging the accumulated residue. Rubber gaskets, if present, as the metal 
framework that makes up the grid system should be removed from the grid work and 
cleaned with a damp sponge as well. Any unusual conditions, such as damaged floor 
suspension, floor tiles, cables and surfaces, within the floor void should be noted and 
reported.

Activity and Processes
Isolation of the data center is an integral factor in maintaining appropriate conditions. 
All unnecessary activity should be avoided in the data center, and access should be 
limited to necessary personnel only. Periodic activity, such as tours, should be limited, 
and traffic should be restricted to away from the hardware so as to avoid accidental 
contact. All personnel working in the room, including temporary employees and 
janitorial personnel, should be trained in the most basic sensitivities of the hardware 
so as to avoid unnecessary exposure. The controlled areas of the data center should be 
thoroughly isolated from contaminant producing activities. Ideally, print rooms, check 
sorting rooms, command centers or other areas with high levels of mechanical or 
human activity should have no direct exposure to the data center. Paths to and from 
these areas should not necessitate traffic through the main data center areas. 
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2N

An optional power configuration that provides both AC and DC redundancy. There is 
one power supply for every four tape drives and one supply for every robot. This 
configuration requires a second AC power source to support an additional system 
PDU. All four accessory racks are powered. See also N+1.

ADI

Automation drive interface. Supports rich data for StorageTek Tape Analytics.

access door

A door on either side of the CIM through which service personnel can enter the 
library.

active cell

A storage cell that can be used for cartridge storage.

active capacity

The number of storage cells the library is authorized to use for storage. This cannot 
exceed the installed capacity or the purchased capacity. Same as allocated capacity.

allocated capacity

The number of active cells. Allocated capacity cannot exceed the purchased capacity 
defined by the hardware activation file. Same as active capacity. See also unallocated 
capacity.

audit

An inventory of cartridge locations in all areas of the library, including the slots in the 
storage and reserved areas. Audits occur when:

■ The library initializes at power-on.

■ After either one or both access doors are opened and closed without activating the 
service safety door.

■ A physical audit request is made through SLC.

See also host audit, physical audit, verified auditand virtual audit.

away library

The SL8500 library located on the left side of a home library, as viewed from the front. 
The away library does not supply power to, control, or recover the pass-thru port.
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CAP

See cartridge access port (CAP).

CLI

Command line interface.

capacity

The storage capacity of the library. See also active capacityand installed capacity.

cartridge

A container holding magnetic tape that can be mounted to a drive to read or write 
data. The library uses data, diagnostic, and cleaning cartridges.

cartridge access port (CAP)

A port built into the door panel of the library used to import or export cartridges.

cartridge array

A plastic housing that holds multiple cartridges when not in use. The inner walls of 
the SL8500 library consist of 14-slot arrays and the outer walls consist of 13-slot arrays.

cell

The location in the library in which a tape cartridge is stored. Same as slot.

cleaning cartridge

A tape cartridge that used to clean the tape path in a drive. Cleaning cartridges are 
drive specific and should be replaced after a limited number of uses.

customer interface module (CIM)

The front module of the SL8500 library which contains the touch screen operator panel 
and allows service personnel to access the library and service bay.

DEM

See drive and electronics module (DEM).

dWWN

See dynamic WWN.

data cartridge

A cartridge used to store data.

diagnostic cartridge

A cartridge used for diagnostic routines of a drive.

drive and electronics module (DEM)

The module in the SL8500 library that houses the electronics control module, power 
distribution units (PDUs), power supplies, accessory racks and equipment, and tape 
drives for the library. The module is located at the rear of the library.

drive array

The metal housing installed in the drive and electronics module for mounting tape 
drive tray assemblies. The drive and electronics module holds up to four array 
assemblies, and each array holds up to 16 tape drive tray assemblies.
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drive bay

A section of the drive array that holds one tape drive tray.

drive bay address

A two-digit integer (01–64) that represents the physical locations into which drive tray 
assemblies are inserted.

drive tray

A metal chassis, cables, electronic cards, and tape drive used to interface the tape drive 
to the tape library. The drive tray contains the drive controller card (HBD or LOD).

Dual TCP/IP

Provides two separate host connections between the host software (ACSLS or HSC) 
and the library controller.

dynamic WWN

When enabled, dWWN assigns names to library drive slots rather than devices. When 
a drive is replaced, the new drive receives the same name as the one it replaced, 
thereby eliminating the need for system re-configuration. dWWN assigns names to 
individual tape drive slots rather than devices

ECM

See electronics control module (ECM).

ELS

See Enterprise Library Software.

ERS

See emergency robotics stop switch (ERS).

eject

See export.

electronics control module (ECM)

A module that includes the HBK card, HBC/HBCR card, and HBT card. The ECM 
Processes commands from a host system assembly, coordinates the activities of library 
components, and monitors status inputs from sensors and switches

elevator

The device that transports cartridges vertically. The SL8500 library features two 
elevators that move cartridges between the rails of the library.

emergency robotics stop switch (ERS)

A switch located on the CIM keypad that removes all power to the robots.

enter

See import.

Enterprise Library Software

The software products that automate tape operations for mainframe clients.
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export

The library places a cartridge into a CAP slot so that an operator can remove the 
cartridge from the library. Same as eject.

FRU

Field replaceable unit.

failover

The act of moving to a secondary or redundant path when the primary path fails.

front controller module

The module that houses the controller for the elevators, CAPs, turntables, and safety 
barrier.

front facade

The external portion of the CIM, between the access doors, that holds the keypad and 
local operator panel.

get

An activity in which a robot obtains a cartridge from a cell or drive.

HLI/PRC

Host Library Interface/Panel Row Column

home library

The library that provides power, signal, and control lines to the pass-thru port 
(PTP)mechanisms. This is the library on the right of a library complex as viewed from 
the front.

host audit

The process of updating the cartridge vol-ids and locations in a host database. This 
audit is initiated by a host command.

hot swap

Removal and replacement of a system component while system power remains on and 
system operations continue.

hot-pluggable

The capability that allows an Oracle service representative to replace a system 
component while power to the system is maintained. This feature allows hardware 
maintenance actions and hardware upgrades to proceed without disrupting subsystem 
availability. Contrast with hot swap.

import

The process of placing a cartridge into the cartridge access port so that the library can 
insert it into a storage cell.

inactive cell

A storage cell that is explicitly deactivated and cannot be used for cartridge storage.

installed capacity

The number of storage cells physically present in the library.
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interlock switch

A switch that disconnects power to library mechanisms, excluding tape drives, when 
the front door is opened.

keypad

The interface located on the CIM. The keypad contains the CAP open/close buttons, 
safety door locks, and the ERS button.

LCM

See Library Content Manager (LCM).

LTO

See linear tape open format (LTO).

library complex

Two or more SL8500 libraries attached to each other with a pass-thru port (PTP).

library controller (LC)

The HBC/HBCR card within the library that controls operations and communicates 
with the operator panel.

Library Content Manager (LCM)

Software that provides content management for mainframe automated tape 
environments. Works with host software component, virtual storage manager and 
your tape management system.

library operator panel

See touch screen operator control panel.

library storage module (LSM)

Library component connected to other LSMs in a library complex with a pass-thru 
port. Same as an SL8500 rail.

linear tape open format (LTO)

A set of tape data format standards created to enable data interchange among different 
LTO Ultrium tape drive vendors. These standards allow data cartridges to be shared.

magazine

A removable array that holds cartridges and is placed into the cartridge access port 
(CAP).

Multi TCP/IP

Using TCP/IP connections to multiple libraries to provide redundant communication 
paths between the host software (ACSLS or HSC) and an SL8500 library complex.

MIR

Media Information Region (MIR). A kind of map or directory of the location of user 
data on the physical media. This capability allows the drive to optimize access to user 
data, saving vital time to data access. The MIR data on an encrypted tape is not 
encrypted.
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N+1

The standard power configuration that provides DC power redundancy by adding an 
additional DC power supply to DC power grid. There is one power supply for every 
two robots plus one redundant supply and one supply for every eight drives plus one 
redundant supply. There are two PDUs: one system PDU and one N+1 PDU. Only 
accessory racks 2 and 4 are powered. See also 2N.

online replacement

Replacement or service of a module while the library remains operational. The service 
person may be required to power off the module before removing or replacing it.

operator panel

See touch screen operator control panel.

orphaned cartridge

A cartridge in a partitioned library that is located in an unallocated cell or drive (that 
is, a cell or drive not allocated to any defined partition). Cartridges may become 
orphaned when partition boundaries are changed, partitions are deleted, or cartridges 
are manually moved to unallocated or inaccessible cells.

PDU

See power distribution unit (PDU).

PLI

See primary library interface (PLI).

PTP

See pass-thru port (PTP).

pass-thru port (PTP)

An electro-mechanical device that allow one library storage module to pass a cartridge 
to another adjacent library storage module in the same complex. A library complex is a 
series of libraries connected with pass-thru ports. SL8500 libraries are joined together 
by four PTPs because there are four rails. See also home libraryand away library.

physical audit

Physical audits occur when the robots:

■ Scan the cartridge locations in the library

■ Verify the volumes

■ Update the library control card inventory

■ Set the status of the cartridge location to true

power distribution unit (PDU)

A device for the distribution of AC line power from one inlet to multiple outlets. 
Multiple PDUs provide higher availability because the power continues if one PDU (or 
its alternating current source if the PDUs use separate AC sources) loses power.

primary library interface (PLI)

The communication path between the operator panel and the library controller.
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purchased capacity

The total number of storage slots authorized for activation. The value is defined by the 
hardware activation file. See also allocated capacity and active capacity.

put

An activity in which a robot places a cartridge into a cell or drive.

RE

See redundant electronics (RE).

RIM

See robotics interface module (RIM).

rail

(1) That portion of the upper robot track assembly that provides power and 
communication to the robot. (2) All of the cartridge slots and drives accessible through 
a rail.

redundant electronics (RE)

A feature that provides failover protection in enterprise libraries. RE uses a two sets of 
library controller cards. At any given time, one set is active and the other set is 
standby. The active library controller can failover to the standby in response to a 
command from ACSLS or the SLC. Automatic failover can be initiated by the library if 
a library card failure.

robot

A mechanism that moves horizontally along a track to transport tape cartridges to and 
from other locations in the library.

robotics interface module (RIM)

The module containing the curved rails and pass-thru port (PTP)assemblies.

selected cell

A storage cell that cannot currently be used for cartridge storage, but will be made 
active automatically by the library controller when activated capacity is increased.

service area

An area between the access doors of the customer interface module and the safety 
barrier. In the service area, a redundant or inoperable robot can be stored for service 
and other mechanisms can be repaired or replaced.

service safety door

A motor-driven barrier that lowers and raises. This door separates the service areas of 
the front interface assembly from the rest of the library. The SSD allows service 
personnel to safely repair or replace library mechanisms while the front access door is 
opened and closed., without interference with most library operations.

slot

Same as cell.

TTI

See tape transport interface (TTI).
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tape drive

An electromechanical device that moves magnetic tape and includes mechanisms for 
writing and reading data to and from the tape.

tape storage area

The area in the library where cartridges are stored.

tape transport interface (TTI)

An interface to control and monitor tape movement.

touch screen operator control panel

A flat-panel display with a touch screen interface and a panel mount computer. This 
feature is attached to the front of the library.

track

The horizontal path upon which a robot travels.

unallocated capacity

The number of storage cells available for capacity activation. This value is equal to the 
purchased capacity minus the allocated capacity.

vol-id

Volume ID assigned to a cartridge. Same as VOLSER.

VOLSER

Volume serial number. Same as vol-id.

VSM

See virtual storage manager (VSM).

VTCS

See virtual tape control system (VTCS).

VTD

See virtual tape drive (VTD).

VTSS

See virtual tape storage subsystem (VTSS).

verified audit

Verified audits are invoked from the SLC and actually validate the status of a specific 
cartridge slot or range of slots.

virtual audit

Virtual audits are invoked from the SLC and only display the cartridge inventory in 
the console screen (either local or remote).

virtual storage manager (VSM)

A storage solution that virtualizes volumes and transports in the buffer of a virtual 
tape storage subsystem to improve media and transport use.
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virtual tape control system (VTCS)

The primary host code that controls activity and information about VTSSs, VTVs, 
RTDs, and MVCs.

virtual tape drive (VTD)

An emulation of a physical transport in the VTSS that looks like a physical tape 
transport to MVS. The data written to a VTD is really being written to DASD. The 
VTSS has 64 VTDs that do virtual mounts of VTVs.

virtual tape storage subsystem (VTSS)

The DASD buffer containing virtual volumes (VTVs) and virtual drives (VTDs). The 
VTSS is a STK RAID 6 hardware device with microcode that enables transport 
emulation. The RAID device can read and write "tape" data from/to disk, and can read 
and write the data from/to an RTD.

virtual tape volume (VTV)

A portion of the DASD buffer that appears to the operating system as a real tape 
volume. Data is written to and read from the VTV, and the VTV can be migrated to 
and recalled from real tape.

WWN

See World Wide Name.

World Wide Name

A 64-bit address that uniquely identifies each individual device and vendor, much like 
the MAC address of an Ethernet interface. Each port on a Fibre Channel network must 
have a its own WWN. The WWN is not just a physical hardware address. It also serves 
as the logical address of a node on the SAN. The SAN configuration changes if any of 
the attached hardware changes. If a device fails and is replaced, the WWN of the node 
changes, forcing reconfiguration of the SAN. There are three World wide Names 
reserved for each drive bay: Node, Port A, and Port B.
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A
activated features

capacity, 3-1
display current, 2-3
files, 2-1
partitioning, 4-1
redundant electronics, 5-1

active capacity, 3-1
configuration, 3-1
HLI hosts, 3-2
icon meaning, 3-2
library complex, 3-4
reports, 3-3
single library, 3-3

addressing
CAPs, B-9
elevators, B-10
HandBots, B-10
HLI-PRC, B-4
internal firmware, B-3
library complex, B-2
PTPs, B-9
scheme comparison, B-6
tape drives, B-6

arrays
locating the cartridges, B-4

audience, xiii
audits

audit indicator, 6-6
description, 6-6
full library, 6-7
main access door and, 6-6
physical, 6-6, 6-7
range of cells, 6-7
verified, 6-7

auto enter mode, 7-1
automated mode

determining library state, 14-1
returning the library to, 6-10

automated mode (library)
determine, 14-1

C
capacity

activation, 3-1
configuration, 3-1
HLI hosts, 3-2
icon meaning, 3-2
library complex, 3-4
non-partitioned library, 3-2
single library, 3-3

CAPs
addressing, B-9
bringing online, 7-2
closing, 7-3
display properties, 7-2
display status, 7-2
display summary information, 7-2
inserting cartridges, 9-5
library partitions, 4-2
manual mode, 7-1
modes, 7-1
overview, 7-1
reservations, 4-2
self-test, 7-3, 8-4
taking offline, 7-2

cartridges
addressing, B-4
display information, 9-3
ejects, 9-6
enters, 9-5
exterior cleaning, 9-2
handling, 9-2
inserting in a cell or drive, 9-2
inserting in the CAP, 9-5
inspecting, 9-2
list, 9-3
locate by address, 9-4
locate by VOLID, 9-3
locating by address, 9-3
locating by VOLID, 9-3
mounting, 14-5
move by VOLID, 9-4
move from specified location, 9-4
orphaned, 3-2
recovery moves, 9-4
storing, 9-2
unlabeled, 9-2

cautions
lubrication, 14-3
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moving robot
leaving objects inside, 14-3
mechanical stop, 14-3
position, 14-3

reentering cleaning cartridge, 9-1
solvents for cleaning a cartridge, 9-2

cells
locations in a library, B-4

cleaning cartridges, 9-1

D
delete

hardware activation, 2-3
device status

listing codes, 13-5
diagnostic cartridges

description, 9-7
exporting, 9-7
importing, 9-7
library self-tests and, 6-5
management tasks, 9-7

diagnostic moves (robot)
controlling, 11-6
defining, 11-4
description, 11-3
managing definitions, 11-5
monitoring, 11-6
pool address range, 11-3
random access order, 11-4
robot selection, 11-3
saving, 11-5
sequential access order, 11-4
starting, 11-5
target address range, 11-3

diagnostic support files, 13-1
disruptive installation, 12-1
documentation, 2-xiii
download

hardware activation, 2-2
drive

addressing, B-6
drive cleaning

description, 8-1
drive controller, 6-3
Drive Events Report, 8-3
Drive Media Events Report, 8-3
drive trays

status, 8-2
drive VOP

displaying for T10000, 8-2
drives

bringing online, 8-4
display drive properties, 8-2
display drive summary information, 8-2
display status, 8-2
LED status, 8-2
mounting a cartridge, 14-5
network data, 8-2
power on and off, 14-5

states, 8-4
taking offline, 8-4

E
eject operations, 9-6
elevator

status of, 12-2
summary information, 12-2

elevators
addressing, B-10

emergency robotics stop
usage, 14-2

enter operations, 9-5
entering the library, 14-3
event monitors

display, 13-4
spool data to a file, 13-4
tasks, 13-5

exiting the library, 14-3

F
firmware

addressing
CAPs, B-9
elevators, B-10
HandBots, B-10
PTPs, B-9

G
General Events Statistics Report, 6-4

H
HandBot

initialization, 11-2
HandBots

addressing, B-10
hardware activation

delete, 2-3
download, 2-2
Feature Audit Log, 2-3
file type, 2-1
install, 2-2
legacy files, 2-1
overview, 2-1

hardware activation file
display current, 2-3

HLI interface
displaying port status, 6-2

HLI-PRC
description, B-4

host interfaces
HLI. See HLI interface., 6-2

I
initialization

library sequence, 11-2
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inner walls, B-1
install

hardware activation file, 2-2
internal addresses

description, B-3

K
key

maintenance, 14-1
opening the front access doors, 14-3

L
library

capacities, cartridge tapes, B-1
determining not in automated mode, 14-1
entering the library, 14-3
entry precautions, 14-3
exiting, 14-3
mounting a cartridge, 14-5
partitions

CAP operations, 4-6
placing in manual mode, 6-9
placing online, 6-10
power off, 14-4, 14-5
returning to automated mode, 6-10

library complex
addressing, B-2
displaying status, 6-2
locating cartridges, 9-3
properties, 6-3

library configuration
display, 6-3

library controller
display redundant electronics, 5-4
log in to alternate, 5-2
properties, 6-3

library firmware upgrades, 6-8
activate, 6-8
download, 6-8

library partitions
and hosts, 4-2
CAP reservations, 4-2
deleting, 4-4
orphaned cartridges in, 4-2

library reboot, 6-9
library reports

displaying, 6-3
saving data to a file,SL Console report tasks, 6-3
searching, 6-3

library self-tests, 6-5
performing, 6-5

library status
display, 6-2

local operator panel
factory alignment, 1-6
logging in, 1-6
overview, 1-6
re-calibrating, 1-6

log snapshot file
generating process, 6-5
transfer process, 6-5

login IDs, 1-7
logs

Feature Audit Log, 2-3

M
main access door

audits and, 6-6
automated mode and, 14-1

maintenance key, 14-1
manual CAP, 7-1
manual mode

determining library not in automated mode, 14-1
entering the library, 14-3
exiting the library, 14-3
mounting a cartridge, 14-5
moving the robot, 14-2
physical restrictions, 14-1
placing the library in manual mode, 6-9
returning the library to automated mode, 6-10

manual operations
safety precautions, 14-1

general, 14-1
tasks, 14-1

MIB file
described, 13-1
transfer process, 6-4

N
nondisruptive installation, advantages, 12-1
numbering

cartridge cell locations, B-4
tape drives, B-6

O
Oracle Technical Network, xiii
orphaned cartridges, 3-2

partitioned libraries and, 4-2
OTN, xiii
outer walls, B-1

P
partitioning, 4-1
partitions

overview, 4-1
pass-thru ports

addressing, B-9
Pass-thru Ports (PTPs)

configuration, 12-1
disruptive installation, 12-1
locating cartridges, 9-3
nondisruptive installation, 12-1

passwords
activation, 1-7
modifying, 1-7
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placing the library in manual mode, 6-9
port bonding, 6-2
ports

status, 6-2
power

off, 14-5
switches, 14-4

power supplies
monitoring tasks, 6-4
status of, 6-4
summary information, 6-4

PTP
properties, 12-2
status of, 12-2

R
reboot

library, 6-9
recovery moves, 9-4
redundant electronics

manual switch, 5-4
tasks, 5-4

report
capacity activated, 3-3
orphaned cartridges, 3-3

reports
cartridge summary, 9-3
cartridge table, 9-3
drive events, 8-3
feature audit log, 2-3

resources, 2-xiii
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robot
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monitoring tasks, 11-2
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S
safety door
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operation of, 14-6
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summary information, 11-1

safety precautions, 14-1
general, 14-1
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drive, 8-4
library, 6-5
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SL Console
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first-time access, 1-7
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screen, components, 1-2
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security, 1-7
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user ID, 1-7

SL Console reports
Drive Events, 8-3
Drive Media Events, 8-3
General Events, 6-4

SLConsole
downloading, 1-1
local operator panel, 1-6
media pack, 1-1
modes, 1-1
overview, 1-1
standalone, 1-3
web-launched, 1-4

SNMP
transfer the library MIB file, 6-4

standalone SL Console
logging in, 1-4
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requirements, 1-4
security, 1-3
updating, 1-3

status alerts
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U
User ID

types, 1-7

V
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W
warnings

entering the library procedures, 14-3
exiting the LSM, 14-3



Index-5

web-launched SLConsole
client requirements, 1-5
installing, 1-4
log in, 1-5
overview, 1-4
security, 1-5
updating, 1-5



Index-6


	Contents
	List of Figures
	List of Tables
	Preface
	Related Documentation
	Documentation Accessibility

	1 StorageTek Library Console
	SLC Versions
	Downloading the SLC Media Pack
	SLC GUI Overview
	Modifying a Tabular Display
	Synchronizing SLC with the Controller Database

	Standalone SLC
	Security Considerations
	Installation Requirements
	Installing the Standalone SLC
	Logging in to the Standalone SLC

	Web-launched SLC
	Security Considerations
	Client Requirements
	Logging in to the Web-launched SLC

	Local Operator Panel
	Logging in to the Local Operator Panel
	Calibrating the Touch Screen
	Re-calibrating the Local Operator Panel
	Resetting the Local Operator Panel Calibration

	Rebooting the Local Operator Panel

	User Management
	User IDs
	Passwords
	Changing a User Password



	2 Hardware Activation Files
	Oracle Hardware Activation Files Overview
	Legacy Hardware Activation Files
	Hardware Activation File Installation Overview

	Downloading a New Hardware Activation File
	Installing a New Hardware Activation File
	Deleting a Hardware Activation File
	Displaying Current Hardware Activation Files
	Displaying the Feature Audit Log

	3 Capacity Activation
	Active Capacity Configurations
	Default Configuration
	Customized Configuration
	Guidelines for Customized Activation


	Capacity Activation in Non-partitioned Libraries
	Capacity Activation in HLI Hosted Libraries

	SLC Capacity Icons
	Activating Capacity using SLC
	Configuring Active Capacity in a Single Library
	Designing the Active Cells Configuration in a Single Library
	Displaying Active Cells Report

	Configuring Active Capacity in a Library Complex
	Designing the Active Cells Configuration in a Library Complex



	4 Library Partitioning
	Single Library versus Library Complex Partitioning
	Affect of Partitioning on Active Capacity
	Host Access to Partitions
	CAPs in a Partitioned Library are a Shared Resource

	Planning and Preparations for Partitioning
	Verifying the Physical Configuration of a Partition
	Resolving Orphaned Cartridges

	Partitioning to Maximize Library Performance
	Partitioning the Library Using SLC
	Preparing for Partitioning
	Adding or Deleting Partition Definitions
	Adding a Partition Definition
	Deleting a Partition Definition

	Allocating and Verifying Resource in a Partition for a Single Library
	Allocating and Verifying Resources in a Partition for a Library Complex
	Committing Partitioning Changes
	Generating Partitioning Reports (Single Library Only)

	Overriding a CAP Reservation of a Partition

	5 Redundant Electronics
	Redundant Electronics Requirements
	Redundant Electronics Overview
	Automatic Failover
	Manual Failover
	Network Connections
	Firmware Upgrades

	Controller Card Status Overview
	Controller Card LEDs
	SLC Status of Controller Cards

	Displaying Redundant Electronics Information
	Performing a Manual Redundant Electronics Switch

	6 Library Management
	Library and Device Status Overview
	Clearing Library Status Alerts
	Displaying Library Information
	Displaying Library Status
	Display Library Properties
	Viewing Library Reports
	Search a Library Report
	Save Library Report Data to a File
	Display Library Events Statistics

	Displaying Library Power Supply Information

	Generating Library Diagnostic Files
	Transferring the Library MIB File
	Generating and Transferring the Library Log Snapshot File

	Performing a Library Self-Test
	Auditing the Library
	Performing a Physical Audit
	Auditing the Entire Library
	Auditing a Range of Cells

	Performing a Verified Audit

	Upgrading Library Firmware
	Downloading Code to the Library Controller
	Activating Code on the Library Controller

	Rebooting the Library
	Placing the Library Online or Offline
	Placing the Library Offline
	Bringing the Library Online
	Bringing the Drives Online


	7 CAP Management
	CAP Modes
	Recommendations for CAP Use
	Maximizing Library Performance

	Displaying CAP Information
	Changing the CAP Online/Offline Status
	Locking/Unlocking a CAP
	Performing a CAP Self-test

	8 Drive Management
	Maximizing Library Performance with Drive Placement
	Configuring Drive Cleaning
	Configuring Host-Managed Drive Cleaning

	Displaying Drive Information
	Displaying the Drive and Drive Media Reports
	Configuring the Drive Tray Serial Numbers
	Changing the Drive Online/Offline Status
	Performing a Drive Self Test

	9 Cartridge Management
	Cartridge Types
	Cartridge Labels

	Cartridge Handling
	Inspecting a Cartridge
	Cleaning the Cartridge Exterior
	Storing Cartridges

	Maximizing Library Performance with Cartridge Placement
	Displaying Cartridge Information
	Locating Cartridges
	Locating a Cartridge by vol-id
	Locating a Cartridge by Address

	Moving Cartridges (Recovery Moves)
	Moving a Cartridge by Vol-id or Specified Location

	Entering Cartridges
	Ejecting Cartridges
	Importing or Exporting Diagnostic Cartridges
	Importing Diagnostic Cartridges
	Exporting Diagnostic Cartridges


	10 Media Validation
	Media Validation Pool Overview
	Validation Types
	Adding Drives to the Media Validation Pool
	Removing Drives from the Media Validation Pool
	Validating a Cartridge
	Stopping a Validation in Progress

	11 Robot and Safety Door Management
	Safety Door Overview
	Displaying Safety Door Information
	Robots Overview
	Fast Load Feature
	Robot Initialization

	Displaying Robot Information
	Changing the Robot Online/Offline Status
	Performing a Robot Self-Test
	Defining and Running Robot Diagnostic Moves
	Defining a Diagnostic Move
	Managing Diagnostic Move Definitions
	Saving a Diagnostic Move
	Starting a Diagnostic Move
	Monitoring and Controlling Open Diagnostic Moves


	12 Elevators and Pass-Thru Ports
	Maximizing Library Performance by Reducing PTP and Elevator Usage
	PTP Installation Overview
	Displaying Elevator Information
	Displaying Pass-Thru Port Information

	13 SLC Diagnostics and Utilities
	Library and Device Self-tests
	Diagnostic Support Information
	Troubleshooting
	Using the Monitors Utility to Open an Event Monitor
	Event Monitor Overview
	Opening an Event Monitor
	Arranging Multiple Monitors

	Spooling Event Monitor Data to a File
	Displaying Result Code Definitions


	14 Manual Operation
	Modes of Operation
	Safety Precautions when Entering the Library
	Emergency Robotics Stop Switch
	Moving a Robot

	Entering or Exiting the Library
	Entering the Library
	Exiting the Library

	Turning the Library On or Off
	Turning Off the Library
	Turning On the Library

	Manually Mounting and Dismounting Cartridges
	Manually Mounting a Cartridge in a Drive
	Manually Dismounting a Cartridge from a Drive

	Operating the Service Safety Door
	Left Maintenance Area
	Right Maintenance Area

	audit
	capCommand
	cleaning
	config
	date
	drive
	hwActivation
	mediaValidation
	network
	partition
	reControl
	snmp
	ssh
	time
	traceRoute
	version
	whereAmi
	Structural Elements Used in Addressing
	Library Walls, Arrays, and Slots
	Library Storage Module (LSM)
	Library Complex HLI Numbering

	Panels and Columns

	Internal Firmware Addressing Scheme
	HLI-PRC Addressing Scheme
	Comparison of the Addressing Schemes
	Tape Drive Addressing
	Hardware Address
	Internal Firmware Address
	HLI-PRC Address
	Drive Numbering Comparison

	Internal Firmware Addressing Components
	CAP Internal Firmware Addressing
	PTP Internal Firmware Addressing
	Elevator Internal Firmware Addressing
	Robot Internal Firmware Addressing

	Environmental Contaminants
	Required Air Quality Levels
	Contaminant Properties and Sources
	Operator Activity
	Hardware Movement
	Outside Air
	Stored Items
	Outside Influences
	Cleaning Activity

	Contaminant Effects
	Physical Interference
	Corrosive Failure
	Shorts
	Thermal Failure

	Room Conditions
	Exposure Points
	Filtration
	Positive Pressurization and Ventilation
	Cleaning Procedures and Equipment
	Daily Tasks
	Weekly Tasks
	Quarterly Tasks
	Biennial Tasks

	Activity and Processes

	Glossary
	Index
	A
	C
	D
	E
	F
	G
	H
	I
	K
	L
	M
	N
	O
	P
	R
	S
	T
	U
	V
	W


