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Preface

This guide is intended for administrators and operators of Oracle's StorageTek SL3000 
modular library system. It assumes the reader is familiar with the SL3000 library 
modules and components. For introductory and planning information, see the SL8500 
Systems Assurance Guide on OTN (refer to the Related Documentation section below)

Oracle's StorageTek SL3000 Modular Library System is an enterprise storage solution 
that provides fully automated tape-cartridge storage and retrieval. This document 
provides guidelines for library and device management using StorageTek Library 
Console (SLC).

Related Documentation
For more information related to the SL3000 library, see the following documents on the 
Oracle Technical Network (OTN) at:

http://www.oracle.com/technetwork/documentation/tape-storage-curr-187744.h
tml

■ SL3000 Systems Assurance Guide - overview of the library and installation planning 
guide

■ SL3000 Host Connectivity Guide - networking information on Dual TCP/IP, 
redundant electronics, and partitioning

■ Barcode Technical Brief - barcode and label guidelines

■ SL3000 SNMP Reference Guide - SNMP information

■ Library management software documentation:

■ ACSLS Administrator's Guide

■ ELS System Programmer's Guide

Documentation Accessibility
For information about Oracle's commitment to accessibility, visit the Oracle 
Accessibility Program website at 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

Access to Oracle Support
Oracle customers have access to electronic support through My Oracle Support. For 
information, visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or 
visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing 
impaired.

http://www.oracle.com/technetwork/documentation/tape-storage-curr-187744.html
http://www.oracle.com/technetwork/documentation/tape-storage-curr-187744.html
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1StorageTek Library Console

Oracle’s StorageTek Library Console (SLC) is a graphical user interface (GUI) 
application for configuring, monitoring, and managing the SL3000 tape library.

■ SLC Versions

■ Downloading the SLC Media Pack

■ SLC GUI Overview

■ User Management

■ Web-launched SLC

■ Standalone SLC

■ Local Operator Panel

SLC Versions
There are three versions of SLC. Throughout this document, you can perform the 
procedures using any SLC version, unless otherwise noted.

■ Local Operator Panel — enables SLC to run remotely from any system that has a 
network connection to the library.

■ Web-launched SLC — enables SLC to be installed on a server, allowing individual 
clients to use a browser to access SLC.

■ Standalone SLC — enables SLC to run remotely from any system that has a 
network connection to the library.

Downloading the SLC Media Pack
The media pack includes the web-launched SLC server, web-launched SLC client, and 
the standalone SLC. To download the media pack:

1. Go to the Oracle Software Delivery Cloud at: http://edelivery.oracle.com/

2. Click Sign In/Register.

Note: Customer data on tape cartridges is never available to SLC or 
the library. The external data interface of the tape drives is separate 
from the library infrastructure.



SLC GUI Overview

1-2 StorageTek SL3000 User's Guide

3. On the Terms & Restrictions screen, read the License Agreement and Export 
Restrictions, and select the check boxes to indicate your acceptance. Click 
Continue.

4. On the Media Pack Search screen:

a. In the Select a Product Pack list, select Oracle StorageTek Products.

b. In the Platform list, select Generic Platform.

c. Click Go.

5. Select the SLC version to download, click Continue.

6. To review the download instructions, click Readme. Optionally, use the View 
Digest button to verify the MD5 and SHA-1 digests of the download files.

7. Verify the SLC version is correct, click Download.

8. Save the file. Extract the media pack to the desired location.

SLC GUI Overview

Figure 1–1 SLC Screen Layout

Figure Legend:

1. Menu Bar — includes the Tools menu and Help menu.
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2. Utility Title — displays the title of the current screen.

3. Function Tabs — identifies the available functions for a utility. Some utilities 
contain second level tabs.

4. Options Bar — location of buttons related to the current utility screen (for 
example, Apply, Refresh, Print).

5. Utility content.

6. Library health indicator — identifies the library connected to SLC, and displays 
library health (see "Library and Device Status Overview" on page 7-1).

7. UserID indicator — displays the user ID currently logged in to SLC.

8. Server communication health indicator — displays a graphical heartbeat monitor 
indicating the state of server communication health (see "Library and Device 
Status Overview" on page 7-1).

9. Navigation tree — lists the devices contained in the library.

Modifying a Tabular Display
Many SLC utilities use a tabular display. You can modify the table:

■ To sort by a column, click the heading of a column. Initially the sort is in ascending 
order. Click the heading again to switch to descending order.

■ To move a columns, click and drag a column heading horizontally to any position 
in the heading row.

■ To re-size a column, click and drag the border of the column heading.

Synchronizing the SL Console With the Controller Database
SLC receives library configuration data from the library controller. Configuration data 
may be unavailable if you log in to SLC before the library is fully initialized. Exit and 
log in again after initialization. Additionally, configuration data displayed during an 
audit may not be accurate until the audit completes.

SLC displays the most recently saved data from the library controller database. When 
the configuration changes (such as taking a drive offline, or removing or adding a 
cartridge), synchronize SLC by clicking the Refresh button.

Multiple users can access the library simultaneously. Coordinate with other library 
users when making major modifications to the configuration (such as adding modules, 
defining partitions, and so on) to prevent conflicts.

Standalone SLC
The standalone version runs SLC remotely from any system with a network 
connection to the library.

You must uninstall the previous version of standalone SLC before installing a new 
version. Running multiple versions of SLC on the same system can cause inconsistent 
data.
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Security Considerations
SLC interfaces with the primary library interface (PLI) over a secure sockets layer 
(SSL). SSL provides a secure communication path between the library and the SLC 
session. This prevents an unauthorized network user from monitoring library activity.

Installation Requirements

Qualified Platforms
■ Solaris 10 SPARC, Solaris 10 x86

■ Windows Server 2008 SP2: 64bit, Windows 2012 Enterprise Server

■ Windows 7 SP1: 64bit, Windows 8 64bit, Windows 8.1 64 bit

■ Oracle Unbrakable Linux 5 (2.6.18) 32 bit

■ SUSE Enterprise Linux 10.2 (2.6.16) 32 bit

Other
■ Network connection to the library

Installing the Standalone SLC
Uninstall any previous versions of SLC before installing an update.

1. Download and extract the standalone SLC media pack (see "Downloading the SLC 
Media Pack" on page 3-1).

2. Select the SLC installer file for your operating system (refer to the media pack 
readme).

3. Review the information. Click Next.

4. Specify where to install SLC. Click Next.

5. Specify where to create the SLC shortcut icons. Click Next.

6. Verify the information is correct. Click Install.

7. Click Done.

Logging in to the Standalone SLC
1. To start SLC on your system either:

■ Double-click the SLC icon on the desktop.

■ Select Start > RunSLC or Launch > RunSLC.

2. Enter your login information, and click Log on.

For additional login and user management information, see "User Management" 
on page 3-7.

Note: On Solaris, you cannot choose the default root directory. 
Oracle recommends /u-sr/bin or a similar location.
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Web-launched SLC
The web-launched version enables SLC to be installed on a web server. Then, 
individual clients can use a browser access SLC.

To install the web-launch version on a server, download the web-launch SLC server 
(.war) file from the Oracle Software Delivery Cloud (see "Downloading the SLC Media 
Pack" on page 3-1). Deploy the file on the server of your choice (refer to the media 
pack readme). The web-launched SLC is delivered to clients as a Java Web Start 
process, which executes outside the browser.

You only need to install updates on the web-launched SLC on the server. You can 
update the web-launched SLC server while it is running. After the updates are 
installed on the server, they are downloaded automatically to all clients whenever the 
application is started.

Security Considerations
The web-launched SLC software is digitally signed, which guarantees that it has been 
issued by Oracle Corporation and has not been altered or corrupted since it was 
created. As a Java Web Start process, the web-launched SLC includes the security 
features provided by the Java 2 platform. 

You are responsible for implementing all appropriate security systems, including 
firewalls, user access, and so on.

Client Requirements

Qualified Platforms
■ Internet Explorer 8 (on Windows 7: 64 bit)

■ Firefox 17.0.2 ESR (on Windows 7: 64bit)

Other
■ Java 1.5 Plug-in (the browser should install this automatically)

■ Network connection to the web-launched SLC server

Logging in to the Web-launched SLC
To log in using a browser, download Mozilla Firefox from http://www.mozilla.com. 
On Solaris platforms, you can also log in to the web-launched SLC using the command 
line. 

1. Obtain the DNS alias or IP address of the SLC server. See your library 
administrator for assistance.

2. Choose a login method:

– Command line: Available on Solaris only. In the terminal window, enter:

javaws http://server_ID:port_ID/opel/slc.jnlp

– Web browser: Available on Windows or Solaris. In a browser on the client 
system, go to the SLC Web Start application:

http://server_ID:port_ID/opel

where:

■ server_ID: Either the IP address or DNS alias of the SLC server
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■ port_ID: Port ID of the SLC application, typically 8080

■ opel: The name (context root) of the web-launched SLC application on the 
server.

3. Click Launch Now.

4. Specify the action to take with the slc.jnlp file. Select either:

■ Open with Java(TM) Web Start Launcher to start SLC directly.

■ Save to Disk to save the slc.jnlp file to your client and log in to the SLC later.

5. If this is your first time running the web-launched SLC, complete the digital 
signature warning dialog box: verify the publisher and click Run.

6. Enter your SLC login information, and click Log on.

For additional login and user management information, see "User Management" 
on page 3-7.

Local Operator Panel
The local operator panel is touch screen interface built in to the Customer Interface 
Module (CIM). It enables you to run most of the SLC utilities directly at the library.

Logging in to the Local Operator Panel
Only one user at a time can log in to the local operator panel.

1. If the screen is blank, touch the screen anywhere to activate the Login screen.

2. Use the virtual keypad to enter your login information.

3. Click Log on.

For additional login and user management information, see "User Management" 
on page 3-7.

Calibrating the Touch Screen
Alignment of the touch screen is calibrated at the factory. If the touch screen becomes 
mis-aligned, you can re-calibrate or reset it. View the operator panel version and type 
using the Tools > Diagnostics > Library Folder > Op Panel Tab:

■ If you have a Linux-based local operator panel (DL or OL), you can re-calibrate it 
yourself or reset it to factory setting with the procedures below.

■ If you have a Windows-based local operator panel (W), contact your Oracle 
support representative.

Re-calibrating the Local Operator Panel
For an accurate calibration, make sure there is no debris on the touch screen.

1. Log in to the local operator panel.

2. Select Tools > Calibrate.

3. Tap Calibrate.

4. A series of targets will display. Gently tap in the center of each target with your 
finger or a pointing stylus.

5. To save the new settings:
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a. Tap the Click Me buttons within the indicated time period.

If the buttons do not depress, the touch screen is not properly aligned. Discard 
the new settings, see Step 6.

b. Click OK to save the new settings.

6. To discard the new settings:

a. Let the timer run out without tapping the Click Me button.

b. Return to Step 4 and re-calibrate.

The local operator panel reboots automatically after an unsuccessful second 
calibration and restores the previously saved alignment.

Resetting the Local Operator Panel Calibration
To restore the alignment to the factory settings:

1. Log in to the local operator panel.

2. Select Tools > Calibrate.

3. Click Reset Calibration. The local operator panel reboots.

Rebooting the Local Operator Panel
You may need to reboot the local operator panel if it hangs or the help content is not 
visible.

1. Select Tools > Diagnostics > Library Folder > OpPanel Tab

2. Click the Reboot Operator Panel button.

3. If rebooting from the local operator panel, the screen will go blank. The reboot is 
complete when the operator panel comes back online.

If rebooting from a remote SLC session, a series of messages will display. "Reboot 
Complete" indicates the reboot of the local operator panel has finished.

User Management
To access SLC, you must have a valid user ID and password. Only one user at a time 
can log in to the local operator panel, but any number of users can log in to the 
standalone or web-launched SLC.

User IDs
Each user ID is assigned a set of permissions that determines access to utilities within 
SLC. There are a fixed set of user IDs at each site:

■ admin: customer administrator

■ service: Oracle support representative

■ oem: third-party field service technician

Passwords
After library installation, an Oracle support representative will provide a one-time use 
activation password. The library administrator must activate the admin user ID with 
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the first eight characters of a this password provided. After the initial log in, the 
administrator should change the admin user ID password to ensure system security.

Changing a User Password
1. Log in to SLC using the account you want to modify.

2. Select Tools > User Mgmt.

3. On the navigation tree, expand the Permanent folder. Select the current user 
account.

4. Complete the following fields: Current Password, New Password, and Retype 
Password.

5. Click Modify.
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2Hardware Activation Files

The hardware activation utility enables you to activate and monitor optional features 
on the SL3000 library. Some library features are activated by the customer, while others 
must be installed and enabled by an Oracle support representative. Features you can 
activate include capacity upgrades, dual TCP/IP, redundant electronics, and 
partitioning.

Oracle Hardware Activation Files Overview
An Oracle hardware activation file is a digitally signed Java Archive (.jar) file 
containing a feature activation key. You must install one hardware activation file for 
each feature purchased. Once installed, the feature is added to the features already 
activated on the library.

Legacy Hardware Activation Files 
For SL3000 libraries with firmware version FRS_3.0 and below, hardware activation 
files are delivered by e-mail from Oracle Corporation. Do not use the procedures 
described in this chapter to download hardware activation files. In addition, all 
features purchased for a library are included in a single hardware activation file. When 
you install a new hardware activation file on the library, it overlays any previously 
installed activation files.

After upgrading to firmware version FRS_3.0 and above, use the process described in 
this chapter to activate new features.

Hardware Activation File Installation Overview
1. Purchase the feature from Oracle. 

2. Download the file from the Oracle Software Delivery Cloud and save it to a 
system accessible to your SLC session. See "Downloading a New Hardware 
Activation File" on page 4-2.

3. Install the file using SLC. See "Installing a New Hardware Activation File" on 
page 4-2. 

4. Configure the new feature. See: 

a. Chapter 3, "Capacity Activation"

b. Chapter 4, "Library Partitioning"

c. Chapter 6, "Redundant Electronics"
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Downloading a New Hardware Activation File 
1. Go to the Oracle Software Delivery Cloud at:

http://edelivery.oracle.com/

2. Click Sign In /Register.

3. On the Terms & Restrictions screen:

a. Read the License Agreement and Export Restrictions, and select the check 
boxes to indicate your acceptance.

b. Click Continue.

4. On the Media Pack Search screen:

a. In the Select a Product Pack list, select Oracle StorageTek Products.

b. In the Platform list, select Generic Platform.

c. Click Go.

5. Select the SL3000 hardware activation file media pack. Click Continue.

6. Verify that you have selected the correct media pack. Click Download beside each 
desired feature. 

7. Save the file.

8. Extract the files to a location that you can reach from SLC.

Installing a New Hardware Activation File
1. Complete the steps in "Downloading a New Hardware Activation File" on 

page 4-2.

2. Use SLC to log in to the target library.

3. Select Tools > Hardware Activation.

4. Click the Install Hardware Activation Keys tab. 

5. Enter the full path of the hardware activation file to install, and press Enter. 
Optionally, click Browse and navigate to the file location.

6. Review the hardware activation file details. Click Install.

7. Click Yes, and then OK.

8. Verify that the activation file has been installed and activated successfully (see 
"Displaying Current Hardware Activation Files" on page 4-3). 

Depending on the features activated, you may need to perform additional tasks to 
use the new features (refer to the feature-specific chapter).

Deleting a Hardware Activation File 
Deleting a hardware activation file is rarely necessary and can impact library 
operations. Having extra hardware activation files installed on a library does not 
present any problems (for example, capacity activation files that exceed the physical 
capacity of the library). The extra activation files are simply not used. 

1. Use SLC to log in to the target library.

2. Click Tools > Hardware Activation.
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3. Click the Delete Hardware Activation Files tab.

4. Click the activation file to delete.

5. Verify the correct activation file is selected, and then click Delete....

6. Click Yes.

Depending on the feature of the hardware activation file, you may need to 
perform additional tasks after deleting the file (refer to the feature-specific 
chapter).

Displaying Current Hardware Activation Files 
To display the features currently activated on the library:

1. Select Tools > Hardware Activation. 

2. Select the Current Hardware Activation Keys tab.

Displaying the Feature Audit Log 
The Feature Audit Log displays a list of all feature activation activity for the life of the 
library. Use this log to verify the features installed on the library. 

By default, the report is sorted in chronological order. Optionally, you can change the 
sort order, and rearrange and resize the columns (see "Modifying a Tabular Display" 
on page 3-3). 

1. Select Tools > Reports.

2. Expand the Audit Logs folder, and select the Feature Audit Log tab. The Feature 
Audit Log page appears. 
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3Capacity Activation

There are two types of capacity: physical and active. Physical capacity is the number of 
storage cells in the library. Active capacity is the number of storage cells activated with 
a hardware activation file. The active capacity does not have to equal the full number 
of physical storage cells. Capacity activation requires a hardware activation file.

■ Active Capacity Configuration Overview

■ Defining Activate Capacity Regions Using SLC

■ Setting the Default Capacity Policy

Active Capacity Configuration Overview
In a non-partitioned library, active capacity is automatically assigned after installing 
the hardware activation file. However, you can customize the configuration and select 
which cells will be activated (see "Defining Activate Capacity Regions Using SLC" on 
page 5-2). The automatic configuration activates storage cells in the order specified by 
the Default Capacity Policy (see "Setting the Default Capacity Policy" on page 5-4).

In a partitioned library, capacity is assigned automatically, but the total number of 
storage cells allocated to all library partitions cannot exceed the activated capacity (see 
"Library Partitioning" on page 6-1). 

Coordinate with other library users before configuring the library to prevent conflicts.

Effects of Capacity Changes on HLI Connections
With HLI libraries, you can increase active capacity without stopping host jobs or 
having host connections go offline. When you decrease capacity, the library goes 
offline only momentarily and then comes back online automatically. After a 
configuration change, ACSLS and ELS must perform an audit of the library to account 
for the new library configuration information. Hosts can continue processing jobs 
while the audit takes place.

Adding Active Capacity
Whenever you add active storage cells, the library stays online. The library controller 
sends an asynchronous message to all hosts notifying them that the library 
configuration has changed.

Removing Active Capacity
The library goes offline temporarily whenever you deactivate a storage cell or remove 
an empty drive slot. The library comes back online after the configuration change is 
updated in the library controller database. The library controller sends an 
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asynchronous message to all hosts notifying them that the library configuration has 
changed.

Effects of Capacity Changes on FC-SCSI Connections
With FC-SCSI libraries, the library goes offline temporarily with a Unit Attention 
condition whenever you:

■ Activate or deactivate a storage cell, drive, or CAP cell.

■ Add, change, or remove a host LUN connection.

The library may generate multiple error messages. All hosts must issue the 
appropriate commands to update their library configuration information. See the 
appropriate tape management software documentation for detailed procedures and 
commands. When adding or removing drives, the device SCSI numbering is updated 
as well.

Orphaned Cartridges Caused by Capacity Changes
In non-partitioned libraries, an orphaned cartridge is a cartridge located in an inactive 
storage cells. In partitioned libraries, an orphaned cartridge is a cartridge located in a 
non-allocated cell or drive. Orphaned cartridges are inaccessible to all hosts.

A cartridge can become orphaned when you reduce active storage capacity, change 
partitioning, or manually move a cartridge to an inaccessible cell.

If SLC identifies an orphaned cartridge, it displays a warning message. To help resolve 
an orphaned cartridge issue, you can generate a report of orphaned cartridges, 
perform an audit of the library, or perform a recovery move on a cartridge. To 
resolving orphaned cartridges, see "Moving Cartridges (Recovery Moves)" on 
page 11-4. 

Defining Activate Capacity Regions Using SLC
Capacity is automatically applied in a partitioned library. You may only manually 
activate capacity in a non-partitioned library. Capacity changes cannot be performed at 
the local operator panel.

Use the Tools > Select Active Cells utility to define a custom storage region. No 
changes are committed to the library controller database unless you click Apply User 
Design at the top of the screen and confirm your choice. If you log off SLC, if the 
session times out, or if the connection to the library is lost before you save changes, 
any changes will be lost. At any time, you can discard changes and restore the last 
saved configuration by clicking Refresh.

You can remove all custom capacity activation, remove partitioning, remove media 
validation pools, and apply default capacity as defined by the default capacity policy 
by clicking Reset Default (see "Setting the Default Capacity Policy" on page 5-4). The 
Reset Default button also resets all SCSI element IDs in a SCSI library.

Capacity Icons in SLC

Table 3–1 Capacity Icons

Icon Description

Not Accessible — cell not available for activation (reserved for diagnostic cartridges, 
physically blocked, and so on).



Defining Activate Capacity Regions Using SLC

Capacity Activation 3-3

Modifying Active Storage Regions
You can customize the active storage region by activating or deactivating storage cells 
or deselect storage cells so they will not be automatically activated when capacity is 
increased.

1. Select Tools > Select Active Cells.

2. Click a module to modify.

3. Click the Select Active Cells tab.

Click Move Left or Move Right to display an adjacent module.

4. If you are activating capacity for the first time in a non-partitioned library, follow 
the steps below. Otherwise, proceed to step 4. Before applying a custom design for 
the first time, you must deselect all storage cells: 

a. In the Select by menu, choose Library. Then, select the Remove option.

b. Click any "Selected" cell on the module map. All cells should become 
"Inactive".

5. Choose a Select by method (Cell, Column, Side, Module, Library). Then, click the 
Add option to select cells for the storage region or the Remove option to 
deactivate cells.

6. Using the library map, click the storage cells you want to activate or deactivate.

7. To confirm and verify your changes, click Apply User Design.

8. If there are no warnings, click OK.

9. If there are warnings, click Details.

If orphaned cartridges are reported, do not continue with this procedure until you 
have performed recovery moves on the listed cartridges (see "Moving Cartridges 
(Recovery Moves)" on page 11-4).

10. Reconfigure library host applications to recognize the changes (see the tape 
management software documentation).

Displaying Active Cell Reports
The active cell reports only display data saved to the library controller database.

1. Click Tools > Select Active Cells, and then click the View Reports tab.

Inactive — cell not yet licensed for use

Active — cell licensed for use

Selected — cell designated for activation or deactivation

No activation needed — resource is active by default

Note: Capacity is automatically applied in a partitioned library. You 
may only manually activate capacity in a non-partitioned library. 

Table 3–1 (Cont.) Capacity Icons

Icon Description
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2. Select a report:

■ Cartridge Cell and Media Summary: Displays a detailed list of all library 
resources and their status (active or inactive).

■ Orphaned Cartridge Report: Displays a detailed list of all orphaned 
cartridges.

3. To save the report as a comma-sperated value (csv) file, click Save to File.

Displaying Active Cell Details
Use the Tools > Select Active Cells > Current Active Cells Tab to display which 
storage cells are currently active, inactive, or selected for activation. You can also 
display detailed information about cartridge, drive, and storage cell locations.

1. Select Tools > Select Active Cells.

2. Select the module you want to display.

3. Select the Current Active Cells tab. You can mouse-over a cell or drive to display a 
tooltip for detailed information.

Setting the Default Capacity Policy
Use the Tools > Configuration > Default Capacity Policy Tab to set the capacity 
assignment scheme within the library. The default setting is "Left to Right".

1. Select the type of capacity assignment for the library:

■ Left to Right - capacity assignment begins in upper left slot on the rear wall of 
the left-most module, moves right, then crosses over to the upper left slot on 
the front wall of the left-most module (see Figure B–4).

■ Center Out - capacity assignment begins nearest to the drives and is split 
evenly between the left/right and front/back.

2. Click Apply.

This setting only defines the capacity assignment for new capacity additions in a 
non-partitioned library. To remove existing capacity assignments of the library and 
re-assign capacity to the new default, use the Select Active Cells utility:

a. Select Tools > Select Active Cells > Select Active Cells.

b. Click Reset to Default.

Note: Resetting the capacity to default removes all drives from the 
media validation pool and removes all partitioning settings in the 
library. 
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4Library Partitioning

Library partitioning reserves library resources (drives, cells, and CAPs) for the 
exclusive use of specified hosts. Each partition appears to the host as a separate library. 
Partitioning is an optional feature enabled with a hardware activation file (see 
"Hardware Activation Files" on page 4-1).

■ Partitioning Specifications

■ Partitioning CAPs

■ HLI Host Partitions Overview

■ FC-SCSI Host Partitions Overview

■ Deleting the Partitioning Feature

■ Changing Hardware in a Partitioned Library

■ Partitioning the Library Using SLC

Partitioning Specifications
The SL3000 library partitioning specifications include:

■ Up to eight partitions.

■ Smallest increment is a single storage cell, single tape drive, or CAP.

■ Support for non-contiguous resource assignments.

■ The total number of storage cells allocated to all library partitions cannot exceed 
the activated capacity of the library (see "Active Capacity Configuration 
Overview" on page 5-1).

■ Supports HLI and FC-SCSI (one type per partition). See HLI Host Partitions 
Overview or FC-SCSI Host Partitions Overview.

Partitioning CAPs

A partition can only use a CAP explicitly allocated to it. All cells in the CAP are 
allocated as a whole to the partition. It is not possible to allocate or remove individual 

Note: AEM CAPs are subject to the same partitioning rules and 
restrictions as rotational CAPs. In this chapter, the term CAP refers to 
both types of CAPs, unless otherwise specified. 
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cells within a CAP (the library does not support common CAPs, split CAPs, or the 
allocation of individual CAP cells to a partition).

It may be necessary to share CAPs among partitions when a library has more partition 
than CAPs. Each partition can have dedicated CAPs or shared CAPs, but not both. 
Only partitions with the same host interface type (FC-SCSI or HLI) can share a CAP. 
Only one partition at a time can use a shared CAP (see "HLI CAP Reservations" on 
page 6-2 and "FC-SCSI CAP Associations" on page 6-3).

HLI Host Partitions Overview
An HLI partition can have up to 16 assigned hosts. You define the HLI host-partition 
connection configuration through the library management software, ACSLS or ELS, 
(see the tape management software documentation).

A single ACSLS server can manage multiple partitions in the same library. Each 
partition is configured as a separate automated cartridge system (ACS). 

ELS hosts using a common control data set (CDS) database (called a host group) can 
share one partition. A single ELS CDS database can manage more than one partition 
within the same SL3000 library. Individual HSC hosts and groups of up to 16 ELS 
hosts that share a common control data set can control a single partition. 

Configuration Changes in HLI Partitions 
A partition remains online when allocating resources to the partition. You do not need 
to stop host jobs. However, a partition will go offline temporarily when resources are 
removed from the partition. Neighboring partitions are always left undisturbed. The 
affected partition automatically comes back online and the library notifies all hosts 
connected to the partition that a configuration change has occurred.

After allocating or removing resources, the hosts experience a brief interruption as 
library configuration information is updated. The host automatically continues to 
process jobs. After changing the configuration, the host should perform an audit to 
update the host software database.

HLI CAP Reservations 
HLI hosts use a reservation scheme to manage CAP usage. Each host reserves a CAP 
for exclusive use as needed, then releases the CAP when it is no longer required. A 
host can reserve a CAP if the CAP is empty, closed, locked, and not already reserved 
by another partition. After an enter or eject operation completes, the host terminates 
the enter/eject command. Then, the library controller releases the CAP after verifying 
that the CAP is closed and empty. 

If for any reason a CAP reservation is not released and the enter or eject command 
cannot be terminated in ACSLS or HSC on the host, a library administrator must 
override the host partition reservation (see "Overriding a CAP Reservation" on 
page 9-5).

CAP Auto Enter Mode
CAP auto enter mode enables a library operator to open a CAP and initiate an enter 
operation without issuing an explicit enter request and without an explicit reservation 
from a host application. Auto enter mode is available for HLI CAPs that have been 
dedicated to a partition. CAPs in auto enter mode are left unlocked. Host applications 
manage auto enter mode (see the tape management software documentation).
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CAP States 

FC-SCSI Host Partitions Overview
An FC-SCSI partition can have one or more host-partition connections, but some host 
applications may not allow for CAP sharing (see "FC-SCSI CAP Associations" on 
page 6-3). 

Configuration Changes in FC-SCSI Partitions 
The host-partition connection configuration is user-defined and consists of the world 
wide port name of the FC-SCSI host bus adapter and the logical unit number (LUN) of 
the host. 

After adding or deleting a host-partition connection or changing the LUN, the affected 
partition goes offline with a "LUNS Data Has Changed Unit Attention" condition. If a 
host has unique ITL nexus connection mappings for each partition connection, then 
only the partition experiencing the connection change is affected.

After allocating or removing a storage cell, drive, or CAP in a partition, the affected 
partition goes offline with a condition of "Mode Parameters Have Changed Unit 
Attention". 

Neighboring partitions and their connected hosts are not disturbed. The hosts 
connected to an affected partition must issue the appropriate commands to update 
their library configuration information (see the host software documentation).

FC-SCSI CAP Associations 
Most FC-SCSI host applications typically assume sole ownership of a CAP and 
therefore do not coordinate CAP sharing. To avoid contention among partitions for a 
shared CAP, you must manually associate a partition to a CAP for an enter or eject 
operation (see "Entering or Ejecting Cartridges for FC-SCSI Partition with Shared 
CAP" on page 9-5).

The following rules apply when making partition-CAP associations: 

■ You can associate only one partition at a time to a CAP. 

■ Selecting a partition causes all its allocated CAPs to become associated. You cannot 
select an individual CAP. 

■ Partition-CAP associations remain active until you explicitly remove them, the 
CAP becomes allocated to a different partition, the library reboots, the power 
cycles, the library door open/closes, or the CAP initializes. 

If a partition-CAP association is removed while the CAP is open or has cartridges in it, 
the CAP ownership will be changed to the default requester (the library controller), 
and the CAP will be unavailable to all partitions. You must empty and close the CAP 
before it can be associated to any partitions. 

Table 4–1 Default States of HLI CAPs in Partitioned Library

Type of CAP
Default 
State

Default CAP 
Light Condition Comment

Dedicated or shared Locked Off Host reservation unlocks the CAP and 
turns the light on.

Auto enter mode Unlocked On Not applicable.
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CAP States 

Deleting the Partitioning Feature 
To delete an individual partition, see "Delete a Partition" on page 6-6. It is not 
recommended, but to delete the partitioning feature, you must delete the partitioning 
hardware activation file from the library (see "Deleting a Hardware Activation File" on 
page 4-2). You must reboot the library after deleting the partitioning activation file for 
the deletion to take effect. 

Deleting the partitioning feature has the following effects on the library configuration: 

■ Changes the library state to non-partitioned. 

■ Makes all activated storage cells, drives, and CAPs accessible to hosts. 

■ All existing partition summary information and resource allocations are retained, 
but not usable. If the partitioning activation file is later re-installed, the partition 
allocations are restored. 

Changing Hardware in a Partitioned Library 
Some library hardware changes may require modification of an existing partitioned 
module. Use the following process to make hardware changes without losing 
partitioning information for unchanged library sections. 

1. All resources that will be affected by the hardware change must be removed from 
their respective partitions (see "Designing a Partition - Module Map & Design 
Tabs" on page 6-7).

2. Power down the library (see "Turning Off the Library" on page 15-2). 

3. Install the hardware change. 

4. Power up the library (see "Turning on the Library" on page 15-3). 

All partition allocations for the unchanged parts of the library remain in effect. 

5. Allocate the library resources that have been added due to the hardware change 
(see "Designing a Partition - Module Map & Design Tabs" on page 6-7). 

Partitioning the Library Using SLC
■ "Preparing for Partitioning - Instructions Tab" on page 6-5

■ "Adding, Deleting, or Modifying a Partition - Summary Tab" on page 6-5

Table 4–2 Default States of FC-SCSI CAPs in Partitioned Library

Type of CAP
Default 
State

Default CAP 
Light Condition Comment

Dedicated Unlocked On Not applicable.

Shared Locked Off Partition-CAP association unlocks the CAP 
and turns the light on.

Caution: The partitioning feature cannot be deleted if it was 
activated by a legacy hardware activation file before SL3000 firmware 
version FRS_3.0.
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■ "Designing a Partition - Module Map & Design Tabs" on page 6-7

■ "Confirming Partitioning Changes - Commit Tab" on page 6-7

■ "Generating Partitioning Reports - Reports Tab" on page 6-8

■ "Viewing Current Partition Definitions" on page 6-8

Partitioning Icons in SLC

Preparing for Partitioning - Instructions Tab
You should make the library unavailable to other users before committing partitioning 
changes. Configuration conflicts may arise if you change partition boundaries while 
other users are accessing the library.

1. Quiesce any host operations. 

2. Select Tools > Partitions.

3. Review the Instructions tab. To create a partition, see "Adding, Deleting, or 
Modifying a Partition - Summary Tab" on page 6-5.

Adding, Deleting, or Modifying a Partition - Summary Tab
You can create up to eight partitions. You must designate a partition ID and host 
interface type for each partition.

Add a Partition
1. Select the Summary (Step 2) tab of the Partitions interface.

2. In the Partition Allocation Summary area, click Add Partition.

3. Select the Partition ID and enter the Name and Interface Type. Partition IDs do not 
need to be contiguous. 

4. Click OK.

5. Repeat steps 2-4 until you have added all the required partitions.

6. For FC-SCSI partitions, you must add a host connection (HLI host-partition 
connections are configured through the host library management software):

Note: No actual changes to partitioning occur until the design is 
applied using the Commit tab. At any time, you can discard all 
uncommitted partition changes by clicking the Refresh button.

Table 4–3 Partitioning Icons

Icon Description

(rectangle with X) Not Accessible — resources not available for host operations 
(reserved system cell, physically blocked, and so on).

(white rectangle) Unallocated — resource available for assignment

(yellow rectangle) Partition # — resources assigned to the current partition

(red rectangle) Other Partitions — resources assigned to another partition

(gray rectangle) Shared CAP — a CAP assigned to multiple partitions
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a. In the Partition Allocation Summary area, click the partition.

b. Click Add Connection.

c. Enter the Initiator (WWPN) and LUN. Each initiator connected to the library 
must have one library partition assigned to LUN 0.

d. Click OK.

e. Repeat steps a - d until you have added all required FC-SCSI connections. 
Each partition can have up to nine host connections, and each host can connect 
to multiple partitions. 

7. Design the partition (see "Designing a Partition - Module Map & Design Tabs" on 
page 6-7).

Delete a Partition 
You may want to delete a partition to re-assign resources to another partition or to 
change the partition ID. When you delete a partition:

■ All resources allocated to the partition are marked available. 

■ All host connections for the partition are deleted. 

■ The partition ID is deleted. 

To delete a partition:

1. Click the Summary (Step 2) tab of the Partitions interface.

2. In the Partition Allocation Summary area, click the partition to remove. 

3. Click Delete Partition. 

4. Click OK to confirm the deletion. If partitions still remain in the library, proceed to 
the next step.

If no partitions remain, select the library interface type you want to assign for all 
host connections to the library, either HLI or FC-SCSI. Click OK.

5. Click OK to confirm the change.

6. Commit the changes (see "Confirming Partitioning Changes - Commit Tab" on 
page 6-7). 

Modify a Partition
You can modify the interface type (HLI or FC-SCSI) and for FC-SCSI partitions you can 
modify the host connection information. You cannot change the partition ID. To assign 
a different partition ID, you must delete the old partition and create a new one with 
the new ID (see "Delete a Partition" on page 6-6 and "Add a Partition" on page 6-5).

1. Select the Summary (Step 2) tab of the Partitions interface.

2. To modify the name or interface type:

a. In the Partition Allocation Summary area, click the partition to modify.

b. Enter the changes you want to make. Click OK.

3. To modify a FC-SCSI host connection:

Caution: Changing the interface type can result in loss of active host 
connections or existing shared CAP assignments.
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a. In the Connections section, select the host-partition connection to modify.

b. Click Modify a Connection.

c. Enter the changes you want to make. Click OK.

4. Commit the changes (see "Confirming Partitioning Changes - Commit Tab" on 
page 6-7).

Designing a Partition - Module Map & Design Tabs
You can allocate library resources to only one partition at a time. Use the Module Map 
and Design tabs to add or remove resources. If you want to add currently-allocated 
resources to a different partition, you must first remove the resources from the 
assigned partition, and then add them to the new partition.

1. Click the Module Map (Step 3a) tab of the Partitions interface.

2. Click the module for which you want to design a partition. 

3. Click the Design (Step 3b) tab.

4. Use the list control to select a partition ID.

5. Choose the Select by method, and then select either the Add or Remove option.

6. Use the library map to select the resources to add or remove. Click Move Left or 
Move Right to display an adjacent module.

7. After you have completed the partition configuration, click Verify. This checks for 
orphaned cartridges, oversubscribed capacity, and whether each host has a 
partition assigned to LUN 0.

8. If there are warnings, click Details.

If orphaned cartridges were found, perform recovery moves on all listed volumes 
(see "Moving Cartridges (Recovery Moves)" on page 11-4). After you have 
resolved all orphaned cartridges, re-verify the partitioning configuration. 

9. If there are no warnings, repeat steps 4-8 for each partition ID. After all partitions 
are configured, see "Confirming Partitioning Changes - Commit Tab" on page 6-7.

Confirming Partitioning Changes - Commit Tab
Use the Commit tab to apply the partition configuration. No changes are made to the 
library until you complete these procedures.

1. Take the library offline to ACSLS and ELS tape management software (see the tape 
management software documentation). 

2. Click the Commit (Step 4) tab of the Partitions interface.

3. Click Apply. If the library capacity is over-subscribed, the Apply button is grayed 
out. Remove storage cells from a partition or purchase more capacity. 

4. If there are no warnings, click OK. If there are warnings, click Details >>. 

If orphaned cartridges were found, perform recovery moves on all listed volumes 
before committing partitioning changes. See "Moving Cartridges (Recovery 
Moves)" on page 11-4.

5. Configure all affected library host applications (see the host software 
documentation).
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Generating Partitioning Reports - Reports Tab
You can generate reports to assist in partitioning management and design. See also 
"Viewing Current Partition Definitions" on page 6-8.

1. Select the Reports tab of the Partitions interface. 

2. Select a report from the menu:

■ Cartridge Cell and Media Summary - displays a list of all resource partition 
assignments. 

■ Host Connections Summary - displays host-partition connection information. 

■ Orphaned Cartridge Report - displays a list of all orphaned cartridges. 

■ Partition Details - displays information for a selected partition. 

■ Partition Summary - displays summary information for all partitions. 

3. To print the report data, click Print. To save the report, click Save to File. 

Viewing Current Partition Definitions 
Use the Current Partition Definitions tab to display current partition boundaries and 
allocations. You can also display detailed information about cartridge, drive, and 
storage cell locations. See also "Generating Partitioning Reports - Reports Tab" on 
page 6-8.

1. Click the Module Map (Step 3a) tab of the Partitions interface. 

2. Click a module to display. 

3. Click the Current Partition Definitions tab. You can hover over a cell to display a 
tooltip for detailed information.
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5Library Management

■ Library and Device Status Overview

■ Upgrading Library Firmware

■ Special Library Configuration Options

■ Displaying Library Information

■ Generating Library Diagnostic Files

■ Performing a Library Self-Test

■ Rebooting the Library

■ Placing the Library Online or Offline

■ Changing the Library Interface Type (Non-Partitioned Libraries)

■ Audits Overview

Library and Device Status Overview
SLC shows health status for devices, SLC communication, and the library. See also 
"SLC GUI Overview" on page 3-2.

Health Status of a Device
This information is found in navigation tree of System Details and Diagnostics page.

■ Normal — library device is functioning normally

■ Warning — device is offline or operating in a degraded state

■ Error — device has experienced a failure

Communication Status
This information is found in lower left of all SLC screens. Indicates the communication 
status between SLC and the library controller.

Table 5–1 Status Indicators

Icon Meaning

Normal

Warning

Error
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■ Normal — SLC is communicating normally with the library controller

■ Warning — server is taking longer than 10 seconds to respond

■ Error — server is taking longer than 30 seconds respond

After about 30–60 seconds of lost communication the heartbeat monitor turns gray, 
then red, and the following error message appears:

Heartbeat message not received from the library controller.

Log off SLC, and then log on again to restore communication.

Health Status of the Library
This information is found in lower right of all SLC screens.

■ Normal — all library devices are functioning normally

■ Warning — one or more library devices is offline or operating in a degraded state

■ Error — one or more library devices has experienced a failure

After a device error is fixed, the library health indicator changes to "Warning". The 
indicator will not change to "Normal" until the library is taken offline. If there are 
multiple problems with a device or status alert condition, the health indicator 
displays the most severe condition.

Clearing Library Status Alerts
You can only clear alerts marked as "Clearable" and only if service is active on the 
library.

Clearing an alert only removes it from the Status Module display; it does not resolve 
the underlying cause. The library health indicator returns to "Normal" if there are no 
other device or status alerts. If the alert is subject to periodic updates, it will reappear 
at the next update cycle. 

1. Select Tools > System Detail, and click the Library folder.

2. Click the Status tab, and then the Status Module tab.

3. On the Clear Alert Number list, select the alert number to clear, and then click 
Apply.

Upgrading Library Firmware
To upgrade firmware, an Oracle service representative can use the SLC code load 
utility. You cannot perform a code download or activation at the local operator panel.

Library firmware does not contain drive code upgrades (see drive-specific 
documentation). Firmware upgrades for libraries with the redundant electronics 
feature are minimally disruptive (see Chapter 6, "Redundant Electronics"). 

Downloading Code to the Library Controller
Only Oracle service representatives should download and install new library 
firmware. Contact Oracle Support for assistance.

1. Locate the firmware upgrade package (.jar file) at: http://edelivery.oracle.com

2. Download the code to your workstation.

3. Log in to SLC.
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4. Select Tools > Diagnostics, and then click the Library folder.

5. Click the Load Code tab.

6. Enter the full path of the firmware package to download, and then press Enter. 

Optionally, click Browse and navigate to the file location. 

7. Verify the contents and file name. Click Load.

8. Click OK. The download process could take up to 10 minutes.

9. After the code unpacks, activate the code at any time (see "Activating Code on the 
Library Controller" on page 7-3).

Activating Code on the Library Controller
Only Oracle service representatives should download and install new library 
firmware. Contact Oracle Support for assistance. A reboot of the library is required to 
activate new library firmware. Schedule the code activation accordingly.

The library controller can store up to two versions of firmware, but only one is active. 
The active version is identified as "running". You can restore the earlier firmware 
version if required.

1. If you have not done so, download and unpack the code (see "Downloading Code 
to the Library Controller" on page 7-2).

2. Select Tools > Diagnostics, and then click the Library folder.

3. Click the Activate Code tab.

4. In the Target list, select the code package to activate (in this case SL3000 Code).

5. In the Available Versions section, select the code version to activate.

6. Click Activate.

7. Click OK to start activation.

8. When the activation process finishes, click OK to reboot the library.

9. Click OK to terminate the SLC session.

10. After library initialization completes, log in to SLC.

Special Library Configuration Options
The Library Configuration page provides the following configuration options. In 
partitioned libraries, you can configure these options separately for each partition.

Note: Next to the Failed label, you should see "0". If there are any 
failures indicated, contact your Oracle support representative for 
assistance.

Caution: POTENTIAL INTERNAL FILE CORRUPTION. Do not 
reboot any devices in the library or execute any operations on the 
library while activating code.
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■ Barcode presentation (see"Configure Cartridge Barcode Presentation (FC-SCSI 
only)" on page 11-2)

■ SCSI FastLoad controls the criteria by which cartridge mounts are considered 
complete (see "SCSI FastLoad Feature" on page 13-2).

■ Library Auto Clean controls the management of cleaning cartridge and drive clean 
functions (see "Drive Cleaning" on page 10-1). 

Displaying Library Information
■ "Displaying Library Status" on page 7-4

■ "Displaying Library Properties" on page 7-4

■ "Viewing Library Reports" on page 7-5

■ "Displaying Library Power Supply Information" on page 7-6

Displaying Library Status
1. Select Tools > System Detail, and then click the Library folder in the navigation 

tree.

2. Click the Status tab.

3. Select a secondary tab:

■ General - displays the current operational state of the library. These values 
update whenever there is host activity, background operations, or operator 
activity.

■ Status Module - displays library status alerts and highlights significant 
messages. This feature is available only if service is active on the library. If 
service is not active on the library, this screen will be blank except for a 
message indicating that the "Service activation is not valid". If you see the 
"warning" status, a failure may occur. Contact a service representative.

■ HLI - displays the current status of all HLI interface ports on the library. 
Information includes the local TCP/IP socket, local IP, connection status, port 
status, and transmission sent and received from the time of connection.

■ FC-SCSI - displays the current status of all host FC–SCSI interface ports on the 
library. Detailed information is shown by port number. If the Multi Port Fibre 
feature has been activated on the library, detail is shown for all ports.

Displaying Library Properties
1. Select Tools > System Detail, and then click the Library folder.

2. Click the Properties tab.

3. Select a secondary tab:

■ General - displays the physical, mechanical, logical, and network 
configuration of the library. Some of the information can be set up 
automatically during library initialization, while other information can be 
defined by the user.

■ Library Controller - displays details of the library controller, including the 
serial number and firmware versions.
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■ Drive Controller - displays details of the drive controller, including the serial 
number and current firmware versions.

Viewing Library Reports
Use this procedure to display, search, or save library reports available from the Tools > 
Reports menu. Additional reports are available from the Tools > Partitions menu (see 
"Generating Partitioning Reports - Reports Tab" on page 6-8).

All report output is a static display of information at the time the report is generated. 
Click Update in the upper right corner to refresh the information.

1. Select Tools > Reports.

2. In the navigation tree, expand a report category.

3. Select a report.

Searching a Library Report
1. With the report displayed, click Search.

2. Enter a text string (case-sensitive and wildcards are invalid). Click Search.

Saving Library Report Data to a File
1. With the report displayed, click Save.

2. Browse to the desired directory, enter a file name, select a format, and click Save.

Displaying Library Statistics Reports
The Energy Monitor Reports help you monitor your power and energy usage, and 
identify periods of peak and low usage over time.

To change the sort order of the screen or rearrange and resize the columns, see 
"Modifying a Tabular Display" on page 3-3.

1. Select Tools > Reports.

2. Expand the Statistics folder, and then click a report: .

■ General Events - displays summary statistics for library operations. For each 
event, the report lists the event type, number of occurrences, and the date and 
time of the most recent occurrence of the event.

■ Energy Monitor - Last 24 Hours - displays minute-by-minute energy and 
average power usage for the entire library over the last 24 hours.

■ Last Month Energy Monitor - displays energy and average power usage for 
the entire library, measured in 15-minute intervals over the last 32 days.

■ Last Month Energy Monitor - displays energy and average power usage for 
the entire library, measured in one-day intervals over the last 365 days.

Note: Running multiple instances of SLC on the same workstation 
can cause inconsistent data on reports. It is recommended that only 
one user at a time produce SLC reports.
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Displaying Library Power Supply Information
For power configuration information, see the SL3000 Systems Assurance Guide "Power" 
chapter found on OTN.

The Power Supply Data screen displays summary information for all power supplies 
in the library. Use this screen to monitor the status of the power supplies for 
maintenance or replacement. By default, the display is sorted by internal address. To 
change the sort order, and rearrange and resize the columns, see "Modifying a Tabular 
Display" on page 3-3.

1. Select Tools > System Detail.

2. In the Library navigation tree, click the Power Supply folder to display summary 
information.

3. For detailed information, expand the Power Supply folder. Select a power supply.

Generating Library Diagnostic Files
Generate the following files to help diagnose library problems.

■ "Transferring the Library MIB File" on page 7-6

■ "Generating and Transferring the Library Log Snapshot File" on page 7-6

Transferring the Library MIB File
To help diagnose issues, you can transfer the public SNMP management information 
base (MIB) file to an Oracle support representative.

1. Select Tools > Diagnostics.

2. Click the Library folder in the navigation tree.

3. Click the TransferFile tab.

4. Select the Transfer Type of SNMP MIB. Click Transfer File.

5. Browse to the desired directory, and then enter the file name with a .txt suffix.

6. Click Save.

7. E-mail the file to your Oracle support representative.

Generating and Transferring the Library Log Snapshot File
If a support representative requests a library Log Snapshot, use this procedure to 
generate and transfer the file. The system saves the file in an encrypted format, so you 
cannot view or edit it. You must save the log within 15 minutes of generation.

1. Select Tools > Diagnostics.

2. Click the Library folder in the navigation tree.

3. Click the Transfer File tab.

4. Select the Log Snapshot option.

5. In the Selected Devices list, select either All Devices or Selected Device. If you 
chose Selected Device, select the device.

6. Click Generate Log Snapshot on Library.

7. Click Yes, and then OK.
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8. Click Transfer Log Snapshot To Your Computer.

9. Browse to the desired directory or enter the directory path. Click Save. The file is 
named automatically.

10. E-mail the file to your Oracle support representative.

Performing a Library Self-Test
The self-test can help diagnose library operational problems. A self-test typically runs 
after the library is installed. You can run library self-test routines in either 
non-disruptive (cartridges are returned to home cells) or disruptive mode (cartridges 
may be moved to new cells).

When performing a self-test, the system:

■ Checks the communication path between the library controller, drives, and robots.

■ Performs get and put operations to check the health of the robots and CAPs. This 
includes get and put operations from a reserved system cell to a random empty 
storage cell or CAP cell.

■ Performs a full library audit.

■ Performs mounts and dismounts of diagnostic cartridges for all the drives 
installed in the library. The self-test does not begin unless a diagnostic cartridge is 
found in the system cells. If the system finds a compatible diagnostic cartridge, the 
self-test repeats for each drive type. If the system does not find a diagnostic 
cartridge for a drive type, the system skips the mount/dismount operation for the 
drive.

1. Make sure the proper drive diagnostic cartridges are in the library (see 
"Displaying Cartridge Information" on page 11-2).

2. Select Tools > Diagnostics, and click the Library folder.

3. Click the SelfTest tab.

4. In the Mode list, select the type of self-test:

■ Non-Disruptive - all cartridges used in the test are returned to their original 
locations

■ Disruptive - the library must be taken offline to all hosts before running this 
test

5. Click Run. When the test completes, the results of the test display. 

6. For disruptive tests, bring the library online to resume normal operations.

Rebooting the Library
Use this procedure to reboot the library. This process involves reloading the firmware 
from flash memory and restarting the library controller.

1. Select Tools > Diagnostics.

2. Click the Library folder in the navigation tree.

 Note: Before performing a disruptive test, the library must be taken 
offline. See "Placing the Library Online or Offline" on page 7-8.
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3. Click Reboot. 

4. All other users must log off. Click OK. 

5. If the library is online, click OK to take the library offline. 

6. Click OK to reboot the library.

7. Click OK to terminate this SLC session. Do not log back in to SLC until the library 
has fully initialized.

Placing the Library Online or Offline
Use this procedure only if you are not using ACSLS or ELS tape management 
software, or if ACSLS/ELS servers cannot communicate with the library. For 
instructions on changing the state of the library and its components through ACSLS or 
ELS, see the appropriate tape management software documentation.

Placing the Library Offline
You may need to place the library offline at the following times:

■ Before powering down the library

■ Before opening a library access door

■ When the library is inoperative and requires maintenance

To place the library offline:

1. Take all library drives offline. See "Changing a Drive Online/Offline Status" on 
page 10-5.

2. Select Tools > System Detail.

3. Click the Library folder in the navigation tree.

4. Click the Status tab, and then the General tab.

5. In the Transition Request list, click Take offline. 

6. Click Apply. Before the library goes offline, all outstanding library jobs complete.

7. Wait for the offline confirmation message. If the library does not come offline, 
check the status of the library.

Bringing the Library Online
1. Select Tools > System Detail.

2. Click the Library folder in the navigation tree.

3. Click the Status tab, and then the General tab.

4. In the Transition Request list, click Bring online.

5. Click Apply.

6. If applicable, bring the library online to ACSLS and ELS hosts. See the ACSLS and 
ELS documentation.

Bringing the Drives Online
LTO drives are automatically brought online when you bring the library online. To 
bring T-series drives online manually:
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1. To verify that the T-series drives are ready and online, press the MENU switch. 
The display should now read Online.

2. If the drive displays Offline, press the SELECT switch once to bring it online.

■ If the drive message indicates Online, the transition to online completed.

■ If the Onl Pend message appears, the online state is pending due to 
completion of diagnostic tests.

■ If other messages appear, refer to the drive documentation.

Changing the Library Interface Type (Non-Partitioned Libraries)
Use this procedure to change the interface type that all hosts use to connect to the 
library. This procedure applies to non-partitioned libraries only.

1. Select Tools > Select Active Cells.

2. Click the Select Active Cells tab.

3. In the Interface Type list, select the interface type you want to assign. Click Apply.

4. Click Yes to update the library controller database.

5. Click OK to return to the Select Active Cells page.

The new interface type is active immediately. The library does not need to be 
rebooted.

Audits Overview
An audit is the process of cataloging or verifying cartridge locations within a library 
and updating the cartridge database. The database contains the volume ID (vol-id or 
volser), current location (in library internal address format), and verified status (true 
or false). 

You can use SLC to perform an audit, see "Performing a Physical Audit" on page 7-10 
and "Performing a Verified Audit" on page 7-11. There is also a virtual audit. A virtual 
audit displays a report listing the contents of the cartridge database (see "Displaying 
Cartridge Information" on page 11-2). Audit times vary according to the type of audit, 
size of the library, the number of robots, and the speed of the scan engine for the 
barcode scanner.

The library performs an audit when:

■ One or both access doors have been opened and closed.

■ An audit request is made through SLC.

■ A host request to audit the library is entered. (System-level problems may occur if 
a host's record of the cartridge does not match what is in the cartridge database of 
the library controller.)

■ The library initializes at start up.

Note: To change interface types in a partitioned library, see "Modify 
a Partition" on page 6-6.
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Audit Indicator
To indicate an audit is in progress, SLC displays a spinning indicator and the message 
"Audit in progress". When you see this indicator do not open the library access door. 
This will cause the audit to restart.

The audit indicator only displays when an audit is initiated automatically (library 
access door has been opened and closed, library power up or reboot). The indicator 
does not display for audits initiated from SLC or the host.

Performing a Physical Audit
In a physical audit, the robot visits cartridge locations and records the vol-id of the 
cartridges. The library controller updates the cartridge database based on the physical 
audit. This audit changes the "verified" status of the cartridge locations to true.

You can manually initiate a physical audit for either the entire library or a specific 
range of cells.

Auditing the Entire Library
The robot verifies all cells (storage, CAP, drive, reserved). Although an entire library 
audit is a background process and does not interrupt library operations, it does require 
sharing of robot resources. It is not recommended that you run this audit during peak 
activity periods. The audit takes approximately 1/2 second per cartridge slot.

After the audit completes, you can view the Cartridge Summary report for the latest 
cartridge locations and vol-ids. See "Viewing Library Reports" on page 7-5.

1. Select Tools > Diagnostics.

2. Click the Library folder on the navigation tree.

3. Click the Audit tab.

a. In the Entire Library section, click Yes.

b. Click Audit.

4. Click OK to begin the audit.

Auditing a Range of Cells
During this audit, the library verifies only a specific range of storage cells (including 
the CAP and drives). The audit information is displayed on SLC while the audit is 
performed. After the audit completes, view the Cartridge Summary report for the 
latest cartridge locations and vol-ids. See "Viewing Library Reports" on page 7-5.

1. Select Tools > Diagnostics.

2. Click the Library folder on the navigation tree.

3. Click the Audit tab.

a. In the Entire Library section, click No.

In the Physical Audit section, select Yes. 

In the Verified Audit section, select No.

b. In the Start Address and End Address sections, select the device types to audit 
and the internal address locations.

Note: You cannot stop a physical audit after it begins.
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c. Click Audit.

4. Click OK to begin the audit. The Audit Console section displays the progress of 
the audit. 

Performing a Verified Audit
A verified audit validates the status of a specific cartridge location or range of 
locations (including CAPs and drives) in the cartridge database. If a cartridge address 
has a verified status of false, a physical audit of that location is performed and the 
cartridge database is updated.

1. Select Tools > Diagnostics.

2. Click the Library folder on the navigation tree. 

3. Click the Audit tab.

a. In the Entire Library section, select No. 

In the Physical Audit section, select No. 

In the Verified Audit section, select Yes.

b. In the Start Address and End Address sections, select the device types to audit 
and the internal address locations.

4. Click Audit. The Audit Console section displays the progress of the audit.
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6Redundant Electronics

The optional redundant electronics (RE) feature provides failover protection for the 
library controller. This allows an Oracle support representative to replace the faulty 
card while the library is online and provides minimal disruption during firmware 
upgrades.

■ Requirements for Redundant Electronics

■ Redundant Electronics Overview

■ Controller Card Status Information

■ Displaying Redundant Electronics Information

■ Performing a Manual Redundant Electronics Switch

■ Updating Host Management Software for RE

Requirements for Redundant Electronics
■ Two library controller (HBC) cards

■ Two drive controller (HBT) cards

■ Minimum SL3000 firmware version FRS_3.0 and SLC version 5.00

■ Hardware activation file (see "Hardware Activation Files" on page 4-1)

■ HLI host with TCP/IP or FC-SCSI host using ACSLS (RE is not available to hosts 
using a native FC-SCSI interface)

Redundant Electronics Overview
If the library controller or drive controller experiences errors, operations can switch to 
the standby controller with minimal disruption to the library and host operations. The 
library controller and drive controller installed on the same side of the card cage are 
always switched as a pair. Failover can be initiated automatically or manually. A 
failover cannot occur if:

■ The standby library or drive controller is in a fault or eject state.

■ The standby code is not running on the standby library or drive controller cards.

■ A firmware download or card initialization is in progress.

Note: Any reference to the HBC card also refers to the HBCR card.



Redundant Electronics Overview

6-2 StorageTek SL3000 User's Guide

In a failover, the active library controller attempts to complete all in-process jobs and 
copies the cartridge database to the standby controller card. If the database cannot be 
copied (usually only in a sudden failure), you must perform an audit after the failover 
completes (see "Audits Overview" on page 7-9). Any in transit cartridges are returned 
to their home slots. If a cartridge cannot be moved to its home slot, it is moved to a 
library system cell. The host must return the cartridge to its home cell (see library 
management software documentation).

After all in-process jobs have completed or timed out, the card roles switch. Active 
software is brought up on the standby controller. This controller becomes active and 
the previously active controller becomes the standby. If the standby software cannot be 
brought up on the previously active controller, the controller enters a fault state.

Automatic Failover
An automatic failover can be initiated by either the active or standby library controller.

The active library controller initiates an automatic failover when:

■ Its partner drive controller card is not installed or it is not communicating.

■ It detects a catastrophic internal software error.

The standby library controller initiates an automatic failover if it detects the active 
controller is not functioning normally.

Manual Failover
Before initiating a manual switch, you should verify that the standby library and drive 
controllers are running normally. You can initiate a manual switch using:

■ Host tape management (ACSLS or ELS): Failover can be initiated from either the 
active or standby library controller. The standby library controller accepts only set 
host path group and force switchover HLI requests.

■ SLC: Failover is initiated from the active library controller only (see "Performing a 
Manual Redundant Electronics Switch" on page 8-4).

■ CLI: Failover can be initiated from either the active or standby library controller. 
This function is available to your Oracle support representative only.

You may want to perform a manual switch after initial installation of the standby 
cards, after a firmware upgrade, or periodically to check the failover function is 
working properly. It is not possible to manually switch the library controllers without 
the drive controllers — the controllers are always switched as a pair.

Connections
Each library controller card requires a unique IP address. For libraries with Dual 
TCP/IP, each card requires two unique IP addresses: one for the primary port (2B) and 
one for the secondary (2A) port. A library equipped with both RE and Dual TCP/IP 
requires four unique IP addresses.

The failover process is minimally disruptive to host operations.

■ Users of tape management software (Symantec or Virtual Storage Manager) do not 
see an interruption.

■ HLI host applications (ACSLS and ELS) queue requests during the failover process 
for completion after the failover switch. For ACSLS, only mount and dismount 
requests are affected (see the ACSLS and ELS documentation).
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■ SLC and CLI connections are terminated. You must re-establish connections to the 
library using the IP address or DNS alias of the new active library controller (the 
former standby controller).

Firmware Upgrades
Firmware upgrades for libraries with RE are minimally disruptive to library 
operations. New code is loaded and unpacked simultaneously on the active and 
standby controller cards and on all devices. The code is then activated, and the active 
and standby controllers and most devices are re-initialized. Under most circumstances, 
robot initialization is bypassed.

The loading, unpacking, and activation of code are not disruptive to library operations 
until the library is rebooted. During the reboot process (which takes approximately 10 
minutes), the HLI host applications (ACSLS and ELS) queue all mount and dismount 
requests. After the reboot is complete, the queued requests are submitted to the library 
controller.

For firmware download and activation information, see "Upgrading Library 
Firmware" on page 7-2.

Controller Card Status Information
Controller card status is indicated by LEDs on the card and displayed in SLC.

Controller Card LEDs
The LEDs and meanings are the same on both card types (HBC and HBT).

SLC Status of the Library Controller Card
Some SLC screens identify the individual library controller with an A or B suffix. The 
A suffix indicates the bottom card slot and the B suffix indicates the top card slot. To 
display the status of the controller cards in SLC, see "Displaying Redundant 
Electronics Information" on page 8-4.

Table 6–1 LED Status Indicators

LED Definition

ACTIVE - Green Card is functioning as the active and is running active code.

STANDBY - Amber Card is functioning as the standby and is running standby code.

FAULT - Red Card has experienced a serious error.

EJECT OK - Blue Support representative can safely initiate a card eject. 

Table 6–2 SLC Controller Card Statuses

Status Definition

Duplex: Software ready, 
switch possible

Card is functioning normally. A switch can be performed.

Not installed Card is not installed in the library.

Ok Active or standby drive controller card is functioning normally.

Pre-standby:

Software not ready

Standby library controller card is loading standby code and is not 
ready to be used in an automatic failover or manual switch.
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Displaying Redundant Electronics Information
You can check the status of the controller cards using SLC.

1. Select Tools > System Detail.

2. Click the Redundant Electronics folder to display summary information. 

3. For detailed information about each card, expand the Redundant Electronics 
folder in the navigation tree.

4. Select a card (for status meanings, see "SLC Status of the Library Controller Card" 
on page 8-3 ):

a. hbca: Library controller, A (bottom) slot

b. hbcb: Library controller, B (top) slot

c. hbta: Drive controller, A (bottom) slot

d. hbtb: Drive controller, B (top) slot

Performing a Manual Redundant Electronics Switch
You may want to perform a manual switch after initial installation of the standby 
cards, after a firmware upgrade, or periodically to check the failover function is 
working properly. See also "Manual Failover" on page 8-2.

You cannot perform a manual switch at the local operator panel. 

1. Verify that the device state of the card indicates "switch is possible" (see 
"Displaying Redundant Electronics Information" on page 8-4).

2. Select Tools > Diagnostics.

3. Select the Redundant Electronics folder

4. Click Apply to begin the switch process. If there is a problem with the standby 
library and drive controller cards, you cannot continue with the switch.

5. If there are no errors, click Yes.

6. Click OK to log off SLC.

7. Wait until the switch is complete before logging back into the library. You must 
specify the IP address or DNS alias of the new active controller to log in.

Updating Host Management Software for RE
In order to support an RE configuration, the host management software may need to 
be updated.

Standby: 

Software ready

Standby library controller card is functioning normally and can be 
used for an automatic failover or manual switch.

Table 6–2 (Cont.) SLC Controller Card Statuses

Status Definition
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ACSLS
ACSLS 7.3 or higher is required for RE. Additionally, to update the ACSLS 
configuration to connect to an SL3000 with RE, you may want to add port connections 
to the libraries. There are two methods:

■ Use acsss_config: Stop ACSLS. Run acsss_config, specifying the existing ACSs 
and port connections (with the ACSs in the same sequence) and add the new port 
connections. Start ACSLS.

■ Run the config ports utility while ACSLS is running, specifying the existing 
ports in the same sequence and add new ports at the end. You cannot change or 
delete port connections with config ports.

ELS 
PTFs for 6.2 are L1H15S0(VM)/L1H15S1(MVS), and 7.0 is L1H15S2, are highly 
recommended for RE support. The following table defines the HSC  PTF  HLI 
compatibility level support prerequisites for SL3000 firmware FRS_4.00 and above. 

Table 6–3 HSC/ELS PTF HLI Compatibility Level Support

HSC/ELS 
Level

Level 20 or 
Below Level 21 Level 22

Level 23 
Minimum RE 
Support1

1 Can connect to one SL3000 RE library in an ACS string. Only the library connected can be switched through HSC switch 
command.

Level 23 
Enhanced RE 
Support2

2 Can connect to one SL3000 RE library in an ACS string. All RE library can be switched through HSC switch command. 
Supports 32 TCP/IP connections. Includes dual TCP/IP support, display of acs-id, auto CAP recovery, and support for 64 
read in-transit cartridges during cartridge recovery.

Level 23 
Multi-RE 
Support3

3 Can connect to multiple SL3000 RE library in an ACS string. Includes same functionality as the enhanced RE support.

6.1 Level 21 PTF L1H14UU (VM)

L1H14UV (MVS)

Unsupported Unsupported Unsupported Unsupported

6.2 Level 21 PTF L1HA4UW (VM)

L1H14UX (MVS)

L1H15DH (VM)

L1H15DI (MVS)

L1H15H9 (VM)

L1H15HA (MVS)

L1H15MF (VM)

L1H15ME (MVS)

L1H168F (VM)

L1H168G (MVS)

7.0 (MVS) Level 21 PTF L1H14UY L1H15DJ L1H15HB L1H15MH L1H168H

7.1 (MVS) Included Included Included Included Included L1H168I
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Cartridge access ports (CAPs) are used to enter or eject cartridges to or from the 
library. A CAP can be a shared library resource in a partitioned library (see 
"Partitioning CAPs" on page 6-1). This chapter describes general CAP activities:

■ CAP Modes and States

■ CAP Priorities for FC-SCSI Hosts

■ AEM Operations

■ Displaying CAP and AEM Safety Door Information

■ Locking or Unlocking a CAP or AEM

■ Changing the CAP Assignment Mode for an FC-SCSI Library

■ Performing CAP Self-Test

■ Changing CAP Online/Offline Status

■ Entering or Ejecting Cartridges for FC-SCSI Partition with Shared CAP

■ Overriding a CAP Reservation

CAP Modes and States

Auto Enter Mode
Only HLI libraries support CAP auto enter mode.

Auto enter mode enables you to open a CAP and begin an enter operation without 
issuing an explicit enter request or having an explicit CAP reservation from a host 
application. However, to eject cartridges through the CAP, you still have to issue an 
explicit eject command. When in auto mode, a CAP is unlocked and its LED is on. The 
system locks the CAP only during cartridge enter, eject, or audit operations. To initiate 
an enter operation using an automatic CAP, press CAP Open on the key pad.

Host applications manage the auto enter mode. To place a CAP in auto enter mode, 
enter the appropriate tape management command to unlock the CAP (see the tape 
management software documentation).

Note: The term CAP refers to both AEMs and rotational CAPs, 
unless otherwise noted.
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Manual Mode
Manual mode is the most secure method of CAP operations. When in manual mode, 
the system locks a CAP by default, and its LED is off. To initiate an enter or eject 
operation using a manual CAP, enter an explicit enter or eject request before pressing 
the CAP Open button on the keypad.

Assignment Mode
Only non-partitioned FC-SCSI host connections support assignment mode. The CAP 
assignment mode controls whether library CAPs can be used for normal host 
operations or for manual operations (see "Changing the CAP Assignment Mode for an 
FC-SCSI Library" on page 9-4).

CAP States

CAP Priorities for FC-SCSI Hosts
In a non-partitioned library, the SCSI interface treats all CAPs as one large CAP. When 
you initiate an eject operation from an FC-SCSI host, the robot loads cartridges into the 
left-most rotational CAP, then moves right, and then moves to AEMs. For partitioned 
libraries, the CAP priority depends on how CAPs are allocated to partitions.

For example, assume an FC-SCSI library with a base module, two CEMs (one on each 
side of the base), and two AEMs (one on each end of the library). For an eject operation 
of 350 cartridges, the robots fills CAP cells as shown Table 7–2.

AEM Operations
The front panel of the access door includes the following components:

■ Deadbolt Override Lock — enables fast access to the inside of the AEM (has the 
same effects on library operations as opening the main library access door).

■ Service Access Lock — releases the access door deadbolt (only for Oracle support)

■ Operator Request CAP button — releases the access door deadbolt for normal 
access to the inside of the AEM, to load or unload cartridges.

■ Latch — opens and closes the access door after the deadbolt is released.

Table 7–1 CAP States in Non-partitioned Library

Type of CAP Default State Default CAP Button Light Condition

HLI: Manual mode Locked Off

HLI: Auto enter mode Unlocked On

FC-SCSI Unlocked On

Table 7–2 Fill Order of CAP Cells in Eject Operation

Order Module Number of Cartridges Total Cartridges

1 Left CEM 26 26

2 Base Module 26 52

3 Right CEM 26 78

4 Left AEM 234 312

5 Right AEM 38 350
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Displaying CAP and AEM Safety Door Information
Use this procedure to display information for rotational and AEM CAPs in the library. 
This information is also available through Reports > CAP Summary (see "Viewing 
Library Reports" on page 7-5).

Displaying CAP Status and Properties
To display the current operational state or properties of a rotational or AEM CAP:

1. Select Tools > System Detail.

2. Select the CAP folder in the navigation tree. The system lists all the library's CAPs 
and their locations. For more information, expand the CAP folder, and select the 
CAP to display. AEM CAPs are column –31 for the left and column 31 for the 
right.

3. Select a tab:

■ Status - displays the current status of the selected CAP

■ Properties - displays the CAP properties, including code version

Displaying AEM Safety Door Status and Properties
To display the current status or properties of an AEM safety door: 

1. Select Tools > System Detail.

2. Expand the Safety Door folder, and select the safety door you want to display.

3. Select a tab: 

■ Status - displays the current state of the door. Beside the Door Position label, 
"open" indicates the safety door is up and the TallBot is free to move in and 
out of the AEM. "Closed" indicates the safety door is completely closed and it 
is safe for you to open the AEM access door.

■ Properties - displays detailed information for an AEM safety door, including 
the serial number and current firmware versions.

Locking or Unlocking a CAP or AEM
Normally, the host unlocks a CAP or AEM access door. If the CAP is reserved by a 
host, the host must release the CAP reservation before you can use this procedure. An 
unlocked CAP is reserved by the library and unavailable to all hosts until it is locked. 
Use this procedure to manually lock or unlock a CAP with SLC.

1. Select Tools >Diagnostics.

2. Expand the CAP folder, and select the CAP to modify. AEM CAPs are column –31 
for the left and column 31 the right. 

3. Click the Access tab.

4. In the Locked list select:

■ True to unlock

■ False to lock

5. Click Apply. When locking a CAP, a confirmation message appears. Click OK to 
unlock the CAP.
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Changing the CAP Assignment Mode for an FC-SCSI Library
Use this procedure to change the CAP assignment mode for all CAPs in an 
un-partitioned FC-SCSI library. The CAP assignment mode controls whether library 
CAPs can be used for normal host operations or for diagnostic moves.

1. Verify that all library CAPs are unreserved, empty, closed, and locked.

2. If you are changing the CAPs to diagnostics mode, quiesce the library to all hosts 
(see the tape management software documentation).

3. Select Tools > CAP Assignment.

4. Using the Mode list, select a mode:

■ Diagnostics — causes all CAPs to be available for diagnostic operations. Select 
this to perform manual cartridge moves, such as moving cleaning or 
diagnostic cartridges from the CAPs to system cells.

■ Host Operations — causes all CAPs to be available for normal host 
operations. Select this to return the library to normal tape mount or dismount 
operations.

5. Click Apply and then OK.

Performing CAP Self-Test
You can use a CAP self-test to help diagnose issues. See also "Performing a Library 
Self-Test" on page 7-7.

1. Select Tools > Diagnostics. 

2. Expand the CAP folder, and click the CAP to test. AEM CAPs are identified as 
column –31 for the left and column 31 the right. 

3. Click the SelfTest tab. 

4. In the Mode list, select Non-Disruptive. 

5. Click Run. A message appears when the test finishes. 

Changing CAP Online/Offline Status
Use this procedure only if you are not using ACSLS or ELS tape management 
software, or if their servers are unable to communicate with the library. For 
instructions on changing the state of the library and its components through ACSLS or 
ELS, see the appropriate tape management software documentation.

1. Select Tools > System Detail. 

2. Expand the CAP folder. Click the CAP to modify. AEM CAPs are identified as 
column –31 for the left and column 31 the right.

3. Click the Status tab. 

4. In the Transition Request list, select either:

■ Take Offline - all outstanding jobs for the CAP will complete first.

Note: Library devices that are offline and in an error state cannot go 
online. The error condition must be cleared first.
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■ Bring online

5. Click Apply. 

Entering or Ejecting Cartridges for FC-SCSI Partition with Shared CAP 
Use this procedure to give the partition exclusive ownership of a shared CAP for an 
enter or eject operation for an FC-SCSI partition. The association remains until you 
explicitly remove the association.

This procedure is not necessary for dedicated FC-SCSI CAPs or HLI partitions. For 
HLI hosts or FC-SCSI dedicated CAPs, see "Entering Cartridges" on page 11-5 and 
"Ejecting Cartridges" on page 11-6.

1. Select Tools > Shared CAP Assignment. 

2. Select the partition into which you want to enter cartridges. 

3. Click Apply, and then OK.

4. Perform the enter or eject operation (see "Entering Cartridges" on page 11-5 and 
"Ejecting Cartridges" on page 11-6).

5. Once the operation is complete, remove the CAP association. Select 
Tools > Shared CAP Assignment.

6. Deselect the partition with the CAP associations.

7. Click Apply, and then OK.

Overriding a CAP Reservation 
If for any reason a CAP reservation by a partition is not released and the enter or eject 
command cannot be terminated on the ACSLS or HSC host, use this procedure to 
override the CAP reservation. 

1. Select Tools > Shared CAP Assignment. 

2. Expand the CAP folder, and then click the CAP to override. AEM CAPs are 
identified as column –31 for the left and column 31 the right. 

3. Click the Unreserve tab.

4. Click Apply to override the reservation. 

5. Click OK to continue with the override operation. 

6. If the CAP is locked, unlock using SLC (see "Locking or Unlocking a CAP or AEM" 
on page 9-3).

7. Open the CAP. Remove any cartridges and label them with the partition ID.

8. Close the CAP. The CAP status changes to "unreserved".

9. Determine if the cartridges from the CAP should be re-entered into the library and 
then enter the cartridges into the correct partition.

Note: You must follow all steps in this procedure, or the CAP could 
be left unavailable to all partitions.
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■ Drive Cleaning

■ Displaying Drive Information

■ Displaying the Drive and Drive Media Reports

■ Configuring the Drive Tray Serial Numbers

■ Changing a Drive Online/Offline Status

■ Performing a Drive Self-Test

Drive Cleaning
Library tape drives require periodic cleaning to prevent read/write errors. A drive 
cleaning occurs when the system mounts a compatible cleaning cartridge in response 
to a cleaning request from the drive. You can manage drive cleaning using either:

■ Host-Managed Cleaning — Host applications (such as ACSLS or ELS) or 
direct-attach applications (such as Symantec and NetBackup) manage all cleaning 
cartridge and drive clean functions. This method is available for HLI libraries and 
partitions.

■ Library Auto Clean — The library controller manages all cleaning cartridge and 
drive clean functions. This is required for libraries using the Media Validation 
feature. Check your tape management software documentation to determine 
whether this method is recommended for your library.

For a non-partitioned library, select one method for the entire library. In a partitioned 
library, select one method per partition.

Host-Managed Cleaning
When a drive requires cleaning, it notifies the host and the host mounts a cleaning 
cartridge to the drive. To enter/export cleaning cartridges in the library, use the 
applicable ACSLS or ELS commands. Do not use the SLC import/export feature. All 
cleaning cartridges are stored in data cells.

You must disable library auto clean before enabling host-managed cleaning (see 
"Configuring Library Auto Clean" on page 10-3). To enable host-managed cleaning, see 
the ACSLS Administrator's Guide or ELS System Programmer's Guide.

Library Auto Clean
When a drive requires cleaning, the library controller automatically mounts a cleaning 
cartridge on the drive. While a drive is being cleaned, the system marks it as busy to 
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all hosts. If an FC-SCSI host requests the drive while the drive is being cleaned, the 
request is rejected. 

Ensure that the library contains enough cleaning cartridges that are compatible with 
each drive type in your library. You must use SLC to enter/export cleaning cartridges 
(see "Importing/Exporting Cleaning Cartridges (Library Auto Clean Only)" on 
page 10-3). Imported cleaning cartridges are stored in reserved system cells.

The library tracks cleaning cartridge usage and sends notification when cleaning 
cartridges have expired or have reached a user-defined warning threshold (see 
"Defining Warning Thresholds (Library Auto Clean Only)" on page 10-3). Cleaning 
cartridges are expired based on information from the drives. If a drive cannot use a 
cleaning cartridge, the drive sends a "cleaning cartridge expired" notification to the 
library controller. Expired cleaning cartridges can be exported from the library in bulk, 
by expiration date, or by selected cartridge volume ID (vol-id or volser). Replace 
expired cartridges as soon as possible.

Manually Cleaning a Drive
Normally, either the library auto clean feature or the host tape management software 
manages drive cleaning. However, there may be occasions when you need to perform 
a manual clean. Refer to the drive manufacturer's documentation for information on 
whether manual cleaning is allowed.

1. Verify that the drive needs cleaning (see "Displaying Drive Information" on 
page 10-4).

2. Display a list of cleaning cartridges (see "Displaying Cleaning Cartridges" on 
page 10-2). Verify there is a compatible cleaning cartridge for the drive.

3. Move a compatible cleaning cartridge from a system cell to the drive that needs 
cleaning (see "Moving Cartridges (Recovery Moves)" on page 11-4).

4. When the cleaning operation is complete, move the cleaning cartridge from the 
drive back to a system cell.

Displaying Cleaning Cartridges
You can monitor the status and usage count for all cleaning cartridges in reserved 
system cells. A cleaning cartridge may not appear on this page if it is in use, in transit, 
or was entered into the library with host tape management software.

1. Select Tools > System Details.

2. Select the Library folder on the navigation tree

3. Click the Auto Clean tab, and then the Cleaning Cartridges tab. Possible cleaning 
cartridge statuses are:

■ OK — cartridge is usable for cleaning.

■ warning — usage count has reached or exceeded the warning threshold 
defined for this cartridge type.

■ expired — cartridge has expired, based on information from the drives.

Caution: Cleaning a drive before it is due is not recommended. 
Excessive drive cleaning can wear out a drive head prematurely.
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Configuring Library Auto Clean
If the library is partitioned, you can enable or disable library auto clean for individual 
partitions.

1. Select Tools > Configuration.

2. Set the Enable Auto Clean option:

■ Uncheck the box to turn library auto clean off (default). Host management 
software must manage drive cleaning.

■ Check the box to turn library auto clean on.

3. Click Apply.

Defining Warning Thresholds (Library Auto Clean Only)
The cleaning cartridge warning threshold notifies you when a cleaning cartridge is 
nearing time for replacement. Set the threshold lower than the cartridge's 
recommended maximum usage to allow time to replace the cartridge. Refer to the 
drive manufacturers' documentation for maximum recommended usage for each type 
of cleaning cartridge.

When you import a cleaning cartridge into the library, the library controller sets the 
usage count to zero. The count will not be accurate when importing a used cleaning 
cartridge. To display the current usage count, see "Displaying Drive Information" on 
page 10-4.

To assign usage warning thresholds to selected cleaning cartridge types:

1. Select Tools > System Detail. Click the Library folder on the navigation tree.

2. Select Auto Clean, and then the Warning Threshold tab.

3. In the "Threshold warning index to change" list, select the index number of the 
cleaning cartridge type to configure.

4. In the "New warning threshold count" field, enter the warning threshold for the 
cartridge type. 

All cleaning cartridges of this type are assigned the threshold. An entry of 0 
(default) deactivates the warning threshold feature for the cartridge type. 

5. Click Apply.

Importing/Exporting Cleaning Cartridges (Library Auto Clean Only)
Only one cleaning or diagnostic cartridge import or export operation can be 
performed at a time. The library controller reserves the CAP for the entire operation. 

Importing Cleaning Cartridges
Ensure there are enough empty reserved system cells (one system cell on each side of 
the library must be left open for robot recovery or library initialization). The library 
distributes imported cleaning cartridges evenly in reserved system cells, and sets their 
usage counts to 0. The library auto clean feature requires that cleaning cartridge 
volume IDs (vol-ids or volsers) be eight characters in length, with CLN as the first 
three characters (refer to the Barcode Label Technical Brief on OTN for more information).

1. Verify that the CAP is empty, unreserved, closed, and locked.

2. Select Tools > Diagnostics.
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3. Expand the CAP folder and then select a CAP to use. Click the Import/Export tab.

4. Select Import Cleaning/Diagnostic cartridges.

5. Click Start, and then OK to begin the import operation.

6. Load the cleaning cartridges into the CAP (see steps 2 to 4 of "Entering Cartridges" 
on page 11-5).

Exporting Cleaning Cartridges
1. Verify the CAP is empty, unreserved, closed, and locked.

2. Select Tools > Diagnostics.

3. Expand the CAP folder and then select a CAP to use. Click the Import/Export tab.

4. Select a type of export operation:

a. Export expired cleaning cartridges — exports all cleaning cartridges with an 
"expired" status. 

b. Export specific cleaning cartridges — select the cartridges to export in the 
"Select Cartridges(s) to export" list.

c. Export all cleaning cartridges — exports all cleaning cartridges in the library.

5. Click Start.

6. Click OK to begin the export operation.

7. Remove the cartridges from the CAP (see steps 2 to 5 of "Ejecting Cartridges" on 
page 11-6).

Displaying Drive Information
Use this procedure to display drive information for all drives in the library. This 
information is also available through Reports > Drive Details (see "Viewing Library 
Reports" on page 7-5).

1. Select Tools > System Detail.

2. Click the Drive Folder in the navigation tree to display a table of drive 
information, including the drive FPGA version and the drive tray card type — 
LOD or HBD.

3. For more detailed information, expand the Drive folder in the navigation tree. 
Select a drive.

4. Select a tab:

■ Status tab — displays the current operational state of the selected drive

■ Properties tab — displays configuration information, including the drive type, 
serial number, and port configuration

■ Display tab — displays network data, the Virtual Operator Panel (VOP) for 
T10000 and T9840D drives, and drive LED status

■ Drive Tray tab — displays the current status of a drive tray
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Displaying the Drive and Drive Media Reports
The Drive and Drive Media Events Reports summarize drive and media events and 
errors that have occurred on library drives. Use these reports to help identify and 
diagnose faulty drives and cartridges.

By default, the reports are sorted in drive serial number order. Optionally, you can 
change the sort order and rearrange and re-size the columns (see "Modifying a Tabular 
Display" on page 3-3).

1. Select Tools > Reports.

2. Expand the Statistics folder.

3. In the navigation tree, click a report type:

■ Drive Events — summarizes drive events and errors. For each drive that has 
experienced an event, the report lists the type of drive, type of error, the 
number of occurrences, and the date and time of the last such event. The 
report can display up to 70 entries.

■ Drive Media Events — summarizes media events. For each drive that has 
experienced media events, the report lists the vol-id of the cartridge, the type 
of event, the number of occurrences, and the date and time of the last such 
event. The report can display up to 500 entries.

Configuring the Drive Tray Serial Numbers
Use this procedure to add or edit the drive tray serial number.

1. Select Tools > Configuration.

2. Click the Drive Tray S/N tab.

3. Click Refresh to display the current data.

4. To edit an individual drive tray serial number:

a. Double-click the Drive Tray S/N field.

b. Enter the drive tray serial number. Proceed to step 6.

5. To edit multiple drive tray serial numbers at once, you can edit a 
comma-separated value (csv) file:

a. Click Export, and then save the file to a desired location.

b. Open the file and edit only the drive tray serial numbers. Do not alter any 
other values. Save the changes.

c. In SLC, click Import. Locate the updated .csv file, and then click Open.

6. Click Apply, then Yes.

Changing a Drive Online/Offline Status
A drive can be online (available for read/write operations) or offline (unavailable for 
read/write operations).

Use this procedure only if you are not using ACSLS or ELS tape management 
software, or if their servers cannot communicate with the library. For instructions on 
changing the state of the library and its components through ACSLS or ELS, see the 
tape management software documentation.



Performing a Drive Self-Test

8-6 StorageTek SL3000 User's Guide

1. Select Tools > System Detail.

2. Expand the Drive folder, and then click the drive to modify.

3. Click the Status tab.

4. In the Transition Request list, select either:

■ Take Offline — the system completes all outstanding jobs for the drive first.

■ Bring Online

5. Click Apply.

Performing a Drive Self-Test
You can use a drive self-test to help diagnose issues. See also "Performing a Library 
Self-Test" on page 7-7.

1. Select Tools > Diagnostics.

2. Expand the Drive folder, and then click the drive to test.

3. Click the SelfTest tab.

4. In the Mode list, select Non-Disruptive.

5. Click Run.

Note: Library devices that are offline and in an error state cannot go 
online. Clear the error condition first.
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9Cartridge Management

■ Cartridge Types

■ Cartridge Labels

■ Resolving Orphaned Cartridges

■ Displaying Cartridge Information

■ Locating Cartridges

■ Moving Cartridges (Recovery Moves)

■ Entering Cartridges

■ Ejecting Cartridges

■ Importing or Exporting Diagnostic Cartridges

■ Cartridge Handling

Cartridge Types
■ Data cartridges

■ Diagnostic cartridges — used by service representatives to run read/write tests on 
drives (see "Importing or Exporting Diagnostic Cartridges" on page 11-7)

■ Cleaning cartridges — used to clean the tape path and read/write heads of the 
tape drives (see "Drive Cleaning" on page 10-1)

Library cartridges must meet specifications defined in American National Standard 
Magnetic Tape and Cartridge for Information Interchange. For more information on 
cartridges, refer to the drive vendor's publication and website.

Cartridge Labels
All library cartridges must have a readable external label. The robot reports an error 
when it encounters an unreadable label.

Non-labeled cartridges are not supported. The library exports any non-labeled 
cartridges it finds through the CAP. A non-labeled or unknown type cartridge will not 
mount to a drive.

Caution: Do not re-enter a cleaning cartridge ejected by the library. 
The library will consider it to be new, and set the usage counter to 
zero. 
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Cartridge labels include a media domain and media ID. The media domain indicates 
the cartridge type — data, cleaning (CLN), or diagnostic (DG).The media ID indicates 
the compatible drive type. Some FC-SCSI host applications, may require you to 
configure the barcode presentation to use the full eight-character barcode. For 
information about barcode label standards for each cartridge type, refer to the Barcode 
Label Technical Brief on OTN.

Configure Cartridge Barcode Presentation (FC-SCSI only)
Use this procedure to configure the cartridge barcode presentation format for an 
FC-SCSI library or FC-SCSI partition. This specifies which part of a cartridge barcode 
the library passes to host applications that use the FC-SCSI interface.

1. Select Tools > Configuration.

2. In the Barcode Presentation list, select the presentation format to use for each 
partition. The Partition Name scsi0 indicates a non-partitioned library. Format 
options are:

■ all — passes all eight barcode characters to the host.

■ left6 — passes only the six VOLID characters to host applications. It does not 
pass the domain and type characters, which are the two characters on the right 
of the barcode. This is the default setting.

3. Click Apply.

4. Click OK to dismiss the message.

Resolving Orphaned Cartridges
An orphaned cartridge is a cartridge which is inaccessible to a host. Orphaned 
cartridges can occur when you change the capacity, delete a partition, or move a 
cartridge to a cell or drive that is not allocated to a partition.

In a partitioned library, orphaned cartridges can cause data loss. A host that finds an 
orphaned cartridge in its partition may treat the cartridge as a scratch volume and 
overwrite the data. 

SLC will warn you when it identifies orphaned cartridges. Resolve the orphaned 
cartridges by performing recovery moves on listed cartridges. Recovery moves 
transfer the orphaned cartridges to accessible locations within their parent partitions. 
See "Moving Cartridges (Recovery Moves)" on page 11-4.

Displaying Cartridge Information
The reports feature can display information about all library cartridges, including 
cartridge vol-id, location, and media type. You can display the information in a tabular 
format or a list. For drive-related media events, see "Displaying the Drive and Drive 
Media Reports" on page 10-5.

1. Select Tools > Reports.

2. Expand the Status Summary folder in the navigation tree.

3. Click the report to view:

■ Cartridge Table - displays cartridge information in a tabular form. You can 
modify the layout and display of this screen (see "Modifying a Tabular 
Display" on page 3-3).
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■ Cartridge Summary - displays cartridge information in a list.

4.  To search the report data or save it to a file, see "Viewing Library Reports" on 
page 7-5.

Locating Cartridges
You can display the library internal address of any cartridge by using SLC. You can 
locate a cartridge based on vol-id, internal library address, or HLI address.

This utility is especially useful when you must perform a manual mount of a cartridge. 
The library management software (ELS or ACSLS) provides the vol-id, HLI-PRC 
address of the cartridge, and drive bay address of an available drive. Before you enter 
the library, write down the vol-id, cartridge location, and the drive slot location (see 
"Library Addressing" on page B-1).

Locating a Cartridge by vol-id
Use this procedure to display the current location of a cartridge with a specified 
volume ID. You can display cartridge location in the library internal address or 
HLI-PRC address format.

1. Select Tools > Diagnostics, and then click the Library folder.

2. Click the Search tab.

3. In the Search Type list, select VOLID.

4. Enter the volume ID (wildcards are valid).

5. The Requester field controls the address format of the search results. Select:

■ default to display in library internal address format.

■ hli0 or hli1 to display in HLI-PRC address format.

6. Select the Cartridge Type.

7. Click the Search tab. The Search Results section updates.

Locating a Cartridge by Address
Use this procedure to display detailed information for cartridges with a specified 
location. You can specify the location using library internal address, HLI-PRC address, 
or FC-SCSI address.

1. Select Tools > Diagnostics, and then click the Library folder.

2. Click the Search tab.

3. In the Search Type list, select Location.

4. In the Location list, select the search criteria.

5. In the Location field, enter the address (wildcards are invalid)

6. In the Requester list, select the type of address format - FC-SCSI, HLI, or default 
(internal address). Make sure the type matches what was entered in the Location 
field.

7. Click the Search tab.

8. To see details about a cartridge or to view a location mapping, click the ". . ." 
button in the Details column. 
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Moving Cartridges (Recovery Moves)
Using the recovery move diagnostic function, you can move a cartridge from one 
location to another. For example, you can:

■ Return a cartridge to its original location from a CAP cell, drive, or another storage 
cell location.

■ Transfer orphaned cartridges to accessible locations

■ Group cartridges by data type or move them closer to assigned drives.

■ Eject a cleaning or diagnostic cartridge that has expired.

■ Enter a new cleaning or diagnostic cartridge and move it to a reserved storage cell.

A cartridge in a storage cell can be moved only to a CAP, a system cell, or another 
storage cell, and not to a drive. A cartridge currently in a drive, CAP, or system cell can 
be moved to any other unoccupied location in the library. 

Before moving any cartridge, it is helpful to display or print a report showing where 
cartridges are currently located and which storage cells are unoccupied (see 
"Displaying Cartridge Information" on page 11-2).

Moving a Cartridge by Vol-id or Specified Location
You can move a cartridge in the library to a new specified location. These procedures 
update the cartridge's location in the library controller database, but not in the host 
database. You must perform an audit from the host software to update the host 
database. Failure to do so will cause future mount requests from the host software to 
fail.

1. Select Tools > Diagnostics. Click the Library folder.

2. Click the RcvrMove tab.

3. In the Source Location Mode section, select either:

■ VOLID to use vol-id. In the VOLID field, enter the vol-id of the cartridge to 
move.

■ Location to use a specific location. Select the cartridge's current location type. 
Options are: CAP, Slot, Drive, Reserved Slots.

4. In the Destination Location Type list, select the type of location to which to move 
the cartridge. Options are: CAP, Storage Slots, Drive, and Reserved Slots.

Selection restrictions include:

■ The destination can be a drive only if the source is a CAP or reserved slot.

■ To move a cartridge to a drive, the cartridge media type must be compatible 
with the drive type.

■ You cannot move a cartridge to a location that is already occupied.

■ Only diagnostic or cleaning cartridges should be moved to reserved slots.

Caution: Potential data loss. Use caution when moving cartridges in 
partitioned libraries. Accidentally moving a cartridge from one 
partition to another allows the new partition to overwrite data.
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5. In the Destination Location table, specify the cartridge destination with the library 
internal address lists: Library, Rail, Column, Side, Row.

Options include:

■ Min: First element of that location type (library, rail, column, side, row) in the 
library

■ Max: Last element of that location type (library, rail, column, side, row) in the 
library

6. Click Start to begin the move.

7. Click OK.

8. To verify the new location, you can display a Cartridge Summary report (see 
"Displaying Cartridge Information" on page 11-2).

9. To update the new cartridge location in the host database, initiate a library audit 
from the host software (see the tape management software documentation).

Entering Cartridges
Before you enter a cartridge, verify that it is labeled properly. Do not enter unlabeled 
cartridges or place cartridges upside-down.

A rotational CAP holds 26 cartridges and an AEM hold 234 cartridges. Place cartridges 
in any magazine slot and in any order with the hub gear facing down and cartridge 
label facing you.

After a cartridge is entered through the CAP, the library moves the cartridge from the 
CAP to a library storage slot, records the cartridge's location, and sends the location to 
the host.

Entering Cartridges Using Rotational CAPs
1. If the CAP is in auto enter mode (see "CAP Modes and States" on page 9-1), 

proceed to the next step. If it is in manual mode, initiate the enter operation at the 
host (see tape management software documentation). 

2. Press the CAP button.

The CAP door opens, and the CAP button light turns ON.

3. Place the cartridges in the CAP with the hub gear face down and barcode toward 
you.

4. Press the CAP button.

The CAP closes and locks automatically, and the CAP button light turns OFF. 
When the CAP is empty, the library returns the CAP to its default state

Entering Cartridges Using AEMs
1. If the CAP is in auto enter mode (see "CAP Modes and States" on page 9-1), 

proceed to the next step. If it is in manual mode, initiate the enter operation at the 
host (see tape management software documentation). The "Unlocked" indicator 
lights.

Caution: Possible equipment damage: DO NOT force the CAP to open 
or close.
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2. Push the AEM CAP button. The "Wait" indicator blinks until the safety door is 
completely down. Then the "Enter" light displays solid. Depending on the level of 
activity in the library, this may take several minutes.

3. Lift the latch, and open the door. Place the cartridges in the CAP with the hub gear 
face down and barcode toward you. Close and latch the AEM access door.

4. Push the AEM CAP button. The "Enter" light goes off, and the "Wait" light starts 
blinking. The safety door goes up.

Ejecting Cartridges
A rotational CAP holds 26 cartridges and an AEM holds 234 cartridges. To export a 
cartridge, specify the vol-id of the cartridge to remove from the library. For HLI hosts 
you can select a CAP for the eject operation. For FC-SCSI hosts, the library uses CAPs 
in a pre-defined order (see "CAP Priorities for FC-SCSI Hosts" on page 9-2). The 
system retrieves the vol-id location from the library's memory. The robot locates the 
cartridge and places it into the CAP slot.

After the CAP opens, the system erases the location of the cartridge from the library 
controller database and the host database. The robot does not read cartridge labels 
during export operations.

Ejecting Cartridges Using Rotational CAPs
1. Initiate the eject operation at the host. Specify the vol-ids of the cartridges to 

remove from the library (see the tape management software documentation).

2. Press the appropriate CAP button.

The CAP door opens, and the CAP button light turns ON.

3. Remove the cartridges from the CAP.

4. Push the CAP button to close the CAP.

The CAP closes and locks, and the CAP button light turns OFF.

5. If more cartridges must be exported, the robot continues filling the CAP. Wait until 
the CAP door is unlocked and repeat step 2 through step 4.

Once the system ejects all cartridges, the robot audits the CAP to verify it is empty. 
The CAP returns to its default state.

Ejecting Cartridges Using AEMs
1. Initiate the eject operation at the host. Specify the vol-ids of the cartridges to 

remove from the library (see the tape management software documentation). 

2. Push the AEM CAP button.

Caution: Possible equipment damage: DO NOT force the CAP to open 
or close.

CAUTION: Potential data loss. If you do not remove the cleaning 
cartridge from the CAP and the CAP closes, the library treats the 
cartridge as new and the expired cleaning cartridge is used again.
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The "Wait" indicator blinks until the safety door is in place. The the "Enter" light 
displays solid. Depending on the level of activity in the library, this process may 
take several minutes.

3. Lift the latch, and open the door. Remove the cartridges from the AEM CAP. Close 
and latch the AEM access door.

4. Push the AEM CAP button. The "Enter" light goes off, and the "Wait" light begins 
blinking. The safety door moves up. If more cartridges need to be exported, the 
TallBot continues filling the necessary AEMs. 

5. If more cartridges must be exported, wait until the AEM "Unlocked" light is comes 
on and repeat step 2 through step 4.

Importing or Exporting Diagnostic Cartridges
Library self-tests and some other diagnostic activities require the use of diagnostic 
cartridges. Make sure the library contains a enough diagnostic cartridges for these 
activities. Diagnostic cartridges are stored in the reserved system cells, and cannot be 
imported or exported with host management software.

To import or export a diagnostic cartridge through a CAP, use the SLC Import/Export 
function. The library controller reserves the CAP for the entire operation. The system 
can perform only one diagnostic or cleaning cartridge import or export operation at a 
time.

Diagnostic cartridge volume IDs (vol-ids or volsers) must be eight characters in length, 
with DG as the first two characters. The library Import/Export function works only for 
diagnostic cartridges with labels in this format. You can use any of the following SLC 
reports and searches to display information about diagnostic cartridges. Search for 
cartridges that begin with DG.

■ "Displaying Cartridge Information" on page 11-2

■ "Locating Cartridges" on page 11-3

Importing Diagnostic Cartridges
Make sure that the library has enough empty reserved system cells for the diagnostic 
cartridges. There must be at least one empty system cell on each side of the library for 
robot recovery or library initialization. The diagnostic cartridges are distributed as 
evenly as possible in reserved system cells.

1. Verify that the CAP is empty, available for use (not reserved by a host), and closed 
and locked.

2. Select Tools > Diagnostics.

3. Expand the CAP folder and click a CAP to use. Click the Import/Export tab.

4. In the Operation section, select Import Cleaning/Diagnostic cartridges.

5. Click Start. 

6. Click OK to begin the import operation.

7. Follow steps 2 to 4 of "Entering Cartridges" on page 11-5 to complete the import 
operation.
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Exporting Diagnostic Cartridges
1. Verify that the CAP is empty, available for use (not reserved by a host), and closed 

and locked.

2. Select Tools > Diagnostics.

3. Expand the CAP folder, click a CAP to use. Click the Import/Export tab.

4. In the Operation list, select the type of export operation:

■ Export specific diagnostic cartridges, then select the cartridges to export in 
the "Select Cartridge(s) to export" list

■ Export all diagnostic cartridges, then select a rail in the "Select rail to export 
cartridges from" list.

5. Click Start. 

6. Click OK to begin the export operation. The Import/Export page displays a 
message when the CAP is ready to be unloaded.

7. Follow steps 2 to 5 of "Ejecting Cartridges" on page 11-6 to complete the export 
operation.

Cartridge Handling

■ Keep cartridges clean and inspect for damage before each use.

■ Never open a cartridge.

■ Do not handle tape that is outside the cartridge; the tape edge might be damaged.

■ Do not expose the tape or cartridge to direct sunlight, moisture, or magnetic fields.

Inspecting a Cartridge
Always inspect a cartridge before you insert it into a tape drive or a library. A 
defective or dirty cartridge can damage a tape drive. Never use a damaged cartridge. 
Look for:

■ Dirt or debris

■ Cracked or broken housing

■ Damaged write-protect switch

■ Liquid in the cartridge

■ Labels not firmly attached, or that extend over the cartridge edge

Cleaning the Cartridge Exterior
Wipe all dust, dirt, and moisture from the cartridge with a lint-free cloth. Use Oracle 
StorageTek Tape Cleaner Wipes to clean the cartridges. These wipes are saturated with 
isopropyl alcohol. Do not let any solution touch the tape or get inside the cartridge.

Caution: When cartridges are improperly handled, loss of data or 
damage to a library component can occur.
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Storing Cartridges
Store cartridges in a clean environment. Do not take a cartridge out of its protective 
wrapping until you are ready to use it. Use the tear string, not a sharp instrument, to 
remove the wrapping. Before using a cartridge, ensure that it has been in its operating 
environment for at least 24 hours.

Applying a Label to a Cartridge
If you did not order cartridges with pre-applied labels, you must apply them yourself. 
Use labels that do not leave a residue when they are removed.

1. Make sure the cartridge has been at room temperature for at least 24 hours.

2. Use OracleStorageTek Tape Cleaner Wipes to clean the surface where the label will 
be placed (see "Cleaning the Cartridge Exterior" on page 11-8)

3. Locate the type of label you need (see "Cartridge Labels" on page 11-1). Make sure 
the label contains a vol-id.

4. Peel the backing from the cartridge label.

5. Orient the cartridge:

■ LTO — hold the cartridge so that the write-protect switch is toward you.

■ T-series — hold the cartridge so that the two recessed areas are toward you.

6. Place the label within the indented area of the cartridge so that the edges of the 
label are parallel to the edges of the cartridge. The label must not overlap the edge 
of the indented area. Press into place.

Make sure the edges of the labels do not curl, as the label may be misread or 
become jammed in a drive.

7. For T-series cartridges, repeat step 2 through step 6 for the media ID label. Make 
sure both labels are aligned with each other.

Caution: Potential damage to cartridges. Do not use acetone, 
trichloroethane, toluene, xylene, benzene, ketone, methylethyl ketone, 
methylene chloride, ethyldichloride, esters, ethyl acetate, or similar 
chemicals to remove labels or clean cartridges.
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Media validation allows customers to verify T10000 tape cartridge types using SLC. 
SLC indicates the progress of the validation at the initial start, one minute after the 
start, and then every 10 minutes. The validation provides a "success" or "failure" result 
for each tape cartridge tested.

The media validation feature requires minimum SL3000 firmware FRS_4.30, SLC FRS_
6.50, and a high memory HBT card. You can only validate one cartridge at a time per 
each SLC session. Refer to the StorageTek Tape Analytics (STA) documentation to use 
STA to automate media validation.

■ Media Validation Drive Pool Overview

■ Validation Types

■ Media Validation in a SCSI Library

■ Adding Drives to the Media Validation Pool

■ Removing Drives from the MV Pool

■ Validating a Cartridge

■ Stopping a Validation in Progress

Media Validation Drive Pool Overview
Media validation requires a designated pool of T10000C or T10000D type tape drives 
at TTI level 5.40+. Up to 10 drives can be placed in the media validation pool using 
SLC (see "Adding Drives to the Media Validation Pool" on page 12-2). The drives in 
the pool are not available to any host applications, such as ACSLS, ELS, or a 
SCSI-attached host. The pool is not considered a partition and does not contain 
cartridges. 

Drives in the media validation pool are automatically cleaned by the library. This 
occurs regardless of the auto clean status for the entire library or for partitions in the 
library (see "Drive Cleaning" on page 10-1).

Validation Types
The table below shows the five types of validation available through SLC.

Note: The CSE should ensure there are cleaning cartridges in the 
reserved system slots for auto-cleaning of the drives in the media 
validation pool.
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Media Validation in a SCSI Library
Adding or removing a drive to the media validation pool can renumber the SCSI 
element IDs. If renumbering occurs, you may need to reconfigure the host. When you 
place a drive in the media validation pool, the library automatically re-assigns element 
IDs to the drives. The drive bay that the media validation drive occupies is treated as 
"empty". Therefore, the media validation drive is skipped and not assigned a SCSI 
element ID. Refer to "Default SCSI Storage Element Numbering Scheme" on page B-8 
for the order of default element numbering.

When you remove a drive from the media validation pool, the library logically assigns 
the drive the last element ID regardless of the drive’s physical location.

To avoid renumbering, for the media validation pool use the drive that is both 
physically and logically the last element ID (ensure the drive is a T10000C/D — see 
"Media Validation Drive Pool Overview" on page 12-1 for more information).

Adding Drives to the Media Validation Pool
Use the Media Validation > Slot Selection Tab to create or modify the media 
validation drive pool. Hosts cannot access drives or drive slots in the media validation 
pool. Before defining a media validation pool in a SCSI library, refer to "Media 
Validation in a SCSI Library" on page 12-2.

1. Ensure host applications are not using the drives you want to add to the media 
validation pool. Finish any read or write operations and dismount any cartridges 
from the selected drives.

If ACSLS manages the drives, vary the drives offline to ACSLS to prevent drive 
activity.

Table 10–1 Media Validation Types

Type of Validation Description Starts at
Approximate Duration per 
Cartridge

Basic Verify Simple mount/dismount of the cartridge 
to determine if MIR is unreadable or out of 
sync

Not applicable: Simple 
mount and dismount

2 minutes

Standard Verify Reads:

- 1000 records from the beginning of the 
tape

- The wrap that contains EOD, then into 
the EOD

- Outermost wraps on top and bottom 
bands to verify edges

Beginning of tape (BOT) Maximum of 30 minutes

Complete Verify 
(default)

Reads data at tape speed - Beginning of tape 
(BOT)

- Resumes where it left 
off

T10000C: 6 hours 

T10000D: 9 hours max

Complete Verify 
Plus StorageTek Data 
Integrity Validation1

1 Decompression and encryption key management system are required.

Checks DIV CRC to determine if it exists - Beginning of tape 
(BOT)

- Resumes where it left 
off

T10000C: 6 hours for 
compression ratios less than 
2.5:1.

T10000D: 9 hours for 
compression ratios less than 3:1

Rebuild MIR Reads data at tape speed At invalid position in 
the MIR

T10000C: 5 hours 

T10000D: 9 hours
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2. In SLC, select Tools > Media Validation. Click the Slot Selection tab

3. Click Refresh to update the screen.

4. Highlight the drive slots to place in the media validation pool (a maximum of 10)

5. Click Add.

An error message appears if you add more than 10 drives to the pool. Click OK. 
De-highlight slots until only 10 are highlighted. Click Add.

6. Click Apply. 

Only a non-partitioned library, or the partitions containing drive slots moved into 
the pool, will go offline. For hosts connected to affected partitions:

■ ACSLS and ELS hosts receive "Configuration Changed", "LSM Ready", and 
then "Not Ready" messages from the library. ELS automatically removes any 
media validation drives from its configuration. ACSLS automatically updates 
any media validation drives to an offline state, but ACSLS requires you to 
initiate re-configuration (see step 7).

■ For SCSI hosts, the library renumbers element IDs. SCSI hosts receive two Unit 
Attentions: "Not Ready to Ready Transition" and "Mode Parameters 
Changed". You should initiate a re-configuration of the host.

7. ACSLS only — To remove a media validation drive from the ACSLS configuration, 
use the config drives <panel_id> utility. You can run config drives while the 
library is online and mounts/dismounts to other drives are occurring.

Removing Drives from the MV Pool

1. Select Tools > Media Validation. Click the Slot Selection tab

2. Click Refresh to update the screen.

3. Highlight the drive slots to remove from the pool. Click Remove.

4. Click Apply.

5. To reassign a drive slot removed from the pool:

Table 10–2 Status Indicators for Drive Slots

Status Indicator Meaning

 
Empty drive slot

 
Slot contains either an invalid drive type or a correct drive type in an 
invalid state

 
Correct drive type (T10000C or T10000D) in a valid state

 
Partition number of drive slot/bay

 
Drive slot is in media validation pool

Note: If you try to remove a drive from the pool that is in the process 
of validating a cartridge, an error will be reported.
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■ For a non-partitioned library managed by ACSLS or ELS, the drive slot will be 
available to hosts immediately. ELS hosts begin re-configuration. ACSLS hosts 
require you to initiate re-configuration with the config drives <panel_id> 
utility.

■ For a non-partitioned SCSI library, the library goes offline. The library 
logically assigns the drive the last element ID regardless of the drive’s physical 
location. When the library comes back online, SCSI hosts receive two Unit 
Attentions: "Not Ready to Ready Transition" and "Mode Parameters 
Changed". You should initiate a re-configuration.

■ For a partitioned library, a drive slot removed from the validation pool is not 
allocated to a partition. To assign the drive slot to a partition, see "Library 
Partitioning" on page 6-1.

Validating a Cartridge
Use the Media Validation > Media Validation Tab to validate a cartridge. You can 
only validate one cartridge at a time per each SLC session.

1. Select Tools > Media Validation. Click the Media Validation tab.

2. In the Drive column, select the drive to use. A drive may not be selectable if:

■ The drive is in an invalid state.

■ The drive type is invalid.

■ You are not logged into the library containing the drive.

3. In the center column, choose the cartridge to validate from a list, or type the 
cartridge VOLSER.

4. In the right-hand column, select the validation type. See Table 10–1 for details.

5. Click Start. Validation begins if the cartridge loads successfully.

After validation completes, the cartridge is returned to its source location. If the 
source location is lost, the library moves the cartridge to a system slot for host 
recovery.

Stopping a Validation in Progress
Media validation can be stopped by either a host requesting the cartridge being 
validated or the technician who initiated the validation through SLC.

To stop a validation in progress through SLC:

1. Select Tools > Media Validation. Select the Media Validation tab.

2. Click Stop.

Note: If media validation for a cartridge is interrupted, follow the 
procedures below to resume the validation. For Complete Verify 
validation types, select Resume to resume the validation where it left 
off.

Note: You must log in as the user who initiated the validation.
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Once validation stops, the cartridge is returned to its source location. If the source 
location is lost, the library moves the cartridge to a system slot for host recovery. 
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11Robot and Safety Door Management

■ AEM Safety Door Overview

■ TallBot Overview

■ Rebooting an AEM Safety Door

■ SCSI FastLoad Feature

■ Displaying Robot Information

■ Changing the Robot Online/Offline Status

■ Performing a Robot Self-Test

■ Robot Diagnostic Moves

AEM Safety Door Overview
The safety door is a sliding barrier that closes off an AEM from the operational portion 
of the library. The door slides into place when performing robot maintenance or a bulk 
load/unload operations. With the safety door in place, a service representative can 
perform maintenance on a robot while the library remains online. See "Displaying 
AEM Safety Door Status and Properties" on page 9-3.

TallBot Overview
A TallBot is a robot that moves cartridges between storage slots, tape drives, and 
CAPs. With the dual robotics option, two robots operate in parallel to increase the 
overall performance of the library and provide redundancy. If one robot fails, the other 
robot can move the defective robot into an AEM service area or PEM parking area.

Rebooting an AEM Safety Door 
Use the Tools > Diagnostics utility to reboot an AEM safety door. You may need to 
reboot the door to clear errors when the AEM safety door is in an abnormal condition. 

1. Select Tools > Diagnostics.

2. Expand the Safety Door folder, and then select the AEM safety door. 

3. Click Reboot.

4. If the safety door is online, click OK to take the safety door offline. 

5. Click OK to confirm the reboot. The library controller reboots the safety door. The 
safety door re-initializes, and the TallBot audits the AEM.
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6. Click OK to dismiss the success message.

SCSI FastLoad Feature 
SCSI FastLoad is an optional feature that enables faster mount and dismount 
operations for an FC-SCSI library or partition. After a robot successfully inserts a 
cartridge into a drive, the robot is immediately available for the next request and does 
not wait until the drive reports that the cartridge has been loaded. The library 
controller waits to return the mount request response until it detects that the tape 
drive has successfully loaded the cartridge. If a cartridge fails to load after the robot 
has been released, the FC-SCSI host must move the cartridge from the drive back to 
the source location.

The SCSI FastLoad feature requires minimum SL3000 firmware FRS_2.33 and SLC 
4.47.

Configuring the SCSI FastLoad Feature
You can enable or disable SCSI FastLoad separately for each FC-SCSI partition.

1. Select Tools > Configuration.

2. For each partition, set the Enable FastLoad Feature option:

■ Select to turn SCSI FastLoad on.

■ Unselect to turn SCSI FastLoad off (default).

3. Click Apply, and then click OK. 

Displaying Robot Information

1. Select Tools > System Detail.

2. Select the Robot folder to display summary information.

3. For detailed information, expand the Robot folder and then select a robot.

4. Select a tab:

■ Status — displays the current operational state of the selected robot. Use the 
transition request list to place the robot online or offline (see "Changing the 
Robot Online/Offline Status" on page 13-2).

■ Properties — displays robot configuration information, including the serial 
number and current firmware levels

Changing the Robot Online/Offline Status
Do not use this procedure if you are using ACSLS or ELS tape management software, 
unless their servers cannot communicate with the library. For instructions on changing 
the online or offline state using ACSLS or ELS, see the tape management software 
documentation.

Use this procedure to take a robot offline or bring a robot online through SLC.

Note: This information is also available through Reports > Robot 
Summary. See "Viewing Library Reports" on page 7-5.
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1. Select Tools > System Detail.

2. Expand the Robot folder, and then select the robot to modify.

3. Select the Status tab.

4. In the Transition Request list, select either:

■ Take Offline — the system completes all outstanding jobs for the robot.

■ Bring Online — the robot moves to the end of the rail, and the library cannot 
use it. If the library has redundant robotics, the second robot will take all 
requests.

5. Click Apply. 

Performing a Robot Self-Test

1. Select Tools > Diagnostics.

2. Expand the Robot folder, and then select the robot to test.

3. Click the SelfTest tab.

4. In the Mode list, select Non-Disruptive.

5. Click Run.

Robot Diagnostic Moves
Diagnostic moves can help monitor or diagnose robotic problems with a series of "get" 
and "put" operations. The system chooses a robot for the diagnostic move based on the 
minimum and maximum ranges set for the target and pool addresses. Multiple robots 
may be selected if the address range requires it. 

Successful diagnostic moves do not rearrange the cartridges in the library — the 
system returns cartridges to their original locations. However, some diagnostic move 
failures can cause cartridges to be left in new locations.

A diagnostic move is defined by:

■ Target Address Range — defines the area used to perform the "get" operation in a 
diagnostic move. Valid target address types are storage cells, CAP, drive and 
storage cells, system cells, or all.

Note: Library devices that are offline and in an error state cannot go 
online. The error condition must be cleared first.

Note: To perform a robot self-test, diagnostic cartridges must be 
available in the library.

Note: All resources within the target address range are reserved. 
However, only the location currently being accessed by the robot for a 
get/put operation is unavailable to the host.
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■ Pool Address Range — defines the area used to supply cartridges or empty cells if 
a target address does not contain a cartridge or no empty cells are available. The 
pool and target address can overlap.

■ Access Order — determines how the robot performs get operations within the 
target address range. There are two options:

– Sequential — robot performs a get operation starting with the first location in 
the target address ranges. The robot continues visiting the locations 
sequentially through the range until it completes the requested number of 
moves.

– Random — robot randomly selects a location in the target address range to get 
a cartridge. The robot can also visit the same location in the target address 
range multiple times to get a cartridge, however if you specify enough move 
request the robot is guaranteed to visit all cells. The random access routine 
ends after performing the requested number of moves.

Defining a Diagnostic Move
You can set up and run multiple diagnostic move routines simultaneously if the target 
and pool ranges for each diagnostic move do not overlap.

1. Select Tools > Diagnostics.

2. Click the Library folder in the navigation tree.

3. Click the DiagMove tab, and then the Manage tab.

4. In the Defined Sequence section, click Add. 

5. Complete the Sequence screen to define the target address:

a. In the Selection Mode section, select the type of cells to diagnose.

b. In the Minimum Address and Maximum Address sections, select the library 
internal address of the starting and ending locations of the cells to diagnose.

6. Click Next.

7. Complete the SOURCE screen to define the pool address:

a. In the Selection Mode sections, select the appropriate cartridge pool address 
type.

b. In the Minimum Address and Maximum Address sections, select the library 
internal addresses of the starting and ending locations of the cartridge pool to 
use.

8. Click Next.

9. Complete the Sequence screen:

a. Name of the diagnostic move.

b. Move Count: Specify a number between 1 and 5000.

c. Access order: Sequential or Random.

d. Move Type: Robot and Cartridge or Robot Only.

Note: This procedure requires sharing of robot resources. You should 
not run it during peak activity periods.
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e. If you are certain the cartridges and drives in the diagnostic move are 
compatible, select "Disable pre-move cartridge compatibility check".

10. Click Finish. The Defined Sequences section lists all diagnostic sequences.

Managing Diagnostic Move Definitions
Use the Manage tab to add, modify, start, or remove a diagnostic move definition. 
Each open diagnostic move displays in its own monitor screen.

1. Select Tools > Diagnostics.

2. Click the Library folder on the navigation tree.

3. Click the DiagMove tab, and then the Manage tab.

4. In the Defined Sequences section, select an option:

5. See "Monitoring and Controlling Open Diagnostic Moves" on page 13-6 to manage 
the diagnostic moves currently open.

Saving a Diagnostic Move
You can save a defined diagnostic move to a file. The file is saved as a JavaBean 
component represented as an XML 1.0 document (.xml). You can use the file to restore 
a deleted move definition or copy the move definition to a different library (see 
"Restoring a Diagnostic Move" on page 13-5).

1. Select Tools > Diagnostics.

2. Click the Library folder on the navigation tree.

3. Click the DiagMove tab, and then the Manage tab.

4. Select a diagnostic move. Click Save. 

5. Browse to the desired directory, enter a file name, and click Save.

Restoring a Diagnostic Move
You can load a saved diagnostic move definition file (see "Saving a Diagnostic Move" 
on page 13-5). 

1. Select Tools > Diagnostics.

2. Click the Library folder on the navigation tree.

3. Click the DiagMove tab, and then the Manage tab.

Table 11–1 Diagnostic Moves Options

 Option Definition Notes

Add Define a diagnostic move None

Open Start a diagnostic move Multiple diagnostic moves may be open at a time, 
so long as the target and pool address ranges setup 
for the moves do not overlap.

Modify Modify options for a 
diagnostic move

This diagnostic move routine must not be open or 
if open must be in a "Stopped" state.

Remove Remove a diagnostic move This diagnostic move routine must not be open.

Copy Copy an existing diagnostic 
move

Copy a diagnostic move definition, make changes 
if necessary, and assign a different name.
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4. Click Restore.

5. Browse to the saved diagnostic move file, and then click Open.

Starting a Diagnostic Move
A monitor window displays for each move you start. You can run multiple moves at 
the same time, if the target and pool address ranges for the moves do not overlap.

1. Select Tools > Diagnostics.

2. Click the Library folder on the navigation tree.

3. Click the DiagMove tab, and then the Manage tab.

4. In the Defined Sequences section, select a diagnostic move. Click Open.

5. From each monitor window, select File > Start Sequence to start the move.

Monitoring and Controlling Open Diagnostic Moves
A monitor window displays for each open move. Use the Monitor tab control and 
monitor the status of any open diagnostic moves.

1. See "Starting a Diagnostic Move" on page 13-6 to open a diagnostic move.

2. Select Tools > Diagnostics. Select the Library folder.

3. Click the DiagMove tab, and then the Monitor tab. Each monitor window 
indicates the status of the move.

4. Use the File menu in each Monitor window to start/stop/pause the sequence, 
clear the output window, or start/stop spooling.

Table 11–2 Status Indicators for Moves

Status Indicators Valid Values

Spooling Status — whether the move output is being spooled to a file True, False

State — execution state of the move Running, pausing, paused, 
stopping, stopped

Health — health state of the move OK, warning, error

Completed moves — Number of moves completed in the requested move 
count

Not applicable
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12SLC Diagnostic Utilities

SLC provides many diagnostic utilities, including library self-tests, event monitoring, 
and device diagnostics: 

■ Library and Device Self-Tests

■ Diagnostic Support Information

■ Troubleshooting

■ Using the Monitors Utility to Open an Event Monitor

For information on using SLC diagnostic tools not described in this chapter, see:

■ Importing or Exporting Diagnostic Cartridges

■ Robot Diagnostic Moves

Library and Device Self-Tests 
Self-tests can help diagnose issues with the library or devices. Refer to: 

■ Performing a Library Self-Test

■ Performing CAP Self-Test

■ Performing a Drive Self-Test

■ Performing a Robot Self-Test

Diagnostic Support Information
The following diagnostic tools aid in troubleshooting. Your Oracle support 
representative may request that you capture and transfer these files.

■ Management Information Base (MIB) file - an SNMP database used to manage your 
library devices. This file can be saved as a text file. See "Transferring the Library 
MIB File" on page 7-6.

■ Log Snapshot file - an encrypted snapshot of the library event log. You cannot view 
or edit this file. This file is available for only 15 minutes from the time it is 
generated. See "Generating and Transferring the Library Log Snapshot File" on 
page 7-6.

■ Device Reserve Table - a table displaying device information and status. See 
"Viewing Library Reports" on page 7-5.

■ Event monitors - spool of events that captures error data. See "Using the Monitors 
Utility to Open an Event Monitor" on page 14-3.
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Troubleshooting
Before you run diagnostic tests, check the following areas of the library:

Service Required (amber) LED is constantly on
Use SLC to check the health of the library and the attached devices (drives, CAPs, and 
robots). See Chapter 5, "Library Management".

To perform a health check:

1. Log in to SLC.

2. Access the System Detail module, Tools > System Detail.

3. Check the navigation tree for the following indicators: Device Healthy or Device 
Error

Additional checks:

1. Check the Status (for example, online/offline) and Statistics (for example, uptime, 
downtime, errors and warnings) tabs for more information on the health of the 
library and devices.

2. Make sure the cartridges are fully seated and properly oriented in their storage 
cells.

3. Inspect for any foreign objects or debris and remove them if found.

Library does not turn on and SLC does not display any messages
1. Check that the library power switch is in the ON position.

2. Check all power cord connections.

3. Make sure that there is power to the outlet.

4. Replace the power cord.

CAP Open LED is on and blinking
Open the CAP and make sure the cartridges in the CAP cells are properly seated. 
Close the CAP.

SLC does not display modified data or information remains static
Check the SLC Heartbeat icon.

Robot Fault or Library Fault Amber LED is constantly on
1. Check SLC for any displayed error messages.

2. Open the front door. Observe the state of the cartridges, robot hand, and tape 
drives.

3. Make sure cartridges are fully seated and properly oriented in their storage cells.

4. Make sure packing materials have been removed.

5. Remove any objects or debris from the library floor.

6. Check the status of the tape drives.

7. Close the front door.

8. Make sure the tape drives are fully seated and locked forward by pushing and 
pulling on the rear of the drive tray. Any motion of the tray indicates that it 
requires re-seating and locking down.
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Client computer cannot communicate with the library or tape drives
Make sure cables are securely attached to their connectors on the rear of the library, the 
tape drives, and the client computer.

Library cannot communicate with the drives and drive status on SLC displays "Not 
communicating" 
Make sure cables are securely attached to their connectors on the rear of the library, the 
drives, and the client computer.

Repeated or excessive drive cleaning or cleaning messages
1. Replace the cleaning cartridge with a new one.

2. Run the Library Self-Test and note if errors are reported for the drive.

3. Run any client computer-based drive diagnostic tests.

Using the Monitors Utility to Open an Event Monitor
The library controller continually monitors library operations and logs all events. 
Using the Monitors utility of SLC, you can open an event monitor to display event 
data or spool it to a file. Event monitors are useful tools for root cause analysis. 

■ "Event Monitor Overview" on page 14-3

■ "Opening an Event Monitor" on page 14-4

■ "Spooling Event Monitor Data to a File" on page 14-4

■ "Arranging Multiple Monitors" on page 14-4

■ "Displaying Result Code Definitions" on page 14-5

Event Monitor Overview
There are four types of event monitors: All, Error Warn Info, Error and Warnings, and 
Errors. Each monitor type logs events based on the severity of the event. For example, 
the Errors monitor only logs error events (see "Severity" on page 14-4 for a description 
of the event types).

Each event logged in the event monitor contains the following information:

Time
Identifies when the event occurred.

Device ID
Identifies the library address of the device corresponding to the event.

User
Identifies the user that originated the event. This is "root" for HLI or SCSI host 
activities.

I / F
Identifies the interface type of the requester. The interface can be hli, scsi, or default 
(for SLC or CLI requests). 

Activity
Identifies the command that was issued, such as "load drive".
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Request Identifier
Identifies all host interface requests. Helps track the sequence of log activity resulting 
from each host request.

Severity
Identifies the significance of the event. Some event data is non-volatile, meaning it 
persists across system power cycles.

Error — non-volatile data indicating a fault that prevented a request (host or 
diagnostic) from completing successfully.

Warning — non-volatile data indicating a fault that has not stopped the library's ability 
to complete requests (host or diagnostic). A warning can identify a loss of performance 
or a condition that may indicate future irrecoverable errors.

Information — volatile data indicating general device or library information (such as 
the device state, device added, listener registered, tray serial number updated, and so 
on). This information may be important to establish a history of activity for the 
warning or error event.

Trace — volatile data indicating diagnostic activity tracing.

Result Code
Identifies the library event type (result codes are the same as library EventIds). To 
search for the meaning of the Result Code using SLC, see "Displaying Result Code 
Definitions" on page 14-5 or refer to the SL3000_FRSxxx_JavaErrorCodes.html file 
included in the library firmware code package.

Result Text
Provides information about the results of the request or event.

Opening an Event Monitor
1. Select Tools > Monitors.

2. Expand the Permanent Monitors folder in the navigation tree.

3. Click an event monitor type. Click Open.

4. Use the Monitor menu to pause, resume, permanently stop, or clear the event 
monitor.

5. To close a monitor, click the X in the upper right corner of the window.

Arranging Multiple Monitors
Arrange multiple event monitors using the Window menu in the upper right corner.

Spooling Event Monitor Data to a File
You can send an event monitor file to Oracle Support to assist in diagnosing problems.

1. Open an event monitor (see "Opening an Event Monitor" on page 14-4).

Menu Option Description

Window > Arrange Custom arrange the open monitors on screen

Window > Tile Horizontal Arrange the event monitor windows horizontally

Window > Tile Vertical Arrange the event monitor windows vertically

Window > Cascade Stack the event monitors
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2. In the event monitor window, select Spool File > Start Spooling.

3. Browse to the desired directory, enter the file name, and click Save.

4. To stop spooling, select Monitor > Stop Spooling.

Displaying Result Code Definitions
Use the following procedure to search for the definition of a result code from the event 
monitor.

1. Select Tools > Diagnostics.

2. Click the Library folder in the navigation tree.

3. Click the Search tab.

4. In the Search Type list, select Result Code.

5. Complete the remaining fields:

a. To search for a specific result code, enter the complete code. Wildcards or 
partial codes are not accepted.

b. To list all result codes, select List All.

6. Click Search.
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13Manual Operations

■ Modes of Operation

■ Safety Precautions when Entering the Library

■ Turning the Library On or Off

■ Accessing the Main Door and AEM Door

Modes of Operation

Manual Mode
Manual operation may be required if the library has experienced an unrecoverable 
error or a library component requires service or installation. To perform manual 
operations, the library is placed in manual mode. 

A library in manual mode cannot accept host requests (host requests may continue to 
generate and cartridge mounts and dismounts require human intervention). The 
library is in manual mode when a library main access door is open, a robot does not 
automatically mount and dismount cartridges, or the SLC navigation tree indicates 
that there is a problem with the library.

Maintenance Mode
Maintenance mode is active when a service representative enters the access door to 
perform maintenance or to replace a component. The library continues to operate and 
process host request.

Safety Precautions when Entering the Library

When entering a library, strictly observe the following safety precautions:

■ Know the location of the emergency door unlocking mechanisms (see "Door 
Interlocks" on page 15-2).

■ Ensure the library is offline (see "Placing the Library Online or Offline" on 
page 7-8). Do not enter the library or move any of the robot mechanisms if you 
have any reason to suspect the robots are online.

WARNING:  When entering the library, lock the access door open 
and retain the key to prevent accidental closure.
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■ Leave the access door open whenever working inside the library. This disconnects 
DC power and signal lines to the library's motors (see "Servo Power Interrupt" on 
page 15-2).

■ Know the location of the mechanical door releases (see "Mechanical Door 
Releases" on page 15-2).

■ Know the physical restrictions of the library. Be careful not to bump your body 
against the arrays or to snag clothing on the arrays (only 0.4 m [18 in.] of aisle 
clearance).

■ If you must move a robot, avoid damaging the robot's mechanical or electronic 
components.

■ If you are manually loading or unloading a cartridge, your hands must remain 
clear of the drive's mechanical and electronic load components.

Door Interlocks
Door safety interlocks are located behind the front access doors of the base module 
and DEM. To open either access door, an access key is required.

Door safety interlocks are constantly monitored by the library controller. If an access 
door is opened during normal operation, an Emergency Robotics Stop condition is 
initiated and all library motors are immediately disabled. This prevents motors from 
operating while a library door is open. If the library is varied offline, opening the 
access door disconnects DC voltages to the rails and the power bus.

The door switches are also monitored when the library is powered off. A battery 
supplies power for the circuitry to detect a door opening/closing event while the 
library is powered off.

When a base module and DEM are connected together, opening an access door to 
either module automatically suspends operations within the entire library (the two 
door switches are connected in series).

Servo Power Interrupt
An additional safety feature is the servo power interrupt (SPI). If the library controller 
detects that a library motor is out-of-range, it will generate an SPI to turn off drive 
voltage to the faulty motor. This prevents a servo runaway condition until the cause of 
the problem can be determined.

Mechanical Door Releases
Each lock handle on the access doors of the base module and DEM includes a 
mechanical release which is painted yellow. This release serves as a safeguard in case a 
person is inside the library and the access door is accidentally closed and locked. 
When you push the release, it unlocks and opens the door.

Turning the Library On or Off
Use the following procedures to power the library on or off.

Turning Off the Library
Use this procedure to turn off the library.

1. Ensure all jobs have completed and quieces the library.
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2. Take all library drives offline (see "Changing a Drive Online/Offline Status" on 
page 10-5).

3. Take the library offline (see "Placing the Library Online or Offline" on page 7-8).

4. Open the rear doors of the Base Module and DEM (if present).

5. Turn off the power enable switches.

6. If necessary, turn off the circuit breakers on the PDUs.

Turning on the Library
Use this procedure to turn on the library. 

1. Open the rear doors of the Base Module and DEM (if present).

2. If necessary, turn on the circuit breakers on the PDUs.

3. Turn on the power enable switches.

4. The library goes through the initialization sequence. If the access doors have been 
opened and closed, a full audit of the library will be performed.

Accessing the Main Door and AEM Door
Use these procedures to open and close the main library access door. Additionally, you 
can open the AEM door in emergency situations.

Opening the Main Door
1. Observe all safety precautions (see "Safety Precautions when Entering the Library" 

on page 15-1).

2. Take all library drives offline (see "Changing a Drive Online/Offline Status" on 
page 10-5).

3. Take the library offline (see "Placing the Library Online or Offline" on page 7-8).

4. Insert the key into the door lock, and turn the key to unlock the door.

5. Pull up on the door latch to release it, and open the door.

6. Turn the key in the lock, to lock the door open, and then remove the key from the 
lock and keep it with you. This will prevent the door from being closed while you 
are in the library.

7. Enter the library.

Closing and Locking the Main Door
Use this procedure to close and lock the main doors of the library. When you close the 
access door, the library will perform a full audit.

1. Verify that there are no loose items in the library.

2. If the access doors were locked open, insert the key into the door lock, and turn 
the key, to unlock the door.

3. Push the door closed and make sure it latches securely.

4. Turn the key in the lock, to lock the door closed.

5. Remove the key from the lock and keep it in a safe place.
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6. If the library has been powered off, power it on (see "Turning on the Library" on 
page 15-3).

Opening AEM Door for Emergency Access
Use this procedure to gain emergency access to the AEM.

1. Insert the library access door key in the Deadbolt Override lock, and unlock the 
door by turning the key clockwise. The key cannot be removed from the lock 
while it is in the unlocked position.

2. Lift the AEM access door latch, and open the door. DO NOT force the AEM access 
door to open or close.

All power to the TallBots is stopped immediately. All in-process jobs are stopped 
abruptly, and the TallBots and AEM CAPs are brought offline.

Closing AEM Access Door
Use this procedure to close the AEM access door and re-initialize the library after 
performing an AEM emergency access. This procedure initiates a full audit of the 
library.

1. Close and latch the AEM access door. DO NOT force the AEM access door to open 
or close.

2. Lock the door by turning the key counter-clockwise in the Deadbolt Override lock.

a. The library re-initializes.

b. The TallBots go through their initialization sequence.

c. A full audit of the library is conducted.

d. The AEM CAP is brought online and returned to its default state.

Caution: This procedure has the same effects on library operations as 
opening the main library access door. It causes an abrupt interruption 
of library activity. This procedure does not lower the internal AEM 
safety door.
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ACommand Line Interface Reference

This appendix describes the Command Line Interface (CLI) commands available for an 
Admin user for SL3000 version 4.30 firmware and above. Since the CLI is 
firmware-based, not all commands are available for libraries running earlier versions. 

Admin accessible CLI commands include:

■ audit

■ capCommand

■ cleaning

■ config

■ date

■ drive

■ hwActivation

■ FibreConfig

■ mediaValidation

■ network

■ partition

■ reControl

■ snmp

■ ssh

■ time

■ traceRoute

■ version

■ whereAmi

audit
This command performs a physical audit on all or part of the library.

audit
Displays help for the audit command, the same as "help audit".
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audit *
Initiates a physical audit of the entire library. This command returns immediately and 
displays no results.

Example:

SL3000> audit *
   requestId
   requestId 9
   Done
   Failure Count 0
   Success Count 1
COMPLETED

audit <device address> <address>
Performs a physical audit of a single address and displays the results.

■ <device address> - specifies the robot to use in library, rail, column, side, row 
format.

■ <address> - specifies the cell location to audit in library, rail, column, side, row 
format.

Example:

SL3000> audit 1,1,0,1,0 1,1,-10,1,1
   requestId
   requestId 9
   Attributes Media Label #EMPTY..
   Object     Location    1,1,-10,1,1
   Done
   Failure Count 0
   Success Count 1
COMPLETED

audit <device address> <start address> <end address>
Performs a physical audits of a range of addresses and displays the results.

■ <device address> - specifies the robot to use in library, rail, column, side, row 
format.

■ <start address> <end address> - specifies the starting and ending cell location to 
audit in library, rail, column, side, row format. Only the row is variable between 
the start and end addresses.

Example:

SL3000> audit 1,1,0,1,0 1,1,-10,1,1 1,1,-10,1,5
   requestId
   requestId 10
   Attributes Media Label #EMPTY..
   Object     Location    1,1,-10,1,1
 
   Attributes Media Label EN34410R
   Object     Location    1,1,-10,1,5
   ...
   Done
   Failure Count 0
   Success Count 5
COMPLETED

audit multiRowScan {enable | disable | print} <device address>
Enables or disables multiple row scan audit capability to speed up audit time.
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■ print - prints the multi-row scan audit state.

■ <device address> - specifies the robot to use in library, rail, column, side, row 
format.

Example:

SL3000> audit multiRowScan print 1,1,0,1,0
   requestId
   requestId 8401
   Attributes Multi Row Scan enabled
   Object     Robot          1,1,0,1,0
   Done
   Failure Count 0
   Success Count 1
COMPLETED

capCommand
This command is for managing CAPs.

capCommand
Displays help for the capCommand command, the same as "help capCommand".

capCommand forceUnreserve <device address>
Forces the release of a CAP. If cartridges are in the CAP, the reservation changes to 
"default". If there are no cartridges in the CAP, the reservation changes to "none".

■ <device address> - specifies the CAP to release in library, rail, column, side, row 
format.

capCommand {lock | unlock} <device address>
Locks or unlocks a CAP specified by the device address.

■ <device address> - specifies the CAP to lock/unlock in library, rail, column, side, 
row format.

capCommand resetCap {left | right | both}
This command forces the reset of a cap string or strings based on the provided side 
argument.

Example:

SL3000> capCommand resetCap right
   requestId
   requestId 17002
   Done
   Failure Count 0
   Success Count 1
COMPLETED

cleaning
This family of commands displays and controls cleaning and diagnostic 
cartridge-related functions within the library. Only customers with the media 
validation feature should use these commands.

cleaning
Displays help for the cleaning command, the same as "help cleaning".
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cleaning list {cleaning | diagnostic}
Lists all cleaning or diagnostic cartridges in the system cells.

Example:

SL3000> cleaning list cleaning
   requestId
   requestId 9001
   Attributes Expired  false
      Label            CLN0080U
      Location         1,1,-12,1,13
      Max Usage Count  100
      Media Type       9840_Cleaning
      Status           ok
      Usage Count      0
Object Cartridge       cleaning

cleaning import <cap device address>
Imports cleaning and diagnostic cartridges to system cells. Only one import/export 
operation is allowed at a time. There must be a minimum 2 empty system cells for 
SL3000 libraries to allow imports. 

■ <cap device address> - specifies the CAP to use for the import operation, in library, 
rail, column, side, row format.

Example:

SL3000> cleaning import 1,1,5,2,0
   requestId
   requestId 10101
   Message CAP open(ing). Place cartridges to import in CAP, then close CAP.Use 
CONTINUE cmd to proceed...
   Done
   Failure Count 0
   Success Count 0
COMPLETED

cleaning export <cap device address> cleaning [select expired]
Exports cleaning cartridges. Only one import/export operation is allowed at a time.

■ <cap device address> - specifies the CAP to use for the export operation, in library, 
rail, column, side, row format.

Example:

SL3000> cleaning export 1,1,5,2,0 cleaning
   requestId
   requestId 9601
   Address      1.1.-12.1.12
   Success      Cartridge Exported
   Volume Label CLN002CU
   Message CAP open(ing). Remove cartridges, then close CAP.Use CONTINUE cmd to 
proceed...
   Done
   Failure Count 0
   Success Count 1
COMPLETED

cleaning export <cap device address> <cartridge address>
Exports a specific cleaning or diagnostic cartridge to the specified cap. Only one 
import/export operation is allowed at a time. 
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■ <cap device address> - specifies the CAP to use for the export operation, in library, 
rail, column, side, row format.

■ <cartridge address> - specifies the location of the cartridge to export in library, rail, 
column, side, row format. The specified cartridge must be in a system cell and 
must be either a cleaning or diagnostic cartridge.

Example:

SL3000> cleaning export 1,1,5,2,0 1,4,-12,1,12
   requestId
   requestId 9601
   Address      1.4.-12.1.12
   Success      Cartridge Exported
   Volume Label CLN002CU
   Message CAP open(ing). Remove cartridges, then close CAP.Use CONTINUE cmd to 
proceed...
   Done
   Failure Count 0
   Success Count 1
COMPLETED

cleaning threshold list
Displays a list of cleaning cartridge types and their warning thresholds. Each cleaning 
cartridge type has 4 attributes: 

■ Index - cleaning cartridge type used by the "cleaning threshold set" command

■ Media type - the type of cleaning cartridge used

■ Maximum usage count - recommended max usage by tape manufacturer

■ Warning threshold value - user-defined threshold that determines when a 
warning status is set for a cleaning cartridge once its usage count reaches that 
threshold.

Example:

SL3000> cleaning threshold list
   requestId
   requestId 15001
   Attributes
   Object     Index               1
              Media Type          SgtUltrium1_Cleaning
              Recommend Max Usage 100
              Warning Threshold   0
   Attributes
   Object     Index               3
              Media Type          T10000_Cleaning
              Recommend Max Usage 50
              Warning Threshold   0

cleaning threshold set <warning threshold value> <list index number>
Sets a warning threshold value for a particular cleaning cartridge type.

■ <warning threshold value> - can be any positive integer up to 1000. A value of 0 
indicates no warning threshold.

■ <list index number> - cleaning cartridge type as specified by the index number from 
the table listing of the “cleaning threshold list” command.

Example:

SL3000> cleaning threshold set 55 11
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   requestId
   requestId 15101
   Attributes
   Object      Success true
   Done
COMPLETED

cleaning driveWarning set { on | off }
Sets the drive cleaning warning flag to either on or off.

■ on - the drive health status will be set to warn if it needs cleaning

■ off - the drive health status is not affected if the drive needs cleaning

config
This command will either display the current physical library configuration or set 
library configuration parameters.

config
Displays help for the config command, the same as "help config".

config print
Displays the current physical library configuration.

config ilc print
Display the ilc status.

config ilc {enable | disable}
Enables or disables the Inter-Library Communications (ILC) LAN. If a disable is 
requested, the library must first be taken offline using the "accessState offline <device 
address>" command.

config print
Displays the current physical library configuration.

config serviceInfo print
Displays the library service information.

config serviceInfo set
Sets service information: contact ‘contactName’ phone ‘phoneNumber’ streetAddr 
‘streetAddress’ city ‘city’ state ‘state’ country ‘country’ zip ‘zipCode’ description 
‘description data’. 

Currently the maximum string length is 31 characters. Each string must be delimited 
by ‘ ’ (single quotes) to provide the ability to use spaces and other characters.

Example:

SL3000> config serviceInfo set city 'Denver' contact 'Andy' country 'USA' 
description 'Manager' phone '303 222-4444' state 'C0' streetAddr '1 tape drive' 
zip '80027'

requestId
requestId 1512402
Device serviceInfo
Success true
Done
Failure Count 0
Success Count 1
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COMPLETED

date
This command sets the library date in Greenwich Mean Time (GMT).

date
Displays help for the date command, the same as "help date".

date print
Displays the current system date.

date <MM> / <DD> / <YYYY>
Sets the system date. In a library complex, the library with libraryId = 1 is the master. 
Change the date on the master library.

■ <MM> - two digit month

■ <DD> - two digit day

■ <YYYY> - four digit year

drive
This command displays information about the drives or executes the drive utilities 
such as adiEnable, fastLoad, power, and rewindUnload.

drive
Displays help for the drive command, the same as "help drive".

drive adiEnable {on | off | print}
Turns on or off or prints status of drive discovery with ADI. Once enabled, any 
subsequently added drives will attempt ADI drive discovery. To enable ADI for all 
ADI capable drives in the library, the library must be rebooted.

drive fastLoad {on | off | print}
Turns on or off or prints the status of the fastLoad feature. FastLoad changes the 
behavior of drive mounts (move commands). With fastLoad on, the robot will not wait 
for a complete load of a PUT to a drive, but will go immediately to the next operation. 
Also changes the behavior of the rewindUnload command to return immediately, not 
waiting for the drive to unload. The state of the fastLoad applies to all drives.

drive print { <drive address> | * }
Displays summary drive information: location, state, status, type, firmware version, 
interface type, in use, serial number, state (online/offline), status (ok, warning, or 
error), and drive vendor.

■ <drive address> - specifies the drive in library, rail, column, side, row format.

■ * - displays drive information for all drives in the library

drive search {on | off} <drive address>
Causes the green LED on the drive tray to blink. Blinking continues until the search off 
command issued.Used to locate a drive within the library.

Note: This command only affects commands issued in the same CLI 
session where this command was issued.
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■ <drive address> - specifies the drive in library, rail, column, side, row format.

hwActivation
This command activating certain library features after purchasing a hardware 
activation permit.

hwActivation
Displays help for the hwActivation command, same as "help hwActivation".

hwActivation addLicenseFile
Adds a license file. The license file must be named SL3000_license_config.dsf. The full 
path name being /usr/local/SL3000_license_config.dsf.

hwActivation deleteFile <index>
Deletes the specified installed feature file.

■ <index> - specifies file number to delete as specified in the library controller 
hwActivation module database. See "hwActivation listFiles".

hwActivation listFiles
Lists the installed feature files in the library controller hwActivation module database.

hwActivation print
Lists all of the enabled features in the library controller hwActivation module 
database.

FibreConfig
This command obtains and sets multi-port fibre channel configurations for the library 
controller. The Fibre Channels controls and displays by this command are not to be 
confused with the fibre channel configurations to tape drives. This command is only 
available on the SL3000.

fibreConfig print
Displays the status of the library fibre channel connections.

fibreConfig ports print
Displays the number of multi fibre port channels enabled.

fibreConfig config <hard|soft> <loopId> <portNum>
Sets either hard or soft addressing, and sets the fibre loop ID if hard addressing is 
enabled to the provided value. The loop ID is set to 126 if hard addressing is disabled. 
This configuration is on a per port basis.

fibreConfig ports set <number to enable>
Sets the number of multi fibre port channels to enable. The MultiFibrePort license 
limitation and the physical hardware determine the maximum number of ports to 
enable.

Note: The library must be rebooted when disabling openVolser, 
dualRobot, partitioning, or redundant electronics.
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mediaValidation
This command manages the media validation feature.

mediaValidation
Displays help for the mediaValidation command, same as "help mediaValidation"

mediaValidation print { all | poolOnly } { * | @ }
Displays drive locations of the media validation pool.

■ all - lists all drive slots

■ poolOnly - lists only drive slots in the media validation pool

■ * - displays only information for the target library

■ @ - displays information for the entire complex

mediaValidation reservation clear <drive address>
Clears media validation reservation for specified drive.

■ <drive address> - specifies the drive in library, rail, column, side, row format.

mediaValidation stopValidation <drive address>
Stops a validation currently in progress. Cartridge is returned to source storage cell.

■ <drive address> - specifies the drive in library, rail, column, side, row format.

network
This command configures and displays network configuration for the controller card. 
For additional information, see the SL3000 Host Connectivity Guide on OTN.

network clone [Port 2B IP address] [Port 2A IP address]
Used for redundant electronics configuration. Copies all port, routing, and IP policy 
configurations to side B HBC. IP addresses are replaced with the ones specified in the 
command for side B. If no port IP address is specified, then they are not set on side B.

network config print
Displays the target library side (A or B) that is set for network commands.

network config side {a | b}
Sets the target library side for network commands.

network config clear
Clears the network configuration. This command stops network connectivity. 
Reconfiguration requires access to the serial port on the HBC card.

network export
Exports library network configuration file (.lnc) and generates a network configuration 
script (.scr). It can only be used in cases where no prior network configurations have 
been set.

network gateway <IP address>
Sets the external network default gateway.

network gateway clear
Clears the external network default gateway.
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network import
Imports a library network configuration file (.lnc).

network ip <IP address>
Sets the IP address of port 2B.

network ip address add <IP address> dev {2A | 2B}
Sets the IP address of a particular port.

network ip address del <IP address> dev {2A | 2B}
Removes the IP address of a port.

network ip address show [dev {2A | 2B}]
Displays the current address information for a particular port or both ports if dev is 
not specified.

network ip link set dev {2A | 2B} {up | down}
Sets the operation status of a port, which controls whether a port can send and receive 
Ethernet traffic.

■ up - sets port online

■ down - sets port offline

network ip policy {enable | disable} dev {2A | 2B}
Enables or disables policy routing for device 2A or 2B.

network ip policy status
Displays policy routing status for devices 2A and 2B.

network ip policy route {add | del} <IP address> dev {2A | 2B}
Adds or deletes a static route to policy for device 2A or 2B.

network ip policy route {add | del} <IP address> via <Gateway IP address> dev {2A | 
2B}
Adds or deletes a static route to policy for device 2A or 2B via gateway.

network ip policy route show [ dev {2A | 2B} ]
Displays policy route information for device 2A or 2B.

network ip route add default via <IP address>
Sets the default gateway routing IP address.

network ip route delete default
Deletes the default gateway routing IP address.

network ip route {add | del} <IP address [/netmask] > dev {1A | 1B | 2A | 2B}
Adds or deletes a static IP (Internet Protocol) routing address for a specified host. This 
command also enables a user to set the netmask for a particular port.

Example:

SL3000>network ip route add 129.80.81.59/24 dev 1B
COMPLETED

network ip route {add | del} <IP address [/netmask] > via <Gateway IP address>
Adds or deletes a static route to a destination network IP gateway address.
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network ip route show [dev {2A | 2B}]
Displays the current routing table information or routing table information for a 
particular port.

network name <host name string>
Sets the host name.

network netmask <netmask>
Sets the external network netmask in xxx.xxx.xxx.xxx form.

network print
Displays the current network configuration for the external Ethernet ports (2A and 
2B).

partition
This command displays the current status or disables the partition feature.

partition
Displays help for the partition command, same as "help partition".

partition autoClean set { * | <Partition Id> }
Set auto clean in a specified partition (0, for a non-partitioned library).

partition attribute status { * | <Partition Id> }
Displays the status attributes of a single specified partition or all partitions.

partition fastLoad set '<partitionId-mode, partitionId-mode, ...>'
Sets the fastLoad mode for a one or more specified partitions. Currently the only valid 
modes are true or false. This command is only available on the SL3000.

Example:

SL3000> partition fastload set '1-true,3-false'
   requestId
   requestId 40901
   Attributes Success true
   Object
   Done
   Failure Count 0
   Success Count 2
COMPLETED

partition getCapacity
Displays the capacity values for library or any defined partitions.

partition get state <Partition Id>
Displays the current state of the specified partition(s). This command is available on 
SL3000 libraries only

partition predefined file <partition file number>
Uses a predefined partition text file to set the library partition configuration. Each file 
name consists of the word “partition” and a numeric value ie “2” and a “.txt” 
extension. The predefined files are below.

partition1.txt – Non-partitioned Base with a HLI interface.
partition2.txt – Non-partitioned Base with a SCSI interface.
partition3.txt – One partitioned Base with a HLI interface.
partition4.txt – One partitioned Base with a SCSI interface.
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partition5.txt – Two partitioned Base with a HLI interface.
partition6.txt – Two partitioned Base with a SCSI interface.
partition7.txt – Two partition Base w/DEM HLI and SCSI partitions.
partition8.txt – Two partition Base w/DEM SCSI interface.
partition9.txt – Multiple partitions (stripes) HLI interface.
partition10.txt – Multiple partitions (stripes) SCSI interface.
partition11.txt – Multiple partitions (random) HLI interface.
partition12.txt – Multiple partitions (random) SCSI interface.

Example:

SL3000> partition predefined file 5
   requestId
   requestId 7601
   Done
   Failure Count 0
   Success Count 1
COMPLETED

partition setCapacity { <Partition Id> , <Capacity> }
Sets the capacity for the designated partition. Existing partitions not listed in the 
command will have their capacity set to zero.

Example:

SL8500> partition setCapacity 1,200 2,50 3,600
   requestId 7601
   Done
   Failure Count 0
   Success Count 1
COMPLETED

partition setNonPartitionedHLI
Sets the partition to hli0. If there are any drives in the media validation pool, they must 
be removed beforehand. If in complex, it sets all the libraries to hli0. 

partition set state {online | offline} <Partition Id>
Sets the current state (offline/online) of a specified partition.

partition set {hli | scsi}
Sets the interface type for the entire library. Available on SL3000 only.

partition status
Displays the current partitioning status.

reControl
This command controls/switches the redundant electronics and retrieves the library 
controller redundant electronics statuses.

reControl
Displays help for the reControl command, same as "help reControl".

reControl status [ <library address> | * ]
Retrieves the redundant electronics status.

■ <library address> - specifies the library in library, rail, column, side, row format. For 
example: 2, 0, 0, 0, 0.

■ * - retrieves status from all libraries in a complex
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snmp
This command configures the Simple Network Management Protocol (SNMP). For 
detailed information, see the SNMP Reference Guide on OTN.

ssh
This command controls configuration for the ssh daemon/server which resides on the 
HBC. This is the protocol utility which SLC and other various applications use to 
connect to the library controller.

ssh print
Prints the current ssh daemon protocol settings.

ssh set version1and2
Sets the ssh daemon protocol restriction to v1 and v2. (this is the default). The ssh 
server is restarted.

ssh set version2
Sets the ssh daemon protocol restriction to v2 only.

time
This command sets the library time in military time notation.

time
Displays help for the time command, same as "help time".

time print
Displays the current system time.

time <HH> : <MM>
Sets the system time. Resolution is within one minute. In a library complex, the library 
with libraryId = 1 is the master. Change the time on the master library.

■ <HH> - two digit hour

■ <MM> - two digit minute

time <HH> : <MM> : <SS>
Sets the system time. Resolution is within one second. In a library complex, the library 
with libraryId = 1 is the master. Change the time on the master library.

■ <HH> - two digit hour

■ <MM> - two digit minute

■ <SS> - two digit second

traceRoute
This command traces the network route to a specified IP address.

traceRoute <IP Address>
Executes a traceRoute to the IP address specified.
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version
This command displays the customer version and the versions of the software for the 
device(s) requested.

version print [ <device address> | *]
Displays the software version of code for a device or all devices.

■ <device address> - specifies the device in library, rail, column, side, row format. 

whereAmi
This command displays the system and logic card information relative to the library 
and card related to redundant electronics command is being executed.

whereAmi
Displays the information relating to where the command is being issued.

Example:

SL8500> whereAmI
   Host Name: gulibtst02b
   Port 2B IP Address: 172.20.151.24
   Library Type: SL8500
   HBC side: B
   Active side: B
COMPLETED
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BLibrary Addressing

This appendix explains the addressing schemes used in the SL3000 library. There are 
four main types of addressing schemes:

■ Internal Firmware (Library, Rail, Column, Side, Row) — used by the firmware 
and internal communications to represent all devices and locations within the 
library.

■ HLI-PRC (LSM, Panel, Row, and Column) — used by HLI clients, such as ACSLS 
and ELS, to represent library locations and components.

■ FC-SCSI Element Numbering — used by hosts with FC-SCSI connections to the 
library.

■ External hardware numbering — used for drive bay locations (see "Tape Drive 
Numbering" on page B-12).

CenterLine
Internal firmware and HLI addressing use the centerline as a reference point. When 
additional modules are added to either end of the library, the existing components do 
not change address number.

The basis of centerline technology involves balancing additional modules on the left 
and right side of the Base Module. This reduces the overall travel of the robot to help 
balance the work load and improve library performance. 

Figure B–1 shows the location of the centerline for various library configurations.

Note: In this appendix, "left" and "right" are in reference to viewing 
the library from the CAP-side (front) unless otherwise specified.
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Figure B–1 CenterLine Location in Sample Libraries

Internal Firmware
Internal firmware addressing designates physical location using five parameters: 
Library, Rail, Column, Side, Row (L,R,C,S,W).

Library
Always equal to 1.

Rail
Always equal to 1.
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Column
Indicates the horizontal location of a tape cartridge referenced from the centerline of 
the library. Numbering is static, allowing modules to be added without renumbering 
existing columns.

■ Positive (+) value indicates right of centerline

■ Negative (-) value indicates left of centerline

Base Module

■ Contains columns 1 to 6 for data cartridges and 1 to 4 for tape drives.

DEM

■ Contains columns -1 to -6 for data cartridges and -1 to -4 for tape drives.

CEM

■ Contains six columns for data cartridges.

■ Column numbering continues consecutively from the adjacent module. However, 
if there is no DEM, a CEM placed directly to the left of a Base contains columns -7 
to -12 (columns -1 to -6 are skipped).

PEM

■ Contains only three columns for data cartridges. The outer most three columns are 
inactive.

AEM

■ AEM columns are numbered as if a DEM and four CEMS are installed to the left of 
the Base Module and four CEMs are installed to the right.

■ Left AEM columns are always numbered -33 to -31.

■ Right AEM columns are always 31 to 33. 

Side
Indicates the front or rear walls of the library.

■ Rear wall = 1

■ Front wall = 2

Row
The vertical location of a tape cartridge, consecutively numbered from the top (1) 
down (52).
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Figure B–2 Internal Firmware Addressing Examples (viewed from top of library)

HLI-PRC
HLI-PRC addressing designates physical location using four parameters: LSM, Panel, 
Row, and Column. 

LSM
Always equal to 0. 

Panel
Indicates the front or rear wall of a module. The panel number can range from 0 to 23 
depending on the configuration of the library.

■ Rear wall = even numbers

■ Front wall = odd numbers



HLI-PRC

Library Addressing B-5

The panel location is defined relative to the Base Module (panels 12 and 13). Panel 
values less than 12 indicate the module is to the left of the Base Module, while values 
greater than 13 indicate the module is to the right of the Base Module.

Base Module

■ Panels 12 and 13

DEM

■ Panels 10 and 11

CEM

■ Panels are numbered consecutively from the adjacent module. However, if there is 
no DEM, a CEM placed directly to the left of a Base Module contains panels -8 and 
-9 (panels -10 and -11 are skipped).

AEM

■ AEMs are considered CAPs by HLI addressing. Therefore, AEMs have a CAP ID 
instead of a panel number (see "Cartridge Access Ports - HLI" on page B-16)

■ Left AEM CAP ID is always numbered 0 

■ Right AEM CAP ID is always numbered 11

Row
The vertical location of a slot, consecutively numbered from the top down (0 to 51). 
However, drive bays have row numbering from 0 to 23 for the Base Module, and 0 to 
31 in the DEM.

Column
The horizontal location of a slot from left to right (0 to 5). However, drive bays always 
have a column value of 0 (see "Tape Drive Numbering" on page B-12").

AEM column numbering starts at the rear wall and runs left to right (columns 0–2), 
then proceeds to the front wall and runs left to right (columns 3–5).

Tape Drives and CAPs
HLI addressing defines tape drives with a drive ID instead of a row value. The 
addressing is LSM, panel, drive ID, column (see "Tape Drive Numbering" on 
page B-12).

HLI addressing defines CAP locations with a CAP ID instead of a panel value. The 
addressing is LSM, CAP ID, row, column (see "Cartridge Access Ports - HLI" on 
page B-16").
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Figure B–3 HLI-PRC Addressing Examples (viewed from top of library)

FC-SCSI Element Numbering
For FC-SCSI element numbering, each active component in the library is defined by a 
unique element ID number. SCSI element numbering consists of three element types:

■ Storage Elements (active cartridge slots)

– Begins at 2000 and increments by one for every active slot.

– Numbered top to bottom, left to right, and rear to front (see Figure B–4).

■ Import/Export Elements (rotational CAPs)

– Begins at 10 for the left most CAP in the library. Storage and Import/Export 
elements are numbered sequentially by slot. No slots are skipped. 

– Numbered top to bottom, left to right (see Figure B–7).
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■ Data Transfer Elements (tape drives)

– Begins at 1000 and increments by one for every installed tape drive.

– Numbered left to right, top to bottom, starting at the centerline in the Base 
module and continuing in the DEM if installed. This numbering scheme 
allows the user to add a bank of drives and not disturb the ordering of the 
banks above (see Figure B–5).

The behavior of the FC-SCSI element numbering depends on the whether the library is 
partitioned and if the active capacity was assigned by default or was user-selected.

Default Capacity Assignment
Active capacity assignment is based on the Default Capacity Policy setting (see 
"Setting the Default Capacity Policy" on page 5-4). The default setting is "Left to Right". 
For this setting, the library always begins the active capacity from the upper left slot 
on the rear wall of the left-most module. The activated capacity and SCSI numbering 
scheme follows the pattern defined in Figure B–4. The default SCSI element 
numbering for tape drives follows the numbering scheme defined in Figure B–5. 

With default numbering, any configuration change to the library causes the element 
numbers to be reassigned. Therefore, the element numbers will be reassigned and the 
library will reboot when:

■ A storage module is added/removed from the library

■ Activated capacity changes

■ Tape drives are added/removed

User Defined—Non-Partitioned Capacity Assignment
When the active capacity location is selected by the user in a non-partitioned library, 
the numbering begins with the left most slot on the rear wall within the selected active 
area. The numbering scheme follows the pattern defined in "Default SCSI Storage 
Element Numbering Scheme" on page B-8 for all active slot cells, but skips over any 
inactive cells.

If additional capacity is activated, the SCSI numbering of previously activated cells 
does not change — the library simply appends the SCSI numbering for newly 
activated cells (see Figure B–8 and Figure B–9  on page B-11).

However, if tape drives are added to a user-defined, non-partitioned library, the 
library reassigns SCSI Data Transfer element numbering following the "Default SCSI 
Data Transfer Element Numbering Scheme" on page B-8. Then, the library reboots

User Defined—Partitioned Capacity Assignment
When the active capacity location is selected by the user in a partitioned library, the 
numbering begins with the left most slot on the rear wall within the partition. The 
numbering scheme follows the pattern defined in Figure B–4 for all active slot cells, 
but skips over any inactive cells and cells not within the partition. Therefore, element 

Note: When the library powers on, a vacant drive slot will not be 
included in the element number sequence. Open Systems backup 
applications do not tolerate Data Transfer Elements that cannot or do 
not respond when you power-on the library.
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numbering is continuous within each partition, even if cell locations for the partition 
are not adjacent. 

If additional capacity is activated or tape drives are added to a partition, the SCSI 
numbering of previously numbered elements in the partition does not change. The 
library simply appends the SCSI numbering for newly activated cells or newly 
inserted tape drives within the partition.

Default SCSI Storage Element Numbering Scheme
Figure B–4 shows the default numbering scheme for SCSI Storage Elements. The 
numbering scheme follows these rules:

1. The numbering starts in the upper left slot on the rear wall of the left-most 
module. 

2. The numbering increases from top to bottom and left to right.

3. When the numbering reaches the last slot on the rear wall, it crosses to the front 
wall of the left-most module (A to B in Figure B–4). 

4. The numbering continues top to bottom, left to right, and ends at the lower right 
slot of the right-most module.

Figure B–4 SCSI Storage Element Numbering

Default SCSI Data Transfer Element Numbering Scheme
Figure B–5 shows the default numbering scheme for SCSI Data Transfer Elements. The 
numbering scheme follows these rules:

1. The numbering starts in the upper left drive slot in the Base Module.

2. The numbering increases from left to right and top to bottom (skipping any empty 
drive slots). 
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3. When the numbering reaches the lower right drive slot on the Base Module, it 
crosses to the Drive Expansion Module (A to B in Figure B–5). 

4. The numbering continues left to right, top to bottom, and ends at the lower right 
slot of the DEM.

Figure B–5 SCSI Data Transfer Element Numbering (viewed from front of library)

Element Numbering Examples
The library in the example has been simplified and is not an exact representation of a 
SL3000 library.

Default Numbering
Figure B–6 and Figure B–7 provide an example of default SCSI element numbering. 
The example library includes:

■ Four modules: one Base, one DEM, and two CEMs 

■ 166 data cartridge slots: numbered 2000 to 2165

■ 40 tape drive bays (two tape drives are missing, one in each module): numbered 
1000 to 1037

■ Two CAPs, each with seven slots: numbered 10 to 23
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Figure B–6 SCSI Element Numbering - Rear Wall (viewed from front of library)

Figure B–7 SCSI Element Numbering - Front Wall (viewed from front of library)

User-Defined Numbering
Figure B–8 and Figure B–9 provide an example of user-defined SCSI element 
numbering. The library in the example has been simplified and is not an exact 
representation of a SL3000 library. For simplification, the active areas selected are only 
on the rear wall.

For this example, the user has decided to activate 50 cells, beginning with the DEM. As 
a result, the SCSI storage element numbering begins at 2000 with the upper left-most 
active cell in the DEM. The cells in the left CEM are currently inactive and are 
therefore not numbered (Figure B–8).
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Figure B–8 User Defined Capacity SCSI Element Numbering - Rear Wall

At a later date, the user decides to activate the remaining 30 cells in the library. Since 
the active capacity was initially user-defined, the SCSI numbering does not re-assign 
numbering to the previously-activated cells. The SCSI storage element numbering for 
the newly-activated cells is appended (Figure B–9).

Figure B–9 User Defined Added Capacity SCSI Element Numbering - Rear Wall

Comparison of Addressing Schemes
Internal Firmware

■ Uses: library, rail, column, side, and row.

■ Begins at 1 and uses negative numbers.

■ Side indicates the front or rear wall of the library.

■ Drive bays have column values 1 to 4 (BM) and -1 to -4 (DEM).

HLI-PRC

■ Uses: LSM, panel, row, and column.

■ Begins at 0 with no negative numbers.



Tape Drive Numbering

B-12 StorageTek SL3000 User's Guide

■ Panel indicates the front or rear wall of a specific module.

■ Drive bays always have column value of 0.

FC-SCSI Element

■ Uses single positive number for the element ID.

■ Cartridge slots begin at 2000, tape drives begin at 1000, CAPs begin at 10.

■ Inactive slots and empty drive bays are skipped when element numbers are 
assigned.

■ Default element numbering is reassigned with any library configuration change.

■ Element numbering depends on active capacity.

Tape Drive Numbering
All of the tape drives in the SL3000 library are physically located at the rear of the Base 
Module or Drive Expansion Module. There are four addressing schemes used to define 
the location of drives:

■ "Hardware Numbering" on page B-12

■ "Internal Firmware" on page B-13

■ "HLI-PRC" on page B-14

■ FC-SCSI Element numbering (see "Default SCSI Data Transfer Element Numbering 
Scheme" on page B-8).

Hardware Numbering
The physical hardware numbering of tape drives is assigned by the HBC controller 
card. The card automatically assigns a number, 1-56, to each drive bay.

Note: The perspective in Figure B–10 is from the drive-side (rear) of 
the library.
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Figure B–10 Tape Drive Physical Hardware Numbering (viewed from rear of library)

Internal Firmware
The firmware addressing (library, rail, column, side, row) distinguishes a drive based 
on column and row. The library, rail, and side values are always equal to 1.

Note: The perspective in Figure B–11 is from the drive-side (rear) of 
the library. 
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Figure B–11 Tape Drive Internal Firmware Addressing (viewed from rear of library)

HLI-PRC
The HLI-PRC uses drive IDs instead of row values. Therefore, the addressing is LSM, 
panel, drive, column. HLI distinguishes a drive based on the panel and drive value. 
The LSM and column values are always equal to 0.

Note: The perspective in Figure B–12 is from the drive-side (rear) of 
the library.
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Figure B–12 Tape Drive HLI-PRC Addressing (viewed from rear of library)

Addressing of Components—CAPs and Robots
The addressing of components, such as CAPs and robots, have unique addressing 
rules: 

■ The library and rail values are always 1.

■ A row value of 0 indicates the address is referring to the device, not a slot in the 
device.

■ The column value of a rotational CAP depends on module location.

Cartridge Access Ports - Internal Firmware
Both rotational CAPs and AEMs are considered cartridge access ports for addressing 
purposes.

Rotational CAPs

Column
The column value depends on the size of the library and the location of the module 
that contains the CAP.

For modules to the left of centerline, the CAP column value corresponds to the second 
column from the right of the module. For example, in a DEM, the column value for the 
CAP would be -2 and a CEM to the left of the DEM would have a CAP column value 
of -8.

Note: "Left" and "right" are in reference to viewing the library from 
the CAP-side (front) unless otherwise specified.
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For modules to the right of centerline, the CAP column value corresponds to the fifth 
column from the left of the module. For example, a CAP in the Base has a column 
value of 5 and a CEM to the right of the Base would have a CAP column value of 11.

Side
The side value is always 2, since the CAPs are only located on the front of the module.

Row
When addressing the device: the row value is 0.

When addressing a specific slot: the row value is the slot in the CAP magazine (values 
1 to 26).

Example - Rotational Firmware Addressing
For this example, the library has a Base, DEM, and four CEMs (two on each side). The 
address refers to the sixth cell down in the CAP in the CEM on the far left.

The firmware address is: (1, 1, -14, 2, 6)

AEM CAPs

Column
The column value when referencing the CAP is:

■ -31 for left AEM

■ 31 for right AEM

The column value when referencing a slot in the CAP:

■ -31 to -33 for left AEM

■ 31 to 33 for right AEM

Side
Indicates the front or rear CAP doors on the library.

■ Rear wall = 1

■ Front wall = 2

Row
When addressing the device: the row value is 0.

When addressing a specific slot: the row value is the slot in the CAP (values 1 to 26).

Example - AEM CAP Firmware Addressing
For this example, the address is referencing a cartridge slot in the right AEM. The slot 
is the 37th down in the far right column in the rear CAP door.

The firmware address is: (1, 1, 33, 1, 37)

Cartridge Access Ports - HLI
CAPs have CAP IDs instead of panel values. CAP IDs range from 0 to 11, depending 
on location. 

Rotational CAPs

LSM
Always equal to 0.
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CAP ID
Ranges from 1 to 10

■ CEMs left of centerline = 1 to 4 (left to right)

■ DEM = 5

■ Base Module = 6

■ CEMs right of centerline = 6 to 10 (left to right)

Row
The value is the slot in the CAP (can be values 0 to 25).

Column
The value always equals 0.

Example - Rotational CAP HLI Addressing
For this example, the library has a Base, DEM, and eight CEMs (four on each side). The 
address refers to the sixth cell down in the CAP in the CEM on the far left.

The HLI address is: (0, 1, 5, 0)

AEM CAPs

LSM
Always equal to 0.

CAP ID
Left AEM equals 0.

Right AEM equals 11.

Row
The value is the slot in a column (can be values 0 to 38). 

Column
Rear wall = columns 0 to2

Front wall = columns 3 to 5

Robots - Internal Firmware

Column
The column value is always 0.

Side
If there is only one robot: the side value is always 1.

For redundant robot configurations:

■ Left robot = 1

■ Right robot = 2

Row
When addressing the device: the row is 0.

When addressing the specific slot: the row is the slot value (1).
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Example - Robot Firmware Addressing
For this example, the address is referring to the right robot in a redundant robotics 
library.

The firmware address is: (1, 1, 0, 2, 0)
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This appendix explains special library cells, such as reserved system slots and the 
module identification blocks. Additionally, the appendix contains library wall maps 
for each possible module configuration.

■ Reserved System Slots

■ Module Identification Block

■ Wall Diagrams

Reserved System Slots
Both the Base Module and the Drive Expansion Module have reserved system cells on 
the lower rear wall. These cells provide special functions for the library and tape 
drives. Do not place data cartridges in a reserved slot. The reserved cells are composed 
of: 

■ Two swap cells in column 2, rows 49 and 50.

■ One diagnostic cell in column 2, row 51, and four diagnostic cells in column 3, 
rows 49, 50, 51, and 52.

■ A module identification block in column 4, rows 49, 50, 51, and 52 (see 
Figure C–1).

■ Four cleaning cartridges in column 5, rows 49, 50, 51, and 52, and four cleaning 
cartridges in column 6, rows 49, 50, 51, and 52.

Figure C–1 Reserved System Cells

Module Identification Block
Each module has an identification block with labels that identify the module 
configuration. This block is on the lower rear wall in the forth column from the left, 
rows 49, 50, 51, and 52. 
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During an initialization or after an upgrade, the robotic assembly visits the module 
identification block to determine the module configuration.

The block identifies the: 

■ Type of module: Base Module, Drive Expansion Module, Cartridge Expansion 
Module, Parking Expansion Module, or Access Expansion Module.

■ Back wall configuration: 1 drive array, 2 drive arrays, 3 drive arrays, 4 drive arrays, 
arrays, bulk load magazines, or empty.

■ Front wall configuration: Arrays, cartridge access port, CAP window, empty, or bulk 
load magazines.

■ Options: Arrays, op panel or window, empty, or service bay.

Figure C–2 Module Identification Block Base Module Example

Special Labels
The CAPID/ label and NOMAG/ label are special labels that do not include an icon. 

■ CAPID/ is mounted only at the top of all CAPs as a generic identifier for the 
library if the CAP does not have any magazines installed on which to target. 

■ NOMAG/ is mounted behind the removable magazines in the bulk load AEM.

Table C–1 Special Labels

Function Label Text Barcode Icon

Cartridge Access Port ID SPECIAL: CAP IDENTIFICATION CAPID/ None

No Magazines SPECIAL: NO MAGAZINES NOMAG/ None
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Wall Diagrams
■ Base Module front wall (Figure C–3)

■ Base Module rear wall (Figure C–4 and Figure C–5)

■ DEM front wall (Figure C–6 and Figure C–7)

■ DEM rear wall (Figure C–8 and Figure C–9)

■ CEM front wall (Figure C–10)

■ CEM rear wall (Figure C–11)

■ Left PEM (Figure C–12)

■ Right PEM (Figure C–13)

■ Left AEM (Figure C–14)

■ Right AEM (Figure C–15)
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Figure C–3 Base Module, Front Wall
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Figure C–4 Base Module, Rear Wall
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Figure C–5 Base Module, rear wall with 24 drives

.
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Figure C–6 DEM Front Wall
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Figure C–7 DEM Front Wall (continued)
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Figure C–8 DEM Rear Wall
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Figure C–9 DEM Rear Wall (continued)
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Figure C–10 Cartridge Expansion Module, Front Wall
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Figure C–11 Cartridge Expansion Module, Rear
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Figure C–12 Parking Expansion Module, Left
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Figure C–13 Parking Expansion Module, Right
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Figure C–14 Access Expansion Module, Left
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Figure C–15 Access Expansion Module, Right
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DControlling Contaminants

This chapter includes information on the importance of preventing contaminants.

■ Environmental Contaminants

■ Required Air Quality Levels

■ Contaminant Properties and Sources

■ Contaminant Effects

■ Room Conditions

■ Exposure Points

■ Filtration

■ Positive Pressurization and Ventilation

■ Cleaning Procedures and Equipment

■ Activity and Processes

Environmental Contaminants
Control over contaminant levels in a computer room is extremely important because 
tape libraries, tape drives, and tape media are subject to damage from airborne 
particulates. Most particles smaller than ten microns are not visible to the naked eye 
under most conditions, but these particles can be the most damaging. As a result, the 
operating environment must adhere to the following requirements: 

■ ISO 14644-1 Class 8 Environment.

■ The total mass of airborne particulates must be less than or equal to 200 
micrograms per cubic meter.

■ Severity level G1 per ANSI/ISA 71.04-1985.

Oracle currently requires the ISO 14644-1 standard approved in 1999, but will require 
any updated standards for ISO 14644-1 as they are approved by the ISO governing 
body. The ISO 14644-1 standard primarily focuses on the quantity and size of 
particulates as well as the proper measurement methodology, but does not address the 
overall mass of the particulates. As a result, the requirement for total mass limitations 
is also necessary as a computer room or data center could meet the ISO 14644-1 
specification, but still damage equipment because of the specific type of particulates in 
the room. In addition, the ANSI/ISA 71.04-1985 specification addresses gaseous 
contaminations as some airborne chemicals are more hazardous. All three 
requirements are consistent with the requirements set by other major tape storage 
vendors.
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Required Air Quality Levels
Particles, gasses and other contaminants may impact the sustained operations of 
computer hardware. Effects can range from intermittent interference to actual 
component failures. The computer room must be designed to achieve a high level of 
cleanliness. Airborne dusts, gasses and vapors must be maintained within defined 
limits to help minimize their potential impact on the hardware. 

Airborne particulate levels must be maintained within the limits of ISO 14644-1 Class 8 
Environment. This standard defines air quality classes for clean zones based on 
airborne particulate concentrations. This standard has an order of magnitude less 
particles than standard air in an office environment. Particles ten microns or smaller 
are harmful to most data processing hardware because they tend to exist in large 
numbers, and can easily circumvent many sensitive components' internal air filtratio 
systems. When computer hardware is exposed to these submicron particles in great 
numbers they endanger system reliability by posing a threat to moving parts, sensitive 
contacts and component corrosion.

Excessive concentrations of certain gasses can also accelerate corrosion and cause 
failure in electronic components. Gaseous contaminants are a particular concern in a 
computer room both because of the sensitivity of the hardware, and because a proper 
computer room environment is almost entirely recirculating. Any contaminant threat 
in the room is compounded by the cyclical nature of the airflow patterns. Levels of 
exposure that might not be concerning in a well ventilated site repeatedly attack the 
hardware in a room with recirculating air. The isolation that prevents exposure of the 
computer room environment to outside influences can also multiply any detrimental 
influences left unaddressed in the room. 

Gasses that are particularly dangerous to electronic components include chlorine 
compounds, ammonia and its derivatives, oxides of sulfur and petrol hydrocarbons. In 
the absence of appropriate hardware exposure limits, health exposure limits must be 
used. 

While the following sections will describe some best practices for maintaining an ISO 
14644-1 Class 8 Environment in detail, there are some basic precautions that must be 
adhered to:

■ Do not allow food or drink into the area.

■ Cardboard, wood, or packing materials must not be stored in the data center clean 
area.

■ Identify a separate area for unpacking new equipment from crates and boxes.

■ Do not allow construction or drilling in the data center without first isolating 
sensitive equipment and any air targeted specifically for the equipment. 
Construction generates a high level of particulates that exceed ISO 14644-1 Class 8 
criteria in a localized area. Dry wall and gypsum are especially damaging to 
storage equipment.

Contaminant Properties and Sources
Contaminants in the room can take many forms, and can come from numerous 
sources. Any mechanical process in the room can produce dangerous contaminants or 
agitate settled contaminants. A particle must meet two basic criteria to be considered a 
contaminant:

■ It must have the physical properties that could potentially cause damage to the 
hardware.
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■ It must be able to migrate to areas where it can cause the physical damage.

The only differences between a potential contaminant and an actual contaminant are 
time and location. Particulate matter is most likely to migrate to areas where it can do 
damage if it is airborne. For this reason, airborne particulate concentration is a useful 
measurement in determining the quality of the computer room environment. 
Depending on local conditions, particles as big as 1,000 microns can become airborne, 
but their active life is very short, and they are arrested by most filtration devices. 
Submicron particulates are much more dangerous to sensitive computer hardware, 
because they remain airborne for a much longer period of time, and they are more apt 
to bypass filters.

Operator Activity
Human movement within the computer space is probably the single greatest source of 
contamination in an otherwise clean computer room. Normal movement can dislodge 
tissue fragments, such as dander or hair, or fabric fibers from clothing. The opening 
and closing of drawers or hardware panels or any metal-on-metal activity can produce 
metal filings. Simply walking across the floor can agitate settled contamination 
making it airborne and potentially dangerous.

Hardware Movement
Hardware installation or reconfiguration involves a great deal of subfloor activity, and 
settled contaminants can very easily be disturbed, forcing them to become airborne in 
the supply air stream to the room's hardware. This is particularly dangerous if the 
subfloor deck is unsealed. Unsealed concrete sheds fine dust particles into the 
airstream, and is susceptible to efflorescence -- mineral salts brought to the surface of 
the deck through evaporation or hydrostatic pressure. 

Outside Air
Inadequately filtered air from outside the controlled environment can introduce 
innumerable contaminants. Post-filtration contamination in duct work can be 
dislodged by air flow, and introduced into the hardware environment. This is 
particularly important in a downward-flow air conditioning system in which the 
sub-floor void is used as a supply air duct. If the structural deck is contaminated, or if 
the concrete slab is not sealed, fine particulate matter (such as concrete dust or 
efflorescence) can be carried directly to the room's hardware. 

Stored Items
Storage and handling of unused hardware or supplies can also be a source of 
contamination. Corrugated cardboard boxes or wooden skids shed fibers when moved 
or handled. Stored items are not only contamination sources; their handling in the 
computer room controlled areas can agitate settled contamination already in the room.

Outside Influences
A negatively pressurized environment can allow contaminants from adjoining office 
areas or the exterior of the building to infiltrate the computer room environment 
through gaps in the doors or penetrations in the walls. Ammonia and phosphates are 
often associated with agricultural processes, and numerous chemical agents can be 
produced in manufacturing areas. If such industries are present in the vicinity of the 
data center facility, chemical filtration may be necessary. Potential impact from 
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automobile emissions, dusts from local quarries or masonry fabrication facilities or sea 
mists should also be assessed if relevant.

Cleaning Activity
Inappropriate cleaning practices can also degrade the environment. Many chemicals 
used in normal or office cleaning applications can damage sensitive computer 
equipment. Potentially hazardous chemicals outlined in the "Cleaning Procedures and 
Equipment"section should be avoided. Out-gassing from these products or direct 
contact with hardware components can cause failure. Certain biocide treatments used 
in building air handlers are also inappropriate for use in computer rooms either 
because they contain chemicals, that can degrade components, or because they are not 
designed to be used in the airstream of a re-circulating air system. The use of push 
mops or inadequately filtered vacuums can also stimulate contamination.

It is essential that steps be taken to prevent air contaminants, such as metal particles, 
atmospheric dust, solvent vapors, corrosive gasses, soot, airborne fibers or salts from 
entering or being generated within the computer room environment. In the absence of 
hardware exposure limits, applicable human exposure limits from OSHA, NIOSH or 
the ACGIH should be used. 

Contaminant Effects
Destructive interactions between airborne particulate and electronic instrumentation 
can occur in numerous ways. The means of interference depends on the time and 
location of the critical incident, the physical properties of the contaminant and the 
environment in which the component is placed.

Physical Interference
Hard particles with a tensile strength at least 10% greater than that of the component 
material can remove material from the surface of the component by grinding action or 
embedding. Soft particles will not damage the surface of the component, but can 
collect in patches that can interfere with proper functioning. If these particles are tacky 
they can collect other particulate matter. Even very small particles can have an impact 
if they collect on a tacky surface, or agglomerate as the result of electrostatic charge 
build-up.

Corrosive Failure
Corrosive failure or contact intermittence due to the intrinsic composition of the 
particles or due to absorption of water vapor and gaseous contaminants by the 
particles can also cause failures. The chemical composition of the contaminant can be 
very important. Salts, for instance, can grow in size by absorbing water vapor from the 
air (nucleating). If a mineral salts deposit exists in a sensitive location, and the 
environment is sufficiently moist, it can grow to a size where it can physically interfere 
with a mechanism, or can cause damage by forming salt solutions.

Shorts
Conductive pathways can arise through the accumulation of particles on circuit boards 
or other components. Many types of particulate are not inherently conductive, but can 
absorb significant quantities of water in high-moisture environments. Problems caused 
by electrically conductive particles can range from intermittent malfunctioning to 
actual damage to components and operational failures.
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Thermal Failure
Premature clogging of filtered devices will cause a restriction in air flow that could 
induce internal overheating and head crashes. Heavy layers of accumulated dust on 
hardware components can also form an insulative layer that can lead to heat-related 
failures.

Room Conditions
All surfaces within the controlled zone of the data center should be maintained at a 
high level of cleanliness. All surfaces should be periodically cleaned by trained 
professionals on a regular basis, as outlined in the "Cleaning Procedures and 
Equipment"section. Particular attention should be paid to the areas beneath the 
hardware, and the access floor grid. Contaminants near the air intakes of the hardware 
can more easily be transferred to areas where they can do damage. Particulate 
accumulations on the access floor grid can be forced airborne when floor tiles are lifted 
to gain access to the sub-floor.

The subfloor void in a downward-flow air conditioning system acts as the supply air 
plenum. This area is pressurized by the air conditioners, and the conditioned air is 
then introduced into the hardware spaces through perforated floor panels. Thus, all air 
traveling from the air conditioners to the hardware must first pass through the 
subfloor void. Inappropriate conditions in the supply air plenum can have a dramatic 
effect on conditions in the hardware areas.

The subfloor void in a data center is often viewed solely as a convenient place to run 
cables and pipes. It is important to remember that this is also a duct, and that 
conditions below the false floor must be maintained at a high level of cleanliness. 
Contaminant sources can include degrading building materials, operator activity or 
infiltration from outside the controlled zone. Often particulate deposits are formed 
where cables or other subfloor items form air dams that allow particulate to settle and 
accumulate. When these items are moved, the particulate is re-introduced into the 
supply airstream, where it can be carried directly to hardware.

Damaged or inappropriately protected building materials are often sources of subfloor 
contamination. Unprotected concrete, masonry block, plaster or gypsum wall-board 
will deteriorate over time, shedding fine particulate into the air. Corrosion on 
post-filtration air conditioner surfaces or subfloor items can also be a concern. The 
subfloor void must be thoroughly and appropriately decontaminated on a regular 
basis to address these contaminants. Only vacuums equipped with High Efficiency 
Particulate Air (HEPA) filtration should be used in any decontamination procedure. 
Inadequately filtered vacuums will not arrest fine particles, passing them through the 
unit at high speeds, and forcing them airborne.

Unsealed concrete, masonry or other similar materials are subject to continued 
degradation. The sealants and hardeners normally used during construction are often 
designed to protect the deck against heavy traffic, or to prepare the deck for the 
application of flooring materials, and are not meant for the interior surfaces of a 
supply air plenum. While regular decontaminations will help address loose 
particulate, the surfaces will still be subject to deterioration over time, or as subfloor 
activity causes wear. Ideally all of the subfloor surfaces will be appropriately sealed at 
the time of construction. If this is not the case, special precautions will be necessary to 
address the surfaces in an on-line room.

It is extremely important that only appropriate materials and methodology are used in 
the encapsulation process. Inappropriate sealants or procedures can actually degrade 
the conditions they are meant to improve, impacting hardware operations and 
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reliability. The following precautions should be taken when encapsulating the supply 
air plenum in an on-line room:

■ Manually apply the encapsulant. Spray applications are totally inappropriate in an 
on-line data center. The spraying process forces the sealant airborne in the supply 
airstream, and is more likely to encapsulate cables to the deck.

■ Use a pigmented encapsulant. The pigmentation makes the encapsulant visible in 
application, ensuring thorough coverage, and helps in identifying areas that are 
damaged or exposed over time.

■ It must have a high flexibility and low porosity to effectively cover the irregular 
textures of the subject area, and to minimize moisture migration and water 
damage.

■ The encapsulant must not out-gas any harmful contaminants. Many encapsulants 
commonly used in industry are highly ammoniated or contain other chemicals 
that can be harmful to hardware. It is very unlikely that this out-gassing could 
cause immediate, catastrophic failure, but these chemicals will often contribute to 
corrosion of contacts, heads or other components.

Effectively encapsulating a subfloor deck in an on-line computer room is a very 
sensitive and difficult task, but it can be conducted safely if appropriate procedures 
and materials are used. Avoid using the ceiling void as an open supply or return for 
the building air system. This area is typically very dirty and difficult to clean. Often 
the structural surfaces are coated with fibrous fire-proofing, and the ceiling tiles and 
insulation are also subject to shedding. Even before filtration, this is an unnecessary 
exposure that can adversely affect environmental conditions in the room. It is also 
important that the ceiling void does not become pressurized, as this will force dirty air 
into the computer room. Columns or cable chases with penetrations in both the 
subfloor and ceiling void can lead to ceiling void pressurization.

Exposure Points
All potential exposure points in the data center should be addressed to minimize 
potential influences from outside the controlled zone. Positive pressurization of the 
computer rooms will help limit contaminant infiltration, but it is also important to 
minimize any breaches in the room perimeter. To ensure the environment is 
maintained correctly, the following should be considered: 

■ All doors should fit snugly in their frames. 

■ Gaskets and sweeps can be used to address any gaps. 

■ Automatic doors should be avoided in areas where they can be accidentally 
triggered. An alternate means of control would be to remotely locate a door trigger 
so that personnel pushing carts can open the doors easily. In highly sensitive areas, 
or where the data center is exposed to undesirable conditions, it may be advisable 
to design and install personnel traps. Double sets of doors with a buffer between 
can help limit direct exposure to outside conditions.

■ Seal all penetrations between the data center and adjacent areas. 

■ Avoid sharing a computer room ceiling or subfloor plenum with loosely controlled 
adjacent areas.

Filtration
Filtration is an effective means of addressing airborne particulate in a controlled 
environment. It is important that all air handlers serving the data center are 
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adequately filtered to ensure appropriate conditions are maintained within the room. 
In-room process cooling is the recommended method of controlling the room 
environment. The in-room process coolers re-circulate room air. Air from the hardware 
areas is passed through the units where it is filtered and cooled, and then introduced 
into the subfloor plenum. The plenum is pressurized, and the conditioned air is forced 
into the room, through perforated tiles, which then travels back to the air conditioner 
for reconditioning. The airflow patterns and design associated with a typical computer 
room air handler have a much higher rate of air change than typical comfort cooling 
air conditioners so air is filtered much more often than in an office environment. 
Proper filtration can capture a great deal of particulates. The filters installed in the 
in-room, re-circulating air conditioners should have a minimum efficiency of 40% 
(Atmospheric Dust-Spot Efficiency, ASHRAE Standard 52.1). Low-grade pre-filters 
should be installed to help prolong the life of the more expensive primary filters.

Any air being introduced into the computer room controlled zone, for ventilation or 
positive pressurization, should first pass through high efficiency filtration. Ideally, air 
from sources outside the building should be filtered using High Efficiency Particulate 
Air (HEPA) filtration rated at 99.97% efficiency (DOP Efficiency MILSTD-282) or 
greater. The expensive high efficiency filters should be protected by multiple layers of 
pre-filters that are changed on a more frequent basis. Low-grade pre-filters, 20% 
ASHRAE atmospheric dust-spot efficiency, should be the primary line of defense. The 
next filter bank should consist of pleated or bag type filters with efficiencies between 
60% and 80% ASHRAE atmospheric dust-spot efficiency.

Low efficiency filters are almost totally ineffective at removing sub-micron particulates 
from the air. It is also important that the filters used are properly sized for the air 
handlers. Gaps around the filter panels can allow air to bypass the filter as it passes 
through the air conditioner. Any gaps or openings should be filled using appropriate 
materials, such as stainless steel panels or custom filter assemblies.

Positive Pressurization and Ventilation
A designed introduction of air from outside the computer room system will be 
necessary in order to accommodate positive pressurization and ventilation 
requirements. The data center should be designed to achieve positive pressurization in 
relation to more loosely controlled surrounding areas. Positive pressurization of the 
more sensitive areas is an effective means of controlling contaminant infiltration 
through any minor breaches in the room perimeter. Positive pressure systems are 
designed to apply outward air forces to doorways and other access points within the 
data processing center in order to minimize contaminant infiltration of the computer 
room. Only a minimal amount of air should be introduced into the controlled 
environment. In data centers with multiple rooms, the most sensitive areas should be 
the most highly pressurized. It is, however, extremely important that the air being 
used to positively pressurize the room does not adversely affect the environmental 

Dust spot efficiency 
%

Fractional 
Efficiencies % for: 
3.0 micron

Fractional 
Efficiencies % for: 
1.0 micron

Fractional 
Efficiencies % for: 
3.0 micron

25-30 80 20 <5

60-65 93 50 20

80-85 99 90 50

90 >99 92 60

DOP 95 -- >99 95
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conditions in the room. It is essential that any air introduction from outside the 
computer room is adequately filtered and conditioned to ensure that it is within 
acceptable parameters. These parameters can be looser than the goal conditions for the 
room since the air introduction should be minimal. A precise determination of 
acceptable limits should be based on the amount of air being introduced and the 
potential impact on the environment of the data center.

Because a closed-loop, re-circulating air conditioning system is used in most data 
centers, it will be necessary to introduce a minimal amount of air to meet the 
ventilation requirements of the room occupants. Data center areas normally have a 
very low human population density; thus the air required for ventilation will be 
minimal. In most cases, the air needed to achieve positive pressurization will likely 
exceed that needed to accommodate the room occupants. Normally, outside air 
quantities of less than 5% make-up air should be sufficient (ASHRAE Handbook: 
Applications, Chapter 17). A volume of 15 CFM outside air per occupant or 
workstation should sufficiently accommodate the ventilation needs of the room.

Cleaning Procedures and Equipment
Even a perfectly designed data center requires continued maintenance. Data centers 
containing design flaws or compromises may require extensive efforts to maintain 
conditions within desired limits. Hardware performance is an important factor 
contributing to the need for a high level of cleanliness in the data center.

Operator awareness is another consideration. Maintaining a fairly high level of 
cleanliness will raise the level of occupant awareness with respect to special 
requirements and restrictions while in the data center. Occupants or visitors to the data 
center will hold the controlled environment in high regard and are more likely to act 
appropriately. Any environment that is maintained to a fairly high level of cleanliness 
and is kept in a neat and well organized fashion will also command respect from the 
room's inhabitants and visitors. When potential clients visit the room they will 
interpret the overall appearance of the room as a reflection of an overall commitment 
to excellence and quality. An effective cleaning schedule must consist of specially 
designed short-term and long-term actions. These can be summarized as follows:

Daily Tasks
This statement of work focuses on the removal of each day's discarded trash and 
rubbish from the room. In addition, daily floor vacuuming may be required in Print 
Rooms or rooms with a considerable amount of operator activity.

Table D–1 Frequency of Actions

Frequency Task

Daily Actions Rubbish removal

Weekly Actions Access floor maintenance (vacuum and damp mop)

Quarterly Actions Hardware decontamination

Room surface decontamination

Bi-Annual Actions Subfloor void decontamination

Air conditioner decontamination (as necessary)
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Weekly Tasks
This statement of work focuses on the maintenance of the access floor system. During 
the week, the access floor becomes soiled with dust accumulations and blemishes. The 
entire access floor should be vacuumed and damp mopped. All vacuums used in the 
data center, for any purpose, should be equipped with High Efficiency Particulate Air 
(HEPA) filtration. Inadequately filtered equipment cannot arrest smaller particles, but 
rather simply agitates them, degrading the environment they were meant to improve. 
It is also important that mop-heads and dust wipes are of appropriate non-shedding 
designs.

Cleaning solutions used within the data center must not pose a threat to the hardware. 
Solutions that could potentially damage hardware include products that are:

■ Ammoniated

■ Chlorine-based

■ Phosphate-based

■ Bleach enriched

■ Petro-chemical based

■ Floor strippers or re-conditioners

It is also important that the recommended concentrations are used, as even an 
appropriate agent in an inappropriate concentration can be potentially damaging. The 
solution should be maintained in good condition throughout the project, and excessive 
applications should be avoided.

Quarterly Tasks
The quarterly statement of work involves a much more detailed and comprehensive 
decontamination schedule and should only be conducted by experienced computer 
room contamination-control professionals. These actions should be performed three to 
four times per year, based on the levels of activity and contamination present. All 
room surfaces should be thoroughly decontaminated including cupboards, ledges, 
racks, shelves and support equipment. High ledges and light fixtures and generally 
accessible areas should be treated or vacuumed as appropriate. Vertical surfaces 
including windows, glass partitions, doors, etc. should be thoroughly treated. Special 
dust cloths that are impregnated with a particle absorbent material are to be used in 
the surface decontamination process. Do not use generic dust rags or fabric cloths to 
perform these activities. Do not use any chemicals, waxes or solvents during these 
activities.

Settled contamination should be removed from all exterior hardware surfaces 
including horizontal and vertical surfaces. The unit's air inlet and outlet grilles should 
be treated as well. Do not wipe the unit's control surfaces as these areas can be 
decontaminated by the use of lightly compressed air. Special care should also be taken 
when cleaning keyboards and life-safety controls. Specially treated dust wipes should 
be used to treat all hardware surfaces. Monitors should be treated with optical 
cleansers and static-free cloths. No Electro-Static Discharge (ESD) dissipative 
chemicals should be used on the computer hardware, since these agents are caustic 
and harmful to most sensitive hardware. The computer hardware is sufficiently 
designed to permit electrostatic dissipation thus no further treatments are required. 
After all of the hardware and room surfaces have been thoroughly decontaminated, 
the access floor should be HEPA vacuumed and damp mopped as detailed in the 
Weekly Actions.
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Bi-Annual Tasks
The subfloor void should be decontaminated every 18 months to 24 months based on 
the conditions of the plenum surfaces and the degree of contaminant accumulation. 
Over the course of the year, the subfloor void undergoes a considerable amount of 
activity that creates new contamination accumulations. Although the weekly above 
floor cleaning activities will greatly reduce the subfloor dust accumulations, a certain 
amount of surface dirt will migrate into the subfloor void. It is important to maintain 
the subfloor to a high degree of cleanliness since this area acts as the hardware's 
supply air plenum. It is best to perform the subfloor decontamination treatment in a 
short time frame to reduce cross contamination. The personnel performing this 
operation should be fully trained to assess cable connectivity and priority. Each 
exposed area of the subfloor void should be individually inspected and assessed for 
possible cable handling and movement. All twist-in and plug-in connections should be 
checked and fully engaged before cable movement. All subfloor activities must be 
conducted with proper consideration for air distribution and floor loading. In an effort 
to maintain access floor integrity and proper psychrometric conditions, the number of 
floor tiles removed from the floor system should be carefully managed. In most cases, 
each work crew should have no more than 24 square feet (six tiles) of open access 
flooring at any one time. The access floor's supporting grid system should also be 
thoroughly decontaminated, first by vacuuming the loose debris and then by 
damp-sponging the accumulated residue. Rubber gaskets, if present, as the metal 
framework that makes up the grid system should be removed from the grid work and 
cleaned with a damp sponge as well. Any unusual conditions, such as damaged floor 
suspension, floor tiles, cables and surfaces, within the floor void should be noted and 
reported.

Activity and Processes
Isolation of the data center is an integral factor in maintaining appropriate conditions. 
All unnecessary activity should be avoided in the data center, and access should be 
limited to necessary personnel only. Periodic activity, such as tours, should be limited, 
and traffic should be restricted to away from the hardware so as to avoid accidental 
contact. All personnel working in the room, including temporary employees and 
janitorial personnel, should be trained in the most basic sensitivities of the hardware 
so as to avoid unnecessary exposure. The controlled areas of the data center should be 
thoroughly isolated from contaminant producing activities. Ideally, print rooms, check 
sorting rooms, command centers or other areas with high levels of mechanical or 
human activity should have no direct exposure to the data center. Paths to and from 
these areas should not necessitate traffic through the main data center areas.
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2N

A PDU that supplies power to the redundant AC power grid and the third and fourth 
accessory racks. See also N+1 and 2N+1. 

2N+1

Two PDUs for AC redundancy. Each PDU has extra DC power supplies for N+1 
redundancy for each PDU. 

ACSLS

See Automated Cartridge System Library Software (ACSLS). 

ADI

Automation drive interface. 

AEM

See access expansion module. 

access expansion module

Essentially a very large CAP, with all the characteristics of a CAP, such as 
online/offline state, ability to be shared by partitions, and so on. The cartridge slots in 
the AEM cannot be used for long-term cartridge storage. 

access door

A door on either side of the front facade through which service personnel can enter the 
library. Optional CAPs are attached to the right access door. 

activated capacity

The number of storage cells the library is activated to use. This cannot exceed the 
installed capacity. 

Automated Cartridge System Library Software (ACSLS)

An open systems software package that manages library contents and controls library 
hardware to mount and dismount cartridges on tape drives. This application also 
provides library management services such as cartridge tracking, pooling, reports, and 
library control. 

audit

An inventory of cartridge locations in all areas of the library, including the slots in the 
storage and reserved areas. Audits occur when: 
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■ The library initializes at power-on. 

■ After either one or both access doors are opened and closed without activating the 
service safety door. 

■ A physical audit request is made through SL Console. 

base module 

Provides the entry level offering for an SL3000 library. Consists of a single frame and 
centralizes the infrastructure for all other modules in the library. This module includes 
the power supplies, robotic units, electronics control module, cartridge access port, 
storage slots, tape drives, and operator controls. 

bar code line scan camera 

A component of the robot that is used for cartridge identification and position 
calibration. 

bulk load 

Manually loading cartridges into the library, for example, during library installation. 

CAP 

See cartridge access port (CAP). 

CDS 

Control data set. 

CEM 

See cartridge expansion module. 

CLI 

Command line interface. 

capacity 

The storage capacity of the library. See also activated capacity and installed capacity. 

cartridge 

A container holding magnetic tape that can be processed without separating the tape 
from the container. The library uses data, diagnostic, and cleaning cartridges. 

cartridge access port (CAP) 

A bi-directional port built into the door panel of the library which provides for the 
manual entry or automatic ejection of data or cleaning cartridges. Same as 
import/export mail slot in SCSI and open system libraries. 

cartridge expansion module 

An optional module for the library that provides additional cartridge slot capacity and 
growth. 

cartridge proximity detector 

A component that determines if a cell is empty or contains an unlabeled cartridge 
during a label reading error recovery procedure. Same as empty cell detector. 

cell 

The location in the library in which a tape cartridge is stored. Same as slot. 
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cell array 

An array that holds multiple cartridges when not in use. 

cleaning cartridge 

A tape cartridge that contains special material to clean the tape path in a transport or 
drive.cold swap 

To remove and replace a system component (typically one such as a logic board that 
has no redundant backup) after system operations have been stopped and system 
power has been disabled.

control data set 

Data set used by the host software to control the functions of the automated library. 
Also called a library database. 

DEM 

See drive expansion module (DEM). 

dWWN 

See dynamic WWN. 

data cartridge 

A term used to distinguish a cartridge onto which a tape drive may write data from a 
cartridge used for cleaning or diagnostic purposes. 

diagnostic cartridge 

A data cartridge used for diagnostic routines. 

data path 

The path where data is transferred between the host and tape drives. 

drive bay 

A partitioned section of the tape drive array assembly that holds one tape drive tray 
assembly. 

drive bay address 

A two-digit integer (01–64) that represents the physical locations into which drive tray 
assemblies are inserted. 

drive expansion module (DEM) 

A module that allows further expansion of tape drives. 

drop-off cells 

Cells used to hold a cartridge if a robot failure occurs while a cartridge is in the robot 
hand. 

Dual TCP/IP 

Provides two separate host connections between the host software (ACSLS or HSC) 
and the library controller. 

dynamic WWN 

When enabled, dWWN assigns names to library drive slots rather than devices. When 
a drive is replaced, the new drive receives the same name as the one it replaced, 
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thereby eliminating the need for system re-configuration. dWWN assigns names to 
individual tape drive slots rather than devices 

ECM 

See electronics control module. 

ELS 

See Enterprise Library Software. 

ESCON 

See Enterprise Systems Connection (ESCON). 

EPO 

See emergency power-off (EPO). 

eject 

See export.

electronics control module 

A module that includes the HBK card, HBC/HBCR card and HBT card. The assembly 
that: 

■ Processes commands from a host system 

■ Coordinates the activities of robots and tape drives 

■ Monitors status inputs from sensors and switches 

emergency power-off (EPO) 

(1) A safety scheme that allows a power down of a subsystem or a system as a whole 
instead of powering it down component-by-component. 

(2) A safety switch on a system or in a data center that allows a user to immediately 
turn off a system or a data center power supply by cutting off the external source 
power. 

enter 

See import. 

Enterprise Library Software 

The software products that automate tape operations for mainframe users. 

Enterprise Systems Connection (ESCON) 

An optical fiber serial interface which supports half duplex data transfers. 

environmental monitors 

A collective term for the sensors that track temperatures, fan speeds, and the status of 
various other mechanism within a library. 

export 

The action in which the library places a cartridge into the cartridge access port so that 
the operator can remove the cartridge from the library. Same as eject. 

FRU 

Field replaceable unit. 
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failover 

The act of moving to a secondary or redundant path when the primary path fails. Also, 
in ACSLS HA, failing over to the standby (alternate) ACSLS server. 

get 

An activity in which a robot obtains a cartridge from a cell or drive. 

gripper 

The portion of the hand assembly that grasps the cartridge. (2) The part of the hand 
assembly that grasps and holds a cartridge during transport. 

HLI/PRC 

Host Library Interface/Panel Row Column 

hand assembly 

A part of the library robot whose function is to grasp cartridges and move them 
between storage cells and drives. A camera on the hand assembly reads cartridge 
volume labels. 

host audit 

The process of updating the cartridge vol-ids and locations in a host CDS. This audit is 
initiated by a host command. 

import 

The process of placing a cartridge into the cartridge access port so that the library can 
insert it into a storage cell. 

installed capacity 

The number of storage cells physically present in the library. 

interlock switch 

A switch that disconnects power to library mechanisms, excluding tape drives, when 
the front door is opened. 

keypad interface 

See membrane keypad. 

LCM 

See Library Content Manager (LCM). 

LTO 

See linear tape open format (LTO). 

LUN 

See logical unit number. 

Library Content Manager (LCM) 

Software that provides content management for mainframe automated tape 
environments. Works with host software component, virtual storage manager and 
your tape management system. 

library operator panel 

See touch screen operator control panel. 
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linear tape open format (LTO) 

A set of tape data format standards created to enable data interchange among different 
LTO Ultrium tape drive vendors. These standards allow data cartridges to be shared. 

logical library 

A virtual representation of a physical library. Same as virtual library partition. 

logical unit number 

A unique identifier for a physical storage allocation. A LUN could reference an entire 
RAID set, a single hard disk or partition, or multiple disks or partitions. Unlike a 
physical LUN, the virtual LUN does not map to a specific device or allocation of 
storage space but a virtualized space that can be created in excess of the actual 
physical space available. 

magazine 

A removable array that holds cartridges and is placed into the cartridge access port 
(CAP). 

membrane keypad 

A keypad mounted on the front facade used to monitor the status of the library and to 
operate the CAPs. 

N+1 

A power configuration that provides AC power and redundant DC power by adding a 
second DC power supply to each DC bus. See also 2N. 

operator panel 

See touch screen operator control panel. 

orphaned cartridge 

A cartridge in a partitioned library that is located in an unallocated cell or drive (that 
is, a cell or drive not allocated to any defined partition). Cartridges may become 
orphaned when partition boundaries are changed, partitions are deleted, or cartridges 
are manually moved to unallocated or inaccessible cells. 

PDU 

See power distribution unit (PDU). 

PEM 

See power distribution unit (PDU). 

PLI 

See primary library interface (PLI). 

parking expansion module (PEM) 

An additional module available for the SL3000 library that allows a redundant robot to 
be parked in it. 

physical audit 

Physical audits occur when the robots: 

■ Scan the cartridge locations in the library 

■ Verify the volumes 
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■ Update the library control card inventory 

■ Set the status of the cartridge location to true 

physical library 

A physically present library as opposed to a logical library. 

power distribution unit (PDU) 

A device for the distribution of AC line power from one inlet to multiple outlets. 
Multiple PDUs provide higher availability because the power continues if one PDU (or 
its alternating current source if the PDUs use separate AC sources) loses power. 

primary library interface (PLI) 

The communication path between the operator panel and the library controller. 

put 

An activity in which a robot places a cartridge into a cell or drive. 

RE 

See Redundant Electronics (RE). 

rail 

(1) That portion of the upper robot track assembly that provides power and 
communication to the robot. (2) All of the cartridge slots and drives accessible through 
a rail. 

rail assembly 

The mechanism on which the robot travels between cartridge arrays and tape drives. 

reach mechanism 

A component of the robot that moves the gripper to get or put a cartridge at a 
designated location. 

Redundant Electronics (RE) 

A feature that provides failover protection in enterprise libraries. RE uses two sets of 
library controller cards. At any given time, one set is active and the other set is 
standby. The active library controller can failover to the standby in response to a 
command from ACSLS or the SL Console. Automatic failover can be initiated by the 
library if a library card fails. 

remote operator console 

The customer's operator panel that interfaces with the PLI. See also security software 
layer. 

robot 

A mechanism that moves horizontally along a track to transport tape cartridges to and 
from other locations in the library. 

SSL 

See Secure Sockets Layer (SSL). 

Secure Sockets Layer (SSL) 

A cryptographic protocol that provides communication security. The communication 
path between the PLI and the remote operator console occurs through SSL. 
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slot 

Same as cell. 

TTI 

See tape transport interface (TTI). 

tape cartridge 

A container holding magnetic tape that can be processed without separating the tape 
from the container. The library uses data, diagnostic, and cleaning cartridges. These 
cartridges are not interchangeable. 

tape drive 

An electromechanical device that moves magnetic tape and includes mechanisms for 
writing and reading data to and from the tape. 

tape drive tray assembly 

The mechanical structure that houses a tape drive, fan assembly, power and logic 
cards, cables, and connectors for data and logic cables. Same as drive tray assembly. 

tape storage area 

The area in the library where cartridges are stored. 

tape transport interface (TTI) 

An interface to control and monitor tape movement. 

touch screen operator control panel 

A flat-panel display with a touch screen interface and a panel mount computer. This 
feature is attached to the front of the library. 

track 

The horizontal path upon which a robot travels. 

track drive mechanism 

The component that moves the robot along the track between the cell arrays, CAPs, 
and tape drives. 

vol-id 

Volume ID assigned to a cartridge. Same as VOLSER. 

VOLSER 

Volume serial number. Same as vol-id. 

vacancy plate 

A plate that covers an unused bay, such as a drive bay or power supply bay. 

verified audit 

Verified audits are invoked from the SL Console and actually validate the status of a 
specific cartridge slot or range of slots. 

WWN 

See World Wide Name. 
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wrist 

A mechanism in the robot assembly that allows the robot to access the outer and inner 
storage walls. 

World Wide Name 

A 64-bit address that uniquely identifies each individual device and vendor, much like 
the MAC address of an Ethernet interface. Each port on a Fibre Channel network must 
have its own WWN. The WWN is not just a physical hardware address. It also serves 
as the logical address of a node on the SAN, meaning the SAN configuration changes 
if any of the attached hardware changes. If a device fails and is replaced, the WWN of 
the node changes, forcing reconfiguration of the SAN. There are three World wide 
Names reserved for each drive bay: Node, Port A, and Port B.
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A
access door

closing, 15-3
opening, 15-3
safety interlocks, 15-2
safety release, 15-2

activated capacity
active storage regions, 5-1

defining, 5-3
reports, 5-3

cell activation rules, 5-1
changes and FC-SCSI connections, 5-2
changes and HLI connections, 5-1
orphaned cartridges and, 5-2

activated features
display current, 4-3
install, 4-1

active storage regions
automatic assignment, 5-1
defining, 5-3
manual assignment, 5-1
reports, 5-3

addressing, B-1
AEMs internal firmware, B-16
CAPs HLI, B-16
CAPs internal firmware, B-15
FC-SCSI, B-6
HLI-PRC, B-4
internal firmware, B-2
tape drives, B-12

AEM
allocating to partitions, 6-2
associating to a partition, 9-5
emergency access, 15-4
library partitions and, 6-1
properties, 9-3
rebooting, 13-1
removing partition associations, 9-5
status, 9-3
summary information, 9-3
using to bulk load cartridges, 9-2
using to bulk unload cartridges, 9-2

AEM access door
audits and, 15-4
closing, 9-3

fast access, 15-4
AEM operations

summarized, 9-2
AEM safety door

properties, 9-3
status, 9-3

audits
audit indicator, 7-10
description, 7-9
full library, 7-10
main access door and, 7-10
physical, 7-10
range of cells, 7-10
verified, 7-11

auto enter mode (CAPs)
described, 9-1

automated mode
returning the library to, 7-8

B
barcode presentation, 11-2

C
CAP associations

library partitions and, 6-3, 9-5
removing, 9-5

CAP reservations
library partitions and, 6-2
overriding, 9-5

capacity
activated. See activated capacity.

CAPs
and library partitions, 6-2
auto enter mode, 9-1
closing, 9-3
display properties, 9-3
display status, 9-3
display summary information, 9-3
inserting cartridges, 11-5
library partitions and, 6-1, 9-5
making available for diagnostic moves, 9-4
manual mode, 9-2
self-test, 9-4, 10-6
states
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library partitions and, 6-3, 6-4, 9-2
varying offline, 9-4
varying online, 9-4

cartridges
applying labels, 11-9
barcode presentation, 11-2
display information, 11-2
ejecting into a partition, 9-5
ejects, 11-6
entering into a partition, 9-5
enters, 11-5
exterior cleaning, 11-8
handling, 11-8
inserting in a cell or drive, 11-8
inserting in the CAP, 11-5
inspecting, 11-8
list, 11-2
loading through the AEM, 9-2
locate by address, 11-3
locate by VOLID, 11-3
locating by address, 11-3
locating by VOLID, 11-3
move by VOLID, 11-4
move from specified location, 11-4
recovery moves, 11-4
storing, 11-9
unlabeled, 11-1
unloading through the AEM, 9-2

cautions
reentering cleaning cartridge, 11-1
solvents for cleaning a cartridge, 11-9

CenterLine, B-1
cleaning cartridges, 11-1

exporting, 10-4
importing, 10-3
list, 10-2
warning threshold, 10-3

D
device status, 7-1

listing codes, 14-5
diagnostic cartridges

description, 11-7
exporting, 11-8
importing, 11-7
library self-tests and, 7-7
management tasks, 11-7

diagnostic moves (robot)
controlling, 13-6
defining, 13-4
description, 13-3
managing definitions, 13-5
monitoring, 13-6
pool address range, 13-4
random access order, 13-4
robot selection, 13-3
saving, 13-5
sequential access order, 13-4
starting, 13-6

target address range, 13-3
diagnostic support files, 14-1
diagnostics

CAPs and, 9-4
domain, media labels, 11-2
drive cleaning

configuring library auto clean, 10-3
description, 10-1
display status of, 10-4
exporting cleaning cartridges, 10-4
importing cleaning cartridges, 10-3
library auto clean, 10-1
manual, 10-2

drive controller, 7-4
Drive Events Report, 10-5
Drive Media Events Report, 10-5
drive trays

status, 10-4
drive VOP

displaying for T10000, 10-4
drives

bringing online, 10-5
cleaning. See drive cleaning.
display drive properties, 10-4
display drive summary information, 10-4
display status, 10-4
LED status, 10-4
network data, 10-4
SCSI FastLoad and, 13-2
states, 10-5
taking offline, 10-5

E
eject operations, 11-6

partitioned libraries, 9-5
enter operations, 11-5

partitioned libraries, 9-5
event monitors

description, 14-3
display, 14-4
display multiple, 14-4
spool data to a file, 14-4

F
FC-SCSI elements, B-6
FC-SCSI interface, 7-9

barcode presentation and, 11-2
FastLoad feature and, 13-2

G
General Events Statistics Report, 7-5

H
hardware activation file

comparing to current features, 4-2
delete, 4-2
description, 4-1
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display current, 4-3
displaying contents of, 4-2
download, 4-2
Feature Audit Log, 4-3
file type, 4-1
install, 4-2
installing, 4-1

hardware activation key file
overlaying, 4-1

hardware activation tasks, 4-1
HLI interface, 7-9

displaying port status, 7-4
HLI-PRC addressing, B-4
host interfaces

changing the type, 7-9
HLI. See HLI interface., 7-4
non-partitioned libraries and, 7-9

I
internal firmware addressing, B-2

K
key

maintenance, 15-1

L
library

placing in manual mode, 7-8
placing online, 7-8
returning to automated mode, 7-8

library auto clean, 10-1
library configuration

display, 7-4
library controller

display redundant electronics, 8-4
log in to alternate, 8-3
properties, 7-4

library events, 14-3
library events. See Also event monitors.
library firmware upgrades, 7-2

activate, 7-3
download, 7-2

library initialization sequence, 15-3
library partitions

AEM associations and, 9-5
allocating an AEM CAP, 6-2
barcode presentation and, 11-2
CAP associations and, 6-3, 9-5
CAP reservations and, 6-2, 9-5
CAP states and, 6-3, 6-4, 9-2
commit configuration changes, 6-7
configuration tasks, 6-4
create, 6-5
delete, 6-6
described, 6-1
design, 6-7
displaying, 5-4, 6-8
ejecting cartridges into, 9-5

entering cartridges into, 9-5
hosts and, 6-1
library hardware changes and, 6-4
library resources and, 6-5
orphaned cartridges in, 11-2
reports, 6-8
SCSI FastLoad feature and, 13-2
shared CAPs and, 6-3
using AEMs in, 6-1
using CAPs in, 6-1
using CAPs with, 6-2
verify, 6-7

library power down, 15-2
library power up, 15-3
library reboot, 7-7
library reports

displaying, 7-5
saving data to a file,SL Console report tasks, 7-5
searching, 7-5

library self-tests, 7-7
performing, 7-7

library status, 7-1
display, 7-4

local operator panel
described, 3-6
factory alignment, 3-6
logging in, 3-6
re-calibrating, 3-6

log snapshot file
generating process, 7-6
transfer process, 7-7

login IDs, 3-7
logs

Feature Audit Log, 4-3

M
main access door

audits and, 7-10
maintenance key, 15-1
manual CAP, 9-2
manual cleaning (drive), 10-2
manual mode

placing the library in manual mode, 7-8
returning the library to automated mode, 7-8

manual operations
safety precautions, 15-1

access door interlocks, 15-2
access door release, 15-2
general, 15-1
server power interrupt, 15-2

media
domain labels, 11-2
ID labels, 11-2

MIB file
described, 14-1
transfer process, 7-6
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N
non-disruptive partitioning

FC-SCSI partitions and, 6-3
HLI partitions and, 6-2

O
orphaned cartridges

non-partitioned libraries and, 5-2
partitioned libraries and, 11-2

P
passwords

activation, 3-7
modifying, 3-8

placing the library in manual mode, 7-8
port bonding, 7-4
ports

status, 7-4
power down the library, 15-2
power supplies

monitoring tasks, 7-6
status of, 7-6
summary information, 7-6

power up the library, 15-3

R
reboot

library, 7-7
recovery moves, 11-4
redundant electronics

manual switch, 8-4
tasks, 8-4

reports
cartridge summary, 11-2
cartridge table, 11-2
drive events, 10-5
feature audit log, 4-3

result codes
listing, 14-5

returning the library to automated mode, 7-8
robot

display status of, 13-2
display summary information, 13-2
monitoring tasks, 13-2
properties, 13-2
SCSI FastLoad and, 13-2
self-test, 13-3
varying offline, 13-2
varying online, 13-2

S
safety precautions, 15-1

access door interlocks, 15-2
access door release, 15-2
general, 15-1
servo power interrupt, 15-2

SCSI FastLoad, 13-2
self-tests

CAP, 9-4
drive, 10-6
library, 7-7, 14-1
robot, 13-3

SL Console
activation password, 3-7
communications failures, 7-2
first-time access, 3-7
login ID, 3-7
modes, 3-1
modifying passwords, 3-8
screen, components, 3-2
screen, modifying layout, 3-3
security, 3-7
synchronize with library, 3-3
user ID, 3-7

SL Console reports
Drive Events, 10-5
Drive Media Events, 10-5
General Events, 7-5

SLConsole
downloading, 3-1
media pack, 3-1

SNMP
transfer the library MIB file, 7-6

standalone SL Console
description, 3-3
logging in, 3-4

standalone SLConsole
updating, 3-3

status
library and devices, 7-1

status alerts
clearing, 7-2
described, 7-4
displaying, 7-4

T
tape drives

addressing, B-12
hardware numbering, B-12
HLI-PRCs, B-14
internal firmware address, B-13

transferring the log snapshot file, 7-7
troubleshooting, 14-2

U
User ID

types, 3-7

V
vary the library offline, 7-8
vary the library online, 7-8
VOP

displaying for T10000 drives, 10-4
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W
Web-launched SL Console

client requirements, 3-5
description, 3-5
logging in using a browser, 3-5
logging in using CLI, 3-5
security, 3-5
starting on a client, 3-5
updating on a client, 3-5

web-launched SLConsole
installing, 3-5
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